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Welcome

Avenza welcomes you to map-making in the 21st century!

Combined with Adobe Illustrator, MAPublisher has revolutionized the art of map-making by allowing spatial data 
files to be used in a vector graphics application. MAPublisher allows all cartographic tasks to be performed where 
they should be done: in a powerful graphics environment.

This user guide assumes that the user is familiar with Adobe Illustrator and has at least a basic understanding of 
geographic information systems (GIS) terminology and concepts. Please refer to the Adobe Illustrator user guide for 
more information on using Adobe Illustrator. 

This user guide explains the installation process, licensing, and many features of MAPublisher. All MAPublisher 
panels, functions and tools are thoroughly detailed together with the related concepts necessary to build map and 
perform fundamental cartographic and GIS tasks. Please refer to the Avenza Projections Guide for more information 
on the projections supported in MAPublisher.

As a complement to these guides, the MAPublisher software installer includes tutorial documents (MAPublisher 
9.1 Tutorial Guide, MAPublisher 9.1 Quick Start Guide and MAPublisher 9.1 LabelPro Tutorial Guide) and associated GIS 
datasets. We encourage all users to go through these guides to gain additional experience with MAPublisher tools 
and functions. 

MAPublisher and Adobe Illustrator together constitute an integrated cartographic design software system with 
state-of-the-art graphics tools and GIS functions.
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Introduction

MAPublisher 9.1 is the newest version of a powerful suite of plug-ins for Adobe Illustrator CS5, CS5.1 and CS6 that 
bridges the gap between geographic information systems (GIS) and high-end graphic design software in order 
to facilitate the map creation process. MAPublisher offers additional panels, functions, tools and functions to the 
powerful Adobe Illustrator design environment that enable GIS data files to be used as a base for cartographic 
production destined for print or Web contents.

Working from a traditional Adobe Illustrator document, users create and edit their data organized through layers 
(either new or imported with MAPublisher). Users benefit from the Adobe Illustrator graphic tools as well as 
additional custom MAPublisher functions and panels to create, edit and query the map data.

MAPublisher Simple and Advanced Import functions allow the import of major GIS and CAD formats (ArcGIS, MapInfo, 
AutoCAD, MicroStation, KLM and more) into Adobe Illustrator, while retaining their native geometry (Point, Line, 
Text, Area), layer structure, geographic location and attribute data.

The cartographic workspace is managed through MAP Views that control the geospatial parameters: coordinate 
system, map anchor, map scale and rotation. Layers organized under the same MAP View share the same 
geographic frame of reference. A layer must reside within a MAP View to be managed by MAPublisher functions 
and keep its spatial and attribute information; however layers not related to a MAP View may still be used for 
presentation purposes (such as title, scale and legend). An Adobe Illustrator document may contain more than one 
MAP View. For example, a map with an inset map at a larger scale to represent a zoomed-in area of interest.

The MAP Attributes panel allows for creating, editing and querying attribute information. For example, for a line layer 
containing street data, each line segment may be linked to a table with information relative to the street name 
and street category. Using the MAP Attributes panel, this information can be viewed, queried, edited or additional 
columns of data may be appended.

MAP Themes make use of the attribute data to apply Adobe Illustrator graphic styles, symbols or character styles to 
map features based on an object’s attribute values. Choose from Stylesheet, Charts, and Dot Density themes.

MAPublisher also offers many functions and tools to manage GIS data from within Adobe Illustrator:
•	Import major GIS and CAD formats (MAPublisher Simple and Advanced Import, Spatial Database)
•	Plot a symbol by typing in its world coordinates (MAP Point Plotter)
•	Draw objects with geographic dimensions (MAP Area Tools)
•	Trim the geographic extents of the map (MAP Vector Crop)
•	Join lines or points that share a same attribute value, simplify lines, create a buffer area around a line (Buffer 

Art, Flip Lines, Join Areas, Join Lines, Join Points, Line Plotter, Simplify Lines)
•	Automatically label features based on attribute data (MAP LabelPro, Label Features and MAP Tagger Tool)
•	Select features based on attributes (MAP Selections)
•	Import and export geographically referenced images (Register Image)
•	Create grids and indexes (Grids and Graticules)
•	Create scale bars and north arrows (Scale Bar, Create North Arrow)
•	Export to Geospatial PDF (Export Geospatial PDF) 
•	Export a map to Flash with populated Web tags (MAP Web Author)
•	Export layers to major GIS and CAD formats (MAP Views)
•	And much more... 
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MAPublisher Features

Import and Export Data
Import data from mapping applications such as ArcGIS, MapInfo, MicroStation, Google Earth and other sources 
with all attributes and georeferencing intact. Make vector and database edits, data edits, additions and save your 
changes to a variety of GIS data formats. Newly supported formats are KMZ, GML and S-57 (import only).

MAP Views
The MAP Views panel controls the Adobe Illustrator layers organization into geographically referenced entities. It 
offers many ancillary tools: export to GIS format, layer lock and display control, Switch to MAP View, exchange MAP 
Objects between Adobe Illustrator documents.

Several geographical references can be maintained per document (e.g. main map and inset maps), stored as MAP 
Views. Each MAP View scale, transformation, position on the artboard is configured through the MAP View Editor — 
with many option for display, zoom, rescale, rotation, and so on.

MAP Attributes
The attribute table holds map attribute information for line, area and point data. Add and remove columns, edit 
schemas, join tables, calculate and apply expressions to customize map attributes. MAP Attributes are the base 
to many other MAPublisher tools (such as line functions, MAP Themes, and MAP Web Author). They can also be 
exported to text file for further usage.

MAP Themes
MAPublisher quickly and easily styles map features using Stylesheets, Charts and Dot Density themes. Specify 
rules and expressions to apply preset or custom symbols, graphic styles and character styles to artwork based on 
exisiting map attributes. Use various classification methods to easily create data classes. In addition, create highly 
customizable MAP Theme Legends.

MAPublisher Panels
MAPublisher panels seamlessly integrate into the user interface and can be resized, moved, and docked just like 
native Adobe Illustrator panels.

MAPublisher Toolbar
The MAPublisher Toolbar allows you to easily launch all the main MAPublisher tools with a single click.

MAP Vector Crop Tool
Crop map documents by exact locations (including MAP Locations) and dimensions. Easily remove unwanted data 
while preserving attributes and styles. Perfect for creating inset maps. Crop To Shape tool can use any shape to crop.

MAP Point Plotter Panel
MAP Point Plotter places points (e.g. locations of towns or cities) based on user input locations onto any projected 
map in projected units or lat/long format (decimal degrees, or Degrees Minutes Seconds). MAP Point Plotter also 
offers the option to instantly plot centroids for line or area features.
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Area Plotter
The Area Plotter tool creates new rectangle or ellipse polygons on MAP Area layers by using page or world 
coordinates, and by location type (using either a bounding box or by a single coordinate position). Use it to create 
precise area shapes based on coordinate locations.

Geospatial PDF Import and Export
Ability to import geospatial PDF documents quickly and easily using MAPublisher. This import method can 
automatically assign the content in a geospatial PDF to appropriate MAP Layers and a MAP View. Export map 
data to a geospatially enabled PDF. In this process, all objects and associated MAP Attributes information (when 
available) are ported to PDF, while also maintaining the map coordinate system. When a geospatial PDF is opened 
with Adobe Acrobat Reader 9, one can find locations, measure distances, add location markers as well as copy 
coordinates to the clipboard. Additionally, objects can be selected and queried and their MAP Attributes can be 
viewed in the Adobe Acrobat Model Tree.

MAPublisher Spatial Database import
Import spatial data from Esri Personal Geodatabase (.mdb), File Geodatabase (.gdf ), and ArcSDE servers. This 
function requires Esri software and a valid license installed on the computer and consequently it is only available on 
Windows operating systems. Supported feature types are Point, Polyline, Polygon, Circular Arc, Eliptical Arc, Bezier 
Curve, Annotations (text). The MAPublisher Spatial Database import allows for SQL queries and spatial filters.

MAP Measurement Tool
The MAP Measurement Tool measures straight distances (between two points), path distances (multiple points), 
azimuths, and the perimeter and area of closed paths — in page or map unit (real world distances). Furthermore, 
the measuring path can be converted to a line or area in the currently selected layer.

MAP Selections
Build, edit and apply multiple selection criteria based on the attributes and properties contained in MAP Layers 
using MAP Selections. Selection criteria are created in an expression builder and can be applied to any MAP layer, 
and can be saved so they can be edited or applied later.

Geometry Operations
Join areas, lines or points and flip lines while keeping attributes intact. Use Simplify Line to reduce the number of 
vertices in a point (with preview and information on the number of filtered points). Create lines based on a series 
of point locations. Use Buffer Art to create buffer areas around line, area or point features. Join Areas can dissolve 
multiple areas into a larger area and still retain attributes.

Labeling
Create labels for map objects using values from the MAP Attributes panel. MAPublisher provides two methods of 
adding labels to your map: Label Features labels specified layers automatically; and MAP Tagger Tool labels features 
individually through user selection.
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Register Image
Register images accurately to your vector data. MAPublisher determines the parameters of the raster image and the 
coordinate system of a selected MAP Layer in the registration process. A MAP Layer feature type called Image allows 
georeferenced images to be placed accurately. In addition, Simple and Advanced Import now supports image 
formats which simplifies the process of importing them into an Adobe Illustrator document. 

MAP Elements
Easily add customizable map elements such as scale bars, north arrows and map legends. Choose from preset 
designs or edit an existing one.

Merge Layers
The new Merge Layers tool combines at least two MAP Layers of the same feature type into a new MAP layer based 
on its attribute values. The art from the source layers can either be copied or completely moved to the new layer 
(including its attributes).

Split Layer
The Split Layer function splits a layer into new layers based on an expression or by unique attribute value. The 
qualifying features can either be copied or moved to a new layer, while maintaining all their attribute data.

MAPublisher Log
The new MAPublisher Log records information about which MAPublisher tools were used and when they were 
used. View detailed information about successful operations, warnings and errors. 

MAPublisher License Management
The new MAPublisher License Management system helps users manage their licensing in a more streamlined and 
user-friendly manner. Users can now evaluate the product, register, retrieve their licenses and checkout a floating 
license, all in a single dialog box. Additionally, MAPublisher panels are now marked with a lock icon when the 
software is not licensed.

MAPublisher Preferences
The MAPublisher Preferences allow users to fully customize their MAPublisher experience. Control everything 
from the way layers are sorted to the font used to display attribute data or style of the MAP Selections panel. This 
includes several previously hidden options that used to be the domain of advanced users.

Web Feature Service and Web Map Service
Two new import features: Web Feature Service (WFS) and Web Map Service (WMS). Access these features through 
Simple or Advanced Import. WFS accesses web servers that deliver vector content in GML format. WMS access web 
servers that deliver raster content in a variety of formats.
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Create Halo
The new Create Halo tool produces halo graphic styles and applies halos to features on MAP layers. Halos can be 
independently created as a graphic style without having them applied or they can be directly applied to a MAP 
layer without having to create a graphic style.

Scale and Rotate By Attribute
The new Scale & Rotate By Attribute tool provides options to scale and rotate art objects using specified values or 
the target MAP layer's attributes. 

Document Operations
Text Utilities performs many text actions such as correcting upside down text, separating multiline text into single 
line and cropping text path to text length. These actions can be applied to either all text layers or specific text on a 
layer.  Right-to-Left Text is used to apply proper formatting to right-to-left languages such as Arabic and Hebrew.

MAP Locations
The MAP Locations are used as annotation to identify map world or map page locations. These locations can then 
be used in other MAPublisher functions when specifying map or page anchors and in tools such as Specify Anchors, 
Area Plotter, Line Plotter and Point Plotter.

MAPublisher FME Auto
With the add-on MAPublisher FME Auto license comes the ability to import FME FFS files. Use FME Desktop tools to 
translate GIS data to work with MAPublisher for a true automated workflow.
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What’s New in MAPublisher 9.1

MAPublisher LabelPro™ 2.0
MAPublisher LabelPro™ revolutionizes the way users can label map data, including using symbols as labels and 
label conflict resolution with a high degree of customizable rule-based labeling options. The MAPublisher LabelPro 
engine uses your map data attributes for labeling with styles, rules and controls. The interface was redesigned for 
MAPublisher 9.1 and includes more settings such as label filters and expressions.

MAP Web Author HTML5 export
Export Adobe Illustrator documents with GIS data to interactive HTML5 web maps complete with callout bubbles, 
rollovers, layer control, pan and zoom controls, and with all the underlying GIS attributes intact. HTML5 web maps 
can be created without the  need for browser plug-ins. HTML5 web maps are suitable for mobile use on tablets and 
smartphones. MAP Web Author export settings include recommended sizes for display on mobile devices.

And more enhancements...
Improved interface changes and bug fixes.
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Before using MAPublisher please read this section to ensure 
that you have a suitable hardware environment, are familiar 
with the installation and activation procedures, and have 
adequately prepared your system and workspace to make 
maps with Adobe Illustrator and MAPublisher.

Topics covered in this section:
System Requirements
Installation Instructions
MAPublisher Compatibility Notes
MAPublisher License Management
The MAPublisher Tools
The MAPublisher Toolbar
MAPublisher Preferences 
Preparing the Workspace

Getting 
Started
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System Requirements 

System Requirements 

WINDOWS

•	 Adobe Illustrator CS5 / CS5.1 / CS6 32-bit / CS6 64-bit

•	 2 GHz or faster Intel Pentium 4 processor (Intel Core 2 Duo or better recommended)

•	 Windows XP / Vista / 7 / 8 (compatible with 64-bit versions)

•	 4 GB of RAM minimum (8 GB of RAM or higher recommended)

•	 500 MB of available hard-disk space

MAC OS X

•	 Adobe Illustrator CS5 / CS5.1 / CS6

•	 Intel processor (Intel Core 2 Duo or better recommended)

•	 Mac OS X 10.6 or higher

•	 4 GB of RAM minimum (8 GB of RAM or higher recommended)

•	 500 MB of available hard-disk space

Notes:	 Not all foreign language versions of Adobe Illustrator may be supported. Please contact support@avenza.com 
for more information. 
 
Installing MAPublisher on a system that does not meet the minimum requirements may produce unexpected 
results or errors. These issues may not be supported by Avenza Technical Support.

Before installing MAPublisher, please ensure that these minimum system requirements are met (recommended  
requirements are mentioned as necessary):



17Chapter 1: Getting Started
Installation Instructions 

MAPublisher is licensed for use on a single computer and, once activated, will be node-locked and will only function 
on that computer. Therefore, before proceeding with installation and activation, please ensure that MAPublisher is 
installed on the appropriate computer.

Different versions of MAPublisher can be installed on the same computer if different versions of Adobe Illustrator 
are present. For example, MAPublisher 7.6 for Adobe Illustrator CS2 and MAPublisher 9.1 for Adobe Illustrator CS6.

It is not recommended to do so, but different releases of MAPublisher can be installed on the same machine. 
For example, MAPublisher 8.6 for Adobe Illustrator CS5 and MAPublisher 9.1 for Adobe Illustrator CS6. It is 
recommended to uninstall older versions of MAPublisher before installing the newest release. During the uninstall 
process, an option will be given to backup custom coordinates systems and MAPublisher LabelPro rules.

For users intending to use MAPublisher LabelPro, a system restart is recommended after installing MAPublisher. This 
ensures that included fonts are installed correctly.

WINDOWS

•	 �Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe 
Illustrator is running, exit the program.

•	 DVD version: Insert the MAPublisher 9.1 DVD. If Autorun is disabled on the system, navigate to the 
MAPublisher 9.1 directory on the DVD, and double-click the Setup.exe file.

•	 Electronic version: Double-click the mp91wi-e.zip file to open the WinZip self extractor. When the files are 
unzipped, proceed to the MAPublisher directory and double-click the Setup.exe file.

•	 Proceed through the installation screens as instructed. Options are given to install documentation and 
tutorial data. If these components are selected, the files can be subsequently be found here: Start > All 
Programs > Avenza > MAPublisher 9.1 > MAPublisher Tutorials. 

•	 Launch Adobe Illustrator. Proceed to the section about Registration and Licensing.

MAC OS X

•	 �Make sure that a compatible version of Adobe Illustrator is installed on the computer. If Adobe 
Illustrator is running, exit the program.

•	 DVD version: Insert the MAPublisher 9.1 DVD. Navigate to the MAPublisher 9.1 directory on the DVD, and 
double-click the Install MAPublisher 9.1 icon.

•	 Electronic version: Unstuff the mp91mi-e.dmg file if this operation has not been completed automatically. 
Then proceed to the MAPublisher 9.1 folder and double-click the Install MAPublisher 9.1 icon.

•	 Proceed through the installation screens as instructed. Note that documentation and tutorial data will 
also be installed. After installation, these files can be found in the Applications\Avenza\MAPublisher 9.1\
MAPublisher Tutorials . An Alias to this folder will be created at the end of the installation process which 
will be placed on the desktop.

•	 Launch Adobe Illustrator. Proceed to the section about Registration and Licensing..

Installation Instructions 
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MAPublisher Compatibility Notes 

MAPublisher Compatibility Notes 

MAPublisher 9.1 is compatible with Adobe Illustrator CS5, CS5.1 and CS6. Please read the following important 
compatibility information with respect to working with legacy MAPublisher and Adobe Illustrator documents.

BACKWARDS COMPATIBILITY

All MAPublisher documents are not backwards compatible with previous versions of MAPublisher. 

Saving the Adobe Illustrator document to an older version (e.g. saving a CS5 document as CS4) may have 
unexpected results, such as loss of data attributes. It is recommended to save a copy of the file in the current Adobe 
Illustrator version before attempting to save to a legacy version.

MAPUBLISHER 5 (OR EARLIER) DOCUMENTS

Point Data
MAPublisher introduced new standards on dealing with point data in MAPublisher 6. Pre-MAPublisher 6 documents 
will have font based points converted to symbols on opening of the document. 

MAPUBLISHER 6 (OR EARLIER) DOCUMENTS

Grids and Graticules
Grids and Graticules were redesigned in MAPublisher 7. Please note that grids created in previous versions of 
MAPublisher (6.x and earlier) will need to be recreated with the new tool if the generation of an index is required.

Legend to Stylesheet Conversion
Legend functionality (Assign Legend Info, Draw Legend etc) was ported into MAP Stylesheets in MAPublisher 7. 
Legend information held in legacy MAPublisher documents (6.x and earlier) will be converted into stylesheets on 
document open. Subsequently Graphic Styles (for line and area legends), Character Styles (for text legends) and 
Symbols (for point legends) will automatically be generated and added to the respective Adobe Illustrator panels.

To qualify for legend conversion, legend art in legacy documents must contain the following properties:
•	 Be of a valid art type: i.e. polygon, path, symbol or text
•	 Have a legend expression assigned (via Assign Legend Info or Auto Assign Legend Info)
•	 Have a target MAP Layer

During the conversion process you will be asked to set additional conversion preferences:
•	 Determine if target MAP Layers should be immediately assigned to the applicable stylesheet. Checking 

this option will immediately apply the new stylesheets to map art on target layers, whereas unchecking 
this option means the new stylesheets will not be applied on document open, allowing you to manually 
drag target layers into the applicable stylesheet later. Note auto assignment conversions are slower.

•	 �Determine if you wish to merge similar converted stylesheets (i.e. stylesheets with a matching feature 
type and original map layer) into a single stylesheet. Note this option will be disabled if it is not 
applicable.

Tables
Table information held on table layers (i.e. MPTables layers) will be removed on document open. Therefore ensure 
that all tables have been joined to the vector art prior to opening the document in MAPublisher.
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ALL MAPUBLISHER DOCUMENTS IN ADOBE ILLUSTRATOR 10 (OR EARLIER) FORMAT

Legacy Text Conversion
Adobe introduced new methods for dealing with text art in Adobe Illustrator CS. Therefore files containing 
MAPublisher text objects must be converted using Adobe Illustrator and MAPublisher text conversion utilities.

If the Adobe Illustrator legacy text conversion message appears when opening a legacy document, click OK. This 
will allow MAPublisher to use its own conversion utility to update text items while maintain the text attributes. If 
you click Update, the document will be opened, however all attributes associated with this text will be lost. 

At the MAPublisher Legacy Text Conversion dialog box, choose one of the following: 

All text art To convert both MAPublisher text and regular Adobe 
Illustrator text to the new Adobe Illustrator text format

MAPublisher text art only To convert only MAPublisher text to the new Adobe 
Illustrator text format

Nothing To open the file but lose attribute information 
associated with MAPublisher text elements

COMPATIBILITY WITH THIRD-PARTY PLUG-INS

All efforts have been made to develop MAPublisher in accordance with the Adobe Illustrator SDK and third-party 
development schema. However, Avenza cannot verify and validate compliance and compatibility with other 
third-party plug-ins that may be installed on your system and cannot guarantee that MAPublisher will perform as 
expected in such configurations. If you believe that a third-party plug-in is conflicting with MAPublisher, please 
contact support@avenza.com.
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MAPublisher License Management 

MAPublisher will not function until it is activated. MAPublisher is available in both single-user and floating license 
configurations. Floating licenses are designed to allow an organization to deploy a specific number of licenses 
that can be used and shared on any number of computers over a network. If you have purchased a floating license 
please refer to the floating license installation guide provided with your purchase. The instructions in this user 
guide are for the activation of single-user licenses of MAPublisher only.

IMPORTANT: Some peripheral components might interfere with the activation process. Before activating 
MAPublisher, users must temporarily unplug or disable: mobile phone, blue tooth, wireless or GPS systems. 
Laptop users with a docking station must activate MAPublisher in the undocked state.

After installing MAPublisher, launch Adobe Illustrator. The Welcome to MAPublisher dialog box will appear. When 
an Internet connection is enabled and the latest license is valid, MAPublisher will automatically activate from 
information provided by Avenza license servers.

This screen also provides several licensing options: Evaluate, Register, Retrieve and Floating. 

Note:	 To continue to use Adobe Illustrator without MAPublisher, cancel this dialog box and activate MAPublisher 
license later by navigating to the Help menu in Adobe Illustrator and then to MAPublisher Licensing > License 
Management. MAPublisher panels are marked with a lock icon when the software is not licensed.

MAPublisher welcome dialog box

MAPublisher License Management

Machine ID -  When moving or 
activating a license through 
the Internet or by e-mail, the 
computer's Machine ID here 
can be found here.

0022222c1111
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ACTIVATE AN EVALUATION VERSION OF MAPUBLISHER

1.	 After installation of MAPublisher, click the Evaluate button on the Welcome to MAPublisher or License Management 
dialog box. Complete the form and click Evaluate.

2.	 When you are ready to purchase the software you can open the MAPublisher License Management dialog box 
from Adobe Illustrator Help menu at MAPublisher Licensing > License Management, click Register button and 
follow the instructions in the next paragraph.

Note:	 A MAPublisher evaluation is fully functional. There are no limitations except that an evaluation license is only 
valid for 14 days from the day of activation.

REGISTER A PURCHASED COPY OF MAPUBLISHER

1.	 To register a purchased copy of MAPublisher, click the Register button in either the MAPublisher Welcome Screen 
or MAPublisher License Management dialog box. Enter the license key that was provided when the product was 
purchased. Complete the form and click Register.

Note:	 The license key for MAPublisher 9.1 starts with "MP9-".

RETRIEVE YOUR MAPUBLISHER LICENSE

To retrieve an activated MAPublisher license, click the Retrieve button in either the License Management dialog box 
or Welcome Screen. The license file will be downloaded from the Avenza Systems licensing server.

CHECKOUT A FLOATING LICENSE
If you have purchased a floating license, please refer to the floating license installation guide provided with your 
purchase. Once the server license is fully operational, follow these instructions to checkout a license from the client 
machine (the computer running the actual MAPublisher application).

1.	 After installation of MAPublisher, click the Floating button of the MAPublisher Welcome Screen or MAPublisher 
License Management dialog box.

2.	 Enter the name or IP address of the server where the license manager resides.

3.	 Click the Checkout button to retrieve the one of the licenses from the server. 

Notes:	 If you wish to use Adobe Illustrator without MAPublisher, then click the Check in button from the MAPublisher 
License Management dialog box (at Help > MAPublisher Licensing > License Management). This releases the 
license, so other users can use it.

The link to the server is set once. The next time Adobe Illustrator is started, just click the Checkout button on 
the MAPublisher Welcome Screen or License Management dialog box.
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MAPUBLISHER LABELPRO LICENSING

MAPublisher LabelPro is an optional add-on to MAPublisher (8.1 and newer). Purchased MAPublisher LabelPro 
licenses are added to the main MAPublisher license. During the registration process described earlier in this chapter, 
all valid licenses will be imported. When purchasing a new MAPublisher LabelPro license on top of an existing 
MAPublisher license, the existing license key will be tagged to support MAPublisher LabelPro and the new license 
must be retrieved (see instructions earlier).

To evaluate MAPublisher LabelPro, open the MAPublisher License Management dialog box from the Adobe Illustrator 
menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher LabelPro branch and 
then click the Evaluate button as previously explained.

Click the Log button to see more system information about the license status.

The evaluation version of MAPublisher LabelPro scrambles the text of placed labels but preserves the case, spacing 
and punctuation. The results give a sense of how actual labels would be placed based on the rule settings. See 
chapter 17 for more details on MAP LabelPro functionality and usage. 

Note:	 MAPublisher and MAPublisher LabelPro can only be both floating licenses or both local licenses (fixed or 
evaluation). A user on a floating license wishing to evaluate MAPublisher LabelPro will have their main 
MAPublisher and MAPublisher LabelPro licenses switched to a local evaluation license. At the end of the 
evaluation period, the settings for floating license can be reset as described above.

MAPUBLISHER FME AUTO LICENSING

MAPublisher FME Auto is an optional add-on to MAPublisher (8.6 and newer). It is used in conjunction with 
FME software to import data (see chapter 3). Purchased MAPublisher FME Auto licenses are added to the main 
MAPublisher license. During the registration process described earlier in this chapter, all valid licenses will be 
imported. When purchasing a new MAPublisher FME Auto license on top of an existing MAPublisher license, the 
existing license key will be tagged to support MAPublisher FME Auto and the new license must be retrieved (see 
instructions earlier).

To evaluate MAPublisher FME Auto, open the MAPublisher License Management dialog box from the Adobe 
Illustrator menu (Help > MAPublisher Licensing > MAPublisher License Management). Click the MAPublisher FME Auto 
branch and then click the Evaluate button.
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MOVE A LICENSE

To move a previously activated license to a new computer, use the following steps:

1.	 Uninstall MAPublisher from the current computer.

2.	 Install MAPublisher on the new computer.

3.	 Obtain the machine ID for the new computer (as found in the MAPublisher License Management dialog box 
started from the Adobe Illustrator Help menu at MAPublisher Licensing > License Management.)

4.	 Complete the on-line form at http://www.avenza.com/support/rehost-license. For offline users, call tech support.

LICENSE TROUBLESHOOTING

If you cannot register or retrieve an evaluation or purchased license from within MAPublisher (e.g. firewall 
limitations), visit the Avenza Systems website (www.avenza.com/activation) and provide the Machine ID displayed in 
the License Management dialog box. A zipped license file attachment will be sent to the registered e-mail address 
on record. Unzip this attachment and save the .lic file to the appropriate folder:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9
Windows Vista / 7: C:\ProgramData\Avenza\MAPublisher 9 
Mac OS X: Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In

To quickly access the MAPublisher license file directory, right-click a row in the License Management dialog box and 
click Browse to license folder. Copy or move MAPublisher license files directly into this location.

0022222c1111
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MAPublisher Tools

MAPublisher tools can be found in a number of locations in Adobe Illustrator*.

* Menus reflect Adobe Illustrator CS6.

MAPublisher Import Map Data can be 
found in the File menu

MAPublisher tools can be found in the Object > MAPublisher menu.

MAPublisher Preferences can be 
found in the Edit menu.
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MAPublisher tools can be found in the main Adobe Illustrator Tools panel.

Click and hold tool icon to open context 
menu to choose the related tool.

The MAPublisher panels can be found in the Window > MAPublisher menu.

MAP Area Tool (box) MAP Area Tool (ellipse)

MAP Vector Ellipse Crop Tool

MAP Contour Tagger Tool

MAP Vector 
Rectangle Crop Tool

MAP Measurement Tool

MAP Tagger Tool

MAP Location Tool
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The MAPublisher Toolbar provides easy access to launch the MAPublisher tools and panels. The toolbar was 
redesigned to match the light and dark user interface of Adobe Illustrator CS6. The toolbar is divided into eight 
sections: Import/Export, Properties,  Data Creation, Geoprocessing, Organization, Thematic Tools, Labels and Legend Tools.

The MAPublisher Toolbar can be saved in a workspace (Adobe Illustrator main menu Window > Workspace).

IMPORT/EXPORT

Simple Import

Advanced Import

Copy MAP Objects From

MAP Web Author

Export Geospatial PDF

Register Image

PROPERTIES

MAP Views

MAP Attributes

MAPublisher Log

MAP Locations

MAP Info

DATA CREATION

Area Plotter

Line Plotter

Georeference Data

MAP Point Plotter

MAPublisher Toolbar
Window > MAPublisher > MAP Toolbar
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GEOPROCESSING

Join Areas

Join Lines

Join Points

Simplify Lines

Flip Lines

Buffer Art

Crop To Shape

Vector Crop

ORGANIZATION

MAP Selections

Merge Layers

Split Layers

THEMATIC TOOLS

MAP Themes

Create Halo

Dash Offset

Scale & Rotate By Attribute 

LABELS

MAP LabelPro

Label Features

Right-to-Left Text

Create Knockouts

Text Utilities

LEGEND TOOLS

Grids and Graticules

Make Index

Create North Arrow

Scale Bar
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MAPublisher Preferences
Edit > MAPublisher Preferences (Windows)
Illustrator > MAPublisher Preferences (Mac)

MAPublisher Preferences are options that allow users to customize MAPublisher panels and editors, including those 
for layer ordering, font for attribute data display and panel style. Settings are available for the following categories:

•	 Expression Builder
•	 FME Auto
•	 General
•	 Import Map Data
•	 MAP Attributes (panel)
•	 MAP Crop Tool
•	 MAP Info Panel
•	 MAP LabelPro
•	 MAP Locations (panel)

•	 MAP Measurement
•	 MAP Selections (panel)
•	 MAP Themes (panel and editor)
•	 MAP Views (panel and editor)
•	 Online Maps
•	 Spatial Database (Basic Esri ArcSDE Server Editor, 

Esri Geodatabase Editor and General Spatial 
Database Editor). Windows only.

Property sheet specific to selected 
preference category appears here.

MAPublisher Preferences are saved in an Adobe Illustrator preference file called AIPrefs (Windows) or Adobe 
Illustrator Prefs (Mac), which is launched each time Adobe Illustrator is started. Therefore, MAPublisher Preferences 
are not file dependent. The Adobe Illustrator preference file is located in following directory:

Windows XP: C:\Documents and Settings\[user profile]\Application Data\Adobe\Adobe Illustrator CSX Settings\AIPrefs
Windows Vista / 7: C:\Users/[user]\AppData\Roaming\Adobe\Adobe Illustrator CSX Settings\AIPrefs
Mac OS X: Users/[username]/Library/Preferences/Adobe Illustrator CSX Settings/Adobe Illustrator Prefs

OPEN MAPUBLISHER PREFERENCES

MAPublisher Preferences can be opened from the Adobe Illustrator main menu, Edit > MAPublisher Preferences 
(Windows) or Illustrator > MAPublisher Preferences (Mac), from the panel options menu of the following MAPublisher 
panels: MAP Attributes, MAP Selections, MAP Themes and MAP Views, and by double-clicking the tools buttons: MAP 
Location and MAP Measurement.

When opened through the Adobe Illustrator menu, MAPublisher Preferences opens up with no category selected. 
When started from a specific MAPublisher panel options menu, MAPublisher Preferences open on the current panel 
property sheet. All preferences shown here are the default settings.
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MAPUBLISHER PREFERENCES SETTINGS

Clicking one of the MAPublisher category or sub-categories on the left hand list displays the corresponding 
property sheet displayed on the right. 

Expression Builder Preferences
The Expression Builder property sheet shows the settings relative to the Expression Builder dialog box used with 
the MAP Attributes, MAP Themes and MAP Selections panels (see chapter 5 for more information).

Maximum unique values - Set the 
maximum number of unique 
values visible in the Expression 
Builder (Expression Components > 
Description).

The default value is 1000, users with 
high performance computers can 
increase this number.

Maximum recent expressions: - Set the maximum number 
recent expressions displayed in the  Expression Library 
(Expression Components > Description).

General Preferences
The General property sheet is used to change the layer ordering rule for all MAPublisher panels. By default, layers 
are sorted alphabetically only. The other option is to first group layers by data type first (Legend, Text, Point, Line 
and Area) and subsequently in alphabetical order for each group.

Log notification level – What is recorded by 
the log. By default, Warnings & critical 
messages is chosen. If needed, choose  
No notification or Critical messages only.

Sorting Style - Set to Name, then type 
for an alphabetical sorting. Set to 
Type, then name to first sort the layers 
per data type (Legend, Text, Point, 
Line or Area) 

Format numbers for labeling operations and 
display purposes based on locale  
Change number labels based on 
country (e.g. 400.00 in USA compared 
to 400,00 in Norway)

Locale - This option affects how 
MAPublisher formats numbers (e.g. 
use comma or point as a decimal 
separator). Use the operating system 
local settings or specify a different 
language and country.

Preview quality - Adjust the 
preview quality within various 
MAPublisher dialog boxes

Add notes for layers created by MAPublisher 
operations - Enable to automatically create 
layer notes for MAPublisher operations

Pinned map units - The selected 
map units are listed first in 
the unit drop-down lists of 
MAPublisher (e.g. in Scale Bar 
or Buffer Lines dialog boxes)

Max recent map units - Maximum 
number of map units 
memorized by MAPublisher

Max recent map units - Maximum 
number of map units 
memorized by MAPublisher

Maintain point size/stroke weight/
rotation/text size when rescaling 
Scale changes (made in the 
MAP View Editor) that affect 
stroke, point and text sizes and 
rotation.
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Import Map Data Preferences
The Import Map Data preference category allows users to sort the order of the attributes columns upon import. 
By default, attributes are imported in the same order as in the source GIS data file and the MAPublisher #Property 
attributes are created in front of the imported attributes (see chapter 5 for additional information).

Attribute sort on import - Set to Do not 
Sort to maintain the attributes order 
of the source GIS file. Set to Order 
attributes alphabetically to apply this 
new ordering.

Property disposition on import - Set to 
Move properties to start or Move 
properties to end

Path corners - Set to Miter, Round or 
Bevel join

Path endings - Set to Butt, Round or 
Projecting cap

Append feature type as suffix on imported 
layer names - By default, the feature 
type is appended to the layer name 
(e.g. '_area' or '_point'). Clear this 
check box to prevent this behaviour.
Ensure imported layer names are unique 
By default, MAPublisher appends 
a number 1, 2 etc... to an imported 
layer name if the layer name already 
exists. Clear this check box to 
prevent this behaviour.

Show extensions in Format drop-down list 
By default, the Format drop-down 
list in the Simple and Advanced 
Import dialog boxes shows the 
format extensions (e.g. '.shp'). Clear 
this check box not to display format 
extensions.

Show full file name in Advanced 
Import table - The Advanced 
Import table shows the list of 
selected files for import. By 
default, only the file name is 
displayed. Check this option 
to display the full path.

Show extents in Advanced 
Import table - Check this 
option to display the 
data extents (lower left 
and upper right corners 
coordinates)

Import Geospatial PDFs 
Check this option 
enable the ability to 
import geospatial 
PDF documents.

Import Map Data > Web Services

WMS default output directory 
The default output directory 
for files generated by the 
Web Mapping Service 
import feature

WFS default output directory 
The default output directory 
for files generated by the 
Web Feature Service import 
feature

MAP Attributes Preferences
MAP Attributes Preferences

Replicate attribute data to compound path 
sub-components - Enable this option 
before editing the attribute schema 
so that the attributes do not get 
broken when releasing a compound 
path (see chapter 5)

Default string size - Specify the default 
string size applied when creating a 
new attribute of type  String

Default decimal count - Specify the default 
number of decimals applied when 
creating a new attribute of type  Real
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MAP Attributes > Panel

Table font – Set the text font for 
headers and attribute values

Show icons in column headers – Enable 
this option to display the data type in 
front of the attribute column name  
(  Boolean,  Integer,  Real, and

 String)

Table font size – Set the text font size

Show display names in column headers 
Enable this option to show the 
display name of a column header 
instead of the actual column name

Show recordset navigation – Enable this 
option to show navigation buttons in 
the MAP Attributes panel. Use them 
to scroll through attribute records.

MAP Crop Tool Preferences
The MAP Crop Tool preference category contains point text and path text crop type and crop method settings.

Point Text - Choose how 
point text is handled 
when intersected by a 
crop boundary

Path Text - Choose how 
point text is handled 
when intersected by a 
crop boundary

Points - Choose how points are 
handled when intersected by 
a crop boundary

Cropping Boundary - Adjust 
accuracy for vectorizing a 
bezier path when intersected 
by a crop boundary

Note:	 For Spatial Database spatial filter (crop on import option), there will be no point vectorizing and text will be 
cropped based on whether its bounding box touches the crop area.

MAP Info Panel
The MAP Info panel preference category contains general settings (see chapter 4).

Lat/Long display format- Set the latitude 
and longitude display format:
•	 Decimal degrees 
•	 Delimited Degrees Minutes Seconds 
•	 Degrees.Minutes 
•	 Degrees.MinutesSeconds 
•	 Packed DMS with decimal point
•	 Packed DMS 

Display precision - Set the number of 
decimals shown on the MAP Info panel
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MAP LabelPro Preferences
The MAP LabelPro preference category contains general settings to save the path access to saved rules, styles and 
symbol folders (see chapter 17 for more information on MAP LabelPro). 

Base rule folder – Directory path to the 
rule folder. Click the browse button 
to change the path.

Base style folder – Directory path to the 
style folder. Click the browse button 
to change the path.

Symbol folder – Directory path to the 
symbol folder. Click the browse 
button to change the path.

Ignore invisible artwork – This option 
ignores individual invisible artwork. If 
disabled, individual invisible artwork 
will be taken into account as labeling 
source and obstacle.

Leader line cap style 
Change the leader 
line cap style for 
enabled lines

Merge multiline text 
Merges multiple 
lines of text into a 
single line

Note:	 The default directories for the rule, style and symbol folders:

•	 Default rules and styles folders—respectively Rules and Styles subfolders in the directory: 
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9\LabelPro\.. 
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\.. 
Mac OS X: Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/LabelPro/..

•	 Default symbol folder: 
Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9\LabelPro\Symbols 
Windows Vista/7: C:\Program Files\Avenza\MAPublisher 9\LabelPro\Symbols 
Mac OS X: Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/LabelPro/Symbols

MAP Locations Preferences
The MAP Locations preference to control MAP Location labels, lat/long format and precision.

MAP Locations Preferences
MAP Location label policy – Control how 
the labels appear or disappear

Label proximity – Control how close 
the mouse cursor has to be before a 
label appears

MAP Locations > EditorMAP Locations > Clipboard
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MAP Measurement Preferences

The MAP Measurement category contains display settings for the MAP Measurement Tool (see chapter 7 for details).

Display precision - Set the number 
of decimals shown on the MAP 
Measurement annotations

Line colour - Set the color of the 
digitized measurement path

Positive angle direction - Set the 
positive angle direction as either 
counter-clockwise or clockwise

Show azimuths - Display forward 
and reverse azimuth when using 
the MAP Measurement tool

New line colour - Set the color of 
the current segment (between 
last digitized point and current 
mouse position)

Units - Choose to use the current 
layer's units or select a specific unit in 
the drop-down list
Calculation Method - Choose to calculate 
distance based on datum (geodesic) 
or map projection (Cartesian)

MAP Selections Preferences
The MAP Selections preference category does not contain general settings but has a sub-category for the MAP 
Selections panel (see chapter 11 for a full description of the MAP Selections panel).

Show selections on two lines - Enable 
this option to display the selection 
filter name and its expression on two 
separate lines. 

MAP Tagger Tool Preferences
The MAP Tagger Tool preference contains general setting for leader lines (see chapter 10).

Leader line attaches - Choose how the 
leader line attaches to the label: side 
of text or center of text.

Note:	 The Center of text setting does not work when labels are curved with lines of latitude.	
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MAP Themes Preferences
The MAP Themes preference category has a main property sheet and also contains a sub-categories for the MAP 
Themes panel (see chapter 9 for a full description of the MAP Themes editor and panel).

Maximum features to use in Rule Generator 
This option specifies the maximum 
number of unique values that can be 
generated by the Rule Generator.

Maximum data classes 
This option specifies the maximum 
number of data classes when that 
can be used with the Rule Generator.

MAP Views Preferences
The MAP Views preference has a sub-category for the MAP Views editor and panel (see chapter 4).

MAP Views > Editor
Start centered on - By default, the 
current artboard is centered in the 
preview area of the MAP Views dialog 
box. Change the option to have it 
centered on the current MAP View.

Show Lat/Long ordering option 
Enable this option to show the 
Latitude/Longitude ordering  
drop-down menu in the MAP Views 
dialog box. This effectively swaps the 
order of how latitude and longitude 
values are shown.

Online Maps Preferences

Online Map HTML file 
Choose a new HTML file to specify a 
different online map service. Leaving 
this blank will use the default online 
map service. 
 
Customization of the HTML file is 
required. Please contact Avenza 
Support for more information.
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Spatial Database Preferences
For Windows only. The MAPublisher Spatial Database preference category does not contain general settings but has 
three sub-categories: Basic Esri ArcSDE Server Editor, Esri Geodatabase Editor and General Spatial Database Editor (see 
chapter 3 for a full description of the MAPublisher Spatial Database).

Spatial Database > Basic Esri ArcSDE Server Editor

ArcGIS Bin Directory – Specify the 
location where the ArcGIS Bin 
directory is installed. Click the Browse 
button to open a folder browser and 
change the path.
Automatically connect to – Check this 
option to automatically connect to a 
specific server connection, selected 
in the drop-down list

Spatial Database > Esri Geodatabase Editor
Use alias as layer name – Enable this 
option to use feature class' alias 
name rather than its true name

Use abbreviated table name for layer name
ArcSDE geodatabases' tables 
are identified as databaseName.
userName.tableName. The 
abbreviated version uses only the 
table name as layer name.

If this option is used in combination 
with the "use alias" option, the alias is 
applied first.

Display coded domain/subtype description 
Option to import attributes with 
coded values from subtypes and 
attribute domains as follow: 
•	 Instead: replace the codes by their 

description (text)
•	 Never: import actual values—codes
•	 In Addition: create two attribute 

columns, one with coded values 
and one with descriptions

Load subtypes as separate layers 
Enable this option to use 

create new layers per subtype

Sort feature datasets alphabetically 
when selecting for import – Enable 

this option to sort feature 
datasets alphabetically in the 

import dialog boxes

Sort feature classes alphabetically when 
selecting for import – Enable this option 
to sort feature classes alphabetically 
in the import dialog boxes

Sort attributes alphabetically when selecting for 
import – Check this option to sort attributes 
alphabetically in the import dialog boxes

Number of points to use to specify a spatial filter 
bounding box – Choose either two opposite 
corner points or four sequential points.

Automatically connect to – Check this 
option to automatically connect to a 
specific server connection, selected 
in the drop-down list
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Spatial Database > General Spatial Database Editor

Number of SQL queries to remember
Select the number of queries 
memorized in the Recent category

Number of default datasets to remember 
Select the number of default datasets 
saved in memory for later use

FME Auto Preferences
The MAPublisher FME Auto preference category can be viewed in Chapter 3.

RESET MAPUBLISHER PREFERENCES TO DEFAULT SETTINGS

MAPublisher Preferences can be reset directly from the MAPublisher Preferences dialog box. A right click on a 
category will display the choice to reset the preference setting of this category or the entire MAPublisher Preferences.

MAPublisher Preferences will also be reset if the Adobe Illustrator preferences are reset or deleted. Adobe often 
recommends this to solve some problems with the application. Adobe Illustrator preferences are reset by doing one 
of the following:

•	 Press and hold Alt+Control+Shift (Windows) or Option+Command+Shift (Mac) as Adobe Illustrator is starting. 
The current settings are deleted.

•	 Remove or rename the AIPrefs file (Windows) or Adobe Illustrator Prefs file (Mac). New preferences files 
are created the next time Adobe Illustrator is restarted.
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MAPublisher Log
Object > MAPublisher > MAPublisher Log or MAP Toolbar  

FUNCTIONALITY

The MAPublisher Log records information about which MAPublisher tools are used, when they were used, and on 
which MAP layers.

USING MAPUBLISHER LOG

To view the MAPublisher Log dialog box, click the MAPublisher Log button on the MAPublisher Toolbar or click  
Object > MAPublisher > MAPublisher Log.

When a MAPublisher tool is used, information such as the tool used, inputs, outputs, warnings and errors are 
recorded into the log.  The log also displays when tools were executed and which layers were involved. However, 
not all MAPublisher tools are recorded as a log entry (such as MAP Tagger Tool, MAP Locations, MAP Selections, 
and MAP Web Author). Certain MAPublisher tools may yield warning messages after completing a process (e.g. 
MAPublisher LabelPro). 

Use the Show toggles to filter information, warning and critical messages.

Click the Export button to export the entire log to a text file.

A maximum of 10,000 messages can be logged. Click the Clear button to remove all messages from the log. This is 
permanent and cannot be undone.

Zoom to/Clear Selection/Add To Selection/
Remove From Selection - Controls to 
view art objects and layers

Log items - Messages about used 
MAPublisher tools are logged 

here. Scroll to the right to view 
details about each tool.

Show information/warning/critical 
messages - Toggle the filters to 

show different message types

Export - Export the list to a text file
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Preparing the Workspace 

Before using MAPublisher, you must first set up your Adobe Illustrator document. It is at this point that you define 
your page size and units, set your print orientation and generally prepare your Adobe Illustrator workspace.

Establish the desired page size and orientation before importing map data as MAPublisher will establish 
georeferencing based on the current page. However editing page dimensions after import will maintain correct 
georeferencing based on the new page dimensions.

Note:	 If no document is open, MAPublisher Simple and Advanced Import initiate the New Document dialog box.

SETTING UP A DOCUMENT

1.	 Create a new Adobe Illustrator document by selecting File > New, or Select File > Document Setup if you already 
have a blank document open - The Adobe Illustrator Document Setup dialog box appears.

2.	 Select the size to use for your page. Letter (8.5” x 11”) is the default size*. You may wish to change the 
orientation to landscape for some files. For example, a map of Chile may be best displayed in portrait but a 
map of Indonesia may be best displayed in landscape.

3.	 Select your desired page units. The default unit type is Points.

4.	 Ensure the page origin is at 0,0. To do this, select View > Show Rulers. Double-click the top left corner of the 		
rulers where the vertical and horizontal rulers intersect.

For more information and details regarding these operations please refer to your Adobe Illustrator User Guide.

* In step 2 the default page size of 8.5” x 11” is for North American versions of Adobe Illustrator. Other language versions 
of Adobe Illustrator may have different default page sizes. Consult your Adobe Illustrator User Guide for more information.

Notes:	 Note that the maximum length and width dimension for an Adobe Illustrator document is 227.54 inches. 
 
Adobe Illustrator CS5 introduced a function called Duplicate Artboard and should be used with caution 
because it also duplicates art and moves it on the page. However, the duplicated art reference is the same 
geographic frame as the original art (they are contained in the same layer). Therefore the geographic 
position of the duplicated art will not be correct.
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MAPublisher imports and exports many of the leading GIS 
industry file formats.

Import Formats
Adobe Geospatial PDF (pdf )
AutoCAD Drawing/Exchange (dxf, dwg)
Delimited Text Data (txt, csv, tsv)
Digital Line Graph (dlg, opt)
Esri ArcInfo Generate (gen)
Esri Interchange File (e00)
Esri Shapefile (shp)
Esri ArcMap Document (mxd)
FME Feature Store (ffs)
Geography Markup Language (gml)
GPS Exchange Format (gpx)
Image (multiple formats)
Google Earth (kml, kmz)
MapInfo Interchange Format (mif )
MapInfo Table (tab)
Microsoft Excel (xls)
MicroStation Design (dgn)
International Hydographic Office S-57 (000)
Spatial Data Transfer Standard (SDTS) (ddf )
TIGER/Line (rt1, bw1)
Web Feature Service
Web Map Service
Basic Esri ArcSDE Server
Basic Personal Geodatabase Reader (mdb)
Esri ArcSDE Geodatabase
Esri File Geodatabase (gdb)
Esri Personal Geodatabase (mdb)

Export Formats 
Adobe Geospatial PDF (pdf )
AutoCAD Drawing/Exchange (dwg, dxf )
Delimited Text Data (txt, csv, tsv)
Esri Interchange File (e00)
Esri ArcInfo Generate (gen)
Esri Shapefile (shp)
Geography Markup Language (gml)
Google Earth (kml, kmz)
MapInfo Interchange (mif )
MapInfo Table (tab)
Microsoft Excel (xls)
MicroStation Design (dgn)

Map Data File 
Formats
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This section provides an overview of the supported formats. For an in-depth analysis of further considerations when 
using these formats during Import, please see appendix A1.

DATA FORMAT DESCRIPTIONS

Adobe Geospatial Portable Document Format (pdf)
Import and Export
The geospatial PDF is considered an Adobe Acrobat Portable Document Format (following the PDF 1.7 specification) 
that contains information that is required to georeference location data. It is an open specification developed and 
maintained by Adobe Systems. See detailed specifications in Section 8.3 at http://www.adobe.com/devnet/acrobat/
pdfs/PDF32000_2008.pdf.

AutoCAD Drawing (dwg) and Drawing Exchange (dxf)
Import and Export
These file types are most commonly created by Autodesk AutoCAD product, though other computer-aided design 
(CAD) programs such as Bentley MicroStation capable of creating them. Two formats are used by AutoCAD: DXF 
(drawing exchange format) files and ASCII representations of the binary DWG (drawing) files. Logically, both files are 
identical and MAPublisher treats both file types in the same manner. AutoCAD files consist of drawing settings and 
configurations, as well as a series of entities, or graphic elements, organized into layers. MAPublisher provides broad 
support for many AutoCAD entity types and options. Prior to import, set the colour mode of the Adobe Illustrator 
document to the same scheme used in the colour table of the CAD file (RGB or CMYK) to ensure colours are 
imported correctly. Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, 
then line, then area layers. Annotation objects are converted to a point containing attribute information including 
the text value to be labeled and its angle. Certain symbols may import as "exploded" objects in MAPublisher. 

Delimited Text Data (txt, csv, tsv)
Import and Export 
MAPublisher also supports the import of Delimited Text Data held in a variety of tabular file formats, as long as the 
data contains coordinate values. File types supported are Text (txt), Tab Separated (tsv) and Comma Separated (csv) 
files. Import Settings dialog box: In order to import point data with MAPublisher the parameters must be set by 
clicking the Settings’ button. This operation is required to choose the columns of the selected attribute file that will 
be used to derive the X and Y coordinates of the data, and ensure correct georeferencing. These and further settings 
are discussed in chapter 6 and in the Delimited Text Data Settings section in appendix A1.

Digital Line Graph (dlg, opt)
Import only
The USGS (United States Geological Survey) DLG file structure is designed to accommodate categories of spatial 
data represented on a conventional line map. Node (point), line, and area data types are accepted. The attribute 
coding scheme is designed to accommodate basic cartographic data categories such as hypsography, hydrography, 
or political and cultural features, as well as additional thematic data categories.

Import and Export Supported Data Formats 
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Esri ArcInfo Generate (gen)
Import and Export
ArcInfo Generate files are created by Esri ArcInfo product, and have a simple ASCII from x-y to x-y format. Due to its 
simplicity you can also use a text editor such as Notepad to create text files and save them with a GEN extension, 
which can then be imported with MAPublisher. 

Esri Interchange File (e00)
Import and Export
Esri Interchange File files are created by Esri ArcInfo product. A single E00 file describes a complete ArcInfo 
coverage. The file itself is actually an archive of several smaller files, or sub files, which will have fixed names and 
follow a predefined data format. MAPublisher will reproduce these sub files as distinct Adobe Illustrator layers on 
import. Therefore importing a single e00 import can result in the generation of point, area, line and text layers.

Note the hierarchy of layers in multi-feature imports is by feature type: text layers, then point, then line, then area layers.

Esri Shapefile (shp)
Import and Export
Shapefiles are most commonly created by Esri ArcGIS or ArcView. Shapefiles store both geometry and attributes for 
features, and a single shapefile will consist of at least three physical files: the SHP portion contains the geometric 
data, the DBF contains attributes for the geometric data, and the SHX contains the index information. There is often 
a PRJ file, which stores coordinate system information and is automatically read by MAPublisher on import. If a 
shapefile folder does not contain a PRJ file, a coordinate system should be specified in MAPublisher. The important 
things to remember when importing shapefiles are that the SHP file must be the one that is selected through 
the MAPublisher import filter and that all its component files must be in the same folder. You may also find that 
a shapefile directory includes two extra files, a SBN and a SBX, which hold the spatial index for the geometric 
data. These two files will not exist unless the shapefile was created with an Esri product, and are not necessary for 
successful import with MAPublisher.

Esri ArcMap Document (mxd)
Import
ArcMap Documents (MXD files) contain information describing the map, page layout, layers associated with it, 
and any objects inserted into the map. The MAPublisher Simple and Advanced Import are used to import ArcMap 
Documents. Due to certain limitations, only the coordinate system, layer order and map data are retained when 
importing an ArcMap Document. Any styles, such as strokes, fills and patterns are not preserved. In addition, to 
import ArcMap documents, at least ArcGIS 9.x must be installed.

FME Feature Store (ffs)
Import
FFS stands for FME Feature Store. This format is a memory dump of FME features; so it supports the complete FME 
data model and can hold anything that FME features carry. This makes the format attractive as a holding spot for 
data that should persist between FME runs.

MAPublisher-FME Auto is a plugin for MAPublisher. It is already installed with MAPublisher and requires activation 
through MAPublisher Licensing. See chapter 3 for more information about FFS import and MAPublisher-FME Auto.
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Geography Markup Language (gml, xml)
Import and Export
The Geography Markup Language (GML) was designed as a geographic interface language for the Geo-Web. It is 
currently in draft as an ISO standard (ISO 19136). The goal of the format is to provide users with a set of abstract 
base objects that can be built into working real world dataset. It uses an XML base to store geometry and feature 
information that can easily be transported across the Internet. 

The GML Simple Feature Profile was created by the Open Geospatial Consortium (OGC) as a restricted but useful 
subset of the GML specification. It provides a reduced geometry and metadata profile that can be shared across 
many GIS tasks. This simple feature model can be used as a base to generate local application profiles for a specific 
work area. Since the GML models base abstract classes, these application profiles (schemas) are required for 
accessing and processing any GML datasets. GML data has a GML extension, and requires a attributes schema file XSD. 
Some GML files may have their XSD file referenced to a URL path, we recommend to copy the XSD files locally, to 
avoid error messages upon import when no internet connection is available.

Users have two options to store their GML and XSD files: they can be both located in a same directory or the XSD 
files can be kept in the MAPublisher GML Schema directory found here:

Windows XP, Vista and 7: C:\Program Files\Avenza\MAPublisher 9\Data Source Files\GMLSchema
Mac OS X: /Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/Data Source Files/GMLSchema

The second option is the most practical if all the GML files are using a same schema (only one instance of the XSD 
file needs to be saved). Installed with MAPublisher are three default XSD files: 

•	 xml.xsd, generic GML attribute schema. 
•	 nen3610.xsd and top10nl.xsd, models standardized in the Netherlands (maintained by the Dutch 

topographic office Kadaster). 

GML files with a missing XSD file or with an invalid attribute schema will cause a GML validation error upon import 
(see chapter 3). Users have the option to find the appropriate XSD file and copy it to the GML Schema directory or 
to the GML file directory. This option will assign a type string to all attributes. See chapter 3 Importing Map Data for 
more details on these settings. 

MAPublisher supports the import of simple features (points, lines, polygons, donuts, and aggregates) in GML 2.0 
and later versions. MAPublisher supports export to GML 3.1.1. 

Google Earth (kml, kmz)
Import and Export
Keyhole Markup Language (KML), is an XML-based language for managing the display of three-dimensional 
geospatial data in the programs Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies 
a set of features for display. Each feature always has a longitude and a latitude and can have other data, such as tilt, 
heading, and altitude. KML shares some of the same structural grammar as GML. KML files are very often distributed 
as KMZ files, which are zipped KML files with a KMZ extension. MAPublisher imports and exports both file type 
based on the KML version 2.2 specifications.
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GPS Exchange Format (gpx)
Import only
GPS Exchange Format (GPX for short) is a light-weight XML-based data format designed for the interchange of GPS 
data. MAPublisher supports GPX schema version 1.1. 

Image (png, jpeg, jpg, jpe, tif, tiff, gif, jp2, jpf, jpx, j2k, j2c, jpc, psd, pdd, bmp)

Import only
Referenced raster files of the above mentioned formats can be imported and placed directly into a MAPublisher 
MAP View from the Simple and Advanced Import tools. These images have the option to be linked or embedded 
into Adobe Illustrator upon import. Images cannot be reprojected by MAPublisher in Adobe Illustrator. Use 
Geographic Imager or another third-party software to properly reproject geospatial images.

International Hydrographic Office S-57 (000, 030)
Import only
S-57 is referring to the IHO (International Hydrographic Office) Special Publication number 57 related to the IHO 
transfer standard for Digital Hydrographic Data . Maintained by the IHO, S-57 format is intended for the exchange of 
digital hydrographic data between national hydrographic offices and for its distribution to manufacturers, mariners 
and other data users. It is used for the supply of ENC cells (Electronic Navigational Charts) to ECDIS (Electronic Chart 
Display and Information System). The objects spatial geometry can be of Point, Line or Area geometry, while object 
descriptions are categorized in object classes, organized in specific attributes schemas. To make full use of this 
format, refer to the online object catalog available on www.s-57.com.

MAPublisher imports non-encrypted S-57 data into MAP layers named per S-57 object acronym, of type Area, Line 
or Points. All S-57 Attributes are converted into MAP Attributes.

An Adobe Illustrator template is supplied to automatically style the map after import. The template contains a series 
of MAPublisher stylesheets linking S-57 imported features to nautical symbols and graphic styles (libraries provided 
by Avenza). This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 
format to interpret the data contents more easily. The S-57 template and the symbols and graphic styles libraries 
can be found in the MAPublisher Helpful Styles & Symbols folder (see Appendix 4).

MapInfo Interchange  Format (mif)
Import and Export
Files of this type are most commonly created by the MapInfo product, though other products, including 
MAPublisher, are also capable of generating files in this format. These files exist in pairs where each file has the same 
name but ends in either a MIF or MID file extension. The MIF portion contains the vector geometric data, and the 
MID contains the associated attributes. Both files are required in order to successfully import a file of this format to 
Adobe Illustrator using MAPublisher. The important things to remember when importing MapInfo files are that the 
MIF file must be the one that is selected through the MAPublisher import filter and that both files must be in the 
same folder. MAPublisher will automatically locate and deal with the MID file.
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MapInfo Table (tab)
Import and Export
The TAB format is a simple, non-topological format for storing the geometric location and attribute information 
of geographic features, and is an integral part of the MapInfo product. The TAB format defines the geometry and 
attributes of geographically-referenced features in several files with specific file extensions that are stored in the 
same folder on disk:

•	 .tab: main file, table structure in ASCII format.
•	 .map: the file that stores the feature geometry.
•	 .id: the file that stores the index of the feature geometry.
•	 .dat: the dBASE file that stores the attribute information of features.
•	 .ind: table field indexes (if necessary)

The geometry of each feature is stored as a shape that comprises a set of vector coordinates. The attributes for each 
feature are stored as a record in a dBASE table (dat) associated with the shapefile (map). There is one record in the 
dBASE table for each feature in the map file. Raster TAB files cannot be imported in MAPublisher.

To ensure successful import, select the TAB component in the MAPublisher importers.

Microsoft Excel (xls) 
Import and Export 
Import geographic point data from an Excel spreadsheet (version 2007 and earlier only;  XLSX is not supported) 
that contains latitude and longitude entries for each row.  In order to import point data, click the Settings button in 
the Import dialog box to choose which columns will be used to as the X and Y coordinates of the data, and ensure 
correct georeferencing. Further settings including other types of are discussed in Appendix A1.

MicroStation Design (dgn)
Import and Export
MicroStation Design files (dgn) are the native files created by Bentley Systems Inc. (and formerly Intergraph) 
MicroStation product. Design Files consist of a header, followed by a series of elements. The header contains global 
information including the transformation equation from design units to user coordinates, as well as the dimension 
of the elements in the file. Each element contains standard display information, such as its colour, level, class, and 
style, as well as a number of attributes specific to its element type. During the import process, MAPublisher will 
produce one layer for each Level that exists in the MicroStation Design File. Annotation objects are converted to a 
point containing attribute information including the text value to be labeled and its angle.

MAPublisher supports the import of MicroStation J (version 7 and 8) files, however attached raster file will not 
be imported (ignored). Prior to import, the colour mode of the Adobe Illustrator document should be the same 
scheme used in the colour table of the original file to ensure that the colours are interpreted correctly.

The hierarchy of layers in multi-feature imports is by feature type in the following order: text layers, then point 
layers, then line layers, then area layers. Raster files attached to DGN files are ignored during the import process.
Files are exported from MAPublisher as MicroStation J files. Upon export, users may select a DGN seed file. All 
information  in the seed file gets carried over to the output file, such as level (layer) definitions, units, colors, line 
styles definitions, etc. If an exported layer name matches a level name in the seed file, the data of that layer is 
appended to the existing level, if not, a new level is created. 
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Spatial Data Transfer Standard (SDTS) (catd.ddf)
Import only
Digital cartographic products of the USGS are available in the Spatial Data Transfer Standard format, and are 
generally distributed over the Internet as a means of promoting the standard. For SDTS import, select the catd file 
(xxxxcatd.ddf ), which is the index file that contains a description of the other files in the SDTS transfer. Individual 
DDF files cannot be imported. Generally all SDTS downloads will contain the CATD file.

TIGER/Line (rt1, r*1, bw1)
Import only
TIGER is an abbreviation of Topologically Integrated Geographic Encoding and Reference System, and was developed 
by the U.S. Census Bureau. TIGER/Line files are a digital database of geographic features, such as roads, railroads, 
rivers, lakes, political boundaries, census statistical boundaries, etc., that cover the entire United States. The 
database contains information about these features such as their location in latitude and longitude, the name, the 
type of feature, address ranges for most streets, the geographic relationship to other features, and other related 
information. TIGER/Line files are the public product created from the Census Bureau TIGER database of geographic 
formation. TIGER was developed in order to support the mapping and related geographic activities required by the 
census and sample survey programs. More information on the TIGER/Line file format and data product can be found 
on the US Census web page at: http://www.census.gov/geo/www/tiger/

MAPublisher considers the RT1 or BW1 file as the TIGER dataset. Even though each county will consist of a series 
of files with a common base name, there may be a number of different extensions. Remember to select the RT1 or 
BW1 file when importing TIGER data. 

Web Feature Service
Import only
Web Feature Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS vector 
data transactions across the Web. The MAPublisher WFS import connects to servers that use versions 1.0.0 and 1.1.0 
of the OGC standard. WFS servers provide GML files, which are read using the MAPublisher GML importer. The GML 
importer supports the GML simple features 2.0+ profile. 

As the WFS importer is read-only, WFS-T is not supported. See Web Feature Service in Chapter 3 "Importing Map 
Data" for information on WFS parameters.

Web Map Service
Import only
Web Map Service is an interface standard designed by the Open Geospatial Consortium (OGC) for GIS raster data 
transactions through http protocol. The MAPublisher WMS import connects to servers that use version 1.1.1 of the 
OGC standard. WMS data formats include PNG, JPG, TIF and GeoTIFF. See Web Map Service in Chapter 3 "Importing 
Map Data" for information on WFS parameters.
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Basic Esri ArcSDE Server†

Import only
ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS 
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft 
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise.  The Basic 
Esri ArcSDE Server import option allows users who have a free Esri desktop application called ArcReader to import 
feature classes from ArcSDE geodatabases, but with some limitations on the selection functions — see chapter 3 for 
more information on spatial databases.

† Basic Esri ArcSDE Servers are not supported on Mac due to limitations of the related Esri libraries.

Basic Personal Database Reader (mdb) (Mac supported)

Import only
The basic personal geodatabase reader can import basic feature class geometries and attributes on systems that 
do not have an Esri license. This makes it possible, for the first time, to open .mdb on Mac systems. The basic reader 
provides limited import capabilites supporting geometries and attributes not annotations or subtypes. Spatial 
Filters can be specified and SQL queries are supported on PC only.�

Esri ArcSDE Geodatabase†

Import only
ArcSDE geodatabases are multi-user Esri spatial databases, that allow users to store, use, and manage their GIS 
data in one of the following commercial database management systems (DBMS): IBM DB2, IBM Informix, Microsoft 
SQL Server, or Oracle. They are available in three levels of flexibility: desktop, workgroup and enterprise. The Esri 
ArcSDE geodatabase import option allows users who have ArcGIS software and a valid license to import all ArcSDE 
geodatabase types with advanced options for the selection — see chapter 3 for more information on spatial 
databases.

† Esri ArcSDE geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri File Geodatabase† (gdb)
Import only
A File geodatabase is a native Esri single-user spatial database. It is a collection of various types of GIS datasets held 
in a file system folder. This is the recommended native data format for ArcGIS. Importing this format requires ArcGIS 
software and a valid license — see chapter 3 for more information on spatial databases.

† Esri File geodatabases are not supported on Mac due to limitations of the related Esri libraries.

Esri Personal Geodatabase (mdb)
Import only
A Personal geodatabase is a native Esri single-user spatial database. This is the original data format for ArcGIS 
geodatabases stored and managed in Microsoft Access data files. Importing this format requires ArcGIS software 
and a valid license — see chapter 3 for more information on spatial databases.

† Esri Personal geodatabases are not supported on Mac due to limitations of the related Esri libraries.
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OTHER SUPPORTED FILES

MAPublisher also supports Adobe Illustrator (ai) files created by Cartographica, a third-party GIS software.
Cartographica users who wish to use files in MAPublisher must check the Include data in export option during export.

MAPublisher reads Adobe Illustrator files exported by Cartographica and extracts the geospatial information to 
convert it into layers and MAP Views—including projection, map scale and page position. However, there may be 
limitations when working with these files and it is recommended that they be saved as the latest version of Adobe 
Illustrator files compatible with your system (this is required before exporting to geospatial PDF).

DATA CONSIDERATIONS

When obtaining GIS data for use with MAPublisher, whether from an online source, commercial vendor, 
government office or from a source within your organization, there are a number of important considerations to 
keep in mind.

First and foremost, obtain data in one of the formats supported by the MAPublisher. In cases where the file format 
native to a particular mapping application is not supported by MAPublisher, you can often request the data 
provider to export a file in one of the supported formats.

When obtaining data you should acquire as much metadata about the files as possible. MAPublisher deals with 
data in the following manner: Unprojected data will be imported by MAPublisher with latitude and longitude map 
anchors, which will therefore range from (x) -180 to 180, (y) -90 to 90. 

If you receive projected data you should be aware of the following. MAPublisher will import projected data 
with a true scale and appropriate map anchors. Unlike unprojected data, these map anchors will not be in lat/
long, but rather in a coordinate system appropriate for the particular projection. For most file formats the name 
of the projection, datum, and units will be recognized by MAPublisher. However if the program cannot find this 
information in the data, and you wish to subsequently reproject your data, you will be required to specify the 
coordinate system.

In addition, MAPublisher is a two dimensional mapping program. If you attempt to import 3D data with 
MAPublisher it will be converted to two dimensional artwork by the importers. Data provided in a generic latitude 
and longitude (unprojected) coordinate system will usually be recognized as a WGS 84 (World Geodetic System 
1984 - EPSG = 4326) coordinate system by the MAPublisher importers.
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ADOBE ILLUSTRATOR 64-BIT DATA IMPORT LIMITATIONS

This occurs on MAPublisher 9.x for Adobe Illustrator CS6 64-bit, the following data formats are not supported:
•	 Esri ArcMap Document (mxd)
•	 Basic Esri ArcSDE Server, (connection to arcServer with only ArcInfo installed libraries)
•	 Esri ArcSDE Geodatabase
•	 Esri File Geodatabase (gdb)

  
To import the any of the above formats, the suggested workaround is to run MAPublisher 9.x for Adobe Illustrator 
CS6 32-bit. Import any of the formats listed above, save and close the Adobe Illustrator file, re-open it with 
MAPublisher 9.x for Adobe Illustrator CS6 64-bit, and then save it. This will ensure that a 64-bit workflow is used for 
the document.

Esri Personal Geodatabase (mdb) is supported only if the Microsoft Access Database Engine 2010 Redistributable is 
installed. Download the redistributable at http://www.microsoft.com/en-us/download/details.aspx?id=13255.

Note:	 This only affects Windows 64-bit operating systems.
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The Import functions are the starting point for most users 
wanting to work with GIS map data in Adobe Illustrator. These 
functions are used to import GIS data, set the initial map scale 
and define your cartographic workspace to start making maps.

The topics covered in this section:
Simple Import
Advanced Import
Web Feature/Map Service
Spatial Databases
Geospatial PDF Import
MAPublisher FME Auto and FME FFS Import

See chapter 2 for detailed descriptions of formats that 
MAPublisher can import.

Importing 
Map Data
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Coordinate System Information - This 
area shows information about the 
coordinate systems. (i.e. Name, 
Type, Envelope, EPSG Code). To 
choose a known source coordinate 
system select it from this list.

Search - Click this button and your 
search results will be populated

Simple Import 
File > Import Map Data > Simple and MAP Toolbar   

Format - Select the data format 
type to import. This drop-down 

list shows all MAPublisher 
supported data types.

Dataset - Displays the directory 
path and filename for the currently 

selected file(s). You can also 
manually type in the dataset 

location here.

Settings - Open the Settings dialog 
box for a file format. Extra parameter 
settings for the import of DGN, DXF, 
DWG, E00, GML/XML, KML/KMZ, 
Image, TAB, WFS, and Delimited XY 
Text Data (see next page).

Browse - Open a Data Source browser 
to select files for import

Encoding - Assign a codec if the 
attribute information held in the 
selected dataset uses a double byte 
character set

Source Coordinate System - Provides 
a description of the coordinate 

system and units detected in the 
data source. If the coordinate system 

of the selected file(s) is known, but 
it was not automatically detected 

by the program, click here. This will 
open the Specify Source Coordinate 

System dialog box (below).

Specify Source Coordinate System

Coordinate Systems - Choose a 
category appropriate to the 

data to be imported. To view 
all of the coordinate systems 

select *All*. For a list of the 
last 10 coordinate systems 

used, select *Recent*.

Search - Specify a text string 
to search the database 
for coordinate systems. 

Results are displayed in the 
*Search* category.

RELATED TOOLS

Accessed by clicking the source coordinate system link.

Clear - Clear the 
existing source 
coordinate system

From File - Choose a coordinate 
system from another file

View Coordinate System 
Information - View more 
information about the 
current coordinate system

Same as - Check this option in 
order to assign a coordinate 
system that matches that of an 
existing MAP View. Enabled when 
another MAP View is present.

Dataset Coordinate Systems
Automatically opens if multiple datasets have been selected which do not have a matching coordinate system.

Dataset - List of all the datasets 
selected for import

Coordinate System - List the coordinate 
system of each individual dataset
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White Lines and Fills - Set the option:
•	  Import as is: import the data 

true to the original colour 
settings contained in the file. 

•	 Change white lines and fills 
to black: import black lines 
instead of the files native 
white lines.

•	 Create black background: 
incorporate a layer containing 
a black background, to mimic 
the AutoCAD environment.

Group Entities - Group entities by 
layer name or geometry

Read Hatches - Read the hatch 
pattern on import

AutoCAD Drawing/Exchange Settings

Add to - Add the incoming data file to a 
matching MAP View

Fit to page based on new MAP View - Create a 
new MAP View for the imported data. 

Existing data and incoming data will be 
treated separately in terms of page scaling 

and position

Matching MAP View

MAP View list - Select the matching coordinate 
system that you wish to align the incoming 
data to.

Resize MAP View to fit - Check this box to scale the 
matching data so that both the selected layer and 
the incoming data fit inside the page extents.

Automatically opens if there is an existing coordinate system in the document that matches the incoming data.

Delimited Text Data Settings

Longitude/Latitude or X/Y Columns 
These two drop-down lists hold 

the names of all the numeric 
columns in the selected file. 

Select the columns containing 
the coordinate information.

Use first line as a header - Enable 
this if the first line of the text 

file contains column headings.

Specify Schema - Specify the data 
schema type for attributes in the 

delimited text data set

Coordinate Format - Select the coordinate format of the data to be 
imported (e.g. Decimal Degrees, Packed DMS. See chapter 6).

X-Y Coordinate Ordering 
Change the order of 
X and Y coordinates. 

This may help 
when an external 

program exports X-Y 
coordinates in reverse.

X-Y Coordinate Ordering 
Change the order of 
X and Y coordinates. 

This may help 
when an external 

program exports X-Y 
coordinates in reverse.

Geography Markup Language Settings Web Feature Service Settings

IMPORT SETTINGS
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Google Earth Settings

Image Settings

Allow random colour mode   
Enable this option to 

generate random colour 
settings for the data

Expand network links 
Enable this option to 

use of network linked 
KML files

Automatically apply Symbols 
when possible 

Enable to use Symbols 
from Google Earth

Image placement  
Embed the image 

into the document 
or Link to it. Please 

see note about 
transparency.

Import KML properties as visible attributes - Enable 
this option to import KML-specific attributes 
into the MAP Attributes panel as visible 
entities. When this option is disabled, these 
KML attributes are imported but are hidden 
in the MAP Attributes panel

The KML attributes are Description and 
Address which are displayed  in the MAP 
Attributes panel as kmlDescription (object 
description) and kmlAddress (object address). 

Drop complex Chains 
Component of a complex 
chain returned as its own 

feature. Otherwise all 
elements of the complex 

chain will be merged into a 
single linear feature.

Ignore tags on import - Ignore 
any tags on import so that it 

does not affect spatial extent.

Create groups for like text 
Text in the same graphic 

group or the same text node 
will be grouped in Illustrator

Group Elements - Choose how to 
group the elements.  

If elements are grouped by 
level, it may result in a large 

number of output files.

Coordinate Units - Specify how 
feature coordinates will be 
interpreted and converted.

MicroStation Design Settings

White Lines and Fills - Set the option:
•	  Import as is: import the data true to the 

original colour settings contained in the file. 
•	 Change white lines and fills to black: import 

black lines instead of the native white lines.
•	 Create black background: incorporate a layer 

containing a black background, to mimic the 
Microstation environment.

Ignore TIC Layer - Enable 
this to suppress creating 

of _tic_point layer. Disable 
to create a layer holding the 

registration control points. 

Esri Interchange File Settings

Pen and Brush Patterns 
Enable this to view the 
pen and brush pattern 
values in the imported 

attribute table.

MapInfo TAB and MIF Settings

Basic Esri ArcSDE Server, Esri ArcSDE Geodatabase, 
Esri File Geodatabase and Esri Personal Geodatabase

Unicode database - Unless specific issues 
importing converted geodatabases, 

keep this option as default. 

Use locale to decode - This option might be 
required if the geodatabase was created by 
converting a file in a format not supporting 
unicode (e.g. Esri shapefile) and if it contains 
non-ASCII characters.

Locale - Specify the locale name (e.g. en-US), 
leave it as 0 to use the locale of the current 
machine.

Note:	 These are advanced settings. Contact Avenza Technical Support (support@avenza.com) for assistance.

Prepend feature dataset name to layer name 
Enable this to prepend feature dataset 

names to layer names. 
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SIMPLE IMPORT FUNCTIONALITY

Simple Import provides a fast, uncomplicated method of importing map data into Adobe Illustrator. Its purpose is 
to import a single piece of map data or several files sharing the same format and coordinate system.

PREREQUISITES

Use Simple Import either before or after an Adobe Illustrator document is created. If no document is open, Simple 
Import will initiate the New Document dialog box.

MAPublisher will interpret the artboard dimensions during the import process, and calculate a map scale for the 
document accordingly. If the document size is changed in the Adobe Illustrator document settings, the scale will 
have to be recalculated using the MAP View Editor (see chapter 4 for more information). Remember, a map of the 
world would fit well into a page with a landscape orientation, whereas a map of South America would fit best into a 
page with a Portrait orientation. 

Some import options are specified in the MAPublisher Preferences Import Map Data category, such as attribute order, 
layer naming convention or display of extents in the import dialogs. For a full description, refer to chapter 1 about 
MAPublisher Preferences.

USING SIMPLE IMPORT

Click the Simple Import button on the MAPublisher toolbar or from the Adobe Illustrator menu File > Import Map Data 
> Simple Import.

Overview
The dialog box itself is split into two sections: the upper section provides options to choose a file format, select 
the dataset to import, and choose any additional settings that may be required; the lower section displays the 
coordinate system of the selected file (if available) and provides an option to specify one manually.

Adding Files
First specify the format of the file to be imported. Set the Format drop-down list as <Auto detect format> or to a 
specific format. With the <Auto detect format> option, all supported GIS files will be displayed in the browser. 
Choosing the required format directly is recommended to ease navigation.

Once a format has been selected, click the Browse button to select the file(s) to be imported and then click Open. 
Alternatively type in the full path of the file(s) in the Dataset text box. Only files in a same format and sharing the 
same coordinate system can be imported at once with the MAPublisher Simple Import dialog box.

Notes:	 The import of multiple Delimited Text files is not supported.



54 Chapter 3: Importing Map Data
Simple Import 

Source Coordinate System
Once the Dataset text box has been populated with a valid path, MAPublisher will read the file(s) to determine if a 
valid coordinate system can be found and will display it in the Source Coordinate System section.

If the program returns the message [No Coordinate System Specified] for the coordinate system, click the hyperlink 
to specify it. In the Specify Source Coordinate System dialog box, coordinate systems are separated into categories 
(geodetic or projected) to ease the process of choosing a coordinate system: under the Coordinate System category 
*All* will list all the coordinate systems in the database. For an overview of Geodetic and Projected systems and 
Datums see appendix A2. To view the parameters of a certain coordinate system, click the Info button. 

Character Encoding
Extended and international character sets are supported as attributes on import. To assign a character codec 
suitable for your selected dataset, choose the appropriate value from the list box.

Format Specific Settings
Certain file formats offer additional configuration parameters which can be accessed by clicking the Settings 
button. These file formats are listed in the Import Settings section above. After selecting a file, if the format accepts 
additional settings, the Settings button will be enabled.
*Additional Settings are mandatory only for importing Delimited Text Data.

Delimited Text Data Settings
MAPublisher also allows for the import of delimited text files as point data provided they contain coordinate values.  
MAPublisher supports the following delimiters between data values: comma, return, end-of-line and tab.

To import delimited text data, first specify the Format: Projected Units, Decimal Degrees, Delimited Degrees Minutes 
Seconds, Degrees.Minutes, Degrees.MinutesSeconds, Packed DMS with decimals and Packed DMS (see chapter 6, for 
more details). In the Coordinate Columns, specify the fields in the source file that contains the coordinate information. 
The caption of the fields display Longitude and Latitude or X and Y, depending on the selected format.  If the first line 
of the text file contains column headings, check the Use first line as a header option (MAPublisher generally detects it 
automatically). If the file does not appear to contain column headers, MAPublisher will assign the default headers 
Column1, Column2 to the attribute columns on import. Assign data schema types to attribute columns in the Select 
Schema frame.

Importing Data
Once the files are selected and settings specified, click OK to start the import process.  If the Adobe Illustrator 
document contains a MAP View with a coordinate system matching the incoming data, the Matching MAP View dialog 
box will open with the following options:

•	 Add to: choose the MAP View from the drop-down list in which to add the incoming data. Check the option Resize 
MAP View to fit to scale all the data (existing and incoming) to fit on the artboard. If this option is not checked, the 
imported data may fall outside the page extents

•	 Fit to page based on new MAP View: the incoming data will be treated separately from the matching data, as if it was 
the first import. The incoming data will overlap with the existing data, use the MAP View Editor to scale and 
move the data on the page (see chapter 4 on MAP Views). 
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RESULTS

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original 
source data type. Layers are named based on the file name or on the layer name in the source file. By default, 
the appropriate feature type extension is appended (e.g. name_area), and a layer name is already present in the 
document, it appends a number (e.g.  name_area 1) — but this may be disabled in the MAPublisher Preferences, 
Import MAP Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new) 
that contains the geospatial, scaling and positioning information. 

Notes:	 When importing data exceeding the allowable 32,000 points per path in Adobe Illustrator, MAPublisher 
automatically simplifies the imported object and shows a warning message. 

The simplification algorithm compares points in a line or polygon in groups of three.  When the shortest 
segment is found, the center point is removed, and the total segment distances are recalculated.  This 
removal process continues until the maximum allowable number of points is reached.
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Advanced Import 
File > Import Map Data > Advanced and MAP Toolbar  

Add - Open the Add dialog box 
(see below).

Remove - Remove selected data 
sources from the list

Edit - Allow editing of the 
selected data by re-opening 
the Add dialog box  
(see below)

Advanced Import - Add

Import Settings
See the Simple Import various Import Settings dialog boxes and options.

Destination MAP View

New based on - Import all of the 
data to one of the coordinate 

systems in the Data List

Use existing - Import all of 
the data to an existing 

coordinate system  
associated with a MAP View 

in the document

Auto scale - If multiple datasets 
are present in the Data List, 

and New Based On or  
Use Existing is selected, 

check this box to ensure the 
imported artwork fits inside 

the page extents

RELATED TOOLS

Accessed by clicking the Add or Edit button in Advanced Import.

Create new - Allows users to import all 
data into a new coordinate system. 
Click the Editor button to open the MAP 
View Editor (see chapter 4).

Coordinate System - Coordinate 
system of the data source

Data Source - Map data to be 
imported (full path or just 
file name depending on 
MAPublisher Preferences - see 
chapter 1).

Features - Number of art 
objects to be imported

(if enabled in Import Map Data 
MAPublisher Preferences).
Extents - Displays the lower 
left (LL) and upper right 
(UR) coordinates (XY) of the 
dataset extents.

Data List - This is a table 
where all data selected for 

import are listed

Details - Displays details of the selected 
data source: coordinate system, page 
anchors, visual scale, map anchors, 
map unit, and map angle.

Format - Select the data type you 
wish to import. This drop-down list 

shows the names of all MAPublisher 
supported data types.

Dataset - Displays the directory 
path and filename for the currently 

selected file(s). You can also 
manually type in the dataset 

location here.

Settings - Open the Settings dialog 
box for a file format. Extra parameter 
settings for the import of DGN, DXF, 
DWG, E00, GML/XML, KML/KMZ, 
Image, TAB, WFS, and Delimited XY 
Text Data (see previous section).

Browse - Open a Data Source browser 
to select files for import.

Encoding - Assign a codec if the 
attribute information held in the 
selected dataset uses a double byte 
character set.

Source Coordinate System - Provides 
a description of the coordinate 

system and units detected in the 
data source. If the coordinate system 

of the selected data is known, but 
it was not automatically detected 

by the program, click here. This will 
open the Specify Source Coordinate 

System dialog box (below).

Clear - Clear the 
existing source 
coordinate system.

View Coordinate System 
Information - View more 
information about the 
current coordinate system

Same as - Check this option in 
order to assign a coordinate 
system that matches that of an 
existing MAP View. Enabled when 
another MAP View is present.

From File - Choose a coordinate 
system from another file
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ADVANCED IMPORT FUNCTIONALITY

Advanced Import provides an alternative method of importing map data into Adobe Illustrator and can import 
data in multiple formats and coordinate systems. All data flagged for import are displayed in the dialog box with 
information relative to their coordinate system. All imported files are reprojected to match a selected coordinate 
system. 

Note:	 Advanced Import is recommended when importing data that will require a coordinate system 
transformation that implies redrawing and path divisions (e.g. world data reprojected from European to 
North American aspect). Applying a coordinate system transformation during Advanced Import allows 
MAPublisher to split paths during transformation, which is not possible at a later stage. Divided paths are 
grouped as compound paths.

PREREQUISITES

Use Advanced Import either before or after an Adobe Illustrator document is created. If no document is open, 
Advanced Import will initiate the New Document dialog box. Please refer to the Simple Import Prerequisites section 
in this chapter.

USING ADVANCED IMPORT

Click the Advanced Import button on the MAPublisher toolbar or from the Adobe Illustrator menu File > Import Map 
Data > Advanced Import.

Dialog Box Overview
The top part of the Advanced Import dialog box provides a list of added data, its coordinate system information and 
the number of features they contain. The bottom part of the dialog box refers to the Destination MAP View settings.

The Add and Edit buttons open a dialog box similar to the Simple Import dialog box. Please refer to the previous 
section for information on the Character Encoding, Format Specific Settings and Delimited Text Data Settings.

Note:	 The dialog box displays the file name or the full path of the selected files depending on the settings specified 
in the MAPublisher Preferences for Import MAP Data (see chapter 1). Users can also choose to display the 
geographical extents of the file.

Adding Data
Click the Add button to select one or more files that share the same format and coordinate system. The Add dialog 
box is similar to the Simple Import dialog box, please refer to previous section for more information. Browse for 
data, then click OK to add the files to the Advanced Import list.

To import more files in a different format or coordinate system, use the Add dialog box again, as often as necessary.
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Advanced Import Data List
All added datasets are listed in the Advanced Import dialog box. Listed features include the data source filename, the 
specified coordinate system and the number of features contained in the dataset.

Click a row in the data list to select a dataset. Then, click Remove to remove the dataset or click Edit to change the 
import parameters. The Edit dialog box provides the same options as the Add dialog box where users can modify 
the access path, settings or source coordinate system.

Note:	 It is not possible to import multiple files with a mix of unknown and known coordinate systems. Therefore 
the unknown coordinate systems will need to be specified before import.

Destination MAP view
Although Advanced Import allows the import of data with multiple source coordinate systems, the destination 
must be a single coordinate system. This information is stored in the Destination MAP View section (for more 
information on MAP Views, please refer to chapter 4).

There are three options to choose the coordinate system of the Destination MAP View.

•	 New based on: choose a coordinate system of one of the files selected for import.
•	 Use existing: choose a MAP View with the desired coordinate system from the list of existing MAP Views in the 

open document.

With the above two options, optionally enable Resize MAP View to fit to scale all the data (existing and incoming) to fit 
on the artboard. If this option is not checked, the imported data may fall outside the page extents

•	 Create new: specify the parameter for a new MAP View. Click the Editor button to open the MAP View Editor. In the 
Destination Source Coordinate system section, click the Specify button to select a coordinate system from a large 
list of existing system or to create a custom one. The MAP View Editor is explained in depth in chapter 4, in brief 
it allows for the edition of the scale, the position of the data on the page and rotation. 

RESULTS

Once the data has been selected for import and properly set up, click OK to start the import process.

The data is imported as individual Adobe Illustrator layers with appropriate feature type matching the original 
source data type. Layers are named based on the file name or on the layer name in the source file. By default, 
the appropriate feature type extension is appended (e.g. name_area), and a layer name is already present in the 
document, it appends a number (e.g.  name_area 1) — but this may be disabled in the MAPublisher Preferences, 
Import Map Data property sheet. The layers are automatically placed as sub-features of a MAP View (existing or new) 
that contains the geospatial, scaling and positioning information.
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WEB FEATURE SERVICE

Import vector data using the Web Feature Service (WFS). It accesses web servers that deliver vector content in GML 
format. To access WFS settings, choose Web Feature Service in the Format drop-down list of the Simple or Advanced 
Import dialog box and click the Settings button.

To manage servers used in the WFS, click Browse. The Browse Web Feature Service dialog box maintains a list of 
loaded map services. To add a new service click the Add button, then add the service URL and version number. This 
list can also be populated with a number of services aggregated by Avenza. To do so, click the Load Services From 
Avenza button. To remove a service, select one, then click the Remove button.

Saved Services
WFS title and map service 

abstract

Add/Remove WFS
Add a WFS by entering a 
name for the service and 

the  connection URL. 

Load Services From Avenza 
Loads an updated list of 
Web Feature Services 
from an Avenza server.

In the Select Features dialog box, choose map features in the layer tree to import them. The layer abstract at the 
bottom of the dialog box displays a descriptive field about the selected layer and its bounding box coordinates. 
Click the Specify Spatial Filter to specify four exact coordinates to limit the area being imported. See Import Personal 
and File Geodatabases for more information. Optionally, check the Save file to directory option and browse to a 
location to save it locally (not required to use the feature). 

Title 
The title of the current WFS

Layer Tree
Structured list of available 

layers. May or may not show 
geometry (Area, Point, Layer) 

type depending on server 
settings

Layer Abstract 
A descriptive field including 

layer metadata

Save file to directory 
Check this and browse to a 

location to save the selected 
map features.

Specify Spatial Filter 
Define a bounding box 
to limit imported 
features

Web Feature/Map Service
Simple or Advanced Import (Format drop-down list)
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Server Info 
WMS title and map service

Layer Tree
Structured list of layers 

available in the current WMS 

Format
Available output formats

Additional Server Parameters 
Additional parameters as 
outlined in WMS abstract

Description 
An abstract of the layer that 

may include metadata 
definitions

Expand/Collapse Layer Items 
Expand or collapse items in 

the layer tree 

Number of X Pixels
Input number of X pixels to  
change output image size. 
Image is resized proportionally.Preview 

Toggle thumbnail preview 
of WMS image. Spatial 

extents displayed around it.

Style - Choose from 
rendering styles available 
for the selected layer

Coordinate System 
Choose from available 
Spatial Reference Systems 

Set Background Transparent 
Toggle background 
transparency on import

Image Placement 
Choose to have the image embedded 
or linked in the document

Specify Spatial Filter - Import 
data based on a specified 
geographic bounding box

Set output directory for 
image - Check to enable 
and browse to a location 
to save the image. 
Optionally, check Write 
reference file to include a 
reference file with the 
output image.

WEB MAP SERVICE

Import raster data with the Web Map Service (WMS). It accesses web servers that deliver raster content in a variety 
of formats. There are no format specific settings associated with this importer. To access WMS, choose Web Feature 
Service in the Format drop-down list in the Simple or Advanced dialog box.

To manage web servers used in the WMS, click Browse. The Browse Web Map Service dialog box maintains a list of 
loaded services. This list can be populated with a number of services aggregated by Avenza. To add a new service 
click the Add button, then add the service URL. MAPublisher WMS importer only supports WMS version 1.1.1.

Saved Services
WMS title and map service 

abstract

Load Services from Avenza 
Loads an updated list of 
Web Map Services from 
an Avenza server.

Add/Remove WMS
Add a WMS by entering a 

name for the service and the  
connection URL. 
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Spatial Databases

A geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic 
datasets of various types and managed in either a file folder structure or a relational database, such as:

•	 Feature classes of points, lines, polygons and annotation for discrete features
•	 Feature datasets (group of feature classes)
•	 Descriptive attributes stored in tables 
•	 Raster datasets and raster catalogs for imagery

MAPublisher can import several types of Esri geodatabases:

File 
extension

User 
access

Size 
limit

RDBMS 
Technology

Esri Licensing
(create)*

MAPublisher 
Import access

Personal geodatabase .mdb Single 2 GB Microsoft Access 
(Jet Engine)

ArcInfo
ArcEditor
ArcView

Folder browser

File geodatabase .gdb Single 1 TB No RDBMS - uses 
local file structure

ArcInfo
ArcEditor
ArcView

Folder browser

ArcSDE Desktop 
geodatabase 

(called Personal in 9.2)
- Multiple 

(limited) 4 GB SQL Server 
Express

ArcGIS Engine
ArcInfo

ArcEditor

ArcSDE server 
connection

ArcSDE Workgroup 
geodatabase - Multiple 

(limited) 4 GB SQL Server 
Express

ArcGIS Server 
Workgroup

ArcSDE server 
connection

ArcSDE Enterprise 
geodatabase - Multiple 

(unlimited)

Depends 
on the 
server

DB2
Informix
Oracle

PostgreSQL
SQL server

ArcGIS Server 
Enterprise

ArcSDE server 
connection

*For all geodatabases, an ArcEngine license is the minimum requirement for direct read of vector and raster data.

MAPublisher has the capacity to import all types of geodatabases (categorized as Personal, File and ArcSDE 
geodatabases). The connection to an ArcSDE server requires server access, user account and versioning information 
to be provided by the database administrator. These parameters are exactly the same required to establish a 
connection using Esri ArcCatalog — with a small exception for SQL Server Express connections, explained later on 
in this chapter.

Once imported into Adobe Illustrator, data does not maintain a link with the original database and database 
functions are not valid (topology, table/feature class relationships, subtypes and attributes domains rules). However, 
MAPublisher can make use of the geodatabases spatial and non-spatial relationships, subtypes and attribute 
domains information during the import process (to populate layer names and attributes).

The following sections include how to:
Import Personal and File Geodatabases
Import Using Basic Personal Geodatabase Reader (Mac supported)
Import Esri ArcSDE Geodatabases
Import from Basic Esri ArcSDE server
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SOFTWARE REQUIREMENTS

The MAPublisher Basic Personal Geodatabase Reader does require any ArcGIS licenses for Mac and Windows. 
However, this means that some import functions are limited in use (explained further in this chapter).

To be able to fully import Esri geodatabases or to fully access an ArcSDE server using MAPublisher Simple and 
Advanced Import, a valid Esri software must be installed and licensed—at minimum, ArcGIS Engine Runtime. More 
commonly, higher licenses that may be used are ArcView, ArcEditor and ArcInfo.

Direct access to feature classes on an ArcSDE Server only requires ArcReader, available for free. However, File and 
Personal geodatabases cannot be read using ArcReader. With this license configuration, access to files with a Basic 
Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connections (explained further in 
this chapter). MAPublisher supports all ArcSDE server connections and SQL queries supported by Esri.

If ArcReader is not installed on the default installation directory, it might be necessary to edit the binary 
location in the MAPublisher Preferences, Basic Esri ArcSDE Server Editor (see chapter 1). 
 
MAPublisher supports geodatabases from versions ArcGIS 9.2 and newer. However, there are some 
limitations to the direct connections from 9.2 clients to the ArcSDE 9.3 geodatabases. Please refer to Esri 
documentation on software requirements (service packs) and limitations. 
 
To access geodatabases created by ArcGIS 10 in MAPublisher, an installation of ArcGIS 10 is required. Having 
a valid installation allows for backwards compatibility with geodatabases created by ArcGIS 9.2 and newer.

SUPPORTED FEATURES

Data Types
The following is a list of supported and unsupported geodatabase geometry types for import in MAPublisher:

Supported Unsupported

Point
Polyline
Polygon
Circular Arc*
Elliptical Arc*
Bezier Curve
Annotations

Raster
Grids
MultiPatch
Dimensions

Note:	 To import a geometry type that requires the use of a Representation in ArcGIS (such as Bezier curves), the 
Behavior when Representation Geometry is Edited must be set to Change the geometry of the supporting 
feature—option specified when creating a new Representation in ArcGIS.

*	 Upon import, MAPublisher 
converts an arc to a line 
where a series of vertices 
will maintain the geometry. 



63Chapter 3: Importing Map Data
Spatial Databases

Aliases
ArcGIS users can give the feature classes an alias that acts as an alternate name. Unlike feature class names, aliases 
can contain spaces, punctuations, and start with a number. In ArcMap, feature classes are referred to with their alias 
name. In ArcCatalog, feature classes are represented by their true names.

Specify to use aliases for layer names in the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor:

Note:	 Aliases for attribute field names are imported as Display Name and true field names as Name of MAP 
Attributes columns.

Subtypes and Attribute domains
Subtypes are particular attribute fields made to create groups of records in a feature class that share the same types 
of properties. The attribute fields designated as subtype fields contain numerical coded values and have a data type 
of short or long integer. Each coded value is associated with a description (textual). In the MAPublisher Preferences 
for Spatial Database > Esri Geodatabase Editor, users may choose to load subtypes as separate layers.

Attribute domains are used to constrain the values allowed in any particular attribute of a feature class (or subtypes). 
There are two types of attribute domain:

•	 A range domain limits the value of a numerical attribute in between minimum and maximum values — 
range domains are not relevant to MAPublisher. 

•	 A coded value domain specifies a valid set of coded values for an attribute (of any type — text, numeric 
or date). Both coded values and their meaningful description are stored in the database.

In the MAPublisher Preferences for Spatial Database > Esri Geodatabase Editor, users can set the option to import 
attributes with coded values from subtypes and attribute domains as follow:

•	 Instead: replace the codes by their description (text)
•	 Never: import the actual values (code)
•	 In Addition: create two attribute columns, one containing the coded values and one containing the 

corresponding descriptions. 
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Spatial Filters
During the import process, users can enter two opposite corner coordinate points in any coordinates system unit to 
limit the geographic area for the data being imported (see next section).

Note:	 When importing a feature class that has no art it is considered to have invalid extents and a spatial filter 
cannot be created.

SQL Queries
During the import process, users can use SQL queries on feature classes and tables to limit the objects and 
attributes to be imported. 

Multiple feature classes can be imported using multiple SQL statements as long as all classes share the same source 
coordinate system. SQL queries can also be used to import a feature class and the attribute information from a 
related non-spatial table. To apply SQL queries on multiple feature classes with different source coordinate systems, 
use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more information on the 
Advanced Import).

MAPublisher uses Esri libraries to run SQL queries. Please refer to Esri documentation for more information on 
supported SQL expressions and syntax — it may vary depending on the geodatabase and database server type.

Non-Spatial Relationships
MAPublisher supports non-spatial relationships between feature classes and tables during the import process using 
SQL queries. Here are some examples:

Query Result

ÌÌ SELECT * FROM Feature_Class,Table WHERE FeatureClass.Id=Table.Id
Import and inner join a feature class to a related table (only 
features with entries in the related table are imported)

ÌÌ SELECT * FROM Feature_Class,Table WHERE FeatureClass.Id=Table.Id 
AND Table.Attribute='ABC'

Import and inner join a feature class to a related table and 
apply a query

ÌÌ SELECT * FROM Feature_Class WHERE FeatureClass.Id IN (SELECT 
Table.Id FROM Table WHERE Table.Attribute='ABC')

Import a feature class without joining to a related table, but 
use a table value to make a query

Note:	 SQL syntax may vary depending on the database server type.

Once vector data is imported into Adobe Illustrator, the database relationships rules do not apply anymore. It is 
however possible to use the MAP Attributes panel Join Table function to join geodatabase tables with MAPublisher 
vector data. For more information, please refer to chapter 5.

Note:	 When the non-spatial table information is imported together with the feature class using a SQL query, only 
the vector features that have a record in the related table are imported. Import first the feature class and use 
Join Table in a second step: all vector features are imported and the related table information is added where 
a record match is found. This second option might be recommended if the database is not well known.
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IMPORT PERSONAL AND FILE GEODATABASES

Format - Select Esri File Geodatabase 
or Esri Personal Geodatabase.

<Auto detect format> can only be 
used for Personal Geodatabases.

Simple Import or Advanced Import > Add 

Browse - Opens a Select dataset 
browser. File Geodatabases have 
the extension gdb and Personal 
Geodatabases have mdb.

FUNCTIONALITY

Esri Personal and File geodatabase feature classes can be imported using Simple Import or Advanced Import. The 
file selection is done in two steps: 1) select the database (mdb file for Personal geodatabase, a gdb folder for File 
geodatabase); 2) select feature classes directly or through an SQL query. Optionally, define a spatial filter to limit the 
geographic extents of the data being imported.

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent 
feature dataset to ease the selection process, but feature datasets are not imported as such. The feature dataset 
name may be prefixed to the name of the data layer created during import (using an import setting).

For each format, multiple feature classes sharing the same source coordinate system may be selected at once in 
the Simple Import or Advanced Import > Add dialog box. To import feature classes that do not have matching 
spatial reference, use Advanced Import and add the feature classes in several Add sessions (see chapter 3 for more 
information on Advanced Import functionality).

The feature classes (objects and attributes) are imported on separated MAP layers. The layer naming convention is 
set in the MAPublisher Preferences for Spatial Databases > Esri Geodatabase Editor.

USING IMPORT ESRI PERSONAL AND FILE GEODATABASES

In the Simple Import or Advanced Import > Add dialog box, set the Format drop-down list to Esri Personal Geodatabase 
or Esri File Geodatabase. Using <Auto detect format> only works with Personal geodatabases (File geodatabases 
cannot be detected because they are directories). The Settings are described in chapter 3. Click the Browse 
button and select a file with the extension mdb (Personal geodatabase) or a directory with the extension gdb (File 
geodatabase)— only one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog 
box where specific feature classes can be imported.
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Select Feature Classes
In the Select Feature Classes dialog box, import one or more feature classes or build SQL queries to select subsets of 
feature classes. Click the names of the feature classes to select them for import—selected classes are highlighted. To 
deselect a class, click the selected name again.

Select Feature Classes - Click one or more 
feature classes to import, only classes 
sharing the same original coordinate 

system (spatial reference) can be 
imported together

SQL Query - Click this option to access 
the Create SQL Select Query dialog box

Specify Spatial Filter- Click this button to 
open the Specify Spatial Filter dialog box

Specify Spatial Filter
A spatial filter consists of a rectangle that defines the extents of imported data. Use extents of an existing MAP 
Layer from the drop-down list or enter new coordinates values manually. When setting points manually, enter 
two opposite corner coordinates that represent the actual extent of the data. When MAP Locations exist on the 
document, it is possible to use them to specify corner coordinates. If required, click the Input Coordinate System 
link to use an alternate coordinate system for the inputs.

Set points manually - Enter two opposite 
corners of the spatial filter boundaries

Use extents of layer - Choose an existing 
MAP Layer and click Update to use its 

spatial extents as the spatial filter

Input Coordinate System - Coordinate 
system specified for entering the filter 

coordinates (if different from source)

Corner - Specify X and Y 
coordinates to use as a corner 

of the spatial filter

Opposite Corner - Specify X and Y 
coordinates to use as the  opposite 

corner of the spatial filter

MAP Locations - Choose 
predefined MAP 
Locations or Artboard 
locations (corners)

Relationship - Specify features to be included (not available for Basic Spatial Databases):
•	 Intersects: includes features that intersects the spatial extent
•	 Contains: includes only features that are entirely contained within the spatial extent
•	 Crop to Filter: includes only features that are cropped to the spatial extent

The Relationship type affects how the spatial filter boundary interacts with the imported features : 
•	 Intersects: import objects that intersect the extents of the spatial filter
•	 Contains: import objects fully contained within the extents of the spatial filter
•	 Crop to Filter: includes only features that are cropped to the spatial extent
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Create SQL Select Query
An SQL statement can be built to limit the number of objects and attributes imported from a single feature class. 
The SELECT clause should always contain one and one only "Shape" object (actual spatial feature). When possible, 
use the operator button to add formatted query statements (including spaces), to limit the typing errors. 
For example: 

•	 In feature class "FC_Point", import all points and the "Valve" attribute (other attributes are not imported).
ÌÌ SELECT FC_Point.Shape, FC_Point.Valve_ID FROM FC_Point

•	 In feature class "FC_Line", import lines (vector only) that have the attribute "Id" equals to 1, 2, 3 or 4.
ÌÌ SELECT FC_Line.Shape  FROM FC_Line WHERE FC_Line.Id IN (1,2,3,4)

Use the Validate button in the Create SQL Select Query dialog box to verify the query syntax prior to import.

Multiple feature classes can be imported using multiple SQL statements separated by a semi-colon (;) as long as all 
classes share the same source coordinate system. SQL queries can also be used to import a feature class and the 
attribute information from a related non-spatial table (see previous section). To perform SQL queries on multiple 
feature classes with different source coordinate systems, use the Advanced Import and add the feature classes in 
several Add sessions (see chapter 3 for more information on the Advanced Import).

Recently used SQL queries are saved and accessed by clicking the Recent button. The number of recent queries 
saved is set in the MAPublisher Preferences on Spatial Database > General Spatial Database Editor (see chapter 1).

SQL Query Editor - Type in an 
SQL query. The SQL syntax 

must be compliant with 
the DBMS server in use.

One and one only "Shape" 
field must be specified in 

the SELECT clause.

Selection - Select a feature 
class name or attribute  

and double-click or click 
Add to Query to add it 

to the SQL Query Editor 
above. Attribute alias 

names are indicated in 
parenthesis.

Add to Query - Select a feature class name 
or attribute and click this button to add 
the item the SQL statement

Recent - Opens a list of recent SQL 
statements (see also MAPublisher 
Preferences on Spatial Database > General 
Spatial Database Editor - chapter 1)

Specify Spatial Filter - Opens 
the Spatial Filter dialog box 

(see previous page)

Operators - Click an operator button to 
add the corresponding formatted text 
(including spaces) to the query

Validate - Click to verify the query syntax

Delete - Click to delete 
recent SQL queries
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IMPORT USING BASIC PERSONAL GEODATABASE READER

Format - Select Basic Personal Geodatabase 
This works in both Windows and Mac 

without an ArcGIS license.

Simple Import or Advanced Import > Add 

Browse - Opens a Select dataset 
browser. Only Personal Geodatabases 
with mdb extension can be chosen.

FUNCTIONALITY

Esri Personal geodatabase feature classes can be imported using Simple Import or Advanced Import. The main 
difference between this format and the Esri Personal Geodatabase format is that the Basic is available to users 
without an ArcGIS license and works on both Mac and Windows.

The Basic Personal Geodatabase Reader can only read the feature classes as tables (and referred to as tables). The file 
selection is done in two steps: 1) select the database (mdb only); 2) select tables directly or through an SQL query. 
Optionally, define a spatial filter to limit the geographic extents of the data being imported.

Several limited functions are worth noting. The Basic Personal Geodatabase Reader doesn't support feature datasets, 
doesn't support relationship (intersect/contains) in spatial filters, and doesn't support domain or subtypes. Other 
than the listed differences, the Basic Personal Geodatabase Reader functions similarly to importing an Esri Personal 
Geodatabase (see previous section, Import Personal and File Geodatabases).

USING BASIC PERSONAL GEODATABASE READER

In the Simple Import or the Advanced Import > Add dialog box, in the Format drop-down list, choose Basic Personal 
Geodatabase Reader. Click the Browse button and select a file with the extension mdb (Personal geodatabase)—only 
one geodatabase can be accessed at a time. Click Open to open the Select Feature Classes dialog box where specific 
feature classes can be imported.

Note:	 Forward slash "/" in paths are not supported in Windows, but are supported on Mac.

Select Tables
Feature classes are referred to as tables using the Basic Personal Geodatabase Reader. In the Select Tables dialog box,  
directly import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the 
names of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note:	 Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Specify Spatial Filter and Create SQL Select Query
The Specify Spatial Filter and Create SQL Query for Basic Personal Geodatabase Reader functions similarly to importing an 
Esri Personal Geodatabase (see previous section, Import Personal and File Geodatabases).
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IMPORT ESRI ARCSDE GEODATABASES

Format - Select Esri ArcSDE Geodatabase.
<Auto detect format> cannot be used.

Simple Import or Advanced Import > Add 

Browse - Opens Browse ArcSDE 
Geodatabase dialog box

FUNCTIONALITY

Esri ArcSDE geodatabase feature classes can be imported using Simple Import or Advanced Import. Importing 
ArcSDE geodatabases requires users to create a connection to the database server containing the database. Once a 
connection is established, feature class selection is done in the same manner as Personal and File geodatabases—
by direct selection or SQL query (see previous section) and using spatial filters.

The connection parameters to an ArcSDE server are saved with the application. The dataset selections (called MAP 
Datasets) are also saved. The maximum number of default MAP Datasets saved is set in the MAPublisher Preferences 
for Spatial Database > General Spatial Database Editor. MAP Datasets saved with a specific name (other than the 
default one given) are always saved.

Like the other geodatabase formats, multiple feature classes sharing the same source coordinate system may be 
selected all at once. To import feature classes that do not have matching spatial reference, use Advanced Import 
and add the feature classes in several Add sessions (see chapter 3 for more information on the Advanced Import). 

The feature classes (objects and attributes) are imported on separated MAP layers. ArcSDE geodatabase tables 
are identified as databaseName.userName.tableName. An abbreviated version using only the table name as layer 
name can be applied as a preference. This option and other layer naming conventions are set in the MAPublisher 
Preferences for Spatial Databases > Esri geodatabase Editor (see chapter 1 and previous section).

When feature datasets are present in the database, MAPublisher uses them to group feature classes per parent 
feature dataset to ease the selection process, but feature datasets as whole cannot be individually imported—only 
its individual feature classes can. An import setting allows the feature dataset name to be prepended to the name 
of the data layer created during import.



70 Chapter 3: Importing Map Data
Spatial Databases

USING IMPORT ESRI ARCSDE GEODATABASES

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Esri ArcSDE 
Geodatabase. <Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the 
Browse ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE 
servers. It also stores recently used and saved MAP Datasets.

Connections - List of connections already 
created within MAPublisher

Recent/saved MAP Datasets - List of recently 
used and saved MAP Datasets

Create new - Opens the Create new ArcSDE 
Geodatabase Connection dialog box.

Edit
•	 If a connection is selected, it opens 

the Edit ArcSDE Geodatabase 
Connection dialog box

•	 If a MAP Dataset is selected, it opens 
the Edit ArcSDE Geodatabase MAP 
Dataset dialog box

Copy - Copy the selected ArcSDE connection

Delete - Delete the selected ArcSDE 
connection or MAP Dataset

Esri ArcSDE Geodatabase Connection
In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings - Specify the 
connection settings: Connection Name, 

Server, Service and Database Name as 
specified in the database Connection 

Properties in Esri ArcCatalog

See next page for specific details for SQL 
Server Express connection (Desktop and 

Workgroup Geodatabases)

Database Authentication - Enter user 
name and password provided by the 

database administrator

Operating System Authentication
The server connection uses 

Windows authentication. The user 
must be logged into Windows 
with a login name that is also 
valid on the database server.

Test Connection - Test the connection 
parameters prior to accessing datasets

Connection Details - Specify the transactional or historical 
version to be accessed. The interface lists the existing 
versions for the database.
Information to be provided by the database administrator.
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Important Note for SQL Server Express Users
There is an exception for connections to SQL Server Express servers — ArcSDE Desktop (called Personal in ArcGIS 
9.2) and Workgroup geodatabases. In ArcCatalog, users set a "Database Servers" connection where only the server 
name followed by \sqlexpress is required to establish a connection. In MAPublisher, there is no specific interface for 
SQL Server Express connections, the same interface as for the other types of ArcSDE geodatabases must be used 
with specific settings: 

Server Name of the server followed by _SQLEXPRESS

Service The server name must be preceeded by sde:sqlserver and 
followed by \sqlexpress (e.g. sde:sqlserver:ServerName\sqlexpress)

Database name The name of the database must be known

Operating System 
Authentication 

Must use this to authenticate SQL Server Express databases

Select MAP Datasets
To make a new selection of feature classes from an ArcSDE geodatabase, click a connection name on the Connections 
tree of the Browse ArcSDE Geodatabase dialog box and click OK. This opens the Select Feature Classes dialog box. This 
dialog box for ArcSDE geodatabases is very similar to the Select Feature Classes dialog box of Personal and File 
geodatabases described in the previous section: users can directly select one or more feature classes (provided that 
they share the same spatial reference) or build an SQL query to select a subset of some feature classes and apply 
spatial filters. The difference with ArcSDE geodatabases is that the feature class selection is saved as a MAP Dataset. 
Type in a MAP Dataset name for the selection at the top of the dialog box.

Feature classes - Click one or more 
feature classes to import - only classes 

sharing the same original coordinate 
system (spatial reference) can be 

imported together

SQL Query - Click to access the Create SQL 
Select Query dialog box. See  

Import Personal and File Geodatabases.

MAP Dataset - Type a name for the selected 
dataset (by direct selection or SQL 
query). This name will be displayed in 
the Recent/saved MAP Dataset list of the 
Browse ArcSDE Geodatabase dialog box.

The number of default recent MAP 
Datasets saved is set in the MAPublisher 
Preferences for Spatial Database > General 
Spatial Database Editor.

Specify Spatial Filter- Click to open the 
Specify Spatial Filter dialog box. See  

Import Personal and File Geodatabases.
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Click a MAP Dataset in the Recent/saved MAP Datasets tree of the Browse ArcSDE Geodatabase dialog box. The MAP Dataset 
name and connection can be changed in the Edit ArcSDE Geodatabase MAP Dataset dialog box.

MAP Dataset - Edit the name of the 
MAP Dataset. It will be displayed in 

the Recent/Saved MAP Dataset list 
of the Browse ArcSDE Geodatabase 

dialog box.

Connection - Set the name of the 
connection to use to access a dataset

Feature Classes - List of 
selected feature classes

SQL Query - SQL query used to select the 
data features (when used)

Spatial Filter - Spatial filter used to limit 
the import extents (when used)

The maximum number of recent MAP Datasets saved with the default name is set in the MAPublisher Preferences 
for Spatial Database > General Spatial Database Editor (user named datasets are saved until deleted).

Settings
Spatial database parameters can by clicking the Settings button in the Simple Import or Advanced Import > Add 
dialog box. These settings are described in chapter 3. Optionally, prefix the feature dataset names to the layer name 
created on import.

Access it by going to MAPublisher Preferences > Spatial Database > Esri Geodatabase Editor

Use abbreviated table name for layer name
ArcSDE Geodatabases' tables 
are identified as databaseName.
userName.tableName. The 
abbreviated version uses only the 
table name as layer name.

If this option is used in combination 
with the "use alias" option, the alias is 
applied first.
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IMPORT FROM BASIC ESRI ARCSDE SERVER

Format - Choose Basic Esri ArcSDE Server
<Auto detect format> cannot be used.

Simple Import or Advanced Import > Add 

Browse - Opens the Browse Basic Esri 
ArcSDE Server dialog box

FUNCTIONALITY

Users who do not have an ArcGIS license can install ArcReader, a free Esri desktop application (www.esri.com). Only 
ArcSDE geodatabases can be read, File and Personal geodatabases are not supported using this format. In addition, 
file access with a Basic Esri ArcSDE Server connection is limited compared to a Esri ArcSDE Geodatabase connection:

•	 Aliases, sub-types and attribute domains are not supported — only true names and actual values 
(codes) are imported.

•	 Feature datasets are not recognized. Feature classes are all listed on the same level, they are not 
grouped by feature dataset.

•	 Feature classes are referred to as "tables"
•	 Operating System Authentication is not supported.

USING IMPORT BASIC ESRI ARCSDE SERVER

In the Simple Import or the Advanced Import > Add dialog box, set the Format drop-down list to Basic Esri ArcSDE 
Server. <Auto detect format> does not detect Esri ArcSDE geodatabases. Click the Browse button to open the Browse 
Basic ArcSDE Geodatabase dialog box.

The Browse ArcSDE Geodatabase dialog box has options to create, edit and delete connection parameters to ArcSDE 
servers. It also stores recently used and saved MAP Datasets.

Recent/saved MAP Datasets - List of recently 
used and saved MAP Datasets

Edit
•	 If a connection is selected, it opens 

the Edit Basic Esri ArcSDE Server 
Connection dialog box

•	 If a MAP Dataset is selected, it opens 
the Edit Basic Esri ArcSDE Server MAP 
Dataset dialog box

Connections - List of connections already 
created within MAPublisher

Copy - Copy the selected ArcSDE connection

Delete - Delete the selected ArcSDE 
connection or MAP Dataset

Create new - Opens the Create new Basic 
ArcSDE Server Connection dialog box.
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Basic Esri ArcSDE Server Connection
In MAPublisher, apply the same connection parameters as in an Esri application (such as ArcCatalog):

Connection Settings  
Connection Name, Server, Service and 

Database Name as specified in the database 
Connection Properties in ArcCatalog

See next page for specific details for SQL 
Server Express connection (Desktop and 

Workgroup Geodatabases)

User Name / Password - Specify 
authentication information provided by 

the database administrator

Test Connection - Tests the connection 
parameters prior to accessing datasets.

Version - Enter the transaction 
version information provided by 
the database administrator.

Unlike ArcSDE Geodatabases, the 
ArcSDE server interface does not list 
the versions existing in the database.

Note:	 If ArcReader is not installed in the default installation directory, it may be necessary to edit the binary 
location in the MAPublisher Preferences > Basic Esri ArcSDE Server Editor (see chapter 1).

Important Note For SQL Server Express Users
Some specific settings are required for SQL Server Express connections. See Esri ArcSDE geodatabase connection.

Select Tables
Feature classes are referred to as tables using the Basic Esri ArcSDE Server. In the Select Tables dialog box,  directly 
import one or more tables or build SQL queries to select attributes of tables. To directly select tables, click the names 
of the table to import—selected tables are highlighted. To deselect a table, click the selected name again.

Note:	 Text layers in a geodatabase are seen as areas in the Select Tables dialog box, but are imported as text.

Select Tables - Click one or more tables to 
import. Only tables sharing the same 

original coordinate system (spatial 
reference) can be imported together.

SQL Query - Click to access the Create SQL 
Select Query dialog box. See  

Import Personal and File Geodatabases.

MAP Dataset - Type a name for the selected 
dataset (by direct selection or SQL 
query). This name will be displayed in the 
Recent/saved MAP Dataset list of the Browse 
Basic ArcSDE Geodatabase dialog box.

The number of default recent MAP Datasets 
saved is set in the MAPublisher Preferences 
for Spatial Database > General Spatial 
Database Editor.

Specify Spatial Filter- Click to open the 
Specify Spatial Filter dialog box. See  

Import Personal and File Geodatabases.
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Geospatial PDF Import

FUNCTIONALITY

The Geospatial PDF Import is an easy way to import a geospatial PDF into Adobe Illustrator using MAPublisher. Its 
purpose is to import the map data and organize them into MAP Layers in a MAP View.

PREREQUISITES

MAPublisher supports geospatial PDF documents generated from MAPublisher and Geographic Imager. It also 
supports third-party georeferenced PDF documents (e.g. ArcGIS and TerraGo).

USING GEOSPATIAL PDF IMPORT

Import a geospatial PDF from the File > Open menu. Browse for a geospatial PDF document and click Open. The 
Select PDF Import Method dialog box will open.

Select PDF Import Method
The Select PDF Import Method contains two options for import: Advanced and Simple.

The Advanced PDF Import method is used to separate art to its respective layer. This method maintains attributes 
and referencing. It will open the Layer Assignment dialog box so that layers in the PDF can be assigned a 
MAPublisher feature type and a MAP View. In most cases, it is recommended to use Advanced PDF Import.

The Simple PDF Import method should be used if any layer order issues are caused by the Advanced import. This 
method imports features to a single MAP View and Adobe Illustrator layer. This method maintains referencing, 
however all attribute information will be lost.
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Layer Assignment
When Advanced PDF Import is used, it will open the Layer Assignment dialog box. It is used to assign the data 
structure found in a geospatial PDF to the appropriate Feature Type and a MAP View. It contains three columns: 
Layer, Feature Type and MAP View. In the Feature Type column, the <Auto-detect> option automatically chooses 
the appropriate feature type (Area, Point, Line, Image, Text or Legend) to assign each layer. Alternatively, click a 
Feature Type cell to assign a layer to the appropriate feature type (or to None for no feature type). Layers can be 
assigned to the AllLayers MAP View or to a Non-MAP Layer. To assign nothing, click the Cancel button.

Note:	 During import, MAPublisher is unable to assign layers to a MAP View when a geospatial PDF does not have 
any layer structure to begin with.

NOTES ABOUT GEOSPATIAL PDF IMPORT

Adobe Illustrator does not import layers set to invisible in a PDF document. This situation may happen if layers in 
MAPublisher are set to invisible and then exported to PDF. To prevent this from happening, ensure that all layers are 
made visible before export to PDF.

In certain cases, point objects may be imported as areas. Depending on how the authoring program created the 
PDF will determine how MAPublisher imports point objects. A possible workaround to this is to recreate point 
objects or create centroids using the existing areas in MAPublisher. Alternatively, try a different authoring program 
to export to PDF.

In certain cases, text objects are imported but every word is broken into independent characters. Resolving this 
issue is dependent on how the authoring program creates the PDF.

There are several TerraGo PDF export settings to be aware of. The Layer Menus export option provides a way to 
organize a layer listing in a PDF document but has no affect on layer structure. MAPublisher does not use this 
option during import. Also, the initial visibility for all layers you wish to import must be set to visible. MAPublisher is 
unable to import layers set to invisible by the TerraGo PDF exporter.
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MAPublisher FME Auto and FME FFS Import

FUNCTIONALITY

MAPublisher has two main functions that support FME Desktop:
1.	 In FME Workbench and FME Universal Viewer, the Adobe Illustrator - Avenza MAPublisher writer provides 

export options to convert GIS data into an Adobe Illustrator document, complete with a MAP View and MAP 
layers (see next page).

2.	 In MAPublisher, FME Auto gives the ability to import FME Feature Store (ffs) files.

The combination of MAPublisher FME Auto and the Adobe Illustrator - Avenza MAPublisher writer in FME Desktop 
creates a full featured GIS processing and design environment. Use Adobe Illustrator templates with FME Auto 
to create an automated workflow from FME Desktop to MAPublisher seamlessly.  Use the MAP Theme styesheet 
Auto-Assign option to automatically have your custom styles applied as data is imported into Adobe Illustrator. 
Templates and MAPublisher MAP Themes and styles can be prepared in advance.

PREREQUISITES

MAPublisher FME Auto is a separate license that must be activated in MAPublisher License Management dialog box 
before use (see Chapter 1).

MAPublisher FFS import is available through Simple and Advanced Import when FME 32-bit is installed (on 
Windows 32-bit or 64-bit).

The Adobe Illustrator - Avenza MAPublisher writer plugin for FME can be used with both 32 and 64-bit FME, 
however the FME Auto component in MAPublisher requires either a 32-bit version of FME or the 32-bit FME 
redistributable (which can be downloaded from Avenza website) to be installed.

IMPORTING FME FFS FILES

This is similar to importing other formats (See Simple Import and Advanced Import). In Simple or Advanced Import, 
choose FME Feature Store [*.ffs] from the Format drop-down list. Click Browse to select the file(s) to be imported and 
then click Open.

FFS files can have password protection. To import an FFS file protected by a password, click the Settings button and 
enter the password. A warning dialog box will appear if the password is incorrect and a notification that says Unable 
to read datasource displays in the import dialog box.
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USING MAPUBLISHER FME AUTO IN FME WORKBENCH AND FME UNIVERSAL VIEWER

FME Workbench is a visual workflow editor used for developing data transformation tools. It is commonly used for 
translations between various GIS data types. FME Universal Viewer is a utility that allows you to view data in any 
FME-supported format. The Adobe Illustrator - Avenza MAPublisher writer provides export options to convert GIS 
data into a new Adobe Illustrator document, complete with a MAP View and MAP layers.

To access the MAPublisher writer in the FME Workbench main window, go to Writers > Add Writer. To access the 
MAPublisher writer in FME Universal Viewer, click File > Save Data As. In the Add Writer dialog box, browse for the 
Adobe Illustrator - Avenza MAPublisher format.

Format - Browse the Writer Gallery to 
select the Adobe Illustrator - Avenza 

MAPublisher writer

Dataset - Browse for the intermediate 
file (ffs) to be translated

Parameters - Specify the destination Adobe 
Illustrator file and advanced settings 
for MAPublisher FME Auto. Detailed 

information about the parameters below.

FME Workbench FME Universal Viewer

Click the Parameters button to access the Adobe Illustrator - Avenza MAPublisher Parameters dialog box:

Adobe Illustrator Parameters 
Specify initial Adobe Illustrator file 
or template to import GIS data to, 

the destination Adobe Illustrator file 
(where it is saved to) and how the 

document behaves (leave open, save, 
or save and close)

Other Parameters 
Additional options to strip format 

attributes, wait for results (stops 
on errors), quit Adobe Illustrator if 

launched using FME, and choose a FFS 
file compression level.

Existing Document MAP View - Use these 
options to fit data to the page and 
choose the appropriate setting if a 
matching MAP View is found.

New MAP View Properties - Optionally, 
use these settings to set a coordinate 
system file, set a map scale and the 
point of origin (lower-left corner or 
center) for the MAP View



79Chapter 3: Importing Map Data
MAPublisher FME Auto and FME FFS Import

Adobe Illustrator - Avenza MAPublisher Parameters
Initial AI File/Template
Translate data from FME to Adobe Illustrator by using existing Adobe Illustrator file (ai) or Adobe Illustrator Template 
file (ait). If no file is set for this option, a prompt will appear to create a new document when the import process 
starts in Adobe Illustrator.

Destination AI file and Document disposition
After GIS data is successfully imported into Adobe Illustrator, there are several options to handle the document 
using the Document disposition drop-down options:

•	 Leave open: After the import process is complete, the Adobe Illustrator document will be kept open
•	 Save: After the import process is complete, the Adobe Illustrator document will be saved, but will  

remain open.
•	 Save and close: After the import process is complete, the document will be saved and then closed.

To save a document using a specified name, enter it into the Destination AI file box and set the document 
disposition to Save or Save and Close. Alternatively, you can specify only the Initial AI File, in which case it will be 
overwritten in the process. When no Destination AI file name is set and the Initial AI file is either a new document or 
a template, a prompt at the end of the automation process to specify a file name will appear.

Existing Document MAP View
Fit to Page After Adding Data
Enable this option to scale the data (existing and incoming) to fit to the extent of the art board.

When an existing Adobe Illustrator file contains a MAP View with the same coordinate system as the data being 
imported with MAPublisher FME Auto, the If Matching Existing MAP View Found option contains several options to 
handle the imported datasets:

•	 Create New MAP View: The datasets will be imported to a new MAP View.
•	 Prompt the User: A prompt will appear during the automation whether or not the GIS data should be 

imported to an existing MAP View. With this option, user can specify which MAP View to use.  This 
option is useful when there are multiple MAP Views with the same coordinate system available in the 
specified Adobe Illustrator file.

•	 All data to first matching MAP View: If the specified Adobe Illustrator file has multiple MAP Views with the 
same coordinate system, GIS data via FME Automation will be brought  to the first MAP View with the 
same coordinate system as the one with the GIS dataset being imported.

New MAP View Properties (optional)
Coordinate System File
Choose a coordinate system file (WKT, PRJ, TAB) for the new MAP View.

Scale
Set an initial map scale for the new MAP View.

Origin
Choose a point of origin (lower-left corner or center) for the new MAP View.
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Other Parameters
Strip Format Attributes
When GIS data is converted to FME Feature Store (FFS) format, the FFS file may contain extra attributes to preserve 
information of the original data format such as dimension, geometry type, and feature type information.  Enable 
this option to prevent these attributes from being imported into the Adobe Illustrator document.

Note that FFS retains all the attribute data from its initial sources, which may include source format-specific 
attributes, source user attributes, etc. While disabling this option minimizes the amount of data imported, enabling 
it may result in better rendering of the original dataset features and allow you to perform stylization in MAPublisher 
based on the original source attributes.

Wait For Result from MAPublisher
By default, after sending a request to MAPublisher to perform an import operation, FME does not wait for the 
application to complete it and immediately proceeds to the next item. When this option is enabled, the format 
writer will wait for MAPublisher to finish its work and report the results to the FME log, rather than having it 
displayed in MAPublisher.

Quit Launched Illustrator If Unused
MAPublisher FME Auto starts Adobe Illustrator if it is not running. Enable this option to quit Adobe Illustrator after 
the import process if it was launched by FME and it has no other pending requests. If Adobe Illustrator is already 
running when MAPublisher FME Auto begins, this option will be ignored. Please also note that all the writers in the 
workspace should have this option enabled for AI to Adobe Illustrator to quit. Please also note that depending on 
timing Adobe Illustrator may quit and launch multiple times if this option is set, since it makes the decision about 
quitting only based on the requests that have arrived so far.

Character Encoding
By default, the current system locale is used to decode language-specific data for attribute definitions and values. 
This option is the way to specify what encoding should be used to interpret the attribute data in MAPublisher.

FFS File Compression Level
This option is inherited from FME FFS writer option and has three settings: None, Medium, and High. A lower 
compression level will result in faster operation while a higher compression level will result in smaller file sizes.

FME Workbench Navigator
All the parameters for the Adobe Illustrator - Avenza MAPublisher writer are available in the FME Workbench 
Navigator. Use this panel to adjust parameters before importing GIS data to Adobe Illustrator.

The Adobe Illustrator - Avenza MAPublisher Parameters dialog box is only accessible once. After it is closed, it 
cannot be accessed again. All the parameters in that dialog box are available in the Navigator panel.
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MAPublisher Preference Settings for FME Auto
FME Auto preference settings are available in MAPublisher Preferences (Chapter 1).

Run this version of Illustrator when using FME Auto
Enable this option to set a specific version of Adobe Illustrator to be used as 
the default when multiple versions of Adobe Illustrator (which are compatible 
with MAPublisher 8.6 and newer) are installed. 

If this preference is not enabled in any of the Adobe Illustrator versions 
installed, the most recent version will be launched when MAPublisher FME 
Auto starts. For example, if a machine has Adobe Illustrator CS5 and CS6 
installed with MAPublisher 9, the CS6 version will be launched.

When Adobe Illustrator is already running before MAPublisher FME Auto starts, 
it will be used for MAPublisher FME Auto regardless of the option selected in 
MAPublisher Preferences.

Seconds before timeout
This option specifies the number of seconds FME Desktop 
will try for when attempting to open Adobe Illustrator. If 
FME Desktop can not open Adobe Illustrator, a message 
will appear in the FME Log.

KNOWN LIMITATIONS

•	 Raster Image import with MAPublisher FME Auto is not supported
•	 Raster Image in FFS format cannot be imported to MAPublisher
•	 Multipoint geometry cannot be imported.
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The MAP Views panel is the hub from which many additional 
MAPublisher features may be accessed. It organizes MAP 
layers into based on distinct coordinate systems known as 
MAP Views. Use this panel to specify coordinate systems 
for MAP Views, peform coordinate transformations, adjust 
scale, change data alignment and placement, and export to 
industry standard GIS formats.

When importing data, an Adobe Illustrator layer is created for 
each feature type, and is by default appended with a _point, 
_line, _area, or _text suffix in the Adobe Illustrator Layers 
panel. Certain file types generate multiple layers, such as 
DGN or DXF, but are similarly split up by feature type. A single 
import of such files produces a single MAP View as an import 
can only take place into a single coordinate system. Custom 
MAP Views may be created in order to georeference existing 
Adobe Illustrator artwork.

The following pages deal with the creation and management 
of MAP Views, specifying and projecting a coordinate system, 
editing scale and data placement on the page, merging Adobe 
Illustrator layers, and exporting to GIS formats.

Topics covered in this section:
MAP Views Panel
MAP View Editor
Export MAP Layers and MAP Views
MAP Info Panel
Copy MAP Objects From

MAP Layers and 
MAP Views
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MAP Views Panel 
Window> MAPublisher > MAP Views and MAP Toolbar 

MAP Views - Each contains 
distinct configurations of 

geospatial parameters

New MAP View - Create a new MAP View and specify its name and coordinate information.

New MAP View For Photoshop Paths- Specify a new MAP View based on paths exported from Geographic Imager/Adobe Photoshop.

Duplicate Selection - Create a duplicate of the currently selected MAP View.

Edit Selection - Open the MAP View Editor to edit the name and coordinate system of the currently selected MAP View.

Delete Selection - Delete the currently selected MAP View or MAP Layer provided it does not contain any Adobe Illustrator layers.

Add MAP Layer - Create a new MAP Layer through Add MAP Layer dialog box.

Specify Anchors - Manually establish the tie-in point between Map and Page Anchors (should only be used for new MAP Views or 
for the correction of georeferencing errors).

Export Coordinate System to File - Exports the selected MAP View coordinate system to a WKT definition (wkt) (see Appendix A2).

Export Selection - Enable the export of the selected MAP View or MAP Layer to various GIS formats.

Layer Name Search & Replace - Search for text within layer names and specify an alternative.  Useful for multi-layer imports.

Sort Art on Layer - Sort art in ascending or descending order based on attribute.

Edit Layer Note - Add or edit the selected layer's note.

Load Custom Coordinate Systems - Load external coordinate systems in XML format (see Appendix A2).

Document Summary - View a summary of all features and other art on both MAP layers and non-MAP layers.

Specify Alternate Coordinate System - Choose a coordinate system that appears as an alternate option on many MAPublisher tools.

Edit Custom Coordinate Systems - Open the custom coordinate system editor to create new coordinate systems and edit the 
parameters of existing ones in the data source (see Appendix A2).

Copy MAP Objects From - Copy MAP Views, MAP layers, MAP Themes (including Stylesheets), and MAP Selection Filters from other 
open documents.

Preferences - Opens MAPublisher Preferences on the MAP Views Panel property sheet (see chapter 1).

MAP Layers - An alphabetical 
list of the layers that comprise 

each MAP View, symbolized by 
feature type.

Non-MAP layers - Lists the Adobe 
Illustrator layers that are not part of 

a specified MAP View, and do not 
contain georeferenced information

Delete selection button - Delete the 
currently selected MAP Layer or 
MAP View

Layer Operations - Zoom, toggle lock, 
and toggle visibility of MAP Views 
and MAP layers.

Lock button - Click box to lock 
or unlock a MAP Layer (lock 
check box is mirrored in the 

Adobe Illustrator Layers panel)

Switch MAP View - Click this button to 
switch the selected layer from one 
MAP view to another. Remove MAP 
data moves the selected layer to 
the [Non-MAP layers] section and 
removes the georeferencing and 
attributes in the process. 

Layer Note - Click this button to 
add a layer note. A note with no 

+ symbol already contains a note.

Export MAP View / Export MAP Layer  
Export the selected MAP View or 

MAP Layer to various GIS formats

MAP Views Panel Options Menu

Add MAP Layer - Creates a new MAP 
layer (in both the MAP Views panel 
and the Adobe Illustrator Layers 
panel). Opens the Add MAP Layer 
dialog box.
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Missing Coordinate System
Automatically opens when dragging a MAP Layer to an alternate MAP View, and 
either the source or destination MAP View has an unspecified coordinate system.

Specify coordinate system Choose this option 
and then click the Select button to specify 

the coordinate system of the named 
MAP View via the Select Coordinate 

System dialog box (see Appendix 2). Once 
selected, the coordinate system will be 

displayed below it.

Same as - Choose this option in 
order to assign a coordinate 
system to the named MAP View 
that matches that of an existing 
MAP View. The coordinate 
system of the selected MAP 
View will be displayed below.

Layer Name Search & Replace

Find what - Type in the 
variable contained in the 
current layer names on 
which you wish to search

Replace with - Type in the 
variable you wish to change 

the layer names to

Undefined Layer
Automatically opens when switching a Non-MAP layer to a specified MAP View.

Apply to all - When multiple layers 
are switched at once to a specified 
MAP View, check this box to apply 
the same feature type to all

RELATED TOOLS

Feature type -Select the type of feature that 
exists on the layer being dragged. This 

drop-down list presents a choice of Area, 
Line, Point, Image, Text or Legend layer 

types.

Base attribute schema on - Check this option to 
copy the attribute schema from the existing 
MAP Layer selected in the drop-down list

Plot Centroids, Label Features, MAP Tagger 
Tool and MAP LabelPro tools make use of this 
option, see specific chapters. 

Add MAP Layer

Specify Anchors
Should only be accessed when creating a new MAP View  

or correcting inaccurate georeferencing information. 
Caution: editing anchors can damage the accuracy of the data.

Map Anchor - The location of the Map 
Anchors in the units of the selected 

coordinate system. Click the MAP 
Location button to choose a World 

MAP Location as a page anchor.

Page Anchor - The location of the  
Page Anchors in the units of the 

current document. Click the MAP 
Location button to choose a Page 

MAP Location as a page anchor.

Input Coordinate System - Specify the 
coordinate system in which the 
anchor position is entered. Use 

the current MAP View's coordinate 
system or specify a different one 
(by default, the geodetic system 

base of the projection or WGS84, in  
latitude-longitude format).

Feature type -Select the type of feature 
of the new layer. This drop-down list 

presents a choice of Area, Line, Point,  
Image, Text or Legend layer types

Base attribute schema on - Check this option to 
copy the attribute schema from the existing 

MAP Layer selected in the drop-down list

Plot Centroids, Label Features, MAP Tagger 
Tool and MAP LabelPro tools make use of this 
option, see specific chapters. 

Layer name - Type the name of the new 
layer (it will appear in both MAP Views 

and Adobe Illustrator Layers panels)
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OVERVIEW

The MAP Views panel displays a list of all the Adobe Illustrator layers in the current document and all MAP Views—
defined configurations for geospatial parameters (coordinate system, anchors, map scale and rotation). Every 
MAP Layer is shown in this panel as belonging to a particular MAP View. Adobe Illustrator layers that do not have 
georeferencing information (e.g. non-map objects such as diagrams and supplemental art) are placed in the 
[Non-MAP layers] category.

Categories are symbolized in the following manner:

 MAP View Contains  layers with georeferenced and attribute information.

 Non-MAP layers Contains layers with no georeferenced or attribute information. 

Each layer that belongs to a MAP View is symbolized in MAPublisher panels and dialog boxes with an icon 
identifying its feature type:

  Area layer (e.g. county boundaries, urban areas, country outlines etc.)

  Line layer (e.g. rivers, roads, railways etc.)

  Point layer (e.g. town and city symbols, railway stations etc.)

  Text layer (e.g. text labels)

  Legend layer (for MAPublisher Legend items: North Arrows, Scale Bars, Grids)

  Image layer (for referenced images)

Note:	 Layers are sorted alphabetically or by data type, as specified in the MAP Views category in the MAPublisher 
Preferences (see chapter 1).

FUNCTIONALITY

MAP Views are designed to give easy access to settings for specifying and transforming coordinate systems, for 
editing scale and data placement on the page and for exporting to GIS formats. The MAP Views panel allows 
toggling Adobe Illustrator layers accessibility, georeferencing existing Adobe Illustrator artwork, changing multiple 
layer names and projecting data on the fly.

USING THE MAP VIEWS PANEL

Creating New MAP Views
To create a new MAP View, click New MAP View in the panel options menu. This opens the MAP View Editor (discussed in 
MAP View Editor section). Specify a coordinate system and enter values for scale, rotation, and page anchors. After 
creating a new MAP View, the Specify Anchors item from the MAP Views panel options menu must be used to define 
the tie-in point between Map Anchors and Page Anchors.

Note:	 Creating a new MAP View is only recommended when registering a non-referenced Adobe Illustrator 
document. To transform an existing MAP View to a new coordinate system and scale (e.g. to create an inset 
map), use the duplicate MAP View function and transform or rescale the copied MAP View.
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Duplicate And Delete MAP Views
MAP Views can be duplicated. For example, to create inset maps make a duplicate and drag MAP Layers into the 
new MAP View. Then use the MAP View Editor to edit the placement, scale or coordinate system of the duplicate. 
Note that MAP Layers can only be duplicated in the Adobe Illustrator Layers panel.

Delete a MAP View or MAP Layer using the Delete button at the base of the panel or through the MAP Views panel 
options menu. When deleting a MAP View, any MAP layers (and sublayers) within it are also deleted.

Create New MAP Layers 
Create new MAP Layers to hold geospatial data or to generate artwork using MAPublisher tools (plot points, labels, 
legends, grids, scale bars and north arrows).  Click the Add MAP Layer button to create a new Adobe Illustrator layer 
which simultaneously places it into a selected MAP View. Specify the appropriate Layer name and Feature type for the 
new layer.  Below are examples of the types of MAPublisher tools that require a specific MAP Layer type:

Area layer Buffer Art, Join Areas, Line Plotter (see chapter 8)

Line layer Buffer Art, Join Lines, Line Plotter (see chapter 8)

Point layer MAP Point Plotter (see chapter 6)
Join Points (see chapter 8)

Text layer Label Features, MAP Tagger (see chapter 10) 
MAPublisher LabelPro (see chapter 17)

Legend layer Grids and Graticules (see chapter 13) 
Scale Bars, North Arrows (see chapter 14)

Image layer Import Image, Register Image (see chapter 3 and 12)

Note:	 The Advanced option Base attribute schema on will copy the attribute schema from an existing MAP Layer (see 
chapter 5 for details). This option is required to enable the copying of attributes from source to destination 
layers in the MAPublisher labelling tools and Plot Centroids function. See respective chapters.

Reproject MAP Layers using the MAP Views Panel
The MAP Views panel can be used to move Adobe Illustrator layers from one MAP View to another; projecting 
vector* data-on-the fly. Alternatively, drag-and-drop layers or use the Switch MAP View button.
* Raster imagery cannot be reprojected with MAPublisher.

Alternatively, use the drag-and-drop method. For example, to reproject a layer that has a UTM projection into a 
Lat/Long projection, click it and drag it from the MAP View with the UTM projection and drop it into the MAP View 
with the Lat/Long projection. MAPublisher will automatically reproject and scale artwork on the layer to match the 
destination MAP View. The Missing Coordinate System dialog box appears when neither the origin nor destination 
MAP View contains a defined coordinate system. Two options are available in this dialog box:

1.	 Specify coordinate system: specify projection using the Source Coordinate System function.
2.	 Same as: specify coordinate system based on an existing MAP View in the document.
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Note:	 Many transformations will inherently cause the loss of precision by the very nature of complex mathematical 
calculations that must be performed. Additionally there are differences in precision between MAPublisher 
and Adobe Illustrator. MAPublisher calculations are in 64-bit for accuracy, but the results are stored in 
Adobe Illustrator as 32-bit. As a result, please be aware that some precision may be lost if layers are dragged 
repeatedly from one coordinate system to another. When determining a coordinate system to use via the 
drag method, we strongly recommend Edit > Undo to revert back until the appropriate system is found.

Assign Georeferencing Information to Adobe Illustrator Layers
Existing Adobe Illustrator layers that do not contain georeferencing or attribute information also appear in this 
panel under the default MAP View entitled [Non-MAP layers]. Such layers can be moved into a specified MAP View with 
a matching geospatial configuration (coordinate system, scale, position on the page, etc.).

Note:	 Moving a non-MAP layer to a MAP View does not imply any transformation (the artwork is not redrawn). 
Ensure that the art on the non-MAP layer is positioned and scaled properly on the page with regard to the 
MAP View definition.

Moving a non-MAP layer into a specified MAP View prompts the Define Layer dialog box. Use it to specify the feature 
type of the moved layer. Multiple layers may be selected and moved together to a specified MAP View. Use the Apply 
to all option to assign the same feature type to all layers being moved. The Base attribute schema on option copies the 
attribute schema from an existing MAP Layer (see chapter 5 for details).

Specify Anchors
The Specify Anchors function should only be accessed when referencing a new MAP View (for example in the 
process of georeferencing an Adobe Illustrator file, see appendix A1) or to correct an inaccurate referencing. 

When the Use Current MAP View's coordinate system option is chosen, Map Anchor coordinate values are entered in the 
map units of the coordinate system of the MAP View. Map Anchor coordinates must be known from information 
written on the map (e.g. graticule crossings) or from external sources (metadata, survey points or other). MAP World 
Locations can be used as Map Anchors.

When the Use: [coordinate system] option is chosen, the current coordinate system link is enabled. Click it to open 
the Select Coordinate System dialog box. The coordinates values entered will be in the unit (Point Style) of the chosen 
coordinate system. When the selected or default coordinate system is projected, X and Y coordinates are entered in 
the unit (Point Style) of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate 
system is Geodetic, Lat and Long coordinates are entered in degrees.

Note:	 When the current MAP View coordinate system is a projected system, the default system specified in 
Use: [coordinate system] is set to the geodetic system base for the projection. For example, if the MAP View 
system is US State Plane NAD83 / Colorado North (ftUS), the default alternative system is set to NAD83 (to 
enter the latitude/longitude coordinates in degrees).

The Page Anchor is entered in the current unit of the document. This unit can be changed through the Adobe 
Illustrator menu File > Document Setup. Positions of points on the document in page coordinates are determined 
using the Adobe Illustrator Info panel (menu Window > Info). MAP Page Locations can be used as page anchors.

Note:	 For CS5 users, Page Anchor values must be relative to Global Rulers. To use Global Rulers, choose View > 
Rulers > Change to Global Rulers.
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Layer Name Search & Replace 
To quickly change the names of multiple Adobe Illustrator layers, use the Layer Name Search & Replace function 
located in the MAP Views panel options menu. For example, MicroStation Design or CAD imports can contain 
a large number of similarly named layers and doing a name search and replace is more efficient than manually 
changing each of them.

Zoom to MAP Layer or to MAP View
To zoom to a MAP Layer, select one and click the Layers Operations button at the bottom of the MAP Views panel. Click 
the Zoom to "[Layer]" in the context menu. When a MAP View is selected, this option becomes Zoom to all layers in "[MAP 
View]". This is particularly useful for documents containing a large number of layers.

Layers Operations
The Layer Operations button will perform a variety of layer operations. If a MAP Layer is selected, use the context 
menu to Lock, Unlock, Hide or Show "[Layer]" or to Lock, Unlock, Hide or Show all layers except "[Layer]". If a MAP View is selected, 
the same options become for all layers in "[MAP View]" or all layers except layers in "[MAP View]".

MAP Layer Note
MAP Layer Notes contain general information about the layer, such as how it was created or on its source data. MAP 
Layers with no layer notes are marked with an Add Note icon.

Layer notes can be automatically added when the layers are created through MAPublisher functions (e.g. MAP Data 
Import, Plot Centroids, Web Feature/Map Service, etc.). To do so, enable the MAPublisher General Preferences option 
Add notes for layers created by MAPublisher operations — see chapter 1 for details. The automatic notes show the function 
and parameters used to create it. For example a note of a layer created by import indicates information such as the 
path of the source data, format and date.

To add or edit a layer note, choose the MAP Views panel options menu Edit Layer Note. In the Add/Edit Layer Note 
dialog box, type new text or edit the existing information. Click the Clear button to clear all information.
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Export MAP Views and MAP Layers 
The MAP Views panel offers the option to export a single MAP View or a single MAP Layer to a multitude of GIS 
formats. This function is explained later in this chapter.

New MAP View For Photoshop Paths
The New MAP View For Photoshop Paths function creates a new MAP View using a reference file and associated 
Adobe Illustrator file exported from Geographic Imager for Adobe Photoshop. 

Adobe Photoshop offers a function to create vector paths and export them to Adobe Illustrator. Adobe Photoshop 
uses Geographic Imager to maintain the spatial reference and outputs it as an .rsf reference file. To import the paths 
into Adobe Illustrator using MAPublisher, use the New MAP View For Photoshop Paths from the MAP View panel options 
menu to create a new MAP View based on the .rsf file. After doing this, the Adobe Illustrator layers can simply be 
dragged from [Non MAP Layers] to the newly created MAP View to finalize the georeferencing. The vector data can 
now be used in a current MAPublisher project, edited, transformed or exported to any external GIS format.

Remove MAPublisher Information
At the end of a project cycle, it may be useful to permanently remove all georeferencing and attribute information 
in the current document. This can be accomplished by switching all MAP Layer(s) to the [Non-MAP layers] category 
in the MAP Views panel via drag and drop or clicking the Switch Map View button and the Remove MAP data option.

Note:	 This function should only be used as required and as a final step. Be sure to save a copy of the document 
before performing this operation as this will erase all attribute data.
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FUNCTIONALITY

The MAP View Editor displays and controls the geospatial parameters of the MAP View (coordinate systems and 
scale on the artboard), the position of the data extents on the page (alignment and rotation) and provides a way to 
change the MAP View name. A preview pane shows and allows users to move the current MAP View relative to the 
artboard and to the other MAP Views in the document.

The MAP View Editor is also where coordinate system transformations are performed. Transformations affect the 
data geometry on the page as map art is redrawn to match the new coordinate system properties.

MAP View Editor 
MAP Views panel > Edit MAP View / New MAP View, 

Advanced Import > Create New > Editor

Same as - Check this option 
to transform to a coordinate 

system used by another  
MAP View in the document

Datum shift - Displays 
the datum shift for the 
transformation

Perform Coordinate System Transformation 
Enable this option to transform the 

data to a new coordinate system. 
Click the coordinate system link 
to open the Specify Destination 

Coordinate System dialog box.

Preview Pane - Displays the data 
extents of the MAP View:

White rectangle - Artboard extents
Colour rectangle - Data extents of the 

current MAP View

Crosshair - Location of the current 
Map and Page Anchors

Configure margins - Adjust the 
artboard margins

Show/hide preview details - Display or 
hide the Map and Page Anchors 

and artboard margins

Name - Name of the MAP View 

Zoom buttons - Zoom in/out

Show all artboards - Display artboards.

Move MAP View Mode - Move the 
position of the current MAP View

Center current MAP View extents on 
screen - Fit preview to the extents

Pan preview mode - Pan around the 
preview pane

Options - Maintain point size, stroke 
width and font size when scaling 
or rotating

Previews and Configure preview 
Select and configure how the 
previews are shown 

 Positioning (also see tabs below)
•	 Quick alignment - Click the grid to control 

the alignment of the data extent relative 
to the artboard

•	 Fine-tuning - Adjust the lower left corner of 
the map extents

•	 MAP Locations - Use MAP World and MAP Page 
locations to choose a position on the artboard

Scale - Edit the MAP View scale 
relative to the page. Auto-scale 

automatically fits the data extents 
to the artboard or the margins.

Angle - Rotation angle of the MAP 
View. Click Reset Angle  to reset 

to zero; click Orient North  to 
orient the MAP View north up. 

Info - View the parameters of a 
selected coordinate system

Source Coordinate System - Displays 
the current coordinate system 
assigned to the MAP View. Click 
the link to open the Specify Source 
Coordinate System dialog box to 
select a new source coordinate 
system. To be used only if the 
source coordinate system is 
undefined or is not matching 
the data.
To apply a new coordinate system to 
a MAP View, use Perform Coordinate 
System Transformation.

Clear - Remove all references 
to a coordinate system

From File - Load a source 
coordinate system from an 
external file

From File - Load a destination 
coordinate system from an 
external file
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USING THE MAP VIEW EDITOR

The MAP View Editor can be accessed as part of the Advanced Import dialog box or from the MAP Views panel:
•	 Advanced Import: click the Create new option in the Destination MAP View section, and then click the Editor 

button to open the MAP View Editor. 
•	 MAP Views panel: select a MAP View, and then select Edit under the Options arrow in the upper right 

corner of the panel. Alternatively, double-click the MAP View name in the MAP Views panel.

Preview Pane and Configure Previews
By default, the Preview Pane displays the data extents with a green rectangle and the MAP View orientation with an 
arrow pointing north. To move the data on the page, click inside the green rectangle and drag the data to a more 
suitable position relative to the page. Use the Zoom In, Zoom Out and Center buttons to set the magnification of the 
preview. To move the page within the Preview Pane, click outside the MAP View extent and drag to move the page. 

The Previews drop-down list changes the preview to Coloured boxes (previews up to ten MAP views, each with 
different colours as specified in the Configure Previews settings), Thumbnails (preview a reduced image of the 
document contents, including all MAP views) and Thumbnails & Boxes (shows both thumbnails and coloured boxes 
of up to 10 MAP views in the document).

Note:	 Due to Adobe Illustrator rasterization limitations, thumbnails cannot be created for very large MAP Views.

To configure the previews, click the Configure preview button. To adjust the colour of the current MAP View preview, 
click the colour chip and choose a colour in the colour picker dialog box. Layer visibility can be individually toggled 
under the Visible column. Use the Show All or Hide All buttons to toggle the visibility of the entire list. To toggle 
only the layers of a particular MAP View, right-click the MAP View to access a context menu that has the options to 
Show All or Hide All. Adjust thumbnail quality using the drop-down list at the bottom of the dialog box. Quality 
settings include: Low, Medium, High, and Very High.

Note:	 Auto-Scale will only apply to the extent of the visible layers.

MAP Layers

MAP View

Thumbnail quality

Current MAP View preview colour 
Click to change the colour

Toggle Visibility (layer's thumbnails) 

Toggle Visibility (MAP View's coloured box)
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MAP View Name
The current name of the MAP View is listed in the Name box, which can be edited. MAP Views are ordered 
alphabetically in the MAP Views panel, so changing a MAP View name may change its position in the panel.

Scale
The scale of the current MAP View is shown in the Scale box. For MAP Views in a projected coordinate system, the 
scale value is a real world scale (exact ratio linear distance on the page over distance on the ground). For MAP Views 
in a geodetic coordinate system (i.e. Lat/Long format in angular unit), the scale value is approximated using the 
common formula 1°= 111.353m (metres per degree at the equator). This is not an accurate number because the 
formula is only valid at the equator, but it is more intuitive for cartographic considerations.

The scale can be edited by typing in a precise value or by using the Up and Down arrows to increase or decrease the 
scale by 10% of the starting value. The Auto-scale button applies the scale to fit the visible data in the preview to the 
artboard or margins and centers the map on the page (see Preview Pane). Click the Auto-scale drop-down arrow to 
use either the artboard or margins as the scale extent.

Rotation
A rotation figure can be applied or edited by specifying an angle in the entry field, or by using the arrow buttons. 
Notice that changes to rotation will be automatically previewed in the Preview Pane with the green rectangle and 
arrow depicting the new orientation of the data. Click the Reset Angle button to reset the angle to 0. Click Orient 
North button to orient the MAP View True North up (True North is calculated at the center of the data extents).

Positioning
During the import process, MAPublisher sets the page and map anchors so that the lower-left corner of the 
artboard coincides with the lower-left corner of the map extents. In CS5/CS5.1/CS6, the page origin (0,0) is located 
in the upper-left corner (for CS4 and lower, the page origin was located in the lower-left corner). Three positioning 
settings are available to precisely move MAP Views around the artboard. The Quick alignment tab provides an 
alignment control grid with nine preset map extent positions relative to the artboard. Click one of the positions 
(center-middle, lower-left, upper-right, etc.) to align the MAP View to the artboard. The Fine-tuning tab shows the 
lower-left X and lower-left Y value boxes which change the position of the lower-left corner of the data extents (in 
document units). The MAP Locations tab provides the ability to position MAP View extents by matching  
MAP Page locations and MAP World locations accordingly.

Notes:	 Editing the lower-left corner position does not affect data integrity. It simply means that the data is shifted 
on the page but the corresponding real world coordinates remain unchanged. 
 
The Page Anchor does not always coincide with the lower-left corner of the map extent. When manually 
registering an Adobe document, users can also enter a specific position using the MAP Views panel options 
menu Specify Anchors (see first section of this chapter).
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Set Source Coordinate System
In most cases, the MAP View source coordinate system is initially assigned during the import process if the imported 
data file contains such information (see chapter 3). To view the properties of the source coordinate system, click the 
info button.

If no coordinate system is assigned during import, the MAP View source coordinate system displays [No Coordinate 
System Specified]. In order to scale, rotate or transform the MAP View, a coordinate system must be specified. Click 
the coordinate system link to open the Specify Source Coordinate System dialog box (explained below). Alternatively, use 
From File to set the source coordinate system using an external file (e.g. .wkt, .map, .prj, or .tab).

Note:	 If you are referencing a non-georeferenced Adobe Illustrator file, it is not enough to specify the source 
coordinate system to reference your map, you'll also need to specify appropriate map and page anchors.  
See Georeferencing an Adobe Illustrator file in appendix A1 General Tips. 

In some rare cases, the source coordinate system may have been wrongly assigned during the import process 
(due to a wrong manual selection or file issue). In this case, users may want to specify another coordinate system. 
This should be done with caution as data integrity may be lost if the current coordinate system is mistakenly 
overwritten. Changing the source coordinate system does not affect the data geometry on the page. To specify a 
new coordinate system for a MAP View, use Perform Coordinate System Transformation.

Coordinate System Transformation
To transform a MAP View to another coordinate system using the MAP View Editor, click the Perform Coordinate System 
Transformation check box (the MAP View must contain data and a source coordinate system for this option to be 
available). Users have three options to select the destination coordinate system:

•	 Select a coordinate system from the MAPublisher database: click the coordinate system link in the Perform 
Coordinate System Transformation frame to open the Specify Destination Coordinate System dialog box.

•	 Select a coordinate system used by another MAP View in the document: click the Same as check box and 
select the appropriate MAP View in the drop-down list. This does not affect the page position.

•	 Select a coordinate system from another file: click From File to set the destination coordinate system 
using an external file (e.g. .wkt, .map, .prj, or .tab).

The Preview Pane displays the new data extents for the transformed MAP View, however the thumbnails view is not 
available until the transformation is finalized by clicking the OK button in the MAP View Editor. 

Some coordinate system transformations require a datum shift. When this is the case, MAPublisher selects the most 
appropriate datum transformation. This can be edited by clicking the Specify button in the datum shifts frame and 
selecting another datum transformation (see appendix A2 and Avenza Projections Guide.pdf for more information).

Note:	 Coordinate system transformations can also be performed in the MAP Views panel. Simply drag a MAP layer 
from one MAP View to another MAP View of a different coordinate system.
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Specify Coordinate System
The Specify Source/Destination Coordinate System dialog boxes allow users to select, copy and edit coordinate systems and 
associated parameters from the MAPublisher coordinate systems (Geodetic Data Source). The MAPublisher Geodetic 
Datasource is explained in depth in Appendix A2.

Coordinate systems are divided in two categories: Geodetic and Projected. For convenience, they are sorted in sub-
folders by continent > country > sub-division (e.g. state or county). The *All* category lists all systems with no sorting; 
the *Recent* category lists the last 10 systems recently selected; the *Search* category lists the result of a coordinate 
system search. The MAPublisher coordinate systems may also contain custom systems.

New MAP Views
After clicking the New MAP View button, the MAP View Editor opens for users to set the name, coordinate system and 
page scaling of the new MAP View. After a new MAP View is created, the Specify Anchors option from the MAP Views 
panel must be used to define the tie-in point between Map Anchor and Page Anchor. Map Anchor coordinates can 
be entered in any chosen coordinate system (for example, latitude and longitude in degree for projected map). This 
functionality is explained in detail in Georeferencing an Adobe Illustrator file in appendix A1 General Tips. 

Long/Lat Order (optional)
Enable the Show Latitude/Longitude ordering option in the MAPublisher Preferences for MAP Views > Editor (see chapter 1) 
to see an additional item in the Lat/Lon Order drop-down list:

The latitude/longitude order—Longitude, latitude or Latitude, longitude—applies to the following tools or panels: 
MAP Info, MAP Point Plotter and Line Plotter.

Options
When the map scale changes, the point size, stroke and text font are maintained by default. To alter how scaling 
affects these options, click the Options button in the MAP View Editor dialog box. In the Options dialog box, under 
the Scaling section, adjust the options to your preference.

Rotation options are also availble. Maintain point and text rotation by enabling the options.
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Multiple Artboards
MAPublisher can manipulate multiple artboards in the MAP View Editor.

When a document contains multiple artboards, the MAP View Editor dialog box has an additional option to select 
the Active artboard. When choosing the active artboard, the preview pane displays the number of each artboard. The 
current active artboard is shown in white, while the others are covered with a dotted pattern. The Quick alignment and 
Scale calculations are based on the active artboard dimensions.

To move the data extent (green box in the preview pane) from one artboard to another, change the Active artboard 
value to the artboard where the data is to be moved, then click the Auto-scale button or one of the Quick alignment 
grid positions.

Artboards - Preview of all artboards  
present on the canvas

Active Artboard - White background

Other Artboards - Greyed out

Active Artboard- Select the number 
of the artboard to be set as Active

Note:	 Adobe Illustrator CS5/CS5.1/CS6 allows users to move artboards. However, this action does not preserve the 
georeferencing (same effect as moving art on the active artboard). Instead of moving the artboard, users 
must use the following workflow:

1.	 Create a new artboard at the desired position on the canvas.
2.	 Open the MAP View Editor and move the MAP View from the initial artboard to the new one.
3.	 Delete the initial artboard.
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Export MAP Layers and MAP Views
MAP Views panel > Export and buttons  (MAP View)  (MAP Layer)

Dataset - Displays the directory path for 
the export of the currently selected 

layer or MAP View

Format - Select the export format for 
the selected layer or MAP View

Release - Specify the AutoCAD version 
number to export to

AutoCAD Settings

Keep format extension - Check 
this option to export layers 

with their feature extension 
(_area, _line, _point, or _text) 

which may have been 
appended to layer names 

during import

Include header 
Add the column 

headers at the 
first line of the 

exported text file

Settings - Opens a Settings dialog box for 
the input of extra parameters (see below)

Character encoding - Assign a codec if the 
attribute information held in the selected 
layer or MAP View uses a double byte 
character set

General Settings
Delimited XY Text Data /  

Microsoft Excel

MicroStation Settings

EXPORT SETTINGS

Export visible attributes 
only - Check this 
option to export 
only the attributes 
that are currently 
visible in the MAP 
Attributes panel

Seed File - If required, select a seed file to be applied 
to the exported dgn file . Click Clear to remove the 
seed file selection.

Coordinate Units - Specifies how feature coordinates 
will be interpreted and converted (Master, Sub or 
Units of Resolution).

Allow area fills - Controls whether or not fill linkages 
will be written out for ellipses, shapes, and solids.

KML/KMZ SettingsGML Settings

X-Y Coordinate Ordering - Set the X-Y coordinate ordering 
for GML files. This may help in third-party software.

MIF/MID Settings

Delimiter - Set the field delimiters to either 
comma, semicolon or tab

E00 Settings

E00 Compression Level - Set the compression of 
the exported E00 file (default is None)

Suppress Pen and Brush lines - Check this option 
to remove all pen and brush styles in the 
output MapInfo MID/MIF files

Suppress Point symbols - Check this option 
to remove point symbols in the output 
MapInfo MID/MIF files

Feature Collection Options - Select output GML schema
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FUNCTIONALITY

MAPublisher supports the export of single MAP Layers or whole MAP Views to various GIS and table formats, 
maintaining all georeferencing and attribute information. The following export formats are supported:

AutoCAD Drawing/Exchange (dwg, dxf )
Delimited Text Data (csv, tsv, txt)
Esri ArcInfo Generate (gen)
Esri Interchange File (e00)
Esri Shapefile (shp)
Image (tif with reference file, see chapter 12)

Microsoft Excel (xls)
Geography Markup Language (gml, xml)
Google Earth (kml, kmz)
MapInfo Interchange Format (mif )
MapInfo Table (tab)
MicroStation Design (dgn)

Notes:	 Exporting a MAP View to CAD or MicroStation format will assemble all hosted layers into a single file. 
 
Exporting a MAP View to Flash map or Geospatial PDF is explained in chapter 15 and 16, respectively. 
 
Only Point MAP Layers can be exported to Excel and delimited text data formats.

PREREQUISITES

The Export function exports a single selected Adobe Illustrator layer contained in a MAP View or all layers contained 
in a selected MAP View. Both imported and user created MAP Views that contain MAP Layers are suitable for export 
to GIS formats. 

USING MAP EXPORT

Export a MAP View 
To export all the MAP layers within a single MAP View, select the MAP View to be exported in the MAP Views panel, 
then click the Export MAP View button. Alternatively, click Export "[MAP View name]" in the panel options menu.

Export a MAP Layer
To export a single layer, select the MAP Layer to be exported in the MAP Views panel, then click Export MAP Layer 
button. Alternatively, click Export "[MAP View name]" in the panel options menu.  In the Export layer dialog box, choose 
the required export Format. Click the Settings button for additional options.

Note:	 Only a single MAP View or a single layer can be exported at one time.

Keep Format Extension
The name of the MAP Layer or MAP View selected for export is the default name of the exported file. However 
the feature type text (i.e. _area, _line, _point, or _text) appended to Adobe Illustrator layers by MAPublisher in the 
Import process, are removed during the export process, unless the Keep format extension option is checked.
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Export Visible Attributes
Enable this option to export only the attributes that are currently visible in the MAP Attributes panel. If this option is 
not checked, all attribute columns (including MAPublisher #Property attributes) are exported.

Format Specific Settings
Depending on the selected export format, additional specific settings may be available. This is the case for the 
following formats: AutoCAD, Delimited XY Text Data, MicroStation, MapInfo Interchange, Esri Interchange, and 
Google Earth. See the Export Settings above. When exporting to Google Earth format, specify the format extension 
(kml or kmz) in the Select Export File dialog box (Save As Type drop-down list).

Note:	 Google Earth format only supports WGS84 geodetic coordinate system. Export to it will automatically transform 
the vector data from the MAP View's coordinate system to this system as part of the export process.

Choose a Destination Folder
Most of the export formats require the selection of a destination folder only. For export to Esri or MapInfo formats, 
click the Browse button to specify a destination folder. Click the OK button to export your MAP Layer.
 
When exporting to AutoCAD format, it is required to specify a name for the exported file, and select the file extension 
(dxf or dwg) to be used. For MicroStation formats, it is required to specify a name for the exported file. To export to 
either of these formats, click the Browse button to name the export file, and then choose the file format from the 
Format drop-down list. 

ADDITIONAL NOTES

Valid Area Direction (Area Layer Exports)
When exporting area layers to GIS formats, polygon outlines must have a positive Area value, whereas holes 
contained inside compound paths (or complex shapes) must have a negative Area value. If some polygons in the 
#Area property column of the MAP Attribute table contradict these guidelines, use the following tools to convert 
the MAPublisher area calculation from a negative to a positive value or vice versa:

•	 Flip Lines tool (chapter 8) to convert multiple areas.
•	 Create a Selection Filter (chapter 11) to select all elements that have an #Area of less than zero (to select 

negative values) or greater than zero (to select positive values). Then use the Flip Lines tool.
•	 Edit the #AreaDirection property value (chapter 5) to convert areas one by one: select the area to edit 

and then choose the alternate value for #AreaDirection in the MAP Attributes panel.

Text Exports 
It is not possible to export values in the #Text property column. An alternative is to create a new string attribute 
column and assign it an expression of #Text. See Edit Schema in chapter 5 on MAP Attributes.

Texts on a path are exported as point text with an angle (main direction of the original path).
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MAP Info Panel 
Window > MAPublisher > MAP Info or MAP Toolbar > MAP Info 

Position - Easting/Northing - The Easting  
and Northing coordinates of the cursor 

in current map units

Geodetic base - Longitude/Latitude - The longitude 
and latitude based on the geodetic datum of 
the coordinate system

FUNCTIONALITY

The MAPublisher MAP Info panel displays the coordinates of the mouse cursor on the selected map layer, in current 
Map Units and in Degrees. Geodetic latitude and longitude values are in reference to the geodetic datum set in the 
coordinate system definition. The WGS84 latitude and longitude values are in reference to the World Geodetic 
System. Ungeoreferenced layers display its coordinates in Page Units. The panel also displays Scale, Rotation and the 
Coordinate System and Units of the active MAP Layer.

USING THE MAP INFO PANEL

Click the MAP Info button on the MAPublisher toolbar or from the menu Window > MAPublisher > MAP Info. The map 
coordinates update in the panel with every change of the location of the mouse cursor.

The map units correspond to the units of the active layer. If it is a MAP Layer, the units are taken from the MAP 
View's source coordinate system. If it is a Non-MAP Layer, the units of the Adobe Illustrator documents are used (see 
File > Document Setup). 

To show Geodetic, WGS84 or MGRS (Military 
Grid Reference System) values, click the panel 
options menu and choose the appropriate 
display. The panel will update to display the 
chosen coordinate values.

Notes:	 The map coordinates update even when other tools are selected. 
 
When the cursor is placed outside of the MAP View extent of the selected layer, positions' values are 
indicated as Unavailable.

Displays the parameters of the currently selected layer.

Scale - Map scale of the current layer

Coordinate System - Coordinate system of 
the current layer (if specified)

Units - Units of the coordinate system (if specified)

Rotation - Angle of rotation
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Copy MAP Objects From
MAP Views panel > Copy MAP Objects From or MAP Toolbar  

MAP Views - List of available 
MAP Views to import

MAP Themes - List of available 
MAP Themes to import

MAP Selections - List of available 
MAP Selections to import

Document - Available open 
map document

Source Toggle - Click 
checkbox to select 
MAP Objects in source 
document for copy to 
the active document

FUNCTIONALITY

The Copy MAP Objects From feature copies MAP objects from an open document to another open document, 
including all MAP Views and the layers that are within them, MAP Themes, and MAP Selections. This can be a useful 
tool when merging parts of several documents into a single document. For example, it might be useful to import a 
commonly used inset map.

PREREQUISITES

At least two Adobe Illustrator documents must be open to use Copy MAP Objects From. The active document does 
not need to contain any MAP View, but the second document must contain at least one MAP View.

Note:	 Copy MAP Objects From imports all the layers contained in the selected MAP View. To choose specific MAP 
layers to import, in the source document, make a duplicate of the MAP View and copy or move only selected 
layers to it. Then proceed to import the duplicate MAP View.

USING COPY MAP OBJECTS FROM

Click the Copy MAP Objects From button on the MAPublisher Toolbar or click Copy MAP Objects From in the MAP Views panel 
options menu.

The Copy MAP Objects From dialog box shows all other documents currently open, along with all the MAP Views, 
MAP Themes and MAP Selections they contain. Click the toggles to select at least one MAP object to be copied from 
the source document and click OK to copy it to the active document.

Note:	 Copy MAP Objects From can also be accessed in the MAP Themes and MAP Selections panel options menus.
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MAPublisher can import GIS files into Adobe Illustrator while 
maintaining both geographic referencing and attribute 
information. This makes it very easy to produce high quality 
maps. 

Attribute information can be used in many powerful 
MAPublisher functions such as MAPublisher labeling engines, 
MAP Themes, MAP Selections and MAP Web Author.

This section explains the principles of attribute information 
and how they are manipulated within MAPublisher. 

Topics covered in this section are:
Attributes Foreword
MAP Attributes Panel
Edit Schema
Expression Builder
Find & Replace Attributes
Apply Expression
Join Table
Export Attributes

MAP 
Attributes
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Attributes Foreword 

ATTRIBUTE INFORMATION

The attribute table that forms part of a GIS map file is one of the most important parts of the data set. It is in the 
attribute table that we find important information such as street names for lines, zoning or zip code numbers for 
areas and elevations for points to go along with our line, area or point vector data. Along with line, area and point 
vector data imported as explained in the previous sections, MAPublisher also imports the attribute data table 
associated with any vector map file that it supports. 

MAP LAYERS

All MAP Layers contain attribute information (except Legend MAP Layers). Each MAP Layer is symbolized in 
MAPublisher panels and dialog boxes with an icon depicting its feature type:

  Area layer (e.g. county boundaries, urban areas, country outlines etc.)

  Line layer (e.g. rivers, roads, railways etc.)

  Point layer (e.g. town and city symbols, railway stations etc.)

  Text layer (e.g. text labels)

  Image layer (for referenced images)

MAPUBLISHER #PROPERTY ATTRIBUTES

In addition to the attribute values that were imported into a work session, Area, Line, Point, Text and Image MAP 
Layers are also assigned a number of additional MAPublisher attribute columns. These property columns (prefixed 
with a #) are designed to indicate the physical properties of map art on the Adobe Illustrator canvas. Art can be 
modified directly from the attribute table by making edits to values in these columns. The following property 
columns are attached to valid map layers in this version of MAPublisher:

  Area layers
#LayerName	 The name of the containing layer. This property cannot be set.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The  name of the polygon. Editing this property will change the name in the Layers panel. 
#AreaDirection	 The direction as clockwise or counter-clockwise. Editing it will reverse the direction.
#VertexCount	 The number of points in the art. This property cannot be set.
#Style	 The Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight	 The stroke weight of the path. Editing this property will alter the stroke weight of the art.
#Perimeter	 The perimeter of the area in world units. This property cannot be set.
#PathClosed	 Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#ArtScale	 The scaling of the line stroke. Editing this value will scale the stroke weight.
#Area	 The area of the path in world units. This property cannot be set.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art.
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 Line layers
#LayerName	 The name of the containing layer. This property cannot be set.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The name of the polygon. Editing this property will change the name in the Layers panel. 
#VertexCount	 The number of points in the art. This property cannot be set.
#Style	 The Graphic Style in use. Editing this property will apply the selected style to the art.
#StrokeWeight	 The stroke weight of the path. Editing this property will alter the stroke weight of the art.
#PathClosed	 Describes whether or not the path is closed (yes or no). Editing this value will open/close the path.
#Length	 The length of the path in world units. This property cannot be set.
#ArtScale	 The scaling of the line stroke. Editing this value will scale the stroke weight.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art.

 Point layers
#LayerName	 The name of the containing layer. This property cannot be set.
#PageX	 The x-coordinate in the document units of the current point. 
#PageY	 The y-coordinate in the document units of the current point.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The name of the point. Editing this property will change the name in the Layers panel.
#HorizontalScale	 The horizontal scaling of a point object. Editing this value will scale the symbol in the X axis.
#VerticalScale	 The vertical scaling of a point object. Editing this value will scale the symbol in the Y axis.
#Rotation	 The rotation in degrees of the art around its anchor point. Editing this value will rotate art.
#Style	 The Symbol in use. Editing this property will apply the selected symbol to the art.
#MapX	 The x-coordinate in the world units of the current point. 
#MapY	 The y-coordinate in the world units of the current point.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art.
 

 Text layers
#LayerName	 The name of the containing layer. This property cannot be set.
#PageX	 The x-coordinate in the document units of the current point text. For text-on-a-path or  text-in-a-		
			        path, this will be the x-coordinate of the first vertex on the associated path.
#PageY	 The y-coordinate in the document units of the current point. For text-on-a-path or text-in-a-path, this 	
			        will be the y-coordinate of the first vertex on the associated path.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#FontSize	 The font size used by the text.
#FontFamily	 The font family used by the text.
#Name	 The name of the text field. Editing this property will change the name in the Layers panel.
#Text	 The contents of the text. Editing this will affect text on the page. Multiline text is allowed.
#TextLength	 The number of characters in the contents of the text art. This property cannot be set.
#Rotation	 The rotation in degrees of the art around its anchor point. Editing this value will rotate art.
#Style	 The Character Style in use. Editing this property will apply the selected style to the art.
#MapX	 The x-coordinate in the world units of the current point. 
#MapY	 The y-coordinate in the world units of the current point.
#HorizontalScale	 The horizontal scaling of a point object. Editing this value will scale the text in the X axis.
#VerticalScale	 The vertical scaling of a point object. Editing this value will scale the text in the Y axis.
#Opacity	 The opacity level of the polygon. Editing this property will change the opacity of the art. 
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 Image  layers
#LayerName	 The name of the containing layer. This property cannot be set.
#ID		  The internal unique ID to refer to Adobe Illustrator artwork within the document. Read-only.
#Name	 The name of the text field. Editing this property will change the name in the Layers panel.
#PixelWidth	 The number of pixels across the width of the image.
#PixelHeight	 The number of pixels across the height of the image.
#Opacity	 The opacity level of the image. Editing this property will change the opacity of the image.
#LowerLeftX	 The lower left X coordinate of the image. Read-only.
#LowerLeftY	 The lower left Y coordinate of the image. Read-only.
#UpperLeftX	 The upper left X coordinate of the image. Read-only.
#UpperLeftY	 The upper left Y coordinate of the image. Read-only.
#UpperRightX	 The upper right X coordinate of the image. Read-only.
#UpperRightY	 The upper right Y coordinate of the image. Read-only.
#LowerRightX	 The lower right X coordinate of the image. Read-only.
#LowerRightY	 The lower right Y coordinate of the image. Read-only.

Warning:	 The #ID property is not persistent. This means that if a document is saved and re-opened, the #ID value 
might change. The value will usually not change over the life of a document session, but there are Adobe 
Illustrator operations that can cause the value to change.

IMPORTANT ADOBE ILLUSTRATOR COMPATIBILITY NOTES

Several Adobe Illustrator functions may cause the link between artwork objects and their attributes to be broken, 
resulting in possible data loss. These functions are:

•	 Compound path (Make)
•	 Pathfinder
•	 Live Paint
•	 Gradient mesh

•	 Blob brush
•	 Shape-builder tool
•	 Eraser Tool
•	 Knife Tool

By default, releasing a compound path also breaks the link between released paths and the attributes. To avoid 
this behaviour, users may enable the option Replicate attribute data to compound path sub-components in the MAPublisher 
Preferences for MAP Attributes. This option must be enabled before the attribute schema is created or updated for 
the attribute data to be copied to the compound path components. To fully enable this option, follow the simple 
steps below:

1.	 Enable Replicate attribute data to compound path sub-components.
2.	 Change the visibility status of one attribute column to force the attribute schema to update itself.
3.	 Release the compound path.

Note:	 This option has an impact on performance, so it should only be enabled if necessary. 

If required, users should first duplicate their working layer in the Adobe Illustrator Layers panel before using these 
functions. The original layer can be kept for labeling (see chapter 10 and 18) or for information purposes.
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MAP Attributes Panel
Window > MAPublisher > MAP Attributes and MAP Toolbar  

Attributes and Properties 
Attribute and property 

values on the selected layer 
are displayed here

Edit Schema - Edit the properties of 
all columns of the current attribute 
table: column names, visibility, 
type and width, assign expressions 
to columns

Pin Current Selection - Attributes remain 
active even after art is deselected

Click header to sort column 
values alpha/numerically

Delete Column - Delete the 
currently selected column

Edit Column - Edit the properties 
of the selected column

Right-click (Windows) or Ctrl-click (Mac) to display the menus:

Show/Hide Columns - Enable or 
disable column names to 
show or hide columns. Or 
choose to show all columns, 
or hide all columns.

FUNCTIONALITY

The MAP Attributes panel displays the map attribute and property attribute records for a map layer, which are 
linked to the graphic elements of the map, and makes them available for editing. This panel is also the hub from 
which you can edit column schemas, toggle visibility, add or delete columns, join tables, find and replace attributes, 
and apply expressions to selected art. Only the visible attributes of selected map features will be displayed in the 
dialog box.

USING THE MAP ATTRIBUTES PANEL

Viewing Attributes
Selected features are sorted by layer. The Layer drop-down list shows all the layers that currently have features 
selected, as well as the number of selected map objects for each layer (also reported at the base of the panel). The 
attribute values displayed in columns in the MAP Attributes panel can be sorted in ascending or descending order 
by clicking the column header. The widths of the columns may be changed by clicking the column separator and 
manually dragging it to resize as desired. Use the recordset navigation controls to scroll through table entries.

Zoom to Feature - Click the 
Feature number or right 
click the attribute and 
select Zoom to Feature

Highlight Feature - Click the 
feature attribute to highlight 
that feature on your map

Layer Selection - If data is 
selected on a number of 

layers, select the map layer 
containing the attributes to 

be viewed with this list

Hide Column - To hide the 
currently selected column

New Column - Adds a new 
column to the attribute table

Join Table - Click to join an external data 
table to the current attribute table

Apply Expression - To assign attribute 
values or graphical properties to 
selected art via the input of an 
expression

Find & Replace - Click to find and 
replace attributes in the current 
attribute table

Export Attributes - Export all 
selected attribute information 
to a delimited text file

Preferences - Opens the MAP 
Attributes panel preferences 
(see chapter 1)

Selected objects - Number 
of objects selected on the 

current layer

Recordset Navigation - Navigate 
through table records using 
these controls and indicator

Context menus

In column header: In a row: 

Panel options menu:

Resize all to fit content 
Resize the width of all columns 
to fit the longest value

Resize [column] to fit content 
Resize only the selected 
columns

Add Calculated Data - Add or edit an 
attribute column with calculated data

Auto-Zoom - When enabled, the 
map document will zoom to the 
selected attribute automatically
Lock Zoom Level - When enabled, 
locks the zoom level
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The type of attribute is indicated by an icon preceding the column name :

Boolean: column contains True or False values
Integer: column contains only whole numbers (limited to 10 digits)

Real: column contains numbers carrying decimal values

String: column can contain attributes that are both alpha and numeric

Edit Attributes
The MAP Attributes panel is a table that displays all the attributes of selected art. All attribute values may be 
edited except for certain MAPublisher Property attributes (see earlier in this chapter). To change the value of a cell, 
double-click it and enter the new value. Keep in mind that entered values must correspond with the column type 
(i.e. only enter numbers into a column of type Real or Integer). The edits will be immediately reflected in the map 
documents database records. Existing attribute records may also be edited or modified by performing a find and 
replace operation on them.

Column Visibility
Click the Show/Hide Columns button (or right-click [Windows] or Ctrl+click [Mac] on a column in the dialog box) to edit 
the column visibility, either toggling visibility for individual columns or for all columns. It is also possible to edit the 
visibility of attribute columns with the Edit Schema tool.

This function will also Show All, Show All Except Properties (show only attributes that are non-property attributes, 
consequently hiding any visible property attributes) or Hide All.

Zoom to Feature and Auto-Zoom
To zoom into a specific feature in the attribute table, select a single attribute and click the Zoom to Feature button. This 
will automatically fit this feature to the screen and highlight it—useful for closer examination or to simply locate it 
on the map. To highlight a specific feature on the page maintaining the current zoom level, click another attribute 
of that feature.

To automatically zoom to a selected feature, enable Auto-Zoom in the panel options menu. As long as it is enabled, 
the zoom will change every time a different feature is selected. Use Lock Zoom Level to maintain the same zoom level 
for all features selected afterwards.

Property Attributes
The attribute table can also be configured to display property attributes for datasets. These attributes describe the 
current assignment of graphical properties such as the stroke weight, style, rotation and scale. Some of these fields 
can be edited and provide the ability to modify a map object's graphical properties directly within the context of 
the MAP Attributes panel.

Pin Attributes
Click the Pin button to keep selected attributes active even after the artwork is unselected. This may be helpful 
during attribute editing when accidentally unselecting artwork may occur. To unpin attributes, click the Pin button 
again. When attributes are pinned, attribute values can be manually edited but the functions at the bottom of the 
panel are disabled except for Zoom to Feature (Show/Hide columns, Edit Schema, Find and Replace, Apply Expression, 
Join Table and Add Calculated). The Export Attributes function is also disabled.



109Chapter 5:  MAP Attributes
Edit Schema 

Edit Schema 
MAP Attributes panel > Edit Schema / Edit Column / New Column  

In MAPublisher, the term schema is used to define the structure of the MAP Attributes table. 

FUNCTIONALITY
The Edit Schema function provides settings to edit and manage the attribute structure of datasets, create, edit and 
delete columns, set visibility preferences and assign expressions. Any changes made to the schema will instantly be 
reflected in the MAP Attributes panel.

USING EDIT SCHEMA 
Select map artwork containing attributes to populate the MAP Attributes panel. Click the Edit Schema button or 
menu item in the MAP Attributes panel options menu to open the Edit Schema dialog box.

Note:	 Edit Schema can also be accessed via the Edit Column context menu. Within the MAP Attributes panel, select 
the column to be edited, right-click the column heading or cell and click Edit [column name]. Edit Schema opens 
with the same column immediately selected in the column list.

Edit Schema lists all of the columns which currently exist in the MAP Layer attribute structure, including MAPublisher 
Property attributes (see previous section). By default, imported or created attributes will be visible, whereas property 
columns will not be shown by default. Please note some #Property column structures cannot be edited (read-only).

Edit Column Format 
Each column has a name and display name. The name is used in the expression builder and for export. The display 
name is used when exporting to geospatial PDF (see chapter 16) and is shown by default in the column name in the 
MAP Attributes panel (see MAPublisher Preferences in chapter 1).

Punctuation characters are not supported in column names in order to avoid potential conflicts when exporting to 
external formats. The following illegal characters are replaced with an underscore '_' upon data import or join table: 

space `  ~  !  @ #  $  % ^ & *  (  )  -  +  = {  }  [  ]  |  ;  :  "  '  \  ,  <  .  >  /  ?

Up / Down - Click to move the 
selected column up or down 
the column list. Affects order 

in the attribute table.

Column list - Attribute and  
(#) property columns on the 
current layer are listed here.
Select a column here to edit 

its properties on the right.

Add - Click to add a new 
column to the column list 

Remove - Click to delete 
the selected column

Name - Edit the name of the 
selected column

Display Name - Edit the column 
display name

Type - Choose column type:  
Integer, Real, String or Boolean

Size / Decimals - Adjust the length 
of String type or number	  
of decimals of Real type

Default Value - Assign the 
same value to all items in the 
selected column, if required

Visible - Choose to show or hide 
the selected column

Read-only - Check this option 
to ensure that values in this 
column can not be edited

Derive value from expression - Check this option to assign 
an expression to the selected column. Either enter 
the expression directly into the entry field, or click the 
Browse button to access the Expression Builder dialog box.
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To rename a column enter new text directly into the Name field. All expressions referring to this attribute name are 
updated instantaneously.

Note:	 Some external file formats have limits on the number of characters allowed for field names. Therefore, during 
the export from MAPublisher, some field names may get truncated to comply to the chosen external file 
format. For example, Esri shapefiles are limited to 10 characters (confirmed up to ArcGIS 9.3), Esri Interchange 
File (e00) to 16 characters, and MapInfo to 30 characters.

Once the name is set, specify a data type by making the appropriate selection in the Type list.

To modify the amount of characters or decimals, enter a value into the Size/Decimal text box (the maximum string 
size is 28000). A Default Value can be assigned for all new objects placed on the selected layer by entering text 
accordingly. Check or uncheck the Visible option to edit a column’s visibility. Check or uncheck the Read-only option 
to edit a column’s read/write status. 

Check the Derive value from expression option to assign an expression to the selected column. Enter a valid expression 
in the Expression field or click the Browse button to enter and edit expressions via the Expression Builder dialog box. 
The Expression Validity icon will report if the expression entered is valid. Otherwise it will report and include additional 
warning notes. This function is useful, for example, to populate the column values based on the contents of other 
columns and/or mathematical formulas.

Note:	 Values derived from expressions are dynamically linked to the attributes used in the expression. Therefore, 
they are read-only. Use the Apply Expression function to generate values that can be modified. 

The following are some examples of basic expressions that can be assigned to columns in Edit Schema:

Basic expression Result

“Ontario” (applied to column = NAME) All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style) All area items are assigned the value “MAP Area 01” in the #Style column and 
are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to column = #Rotation) All point items are assigned the value 45 in the #Rotation column and are 
rotated to 45° on the page.

Note:	 String values are case-sensitive and must be entered between quotation marks (“...”).

Add, Delete and Re-Order Columns
Columns display in the MAP Attributes panel according to the display order established in Edit Schema. The display 
order of attribute columns in the MAP Attributes panel can be set by reordering the existing column list. Any 
column may be moved up or down the list by selecting it and clicking the Up or Down buttons.

To create a new column, click the Add button and input the desired column properties. To delete an existing column, 
choose it from the column list and click the Delete button. Click OK to confirm the edits to the schema. These edits 
will be immediately visible in the MAP Attributes panel.
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Expression Builder
Accessed from Edit Schema, Apply Expression, New/Edit MAP Selection,  

Edit Chart Theme, Edit Stylesheet Theme, Rule Generator  

Expression Validity - Indicates if the 
expression is valid  or invalid . 

If invalid, additional info is reported.

Objects - List of attribute and property 
columns, constants and functions for 

use in the expression. Double-click 
items to insert into expression.

Layer attributes - List of the attribute and 
property columns

Functions - List of functions for use in the 
expression if required

Constants - List of constants for use in the 
expression if required

Description - Displays information about 
the selected item in the Objects panel, 
i.e. a description and example of the 
function or constant, or information 
regarding the format of the MAP layer 
along with its attribute values.

When selecting an attribute, click the 
link Display unique values* to display 
the attribute values of the selected 
attribute column.

Cursor Position - Position of the current 
text entry point

Operator buttons - Click to insert an 
operator into the expression at the 

current cursor position

Expression Entry - Area to compose 
expressions

Expression Builder

Library - Access all expressions for the 
document including recently used, 
attribute filters, named expressions

Save - Save the current expression to a 
named expression.

*Display unique values only lists up 
to a maximum set in the MAPublisher 
Preferences for the Expression builder (see 
chapter 1 for more information)

Save Expression
This dialog box appears when the Save button is clicked

FUNCTIONALITY

The MAPublisher Edit Expression tool is used for the entry and editing of expressions. It is used in a number of 
locations such as creating new attribute values and properties, making selections or apply styles. Expressions are 
built using a combination of names, operators and functions.

Edit Expression provides functionality for a number of tools:

Edit Schema: To create or edit an expression for the generation of values in an attribute or column.
(MAP Attributes panel > Edit Schema > Derive value from expression)

Apply Expression: To apply an expression to an attribute or property column for selected art only.
(MAP Attributes panel > Apply Expression)

New/Edit MAP Selection (chapter 11): To create or edit expression criteria for use in selecting map data.
(MAP Selections panel > New/Edit MAP Selection)

Edit Stylesheet Theme (chapter 9): To create or edit an expression for use in styling map data.
(MAP Themes panel > Edit [Stylesheet Theme name] > Advanced Expression mode
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ENTER EXPRESSIONS

Expressions can be built by typing or by clicking the operator buttons and items in the Objects list (attribute name 
and values, constants and functions). These items are colour coded for easy identification: attribute names in 
purple, string values in orange, operators and numerical values in grey, constants in green and functions in black. 
Click any of the operator buttons or double-click an item from the Objects list to insert it into the expression.

It is recommended to use the interface rather than the keyboard to build expressions, to guarantee functions are 
formatted correctly (e.g. with brackets and appropriate case) and for attribute values of type strings, quotations 
marks are added automatically. Note that expressions are case-sensitive. For string comparison, all strings values 
can be converted to a same case using the appropriate function (LOWER(“string”) or UPPER(“string”)).

Validity
The validity of the expression will be displayed below the Expression Entry text area and will be updated as the 
expression is built. The Expression Validity icon will report if the expression entered is valid (green check mark). 
Otherwise it will report invalid (red exclamation) and include additional warning notes. 

Operator Buttons
Click to insert an operator at the current cursor position. Available operators are as follows:

( Open clause operator < Logical less than comparator
) Close clause operator > Logical greater than comparator
AND Logical AND operator + Mathematical addition operator
OR Logical OR operator - Mathematical subtraction operator
= Logical equal to comparator / Mathematical division operator
!= Logical not equal to comparator * Mathematical multiplication operator

& Text concatenate operator
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Expression Components 

Items in the Objects list are divided 
into three function categories: 
math, string and miscellaneous. 
Information on a selected item is 
displayed in the Description panel. 
Double-click to insert an object at 
the current cursor position.

Function Description
ABS Absolute value of a number
ACOS Inverse of the cosine of an angle
ASIN Arcsine of an angle
ATAN Arctangent of an angle
CONTAINS True if source string contains search string
COS Cosine of an angle
DEGREES Converts values from radians to degrees

<MAP Layer>*  ENDSWITH Returns true the source string ends with the suffix string
List of attribute columns† FIXED Numbers as string values

FROM_HEX Returns the decimal value of the hexadecimal string
List of #property columns IF Conditional statement

IF_CASE Conditional statement based on multiple cases

LEFT Extracts the first N characters of a string
Constants LENGTH Returns the number of characters in a string

 #false	 Boolean false value LIKE Searches the source string using wild cards

 #true	 Boolean true value LOG Gets the logarithm of the value (base 10 log)

 #pi	 π numerical value (3.141592) LN Gets the natural logarithm (base e log, e = 2.718281828)

MAX Returns biggest attribute value

MAX_COLNAME Returns name of attribute which has biggest value

MIN Returns smallest attribute value

MIN_COLNAME Returns name of attribute which has smallest value

LOWER Converts string to lower case
MID Extracts N characters of a string from a specified location
NUMBER String values as numbers
POW Base to the power of an exponent
PROPER Strings converted to capital case
RADIANS Converts values from degrees to radians
RAND Generates a random value between zero (min) and value (max)
REGEX Searches the source string using a regular expression
RIGHT Extracts the last N characters of a string
ROUND Rounds to specified decimals of precision

ROUNDDOWN Rounds down to specified decimals of precision
ROUNDUP Rounds up to specified decimals of precision
SEARCH Returns the position of a character in a string
SIN The sine of an angle
SPLIT Splits a string and extracts the indexed part of it

SQRT Square root of a value

STARTSWITH Returns true if the source string starts with the prefix string

SUBSTITUTE Replaces a set of characters by another in a string

SUBSTITUTE_RX Replaces a regular expression by characters in a string

TAN Tangent of an angle

TO_HEX Returns hex string version of value

TRIM Removes all spaces in a text (except single ones between words)

UPPER Converts string to upper case

* Layer may vary depending on tool. 
For Edit Schema, Apply Expression 
and New/Edit MAP Selections, the 
current layer is displayed. In Edit 
Stylesheet Theme, all layers hosted by 
the stylesheet are displayed.

† Unique values contained in each 
attribute column can be viewed in the 
Description panel.

Notes:	 String values are case-sensitive 
and must be entered in double 
quotes (“...”). 

For functions using indexes for 
text position (MID, SEARCH and 
SPLIT), the first index number 
is 0.
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Examples of Basic Expressions

APPLY EXPRESSION

Expression Result

“Ontario” (applied to column = NAME) All items are assigned the value “Ontario” in the NAME column.

“MAP Area 01” (applied to column = #Style) All area items are assigned the value “MAP Area 01” in the #Style column 
and are assigned the Graphic Style “MAP Area 01” on the page.

45 (applied to column = #Rotation) All point items are assigned the value 45 in the #Rotation column and are 
rotated to 45° on the page.

MAP SELECTIONS

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are selected.

POPULATION < 1000000 All items with values less than one million in the POPULATION column are 
selected.

NAME = “Ontario” OR NAME = “Alberta” All items with the value “Ontario” OR “Alberta” in the NAME column are 
selected.

NAME = “Ontario” AND POPULATION < 1000000 Only the items containing the value “Ontario” in the NAME column AND 
values less than one million in the POPULATION column are selected.

MAP THEME STYLESHEET

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are assigned the 
selected style.

POPULATION < 1000000 All items with values less than one million in the POPULATION column are 
assigned the selected style.

NAME = “Ontario” OR NAME = “Alberta” All items with the value “Ontario” OR “Alberta” in the NAME column are 
assigned the selected style.

NAME = “Ontario” AND POPULATION < 1000000
Only items containing the value “Ontario” in the NAME column AND 
values less than one million in the POPULATION column are assigned the 
selected style. 
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EDIT SCHEMA

Expression Result

LOWER(NAME) (applied to column = name) All items in column name are assigned the value of the column NAME in 
lower case (e.g. “ontario” for “Ontario”)

PROPER(name) (applied to column = Proper_name) All items in Proper_name are assigned the value of the column name in 
proper case (or capital case) (e.g. “Ontario” for “ontario”)

TRIM(JOINING_COLUMN)

All items are trimmed with all spaces except single ones between words 
(e.g. "   Route        66 " becomes "Route 66"). This is particularly useful prior 
to using the Join Table function because extra spaces at the beginning, 
end or in between words will cause the join to fail. 

Examples of Complex Expressions
MAP SELECTIONS or MAP THEME STYLESHEET

Expression Result

LIKE (NAME, “*New*”) All items with the string of letters "New" in the NAME column are selected 
(e.g. “New Brunswick” and “Province of Newfoundland”)

STARTSWITH (NAME, “o”) All items that starts with the letter “o” (“Ontario”) are selected.

EDIT SCHEMA

Expression Result

ROUND((POPULATION/ AREA ),3) 
(applied to column=density)

All items are calculated as “population divided by area”, rounded to three 
decimals.

IF_CASE("null", VALUE>0,"positive",VALUE<0,
"negative")

A default status of "null" is assigned unless the value is strictly greater than 
or less than zero.

SUBSTITUTE_RX(ROAD_NAME,"\D","")

All non digit characters (\D is the regular expression for non-digit char-
acter) are replaced by nothing (two double-quotes indicate that the new 
string is blank), therefore only numerical values are kept. For example, if 
the ROAD_NAME equals "Route 66", the result is "66". This can be useful to 
prepare an attribute table prior to labeling roads with road number rather 
than road names.

SPLIT(GEOLOGIC_UNIT,"(",0)

All items containing one or more open parenthesis are split in several text 
blocks (as many as there are open parenthesis, plus one), and returns 
the first block found (index 0). For example, if GEOLOGIC_UNIT equals 
"Qmw(Qc)", the result is "Qmw".

SUBSTITUTE(SPLIT(GEOLOGIC_
UNIT,"(",1),")","")

Removes all closing parenthesis (i.e substitute all closing parenthesis  
with nothing) in the result of the same SPLIT as above, that returns the 
second text block found (index 1). For example, if GEOLOGIC_UNIT equals 
"Qmw(Qc)", the result is "Qc": first the SPLIT function returns "QC)" and 
then ")" is removed with a SUBSTITUTE.

More examples of each individual function can be found in the Expression Builder dialog box. Expand the Expression 
Components, choose a function or constant on the Objects list and the Description tab is updated with explanations 
and examples.
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EXPRESSION LIBRARY

Expressions already entered in the MAP Attributes panel, MAP Themes stylesheets (see chapter 9) or MAP Selections 
panel (see chapter 11) can be reused by selecting them from the Expression Library. 

Expressions are sorted in three categories: Recent, Named Expressions or Attribute Filter. One or more entries can be 
selected per category. Click the Insert button to add the selection to the Expression Builder—multiple selections are 
concatenated with the AND statement.

Note:	 It is not possible to insert multiple expressions from different categories at once.

Recent Expressions
Expressions in the Recent tab of the Expression Library are expressions saved in memory for the time of the Adobe 
Illustrator session (they are reset if the document is closed). They correspond to expressions recently typed 
in the Expression Builder from the MAP Attributes panel or MAP Themes stylesheets but were not saved as a 
Named Expression.

To delete a recent expression, select it in the Expression Library dialog box and click the Delete button.

Recent Expressions 
List of expressions recently 

used in MAP Attributes or 
MAP Theme Stylesheets 

during the current session.
Select one or more entries 

in the list.

Insert - Adds the selection 
to the expression builder. 
Multiple selections are 
concatenated with the AND 
statement.

Close - Closes the dialog 
without adding expressions

Delete - Delete the selected 
expression (enabled 

for Recent and Named 
Expressions only)

Note:	 In the MAP Attributes panel, expressions are saved in the recent list only when the Edit Schema dialog 
box is closed.
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Named Expressions
Expressions entered in the Expression Builder can be saved as a Named Expression by clicking the Save button. Unlike 
the Recent expressions, named expressions are saved within the Adobe Illustrator document. They are listed in 
the Named Expressions tab of the Expression Library. To delete a named expression, select it in the Expression Library 
dialog box and click the Delete button.

Named Expressions - Lists 
all the expressions saved 
through the Save Named 

Expressions dialog box.
Select one or more 

entries in the list.

Attribute Filter Expressions
The Attribute Filter tab of the library lists the expressions in use in the MAP Selections of type Attribute Filter. See details 
on the MAP Selections panel in chapter 11. Attribute Filter expressions cannot be deleted from the Expression 
Library (only the MAP Selections panel).

Attribute Filter Expressions 
Lists the Attribute Filter 
expression saved in the 

MAP Selections Panel 
(see chapter 11).

Select one or more 
entries in the list.
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FUNCTIONALITY

The Find & Replace tool provides settings to search and/or replace attribute values and properties contained in the 
MAP Attributes panel. Note that only values in visible columns can be found and/or replaced.

USING FIND & REPLACE 

Click the Find & Replace button at the bottom of the MAP Attributes panel or choose it from the panel options menu.

Find Only
Click the Find tab and enter the search criteria directly into the Find what entry field (previous criteria can be selected 
from the list). A search may be performed on all attributes by default, or only on specific columns contained within 
the MAP Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further 
refined by enabling the Case sensitive and Match whole word only options. 

Click the Find Next button to perform the search. Search results can be seen in the MAP Attributes panel; the column 
header and row number containing the first matching record will be displayed in bold text. At this point, a search 
for individual records can be done again by clicking the Find Next button. 

Find & Replace
To replace records selected through the Find operation click the Replace tab. Find & Replace criteria can be typed 
directly into the Find what and Replace with entry fields (previous criteria can be selected from the lists). A find and 
replace may be performed on all attributes by default, or only on specific columns contained within the MAP 
Attributes panel by enabling the Just option and choosing a column from the list. Criteria may be further refined by 
enabling the Case sensitive and Match whole word only options. 

There are two methods to replace values. The first method requires approving each replacement manually by 
clicking the Replace button so that each instance of the attribute located via the search parameters is successively 
replaced in the map attribute table. The second method allows for the replacement of all found records 
simultaneously, accomplished by clicking the Replace All button. 

Find & Replace Attributes 
MAP Attributes panel > Find & Replace  

Find / Replace - Choose to Find variables, or to Find 
and Replace variables simultaneously

Find what - Enter a variable on which to perform a 
search in the current attribute table. Note this list 

will also contain previous criteria.

Replace with - Enter a variable on which to replace 
found items. Note this list will also contain 

previous criteria

Find / Replace All Attributes / Just in Column - Perform 
the Find or Find & Replace on all attributes in the 

current layer or only in a specified column

Find Next - Move to the next value matching the 
Find what variable

Replace - Replace the selected value with the 
Replace with variable

Replace All - Replace all occurrences matching the 
Find what variable

Case sensitive - If checked, only values matching the 
case of the Find what variable will be found

Match whole word only - If checked, only words 
matching the Find what variable will be found 
(words containing the variable will be ignored)
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FUNCTIONALITY

Use the Apply Expression function to assign new values or edit attribute properties. For example, it can be used 
to compute attribute values based on the values in other columns, to assign a style by editing the #Style property 
attribute, or to rotate symbols by assigning a fixed value to the #Rotation property attribute. Read-only attributes 
cannot be edited with Apply Expression.

Note that property attributes are dynamic. Changes made to them in the map attribute table are reflected 
immediately in the graphical properties and on-screen display of the data to which they are linked. Expressions can 
be generated and applied to data based on the values found in an existing attribute column, providing a one-step 
process to transform a vast number of different objects in a single operation. 

Note:	 Unlike the Derive Value From Expression option in Edit Schema, values computed through Apply Expression are not 
tied to the original attributes constructing the expression and can be edited later on. Only currently selected 
artwork is affected by the changes.

APPLY EXPRESSIONS  

Ensure the data required for the application of the expression is selected and appears in the MAP Attributes panel. 
Click the Apply Expression button or choose it from the panel options menu.

First specify a column from the Apply to list to specify which attribute column the expression will be applied to. The 
columns listed here are representative of the attribute structure unique to the data layer currently displayed in the 
attribute table as well as the standard MAPublisher property attributes. 

To assign an expression to a column, enter a valid expression in the Expression text box. Alternatively, click the 
Expression Builder button to open the Expression Builder dialog box. To access other expressions saved in the map 
document, click the Expression Library button to open the Expression Library dialog box.

The Expression Validity icon will report if the expression entered is valid (green check mark). Otherwise it will report 
invalid (red exclamation) and include additional warning notes. 

Apply Expression 
MAP Attributes panel > Apply Expression  

Apply to - Select the attribute 
column on which to apply 

the expression. Attribute and 
MAPublisher Property columns can 

be assigned expressions.

Expression - Enter the 
expression into the text box or 

click the Expression Builder or 
Expression Library button

Expression Validity - Indicates if the 
expression is valid  or invalid . 
If invalid, additional info is reported.

Expression Builder - Opens the Expression 
Builder dialog box

Expression Library - Opens the Expression 
Library dialog box
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FUNCTIONALITY

Join Table provides the ability to merge external data tables directly into an existing MAP Layer attribute schema in 
order to create a single extended attribute table. The following formats are supported:

dBase (dbf ) Delimited Text (csv, tsv, txt)

USGS SDTS (ddf ) Microsoft Excel (xls)

Esri Geodatabases

When exporting tables from spreadsheet applications for use with MAPublisher the preferred format to use is 
Delimited Text (csv).

Note:	 dBase tables created or edited in Microsoft Excel must have a proper data type assigned to each column 
through cell formatting before being saved as dbf. For example, numerical values specified in a cell set with a 
format "General" will import as an Integer type by default, therefore loosing all decimal values. 

Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of geodatabases 
(ArcSDE, File and Personal). For information on Esri software requirements for this option, please refer to chapter 3.

PREREQUISITES

In order to join a table into an existing attribute schema, both MAP Layer and data table must share at least one 
common attribute column with matching values. The column must be of a matching type (i.e. String, Real, Integer, 
Boolean) in both the Source and the Destination table. If not, the join may not be successful.

Join Table 
MAP Attributes panel > Join Table  

Data Type - Choose Files (all Operating 
Systems) or Geodatabase formats 

(Windows only)

Data Set Name - Click the Browse button 
to select the data table to be joined 

Character Encoding - Assign a codec if 
the attribute information held in the 
selected dataset uses a double byte 
character set

Target Layer - Select the layer containing 
the MAP Attribute table about to be 
joined with the source table

Destination Matching Column - Select a 
column from the destination layer to 
match to a column in the Source Table

Case sensitive when matching - Values from 
the two matching columns will be 
matched based on case sensitivity

Specify Schema - Adjust the schema type 
for each column

Add matching column from source - Add 
the matching source column into the 

destination attribute table

Update existing columns instead of adding 
columns when possible - Update existing 

column values instead of adding more

Source Matching Column - Select a column 
from the source table to match to a 

column in the destination layer
First line contains column names 

For Delimited Text and Excel type 
tables, check this box to derive column 

names from the first row

Name/Worksheet - Specify the worksheet 
to use when a Microsoft Excel file is 
selected
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USING JOIN TABLE 

Click the Join Table button or choose Join Table in the MAP Attributes panel options menu.

Source Data (Files)
Click the Browse button to select the data table for import. If a Microsoft Excel file is selected, use the Worksheet 
drop-down list to specify the sheet to be used for joining. Select a column in the Matching Column drop-down list. This 
is the source attribute column to join on.

In MAPublisher, double-byte characters are supported in attributes on import, allowing such attributes to be used 
for labeling and export. To assign a codec suitable for the selected dataset, choose an appropriate entry from the 
Character Encoding drop-down list.

If the table contains column names as headers, check the First line contains column names option. If it does not contain 
headers, do not check this option and each column will be assigned a default heading name: Column1, Column2, etc.

Source Data (Esri geodatabases)
Windows users with licensed Esri software can join tables with feature classes and non-spatial tables of 
geodatabases (ArcSDE, File and Personal are supported but not the multi-OS Basic Personal Geodatabase). 

If the Data type drop-down list is set to Esri ArcSDE Geodatabase, click the Browse button to select the ArcSDE server 
connection and then select the appropriate feature class or non-spatial table. If the Data type drop-down list is set 
to Esri File Geodatabase or Esri Personal Geodatabase, click the Browse button to select a feature class or non-spatial 
table. Please refer to chapter 3 for information on ArcSDE server connection and feature class selection.

The attribute selection is the same as for Files source data.

Destination
The Target Layer is specified under the Destination section. Choose an attribute from the Matching Column drop-down 
list. This column must match the format and values as the column chosen as the Source Matching Column.

Additional Option
If the Case sensitive when matching option is checked, the column entries from the two matching columns will only be 
matched by case. If the Add matching column from source option is checked, the source column is also imported and the 
column name is appended with the number 1. The Update existing columns instead of adding columns when possible option 
attempts to update attributes instead of appending more columns to the table.

Note:	 Attribute names can not contain all numbers. If a source column name contains all numbers the column is 
joined but the attribute column name is changed to Attribute1, Attribute2, etc.
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Add Calculated Data 
MAP Attributes panel options > Add Calculated Data  

Add Centroid / Position Data

Add Colour Data

Add Statistics Data Add North Angle Data

Add Auto-Number

Not available for text layers

Not available for point layers

This option only available when point data is selected

Calculation - Set the type of calculation:
•	 Centroid (area and line layers)
•	 Position (point layers)
•	 North Angle (point layers)
•	 Statistics (all layers)

Column X - Select or add the attribute 
column to receive the x position value

Column Y - Select or add the attribute 
column to receive the y position value

Type - Select the type of coordinates:
•	 Page coordinates: position in 

Adobe document page units
•	 Projected coordinates: available if 

the coordinate system of the MAP 
View is projected

•	 Geodetic coordinates: Longitude/
Latitude position

•	 WGS84 coordinates: Longitude/
Latitude position

Unit - Set the unit when Projected 
coordinates or Geodetic coordinates is 
selected as Type

Colour attribute labels 
Specify attribute labels 

to the associated CMYK 
or RGB colours. Labels 

must be unique. Range 
values can be from zero 

to 1.0 or 100.0

Options - Apply the calculation to all art 
or only selected art

Status -  icon indicates that a new 
column is created,  icon indicates 
that an existing column is being 
updated

Target - Choose or add 
the attribute column to 

receive statistic values

Colour source - Choose 
the colour source as 

the fill or the stroke of 
the layer or objects

Target - Choose or add 
the attribute column 

to receive north 
angle values

Operation - Specify 
the operation to be 

performed: Distribution, 
Deviation, Sum, Mean 
or Standard Deviation

Colour model - Choose 
the colour model: 

CMYK or RGB

Source - Select the 
attribute column to be 
used as source for the 

calculations

Indeterminate Colours 
Colours that cannot 

be determined (such 
as gradients) are reset 
to default or a specific 
value can be specified

Target - Choose or add 
the attribute column to 

receive ID numbers

Starting ID - the number 
value at which to start

Sort by - Choose an 
existing attribute 

column to order the 
auto-number ID by.  

Sort Order - determine 
ascending or 

descending order.
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FUNCTIONALITY

The Add Calculated Data function populates existing or new MAP Attribute columns with values calculated from the art 
geometry or from another column of numerical values. The calculation options are:

•	 Geographic information: centroid position for lines and areas or position and north angle for points.
•	 Perform statistic calculations based on the overall attribute data of a specified column.

Calculated values are not updated automatically when the source column changes. Add Calculated Data must be 
run again for updates to be applied.

For single polygons, the centroid can be assimilated to the center of mass of the surface. For single lines, the 
centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of the 
largest polygon or line is used. 

Note:	 The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor 
points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor Points 
function (Object > Path > Add Anchor Points) before running Add Calculated Data.

Calculated data can be added or updated to all art on a layer or only to the selected art, however statistical 
calculations are based on the entire dataset.

PREREQUISITES

Add Calculated Data can populate new or existing attribute columns. Only attributes of type Real can be updated, 
so users should make sure that the proper data type is applied to these columns. 

For statistics calculations, the source column must be numerical (Integer or Real type). Users may need to use the 
Join Table function to import appropriate numerical data beforehand (e.g. election results per county). See Edit 
Schema in this chapter.

USING ADD CALCULATED DATA 

Make a selection on the MAP layer concerned and click Add Calculated Data from the MAP Attributes panel options menu.

Calculate Centroid or Position
If the selected data is on a Line or Area MAP Layer, choose Centroid from the Calculation drop-down list to calculate 
the x and y position of the line or area centroids. If the selected data is on a Point MAP Layer, choose Position from 
the Calculation drop-down list to calculate the x and y position of points in a specific coordinate format.

Note:	 Centroids positions are calculated using the low accuracy method (see chapter 6 on Plot Centroids for details). 

In the Column X and Column Y drop-down lists, users have the option to keep the default new column names  
(new_position_x and new_position_y), type names of their choice, or select an existing column. Only existing 
columns of data type Real are listed.
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The positions coordinate format is set in the Type drop-down list. The options are:
•	 Page coordinates: x and y positions relative to the Adobe Illustrator page reference, in page units (as 

specified in the Adobe Illustrator document setup).
•	 Projected coordinates: x and y positions in the source coordinate system of the MAP View containing the 

selected layer (if this system is projected).
•	 Geodetic coordinates: longitude and latitude positions — calculated from x and y positions if the source 

coordinate systems of the MAP View containing the selected layer is projected.
•	 WGS84 coordinates: longitude and latitude positions — calculated from x and y positions if the source 

coordinate systems of the MAP View containing the selected layer is projected.

The Unit drop-down list shows a selection of linear or angular units if the coordinate type is set to projected or 
geodetic respectively.

Finally, set the option to calculate the centroid or position to the selected art only or to all art on the current layer.

Calculate Statistics
To calculate statistics based on a source attribute column, choose Statistics from the Calculation drop-down list.

The following statistical operations are available:
•	 Deviation: for each row, difference between the current value and the mean.
•	 Distribution: for each row, current value divided by the sum.
•	 Mean: sum of all the row values divided by the number of rows in the source column (same for all rows).
•	 Standard Deviation: measure of the variability or dispersion of the row values in the source column.  

A low standard deviation indicates that row values are very close to the mean, whereas high standard 
deviation indicates that row values are spread out. Calculated as the square root of the sum of all 
deviations squared, divided by the number of rows in the source column (same for all rows).

•	 Sum: addition of all the row values in the source column (same for all rows).

In the Target drop-down list, users have the options to keep the default new column name (new_stat_col), type a 
name of their choice, or select an existing column. Only existing columns of data type Real are listed.

Then, select the required function in the Operation drop-down list. Deviation and Distribution calculate a value 
specific to each row; Mean, Standard Deviation and Sum create a single value for all rows.

In the Source drop-down list, select the source column from within all numerical attributes of the current layer. 
Users have the option to add calculated data to all art on a layer or only to the selected art, however statistical 
calculations are based on the entire dataset of the source column

Note:	 To obtain a distribution in percents, first use Add Calculated Data with the Distribution operation, then use the 
Apply Expression function to multiply the column values by 100 (e.g. COLUMN = COLUMN * 100). 
 
The standard deviation value MAPublisher uses is n. Microsoft Excel uses n-1.

Calculate North Angle
To calculate north angles of points on a Point layer, , choose North Angle from the Calculation drop-down list.
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Calculate Colours
To calculate colours of layers or objects, choose Colours from the Calculation drop-down list.

In the Colour source drop-down list, choose from either Fill or Stroke of the current layer or objects. This will be the 
source of which MAPublisher retrieves the colour values from.

In the Colour model drop-down list, choose from either CMYK or RGB. This will change the available colour attribute 
label boxes below it and set the colour attribute values. When CMYK is chosen, colour values in the attribute table 
are populated with Real numbers. For example, a cyan value of 0.2562 is equivalent to 25.62 in the Adobe Illustrator 
Color panel. When RGB is chosen, colour values in the attribute table are populated with Integer numbers. 

By default, the colour attribute label boxes are populated with the name of the colour. These are the attribute 
column heading names and can be edited, however, they must remain unique. An indicator to the right of the box 
displays either "Add" or "Update". When calculating new colour attribute values and a new label is entered, the 
indicator will display "Add". It is possible to update the values in the attribute table when the colour of the layer or 
objects are changed. When using the same attribute labels, the indicator will display "Update". This overwrites the 
existing colour values in the attribute table.

Adjust the CMYK colour Range value by representing them as numbers from 0.0 to 1.0 or 0.0 to 100.0.

Indeterminate colours are colours that MAPublisher cannot determine for a layer or object. The colour value will not 
be calculated if:

•	 objects do not have fill or stroke
•	 objects have gradient colour
•	 objects have patterns or hatches
•	 objects have colors not in CMYK or RGB (e.g. Pantone)
•	 colourrs are applied to the layer group (not object level)

In the Indeterminate Colours section, two options are available to deal with these situations. Reset attribute to 
default when colour source is indeterminate sets the attribute values to 0 (zero). The Indicate indeterminate colours 
using option allows you to specify a specific value. The default is -1.0000.

Calculate Auto-Numbers
To calculate auto-numbers for records in the attribute table, choose Auto-number from the Calculation drop-down list.

Choose or add the attribute column in the Target box. In the Starting ID box, specify a numeric value to begin 
numbering from. In the Sort by drop-down list, choose which attribute the ID values should be sorted by. In the Sort 
order drop-down list, choose ascending or descending order. For example, if the attribute to sort by is StreetName 
and sort order is Descending, an attribute table with three records will look like this:



126 Chapter 5: MAP Attributes
Export Attributes 

Export Attributes 
MAP Attributes panel options > Export Attributes

FUNCTIONALITY

The Export Attributes function exports all selected attribute information from the current MAP Layer to a delimited 
text file—comma, semi-colon, space or tab separated.

PREREQUISITES

Attributes will be exported as they are in the MAP Attributes panel. For example, users can change the number of 
decimals for attributes of type Real prior to exporting (see Edit Schema in this chapter), to limit the size of the exported 
file—or to turn on/off the visibility of some attributes, with Edit Schema or the MAP Attributes panel Show/Hide function. 

USING EXPORT ATTRIBUTES

Export attributes is accessed from the MAP Attributes panel options menu. 

In the Export Attributes dialog box, click the Browse button to navigate to the directory where the exported file will 
be saved and type a file name. By default, the exported file will be appended a .txt extension—to export in another 
delimited text format, type another file extension (csv or tsv) in the file name (e.g. world.csv).

Users have the following options to set:
•	 Export all attributes or visible attributes only. 
•	 Set field delimiter in the exported text file to Comma, Semi-Colon, Space or Tab.
•	 Export or not the column names on the first line.

The result is a delimited text file. Text attributes (type String) are exported in double quotes ("...") and are separated 
by commas in example below.

File name - Click the Browse button to select 
the directory and type the file name where 

to save the exported attributes.

Scope - Choose to export all the attributes 
or only the visible attributes.

Delimiter - Specify the field delimiter. Select 
Comma, Semi-Colon, Space or  Tab from the 

drop-down list. 

Include column names on first line 
Click this option to export the 
column names on the first line of 
the exported text file.
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The ability to accurately place locations on a map is basic 
to cartography. This can be achieved with MAP Locations 
to place page locations as well as world locations. MAP 
Locations are used for reference and can be used in other 
MAPublisher tools such Georeferencer, Area Plotter, Line 
Plotter, Point Plotter, and Vector Crop.

Create data points to represent features such as cities, retail 
shop, and airports, using precise location placement of MAP 
Point Plotter. Also use it to plot centroids and create point 
symbols at MAP Locations.

Create data areas with Area Plotter with known coordinates. 
It is a great tool to make land parcels and shapes that have 
been measured on the ground or with a GPS.

Create data lines with Line Plotter using known coordinates. 
Plot multiple locations to draw lines point to point. For more 
control, include distance and direction for navigation style 
line plotting.

Topics covered in this section:
MAP Locations
Georeferencer
MAP Point Plotter
Line Plotter
Area Plotter

MAP Locations 
and Data Creation
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MAP Locations and MAP Locations Tool 
Object > MAPublisher > MAP Locations or MAPublisher Toolbar   and Tools > MAP Location Tool  

Add MAP World Location 
Click to add a new MAP 

World Location to the list

Add MAP Page Location 
Click to add a new MAP Page 
Location to the list

Edit MAP Location 
Edit the highlighted 
MAP Location in the list

Use Online Map Service 
Create new MAP World 
Locations using an online 
map service

Remove MAP Location 
Click to remove a selected 
MAP Location from the list

Use Point Layer
Create new MAP World 
Locations with Point layer

MAP Locations - Displays 
the Name, X and 

Y coordinates, and 
coordinate system 

of each placed MAP 
Location pin.

Copy MAP Location to Clipboard 
Copy single or multiple 

MAP Location coordinates 
to the clipboard

Zoom to MAP Location - Zoom to 
the highlighted MAP Location

FUNCTIONALITY

MAP Locations are used as annotations to identify map world or page locations. These can then be used in other 
MAPublisher functions when specifying map or page anchors and in tools such as Georeferencer, Specify Anchors, 
MAP View editor, Area Plotter, Line Plotter, Point Plotter and Vector Crop.

USING MAP LOCATIONS

Plot MAP World Locations (on MAP Layer)
To plot MAP World Locations, the document must have at least 
a geodetic coordinate system. Click the MAP Location Tool in the 
Tools toolbar to enable it. The cursor changes to a crosshair 
when the mouse cursor is hovering anywhere in the document 
(including outside of the artboard). Click the artboard at an 
appropriate location to open the Add MAP World Location 
dialog box. Indicated are the coordinate system and coordinates 
of the clicked location. Optionally, copy the coordinates to the 
clipboard. MAP World Location pins are blue.

Plot MAP Page Locations (on Non-MAP Layer)
MAP Page Locations can only be plotted on a Non-MAP layer (not contained 
in a MAP View). Click the MAP Location Tool in the Tools toolbar to enable it. The 
cursor changes to a crosshair when the mouse cursor is hovering anywhere 
in the document (including outside of the artboard). Click the artboard at an 
appropriate location to open the Add MAP Page Location dialog box. Indicated 
are the page units of the clicked location. Optionally, copy the page units to the 
clipboard. MAP Page Location pins are green.

When a MAP View already exists, MAP Page Locations can be added through the MAP Locations dialog box using 
the Add MAP Page Location button. Alternatively, add them to a selected Non-MAP layer.
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MAP Locations Dialog Box
Click the MAP Locations button on the MAPublisher Toolbar or double-click the MAP Location Tool. The MAP Locations 
dialog box is used to manage both MAP World and MAP Page Locations. It shows the Name, X and Y coordinates 
and coordinate system for plotted locations. Manage MAP Locations using the Add MAP World Location, Add MAP Page 
Location, Use online map to create MAP World Locations, Edit MAP Location, and Remove buttons.

Only highlighted MAP Locations are shown on map. To copy MAP Location coordinates to the clipboard, select a 
single or multiple MAP Locations, then click the Copy MAP Location to clipboard button.

To see MAP Locations at any time (without the MAP Location Tool active), click View > Show/Hide MAP Locations to 
toggle its visibility. When set to Hide MAP Locations, the MAP Location pins are only visible when the MAP Locations 
Tool is active. Hold Shift to move MAP Locations. Adjust MAP Location label visibility in MAPublisher Preferences.

MAP Locations Used In MAPublisher Tools
MAP Locations can be used in several MAPublisher tools for georeferencing, as reference for corners, locations to 
draw lines and locations to plot points. They can also be used in Specify Anchors to identify map and page anchors.

MAP View editor

Area PlotterGeoreferencer

Line Plotter

Vector Crop

Point Plotter

Point Plotter

Point Plotter



130 Chapter 6: MAP Locations and Data Creation
Georeferencer

Georeferencer
Object > MAPublisher > Georeferencer or MAPublisher Toolbar 

Georeference & Save 
Apply the 
georeferencing 
solution and create a 
MAP View

Save 
Save the reference 
locations, but does 
not georeference

Coordinate System
The coordinate 
system used for each 
reference location

Reference Locations 
The reference location 

table shows connections 
between MAP Page 

Locations and world 
locations. Three sources of 

world locations: manual 
entry, online map, or 

another open document.

Add/Remove Reference Location 
Click Add to insert a new 
reference location. Click 

Remove to delete a selected 
reference location Specify coordinate system 

Specify a known coordinate system 
for more accurate results

Add world locations from: 
Add world locations from an online 

map source (i.e. Google Maps) or from 
another open document.

World Location 
Indicates which source the 

world location is from.
X|Longitude, Y|Latitude world locations 
World locations added from sources

FUNCTIONALITY

Use the Georeferencer tool to give spatial properties to a non-referenced map by establishing a relationship 
between page locations in the document (using MAP Page Locations) and world locations. There are three sources 
for world locations: 1. an online map service; 2. entering location coordinates manually; and 3. MAP World Locations 
from an open document. After connecting page and world locations, the tool calculates combined error using 
different projected coordinate systems. Choose a projected coordinate system based on best fit and create a new 
MAP View to contain the spatial information.

PREREQUISITES

•	 Must start with a non-georeferenced layer (Non-MAP Layer) with defined MAP Page Locations.

•	 A source of world locations. Sources are: an online map service (Google Maps), world location coordinates 
that are manually entered, and MAP World Locations from an open document.

•	 A minimum of four page/world locations should be used. However, it is recommended to use more 
locations for better accuracy.

•	 Data being georeferenced cannot have a perspective or skew. Incorrect results may occur if they do.

•	 Using an online map service requires active Internet connection.
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USING GEOREFERENCER

In all situations, it is required to define MAP Page Locations on a non-georeferenced layer before choosing real 
world locations to connect them to. Use the MAP Locations tool to plot MAP Page Locations in known locations 
so that it is possible to connect them easily to world locations. There are three sources for adding world locations 
which connect to MAP Page Locations: 1. an online map service; 2. entering location coordinates manually; and 3. 
MAP World Locations from an open document.

Click the Georeferencer button on the MAPublisher Toolbar or go to Object > MAPublisher > Georeferencer.

Use online maps to add world locations
Add world locations from online map services such as Google Maps. In the Georeferencer dialog box, click the 
online map service button to choose world locations for matching MAP Page Locations (if multiple map services 
are available, click the drop-down arrow to choose). In the Add World Locations dialog box, choosing a MAP Page 
Location from the drop-down list automatically pans and centers it on the artboard. Use the Zoom in and Zoom out 
buttons to enlarge or decrease the artboard zoom level. To navigate the online map, pan and zoom with the mouse 
(and mouse wheel) or use the navigation control slider. Optionally, enter street or city names into the Place search 
bar to find places quickly. 

Matching MAP Page Location 
Choose a MAP Page Location 

and click the corresponding 
position in the online map. 

Click the Zoom In and Zoom 
Out buttons to adjust the 

zoom level of the artboard.

World Location placemark 
Click the map to pick a world 

location. This placemark 
represents the world location 

that connects to the MAP 
Page Location.

Location search 
Search for streets and cities 
to help you narrow down 
specific locations

Zoom artboard 
Zoom in and Zoom out of 
the artboard.

To plot a world location position on the online map, navigate to a location that matches the chosen MAP Page 
Location and click it. A placemark designates that a world location has been set. To adjust the world location 
position, click and drag the placemark to a new location and release the mouse button. Unassigned MAP Page 
Locations are denoted by (UNASSIGNED) in the drop-down list.

The reference locations list gets populated with the matching MAP Page Locations and world locations. The World 
Location column shows that MAP Page Locations are matched with an online map world location.

Is Valid 
MAP Page Locations are 

connected to online map 
world locations
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Use a georeferenced document to add MAP World Locations
The source for world locations is an open Adobe Illustrator document with MAP World Locations already plotted 
in it. It is essentially retrieving MAP World Locations from another georeferenced artboard and using them in the 
current non-georeferenced artboard. In the Georeference dialog box, click the Open documents button. When 
a document is chosen in the drop-down list, the list populates with found MAP World Locations. Click the list to 
choose MAP World Locations.

Document 
Choose an open document 

from the drop-down list. 
The open document should 

have the appropriate 
MAP World Locations that 

populates the list below it.

MAP World Locations 
Choose the appropriate 

MAP World Locations to add 
to the reference list. Ctrl + 

click to pick multiple items.

The reference locations list gets populated with MAP World Locations. Importing MAP World Locations with the 
same name as a MAP Page Location will automatically match them and add to the solution. Choose the matching 
MAP Page Locations for each row. The World Location column shows that it is matched using an open document.

Is Valid 
Choose appropriate MAP 
Page Locations to match 

the MAP World Locations 
added from the open 

georeferenced document.

Manually add X and Y world locations
In the Georeference dialog box, click the Add button to add new reference locations to the list. The MAP Page 
Location column automatically populates with available locations. To add X and Y (Longitude and Latitude) world 
location coordinates, double-click the X and Y column entries.

Coordinate System 
Choose an appropriate 

coordinate system to 
georeference in

Long/Lat Coordinates
Enter world location 

coordinates that connect to 
MAP Page Locations

 The World Location column shows that MAP Page Locations are matched by manually entered world locations.

Is Valid 
When X and Y world 

locations are entered, it 
connects to the chosen 

MAP Page Location
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Georeference and Save
When at least four reference locations are valid, it is ready for georeferencing. The check box in the Use in solution 
indicates whether or not the reference location should be included in the georeference calculation. A minimum of 
four reference locations are required for georeferencing.

Click Georeference & Save to begin the georeference process. MAPublisher calculates the georeferencing and produces 
a list of coordinate systems that best fit the data.

Coordinate System Name 
Choose an 

appropriate 
coordinate system. 

These are based 
on the calculation 

of the reference 
location points.

Rotation 
The amount of 
rotation required 
to georeference 
the data.

Rank 
This value represents the rank 
of best fit. A value of 1.00 is a 

better fit than a greater value. 

Combined Error 
The total error calculated (between 
page and world locations) of X and 
Y reference locations. Click Details 
to see values of each location used.

The listed coordinate systems each have a Rank, Combined Error, and Rotation Value.  The Rank value represents a 
number that indicates the most appropriate coordinate system for the data. A value of 1.00 means the coordinate 
system is the best fit based on error values, coordinate system envelope fit, rotation, and other calculated factors. 
Rank values should be low but an appropriate match could be greater than 1.00. The Combined Error is the total 
error calculated (between MAP Page Locations and world locations) of X and Y reference locations. Click the Details 
button to see individual Error X, Error Y, and Combined Error for each reference location used in the calculation. The 
Rotation value indicates the amount of rotation required to georeference the data and will vary depending on the 
coordinate system. The resulting MAP View will be assigned this rotation.

After a coordinate system is chosen for the georeference, the final step in the process is to create a new MAP View 
that will contain the referencing information. Optionally, select layers to move to the new MAP View. These layers 
can also be moved to the new MAP View after.

Name of MAP View 
Enter a name for the 

new MAP View

Layers to move to new MAP View 
Select layers to move to the 
new MAP View. These layers 
can also be moved after the 

georeference.
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GEOREFERENCE WORKFLOW (BRIEF)

1.	 Place at least four MAP Page Locations on an unreferenced document in locations that will be matched to 
known world locations (or MAP World Locations for an open document source).

2.	 Decide which georeferencing source to use to connect MAP Page and world locations (online map, open 
document, or manual entry). Choose world locations based on the position of MAP Page Locations. Specify 
the georeference coordinate system if it is known.

3.	 Ensure a minimum of four reference locations are used in the solution and click Georeference & Save.
4.	 In the list of results, view coordinate system details, fitness, combined error, and rotation value. Choose the 

most appropriate coordinate system for the map and assign it to a new MAP View.

IMPORTANT GEOREFERENCING NOTES

•	 Georeferencing cannot be performed on an unprojected map (i.e. a map in a geodetic coordinate system).

•	 It is recommended to use as many points as possible to achieve the best geocoding results.

•	 Reference points should spaced out as best as possible (e.g. one in each corner of artboard).

•	 Zoom in to the maximum zoom level to get the most accurate location. This is true when plotting both 
MAP Page Location and matching world location using an online map service (Google Maps).

•	 See MAPublisher Preferences (chapter 1) to specify an alternate online map service.

•	 It is recommended to provide meaningful names to MAP Locations for easier identification.
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MAP Point Plotter 
Window > MAPublisher > MAP Point Plotter and MAPublisher Toolbar  

PREREQUISITES

To plot points using the Point Plotter, a georeferenced MAP View and Point layer must be chosen because it uses the 
coordinate system to calculate where specified points are plotted.

USING POINT PLOTTER

Click the MAP Point Plotter button on the MAPublisher toolbar or from the menu Object > Window >MAPublisher > MAP 
Point Plotter.

Enter Coordinates
When the Use Current Layer's coordinate system option is chosen, coordinate values can be entered in the current MAP 
units of the coordinate system of the MAP View containing the selected layer. 

When the Use: WGS 84 option is chosen, the Select button becomes enabled. Click the Select button to open the  
Select Coordinate System dialog box and choose a coordinate system as required.

Scale - Change the size of the chosen 
symbol if required. The arrow keys will 
increase or decrease the scale value by 
10% increments.

Symbol Style - Choose a symbol to use. 
Click the symbol name to open the list 
of symbols to choose from

Coordinates - Enter point coordinates in 
MAP units or in a different choice of 

coordinate system

Current Layer - Displays the selected layer 
name and coordinate system 

Format - Select the input format 
for values in degrees (when input 

coordinate system is geodetic)

Input Coordinate System - Specify the 
reference coordinate system in which 

the point coordinates are entered. 
Use the current layer's coordinate 
system, or specify a different one 

(by default WGS84, lat/long format). 
Click the Select button to open the 

Select Coordinate System dialog box and 
choose any coordinate system.

Plot- Click to plot the symbol after 
coordinates have been entered

Note:	 Points can only be plotted on point layers. The plot button will be 
disabled if another map layer type is the active layer.
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When the selected or default coordinate system is projected, X and Y coordinates are entered in the unit (Point 
Style) of the coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is 
Geodetic, Lat/Long coordinates can be entered in degrees in the following formats:

•	 Decimal degrees (D+[.d*])
•	 Delimited Degrees Minutes Seconds (D+ MM SS[.s*])
•	 Degrees.Minutes (D+.MM[m*])
•	 Degrees.MinutesSeconds (D+.MMSS[s*])
•	 Packed DMS with decimal point((D)DDMMSS[.s*])
•	 Packed DMS ((D)DDMMSS[s*])

Notes:	 Items in [ ] are optional, * means zero or more digits, + means one or more digits.

Lines of latitude run East-West (the Equator is an example), whereas lines of longitude run North-South (the 
Greenwich Meridian is an example). Positive degree values represent north latitudes and east longitudes. 
Negative degree values represent south latitudes and west longitudes. Directions can be entered either 
with positive/negative values or using the N, S, E or W letters preceding or following the numerical values, 
separated or not with a space.

Valid delimiters for Delimited Degrees Minutes Seconds format are: 
JJ space, hyphen (-), colons (:) or underscore (_), e.g. 43 41 48.98N, 43-41-48.98N, 43:41:48.98N or 

43_41_48.98N
JJ d (degree), single quote (minute), double quote (second), e.g. 43d41'48.98"N

Packed formats require the use of two digits for degrees of latitude (e.g. 1°N must be written 01) and 3 digits 
for degrees of longitude (e.g. 1°E must be written 001).

Examples of Latitude/Longitude values

Formats Decimals 
Degrees

Delimited 
Degrees Minutes 
Seconds

Degrees.Minutes Degrees.
MinutesSeconds

Packed DMS with 
decimal point

Packed DMS

Avenza Office:
43°41’48.98”N
79°23’32.38”W
(= 48°41.8163’N | 79°23.5396”W)
(= 48.6969°N | 79.3922°W)

Lat 43.6969N 43d41’48.98”N 43.418163N 43.414898N 434148.98N 43414898N

Long 79.3922W 79d23’32.38”W 79.235396W 79.233238W 0792332.38W 079233238W

Lat 43.6969 43 41 48.98 N43.418163 N 43.414898 434148.98 N 43414898

Long -79.3922 W 079 23 32.38 W79.235396 W 79.233238 -0792332.38 W 079233238

Lat N 43.6969 N 43-41-48.98 43.418163 43.414898 N 434148.98 43414898N

Long -079.3922 W 79:23:32.38 -079.235396 -079.233238 W 0792332.38 -079233238

Warning - Double-quotes (") are supported in MAP Point Plotter, but not in the import of Delimited Text.

Set up the Symbol Selection
The symbols used by Point Plotter are a direct reproduction of those that exist in the Adobe Illustrator Symbols 
panel. To open the Adobe Illustrator Symbols panel, click the menu Window > Symbols. To add symbols to the 
Symbols panel, create symbols as closed Adobe Illustrator objects and drag them into the panel. Alternatively, 
open the Symbols panel, click the panel options menu > Open Symbols Library > MAP Symbols > MAP - Symbols. The 
MAP - Symbols.ai file from the Helpful Styles & Symbols folder is installed with MAPublisher (see Appendix 4).
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Choose a Symbol and Scale
After entering coordinate values select an appropriate symbol to use by clicking the symbol name link. Again the 
symbols displayed are the symbols that currently exist in the Adobe Illustrator Symbols panel. To scale the symbol 
used, edit the Scale entry field. Clicking the Up and Down arrows will increase or decrease the value by 10%.

Note:	 When a MAP Themes stylesheet is assigned to a Point layer, it will override the map symbol chosen in the 
MAP Point Plotter panel.

Plot Points
Click Plot to plot the point in the designated MAP layer. To plot subsequent points, edit the coordinates, and if 
required, choose different symbols and click Plot again.

PLOT CENTROIDS

Source Layer - Select the Area or Line 
MAP Layer containing the paths on 

which the centroids will be calculated

Destination Layer - Select either an 
existing Point MAP Layer or create a 

new one where centroid symbols will 
be added

Options: 

Style - Select the symbol to use. 
Available Adobe Illustrator Symbols 
are listed.

Scale - Select the symbol 

MAP View - Select the MAP View 
containing the layers of interest  
(Source Layer and Destination Layer)

Use high accuracy - if the selected source 
layer is an Area MAP Layer, check this 
option for a high placement accuracy.

Plot Centroids adds point symbols at the center of polygons or lines, while copying the attributes from the source 
MAP layer when the New Layer option is selected. This function is useful for cartographic generalization purposes 
(e.g. replacing small island area by a symbol) or to simply add a meaningful symbol at the center of areas. For single 
lines, the centroid is the mid-point of the line. For polygons or lines grouped into a compound path, the centroid of 
the largest polygon or longest line is used. 

Note:	 The centroid of a Bezier polygon (smoothed path) may not be completely accurate because only the anchor 
points are used to calculate the centroid's position. If necessary, use the Adobe Illustrator Add Anchor Points 
function (Object > Path > Add Anchor Points) before running Plot Centroids on Bezier polygons.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains 
art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded 
in the Adobe Illustrator Symbols panel to use them.



138 Chapter 6: MAP Locations and Data Creation
MAP Point Plotter 

Using Plot Centroids
Plot Centroids is located in the MAP Point Plotter panel options menu. 

•	 Choose the MAP View that contains the layers whose centroids are to be plotted
•	 Choose the Source Layer containing the polygons or lines for which the centroids will be based upon
•	 Choose the Destination Layer, an existing Point layer or create a new one, to store the centroids 
•	 Choose the symbol Style and Scale to apply.

The High accuracy placement option makes more advanced calculations for the centroid positions to force them to 
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands).

Note:	 When the New Layer option is enabled, the attributes from the source MAP layer are copied to the new 
Point layer. However, when using an existing point layer, attributes do not get transferred unless the Point 
layer was created with its attribute schema based on the same source MAP Layer (see chapter 4 for more 
information on the Base attribute schema on option when creating new MAP layers).

Results
Symbols are added to the specified Point MAP Layer. Depending on the type of polygon or line (single or 
compound path), symbols are located on the center of the polygons/lines or at the center of the biggest 
polygon/longest line of a group.

Example: result of plotting centroids on a Canadian provincial Area layer.
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PLOT MAP LOCATIONS

Destination MAP View 
Choose which MAP View the  

MAP Locations are plotted to

New layer name 
Enter a Point layer name  for 

the plotted MAP Locations

Include latitude and longitude as 
attributes - Enable to include 

coordinates in the attribute table

MAP Locations to plot 
Select a single or multiple  

MAP Locations to plot.

Symbol - Choose a symbol to represent 
the plotted MAP Locations

Scale - Use the slider or enter a symbol 
scale for MAP Locations

Plot MAP Locations adds point symbols at positions of MAP Locations. This is useful for reference purposes or to simply 
add a symbol at MAP Locations.

The document must contain a georeferenced MAP View that includes a MAP layer of type Area or Line that contains 
art. An existing Point layer may be used as destination layer (Existing Layer option). Desired symbols must be loaded 
in the Adobe Illustrator Symbols panel to use them.

Using Plot MAP Locations
Click the MAP Point Plotter panel options menu and choose Plot MAP Locations. 

•	 Select the MAP Locations to plot in the list
•	 Choose a Destination MAP View to store the Point layer
•	 Specify a new Point layer name for which the MAP Locations will be plotted
•	 Select the Symbol and Scale to apply.

Results
Points are plotted where MAP Locations are positioned. The MAP Locations are maintained.
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Line Plotter 
Object > MAPublisher > Line Plotter* or MAP Toolbar 

Additional Line Points - Choose 
Point By Point to enter the 
consecutive vertices of the line 
by their coordinates

Target layer - Indicates the 
currently selected layer (can 
be area or line layer) and its 

coordinate system

Input Coordinate System 
 Specify the coordinate 

system in which the starting 
point coordinate is entered. 

Use the current layer's 
coordinate system, or specify 

a different one  
(by default, the geodetic 

system base of the projection, 
in latitude-longitude format). 

Starting Point - Enter the 
coordinates of the first point 

of the line or click the MAP 
Locations button to choose a 

location for the Starting Point. 
Valid coordinates are marked 

with a green check mark, 
invalid ones with a red x.

Format - Select the input 
format for values in degrees 

(when input coordinate 
system is geodetic)

Line Plotter (Point By Point)

Line Plotter (Course & Distance)

Remove - Select a row and click  to remove it.

Add and Add Point from MAP Locations - Click  to 
add a new row. Click  to add a new point 
from a list of MAP Locations.

Line vertices - Enter here the 
point coordinates of each 
line vertex

Close path - Check this option to 
automatically close the path 
(recommended when using the 
Line Plotter on Area layers)

Additional Line Points - Choose 
Course & Distance to enter 

a series of heading and 
distance values

Method - The distance method:
•	 Cartesian: distance in the 

map projection
•	 Geodesic: shortest distance 

along the Earth's curvature 
•	 Rhumb Line: distance along 

the Earth curvature at 
constant heading

North type - In the Cartesian 
method, choose one of the 
north options which headings 
are measured from:
•	 Grid North: north along the 

map projection (straight up 
on the map)

•	 True North: actual north 
direction (as given by a 
north arrow)

Units - Select the linear unit for 
distances

Direction - Choose Clockwise 
or Counter-clockwise for the 
direction of the heading value

Heading/Distance - Enter here a 
series of heading and distance 
to define the consecutive 
vertices of the line

Import list of headings and distances 
Click to choose a text file  (.txt)

that contains headings and 
distances to import
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FUNCTIONALITY

The MAPublisher Line Plotter creates a new path to a Line or Area layer. Enter line vertices using two options:

•	 Point by Point: enter a starting point and consecutive point coordinates. 
•	 Course & Distance: enter a starting point and a series of headings (angles) and real-world distances. Each 

consecutive vertex is defined at an angle and distance from the previous point. Additional options are 
available for angle and distance definitions (see hereafter).

The created path is made of straight segments connecting the points. 

PREREQUISITES

Create a new MAP Layer of type Line or Area, or use an existing MAP layer of the appropriate type.

USING LINE PLOTTER

Select a Line or Area layer in the MAP Views panel or Adobe Illustrator Layers panel. Click the Line Plotter button on the 
MAPublisher toolbar or from the menu Object > MAPublisher > Line Plotter.

The name of the selected layer and its source coordinate system are displayed under Current Layer.

Input Coordinate System
The Input Coordinate System sets the system in which the starting point coordinates are entered. It also applies to 
the coordinates of each vertex when the Point by Point option is selected.

When the Use Current Layer's coordinate system option is selected, coordinate values can be entered in the current 
coordinate system of the MAP View containing the selected layer. 

When the Use: [coordinate system] option is selected, the coordinate system link becomes enabled. Click the link to 
open the Select Coordinate System dialog box and choose a coordinate system as required.

When the selected or default coordinate system is projected, X and Y coordinates are entered as the unit of the 
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coordinate system (e.g. meter, kilometer, feet). When the selected or default coordinate system is Geodetic, 
Lat/Long coordinates are entered as degrees. The degree format is selected from the Format drop-down list—see 
chapter 6 for details on the supported formats.

Note:	 The Input Coordinate System is not applied to the distance settings when plotting a line by Course & Distance. 
In that case, the layer's coordinate system applies.

Starting Point
Enter the coordinates of the first point of the line in the X, Y or Long, Lat fields. Click the MAP Locations button to 
choose a MAP Location (if available).

Options
The Close Path option controls if the path will be closed automatically or not. When using Line Plotter on a Line 
layer, this option is disabled by default. On an Area layer, the Close Path option is enabled by default—it is not 
recommended to create open paths on an area layer.

A minimum of three vertices are required to create a closed path. If less points are entered, the path is left opened 
by the Line Plotter.

Plot Line Point by Point
The Point by Point option in the Additional Line Points drop-down list provides a method to add consecutive line 
vertices (or nodes) by typing in the coordinates of each point. This option is typically used to create a line from a list 
of known locations. (Alternatively, Join Points could be used to connect points already plotted on the map.)

To add a new point, click the Add button or click the Add MAP Locations (if available). Then enter the new point 
coordinates based on the selected Input Coordinate System and Format (if the coordinate system is geodesic). To 
remove a point, select a row and click the Remove button.

Plot Line by Course and Distance
The Course & Distance option of the Additional Line Points drop-down list allows to define each consecutive line vertex 
by its heading (azimuth or angle relative to the north direction) and real-world distance from the previous point. 

The Method drop-down list offers three options to define the real-world distances:
•	 Cartesian: Distances in the map projection. They represent the distances as measured on the map and 

multiplied by the scale. This option is only available if the layer's coordinate system is projected.
•	 Geodesic: Shortest distances along the Earth's curvature. Geodesic distances are also known as 

Great-Circle distances and are typically used for navigational purpose maps. They represent the actual 
covered distance while walking or in a moving vehicle. 

•	 Rhumb Line: Distance along the Earth curvature at constant heading. They are typically used for 
navigational purpose maps to represent routes of constant direction.

Note:	 Once the next vertex position is calculated on the map, the path segment is the straight connection between 
the points. The paths are not drawn curved to follow geodesic or rhumb lines
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The North type drop-down list contains two options to define the north direction when the method is set to Cartesian: 
•	 Grid North: Refers to the northward direction of the map projection grid lines—Grid North is constant 

throughout the map.
•	 True North:  Refers to the actual direction to the geographic North Pole. The True North direction can vary 

depending on a point position on a map. Similarly, graticule longitude lines are pointing to True North 
as well as MAP North Arrows (see chapter 14).

Note:	 The Geodesic and Rhumb Line methods are by definition using the True North as northward direction. The 
North Type drop-down list is therefore disabled in these cases.

The Units drop-down list allows to select a linear unit for the distance. By default, the Units list is set to the Point Units 
of the  current layer's coordinate system, if it is projected. If the current layer's coordinate system is geodesic, the 
Units list is set to Meters.

The Direction drop-down list indicates the direction of the heading angles. Typically, navigational headings (or 
azimuths) are given in Clockwise direction. However, the natural angle direction in Adobe Illustrator is Counter-clockwise, 
which may be preferred for simple drawing purpose. 

Once all options are set, click the Add button to create a new entry of heading and distance. To remove an entry, 
select a row and click the Remove button.

Click the Import list of headings and distances button to browse for a text file (.txt) containing headings and 
distances. No column headers are required. Values listed should follow the format of heading then distance.
For example, a text file that contains four headings and distances will look like:

266.883, 400773.2079
13.548, 365969.5053
270.353, 322701.9679
331.837, 99368.0284
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Area Plotter 
Object > MAPublisher > Area Plotter or MAP Toolbar 

Target - Indicate the MAP Area 
layer to plot the area on

Input - Specify which input 
coordinate system to use 

for plotting the Corner and 
Opposite Corner coordinates

Options - Specify shape as 
Rectangle or Ellipse. This  

dialog box shows location 
type as Bounding box. To the 

far right shows options for 
Position location type.

Corner - Specify X and Y 
coordinates to use as a corner 

of the area

Point - Specify 
anchor point 

and X and Y 
coordinate of it

Opposite Corner - Specify X and 
Y coordinates to use as the  
opposite corner of the area

MAP Locations - Choose 
predefined MAP Locations or 
Artboard locations (corners)

Dimensions 
Specify units, 

width and height 
of the area

Location type: Position

Location type: Bounding box

FUNCTIONALITY

The MAPublisher Area Plotter creates new rectangle or ellipse polygons on MAP Area layers by using page or world 
coordinates, and by location type (using either a bounding box or by a single coordinate position). Use it to 
create precise area shapes based on coordinate locations.

PREREQUISITES

Area Plotter only works with  Area layers.

USING AREA PLOTTER

On the MAPublisher Toolbar, click the Area Plotter button or from the menu Object > MAPublisher > Area Plotter.
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Input Coordinates
The Input sets the coordinate system in which the starting point coordinates are entered. Input coordinates can 
either be Page Coordinates or World Coordinates.

When the Page coordinates (Global Rulers) option is chosen, page coordinate values (in pixels) can be entered for the 
Corner and Opposite Corner coordinates.

When the World coordinates option is chosen, the MAP View drop-down list becomes enabled. Choose the appropriate 
MAP View to use. Its coordinate system is displayed directly below the MAP View drop-down list. The options in the 
dialog box will change to reflect a geodetic or projected coordinate system and corner values can be entered either 
as (a variation of ) decimal degrees or in projected units. To use an alternative coordinate system, click the Use check 
box, and click the coordinate system link. Choose an appropriate coordinate system in the Select Coordinate System 
dialog box.

Shape and Location Type Options
There are two shape options to choose from when plotting areas: rectangle and ellipse. More importantly, two 
location types determine how the shapes are plotted: Bounding box and Position.

When Bounding box is chosen, enter (map page or map world) coordinates into the Corner and Opposite Corner 
coordinates to define the area. A preview of the area can be seen on the artboard (you may have to move the Area 
Plotter dialog box to see it). Note: Any corner and its opposing corner can be used for the bounding box.

Rectangle, Bounding Box

Corner Corner

Opposite Corner Opposite Corner

Ellipse, Bounding Box

Note:	 The bounding box for an ellipse is the same as the rectangle.
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When Position is chosen, choose a coordinate point position relative to the shape. These point position options 
include Center, Upper left, Upper right, Lower left, and Lower right. In the Dimensions section, enter a width and 
height and the appropriate units to plot. A preview of the area can be seen on the artboard (you may have to move 
the Area Plotter dialog box to see it).

Rectangle, Position (Center)

Point position Point position

Ellipse, Position (Center)

Use of MAP Locations as Coordinates
To use MAP Locations as coordinates, click the MAP Locations button 
and choose an appropriate one from the context menu. Alternatively, 
choose MAP Page Locations or Artboard Locations from the same 
context menu.

Click the More MAP Locations in the context menu to open the Select 
MAP Location dialog box. The X and Y coordinates and coordinate 
system are displayed in a list. The Artboard Locations tab shows the 
page coordinates for the Upper left, Upper right, Lower left, and Lower 
right corners.
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MAP Area Plotter Tool 
Tools > MAP Area Plotter Rectangle Tool   / MAP Area Plotter Ellipse Tool  

FUNCTIONALITY

Use the MAP Area Plotter Tool to quickly draw georeferenced rectangles and ellipses to MAP Area Layers.

USING THE MAP AREA TOOLS

The MAP Area Plotter Tool consists of two tools: Rectangle and Ellipse. There are two ways to use these tools: click and 
drag to draw the shape; or single-click to open the Area Plotter dialog box and specify plot options.

Draw using Click and Drag
To draw a shape of unspecified size, click and drag in the artboard until the desired area is achieved. Use keyboard 
modifiers to help draw shapes more efficiently: hold the Alt key (Windows) or the Option key (Mac) to draw from 
the center; hold the Shift key to constrain the proportions; or hold the space bar to move the area. Enable Adobe 
Illustrator Smart Guides to snap to features for better control when drawing. Release the left mouse button to finish 
drawing the area.

Enter Specific Dimensions
To draw a shape of specified size, single-click at a point in the MAP document at the desired location to plot the 
shape using options in the MAP Area Plotter dialog box (see previous section). By default, the area is centered over the 
click point and its coordinates populate the X and Y boxes. Enter width and height values to specify a dimension. A 
preview of the area can be seen on the artboard (you may have to move the Area Plotter dialog box to see it).
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Cartographic 
Tools

MAPublisher has several special cartographic tools to handle 
artwork on MAP layers without distorting georeferencing or 
negatively affecting MAP attributes.

Create Halo creates halo around text and features. The 
MAP Vector Crop Rectangle Tool trims all the vector data 
(on all active layers) falling outside of a crop area. The MAP 
Measurement Tools allows users to measure distances in 
page or world units and to save the measuring path as an art.

Topics covered in this section:
Create Halo
Scale & Rotate By Attribute
Dash Offset
MAP Measurement Tool

MAP Themes are covered in Chapter 9.
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Create Halo
Object > MAPublisher > Create Halo or MAPublisher Toolbar  

Create style (not available with 
Simple halo type) - Create a 

graphic style with the 
saved settings

Output - Apply halo to a 
specific MAP layer (to 

layer group, to all art on 
layer, or to selected art 

on layer).

Appearance - Choose halo 
colour, size, opacity and 

feather settings

Halo type - Choose Regular 
or Simple Preview - Choose Area, 

Line, Point or Text type 
to change the preview 
display below. Adjust 
the background colour if 
necessary.

Preview display - Shows a 
preview of the settings 
made in this dialog box.

Preview appearance options 
Changes depending 
on Preview type. Text: 
adjust text colour and 
size. Point: adjust point 
symbol and scale (%).

FUNCTIONALITY

The Create Halo tool creates halo graphic styles and applies halos to MAP layers.

PREREQUISITES

Halos are immediately applied to a MAP layer. A Non-MAP layer cannot have halos directly created for them, 
however, graphic styles can be created and applied to Non-MAP layers manually.

Swatches and colours should be created before creating halos.

USING CREATE HALO

Click the Create Halo button on the MAPublisher Toolbar or from the menu Object > MAPublisher > Create Halo.

Halo type
There are two halo types: Regular and Simple. Simple does not have the Apply to a layer group option and the 
Create style option available. This means that halos can be applied to a MAP layer without creating a graphic style.

Appearance
Set halo appearance settings based on Colour, Size, Opacity and Feather. All appearance settings can be seen in the 
preview display.

The Colour drop-down box is populated with swatches from the Adobe Illustrator Swatches panel. The Size setting 
affects the halo size. By default, the Size units are in pixels. Right-click the Size box to choose different units. Use the 
Opacity slider or spin box to adjust the transparency of the halo (0% for no halo, 100% for opaque). The Use feather 
option creates a soft gradient around the halo (default of 5.0 pixels). Increase feathering for a softer appearance, 
decrease feathering for a sharper appearance.



151Chapter 7: Cartographic Tools
Create Halo

Output
Halos can be applied to one MAP layer at a time. Choose a Target layer from the drop-down list. Next, choose how 
the halo is applied. Three options are available: the Apply to layer group option (for Regular type halo only), Apply to 
all art on layer, or to Apply to selected art on layer.

For Regular type halos, a graphic style can be created. Graphic styles are saved to the Adobe Illustrator Graphic Style 
panel and can be used at a later time. To create one, click the Create style check box and enter a unique name. This is 
not available for Simple type halos.

Preview
The preview provides an idea of what the halo may look like on the artwork of you MAP layer. There are four 
preview types: Area, Line, Point and Text. The Area and Line preview provides a link to change the fill, color and 
stroke of the preview feature. The Point preview provides options to choose a symbol from the Symbol drop-down 
list. The Text preview provides a link to change text options such as colour and size.  For all types, the background 
colour can be adjusted (by default, no colour is set). These Preview options do not affect the halo and only provide 
you with an idea of what the halo may look like in a combination of settings.

RESULTS

Halos applied to a MAP layer are immediately visible (text example below). The Adobe Illustrator Appearance panel 
shows that there is a Fill (halo) positioned at the bottom for this Type object. The halo can be adjusted in the panel. 
This may be useful in cases where a few outliers need some fine tuning to make them more visually appealing.

When enabled, halo graphic styles are saved to the Adobe Illustrator Graphic Styles panel.
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Scale & Rotate By Attribute
Object > MAPublisher > Scale & Rotate By Attribute or MAPublisher Toolbar  

FUNCTIONALITY

The Scale & Rotate By Attribute tool provides options to scale and rotate art objects using specified values or the target 
MAP layer's attributes. 

PREREQUISITES

MAP Attributes used for scale and rotate must be of type Integer or Real (see Chapter 5).

To only scale or rotate specific art objects, they must be selected first.

Target Layer - Choose the 
target layer whose artwork 
should be scaled or rotated

Rotate - Specify angle or choose 
attribute value from target layer

Scale - Choose to scale 
uniformly or non-uniformly 

(see below). Specify scale 
value or choose attribute 

value from target layer.

Scale objects/patterns/strokes and effects 
Scale patterns and strokes and 

effects only applicable to Area and 
Line MAP Layers

Rotate objects/patterns - Rotate 
patterns only applicable to 
Area  and Line MAP Layers

Scale Horizontal - Specify 
horizontal scale value 

or choose attribute 
value from target layer

Scale Vertical - Specify 
vertical scale value or 

choose attribute value 
from target layer

Attribute/Expression Mode Toggle 
Choose between Attribute 
Mode or Expression Mode 
(ability to build expressions).

Scale Non-uniform
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USING SCALE & ROTATE BY ATTRIBUTE

Click the Scale & Rotate By Attribute button on the MAPublisher Toolbar or click Object > MAPublisher > Scale & Rotate By 
Attribute.

Choose a Target MAP layer from the drop-down list. All art on the target layer is scaled or rotated unless the Selected 
art only option is enabled.

Rotate
Click the Rotate check box to enable the rotate settings. To rotate by a value, in the Specified angle spin box, enter 
a value from -360 to 360 degrees. To rotate by a MAP Attribute, click the From attribute drop-down list and choose 
one. Alternatively, click the Attribute/Expression Mode toggle button to change the input settings. Build an 
expression (see Chapter 5) to determine rotate value.

By default, the Rotate objects option is checked. The Rotate patterns option is enabled only when the target is a 
MAP Area or Line layer. When the Rotate patterns option is enabled and checked, the Rotate objects option can be 
unchecked (which will mean that only patterns are rotated).

Scale
Click the Scale check box to enable the rotate settings. There are two scale options: uniform and non-uniform.

The Uniform scale option means that all art is proportionally scaled. In the Specified value spin box, enter a value 
from 0 to 1000 percent. To scale by a MAP Attribute, click the From attribute drop-down list and choose one. 
Alternatively, click the Attribute/Expression Mode toggle button to change the input settings. Build an expression 
to determine scale value.

The Non-uniform scale option provides independent horizontal and vertical scale settings. For each Horizontal and 
Vertical scale settings, in the Specified percentage spin boxes, enter a value from 0 to 1000 percent, or choose a MAP 
Attribute from the drop-down list, or build an expression to determine scale value.

By default, the Scale objects option is checked. The Scale patterns and Scale strokes and effects options are enabled 
only when the target is a MAP Area or Line layer. When either of these two options are enabled and checked, the 
Scale objects option can be unchecked.

Note:	 Scaling or rotating non-point objects may cause the georeferencing for affected features to become 
inaccurate. To maintain accurate georeferencing, scale and rotate using the MAP View Editor.
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Dash Offset 
Tools > Dash Offset  

FUNCTIONALITY

The Dash Offset tool can be used on paths and compound paths to shift or offset dashes by a specific point value.

PREREQUISITES

A path or compound path with a dash must first be selected before that Dash Offset tool can be used. A path must 
have multiple strokes before they can be individually adjusted. Dash Offset only works on one path at a time.

USING DASH OFFSET

Click the Dash Offset button in the Adobe Illustrator Tools panel.

There are two options to apply dash offset: apply to all strokes (of selected art) and specify individually. Choose 
Apply to all strokes and increase or decrease the offset (range of -100.00 to 100.00). Check the Preview check box to 
view how the dash offset settings look on the artboard.

When a selected path has multiple strokes applied to it, the Specify individually option is enabled and lists the stroke 
colors and stroke weight. In the Dash Offset column, the dash offset can be individually adjusted for each stroke.

Note:	 Variable stroke settings (such as corner alignment, arrowheads, and arrowhead scale) on the selected path 
are removed when applying a dash offset. 

Apply to all strokes - Use setting to adjust  
dash offset for the selected path

Specify individually - Specify individual 
dash offset values for each stroke of 

the selected path
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MAP Measurement Tool 
Tools > MAP Measurement Tool  

FUNCTIONALITY

The MAP Measurement Tool measures distances (between two points), path distances (multiple points), azimuths, 
and the perimeter and area of closed paths in page or map units. Furthermore, the measuring path can be 
converted to a line or area in the currently selected layer. 

PREREQUISITES

To measure ground distances (great circle distance in map units), the Adobe Illustrator file must contain at least one 
MAP View with an assigned coordinate system.

The map units used by the MAP Measurement Tool are set in MAPublisher Preferences. Use the current layer's map 
units or select alternative units. The layer's map units are defined in the coordinate system definition of the selected 
MAP View and can be viewed in the MAP View Editor by clicking the information button of the Source Coordinate 
System (called Point Style in the Definition tab)—see chapter 4 and Appendix A2 for details.

The Adobe Illustrator page units can be accessed and changed in the Document Setup dialog box (Adobe Illustrator 
menu File > Document Setup > Units drop-down list).

To use vector snapping while measuring, enable the Adobe Illustrator Smart Guides (Adobe Illustrator menu View > 
Smart Guides). The snapping tolerance is set in the Adobe Illustrator Preferences for Smart Guides (Adobe Illustrator 
menu Edit > Preferences > Smart Guides).

USING THE MAP MEASUREMENT TOOL

Click the MAP Measurement Tool button on the Adobe Illustrator Tools panel. The cursor becomes a crosshair . 

MAP Layers are measured in map units (great circle or real world distances). Select a MAP Layer and then click to 
measure. The units of the layer's parent MAP View will be used in the measurements. 

Non-MAP Layers are measured in page units (distances on the page). Select a non-MAP Layer and then click to 
measure. The units of the document will be used in the measurements. 

Note:	 While the MAP Measurement Tool is enabled, users can change the selected layer in the Adobe Illustrator 
Layers panel. If the new selected layer is contained in a different MAP View, the distance values are updated 
accordingly on the screen automatically without having to start a new measurement — e.g. if the MAP View 
scale is different, the measurement will significantly change. 

When Adobe Illustrator Smart Guides are enabled, the MAP Measuring Tool can snap to existing anchor points. 
When the mouse cursors is near enough a point, Adobe Illustrator highlights it as shown in the image below.
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Measure Distance
By default, the MAP Measurement Tool measures distance between two points. 

Click a starting point to begin measuring. As the mouse moves on the artboard, a distance label indicates the 
distance (and azimuths, if enabled in MAPublisher Preferences) from the starting point to the current mouse 
position. A second click digitizes the end point. As soon as the second point is clicked, the measurement is ended 
and the total distance is displayed.

Measure Path Distance
Click a starting point to begin measuring. Before clicking a second time, hold down the Shift key. The cursor 
changes from  to . A new point is added on the path, but the measurement does not end.

Keep holding the Shift key while adding more points along the path. As the mouse moves on the artboard, a total 
distance label indicates the length of the path already digitized and the distance from the last added point to the 
current mouse position. 

While digitizing the measuring path, hold the Alt key (Windows) or Alt/Option key (Mac) to display the length of each 
digitized path segment.

Before adding the last point, release the Shift key. As soon as the last point is clicked, the measurement is ended 
and the total distance is displayed. Hold the Alt key (Windows) or Alt/Option key (Mac) while clicking the last point to 
display all annotations (segment lengths and total distance).
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Measure Perimeter and Area
To measure the perimeter and area of a closed path, follow the same steps as measuring the distance of a path. 
When digitizing the last point, release the Shift button and place the mouse cursor over the start point—a box is 
drawn around the starting point—click to close the path and end the measurement.

Hold the Alt key (Windows) or Control key (Mac) while digitizing to display the length of each segment.

Note:	 Holding down the Shift key while clicking the start point again prevents the path from being closed and the 
measurement can continue.

Convert Measurement Line to Art
When any of the above measurement methods are finished, two options are available:

1.	 Click anywhere on the artboard once to clear the measurement line and label
2.	 Hold the Shift key and click anywhere on the artboard once. This converts the measurement line to an 

Adobe Illustrator art object, adds it to the current layer and applies the current stroke settings.

A new click on the page starts a new measurement. To exit the MAP Measurement Tool, select another tool in the 
Adobe Illustrator Tools panel.

MAP Measurement Tool Preferences
Access the MAP Measurement Tool Preferences by double-clicking the MAP Measurement Tool button on the 
Adobe Illustrator Tools panel or from the menu Edit > MAPublisher Preferences > MAP Measurement.

Set the number of decimals for the measurement values, enable display of azimuths, and change the digitized path 
and new segment colours. See chapter 1 for more information on MAPublisher Preferences.
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The Adobe Illustrator environment offers lots of flexibility 
when working with vector art. To enhance Adobe Illustrator 
functionality, MAPublisher introduces many geometry 
operations designed specifically for cartographic purposes.

Create a proximity around lines using the Buffer Art tool. 
Change the direction of lines using the Flip Lines tool; useful 
for road mapping applications. Easily join points, lines and 
areas to create seamless datasets. In addition, simplify art to 
reduce the amount of vertex points, while retaining spatial 
referencing.

Topics covered in this section:
Join Areas
Join Points
Join Lines
Simplify Art
Flip Lines
Buffer Art
Vector Crop
MAP Vector Crop Tool
Crop to Shape

Geoprocessing
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Only apply to grouped components that satisfy: 
Use an expression to define which 
joined areas the above attribute field 
options will apply to.

FUNCTIONALITY

Join Areas groups art objects based on a specified similar attribute value. An attribute field is defined and a new 
object is created for each unique value within that field. Options can be set to create Adobe Illustrator groups or 
compound paths, while either maintaining the outlines of the original features or dissolving sub-areas into the 
larger area.

USING JOIN AREAS

To use Join Areas, click the Join Areas button on the MAPublisher toolbar or from the menu Object > MAPublisher > 
Join Areas. Choose the Target Layer on which Join Areas should be performed. Specify the Join Type to either Join all 
selected areas on target layer or Join areas by attribute. Specify an attribute which the join will be based on. It is noted in 
the Attributes section Operation column as Join on.

Select the Join Method type to either Adobe Illustrator Group areas or Create compound areas. For the latter option, 
choose to Dissolve borders between adjacent sub-areas. Not checking this option will maintain the borders of individual 
areas. For example, when grouping the countries of the world by its Continent field attributes, the Continent field 
will result in five new objects, one for each continent. Dissolving borders between adjacent sub-areas will leave the 
continent outlines. Choosing not to dissolve, the outline of each country will remain. In both cases, there will be one 
object for each continent in the attribute table.

When areas are joined, many attributes that were valid to the original lines may no longer be valid. For example, 
after joining the countries of the world on the Continent field, the field containing country capitals will no longer 
be valid, as each continent does not have one capital. Thus, operations can be set to determine how each attribute 
field is handled. By default all attribute operations are set Clear if different, meaning that the attribute is cleared if 
there are more than two unique values present after the join. Depending on the attribute type (string, boolean, 

Join Areas 
Object > MAPublisher > Join Areas* or MAP Toolbar  

Target Layer - Layer on which 
the join will be performed

Destination - Joined results 
are on the target layer or 

copied to a new layer

Join Type - Defines art to be 
joined. Choose all art on 

layer or choose to join all 
or selected art on similar 

attribute values. 

Join Method - Group areas 
creates Adobe Illustrator 

groups of joined art. 
Create a compound path 

for each  grouped art 
with the option to outline 

group or leave internal 
group borders intact.

Attributes - Determines how 
attributes will be handled 
once features are joined 
into a single object. For 
string fields choose to 
either Clear the field, Clear 
if different (two or more 
unique values are found), 
sort Least Alphabetical (Z-A) 
or Most Alphabetical (A-Z). 
For Integer or Real fields 
options include Clear the 
field, Clear if different (two 
or more unique values are 
found), return the Sum or 
Average of the grouped 
values or enter the Largest 
Value or Smallest Value of 
the grouped fields.
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integer or real) other operations include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical 
and Concatenate. The last three operations can only be applied to string attribute types. Alphabetical sorting returns 
either the first or last item from an alphabetized list of attributes. Concatenate joins string values together and 
separates them with a separator.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component 
option to apply all. Alternatively, choose Only apply to grouped components that satisfy to enable the expression builder 
to enter an expression that will only apply the attribute operations to values of the object where the expression 
condition is met. All other values that aren't satisfied will be cleared. For example, the expression "Continent = 
Africa" would only apply the operations to attributes of the object that has the attribute "Continent" and value of 
"Africa". All attributes for this art object will maintain its attributes.

RESULTS

To tell if areas are joined after executing the Join Areas function, look for visual differences of the features on the 
map or look in the Adobe Illustrator Layers panel. Depending on the join method, compound areas or grouped 
areas, the Layers panel will display the results. In the example below, the original Lower 48 layer is shown and two 
join method possibilities. The Group areas method shows states grouped by the attribute Sub Region (W S Cen, 
Pacific, etc). The Create compound areas method shows states joined by compound path (and in this case, with the 
option Dissolve borders between adjacent sub-areas enabled).

Original Join Method: Group Areas Join Method: Compound Areas
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Join Points 
Object > MAPublisher > Join Points or MAP Toolbar  

Sort By Available Columns - Select an 
attribute column containing  

ascending values to sort by. Then 
click the Add button to add the 

column to the Sort Order.

 Source Layer - Select the Point layer 
containing the symbols to join.

Destination Layer - Enter the name 
of the output layer. This new layer 

will contain the generated lines. 
Enable Close paths to generate an 

Area layer. If unchecked, a Line 
layer will be generated.

Group By - Specify the attribute 
column containing similar values 

to determine each group of points

Sort Order - Contains a hierarchical 
list of the columns specified to sort 
by. Move columns up and down 
the Sort Order hierarchy using the 
Up and Down buttons

FUNCTIONALITY

Join Points allows a group of point symbols to be joined to form a line, based upon attribute values used as sorting 
criteria. For example, it is common to form a line based on points collected by a GPS device. When Join Points 
is completed, a new map layer is created that contains the line art. The generated line layer contains the same 
common attribute column that was used to group the points together.

PREREQUISITES

Join Points can only function on Point layers, and can be used on both currently selected point symbols or all the 
point symbols on a specified layer. There must be at least two attribute columns on the specified point layer in order 
to use Join Points. To open the dialog box, click the Join Points button on the MAPublisher toolbar or from the menu 
Object > MAPublisher > Join Points.

USING JOIN POINTS

From the Source Layer drop-down list, select the Point layer containing the points to be joined. A join can be based on 
either all points on the source layer or Only join selected points.

Specify a name for the Destination Layer that this operation will generate. By default, the program will generate a 
Line layer. To generate an Area layer (by linking the line end to the start) check the Close paths option.

In the Group By Column drop-down list, select the attribute column containing the common attributes used to join 
the point together. For example, to join points based on a unique ID, select the column containing the common ID 
names. This will result in point symbols containing the same name being joined together. 

Attributes - Determines how 
attributes will be handled 
once features are joined 
into a single object. For 
string fields choose to 
either Clear the field, Clear 
if different (two or more 
unique values are found), 
sort Least Alphabetical (Z-A) 
or Most Alphabetical (A-Z). 
For Integer or Real fields 
options include Clear the 
field, Clear if different (two 
or more unique values are 
found), return the Sum or 
Average of the grouped 
values or enter the Largest 
Value or Smallest Value of 
the grouped fields.
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A logical order by which the points are being joined must be specified because each point will be represented by 
a node in a line string. To properly join points, a sort order must be chosen based on an attribute columns. These 
should be attribute columns which contain rising alphabetical or numerical values. For example, GPS data may 
contain an attribute that specifies the order in which the points were collected (first node, second node, etc).

In the Sort By Available Columns list, select the primary sorting column. This should be the attribute column that 
contains the best fit for rising alphabetical or numerical values. For example if points have rising values from 1–10, 
the point with a value equal to 1 will be at the start of the generated line, and the point with a value equal to 10 will 
be at the end of the line. Select a column and then click the Add button to place the column into the Sort Order list. If 
all the values contained in the first Sort By column are unique,it is not required to set a secondary column. 

If the first Sort By column contained any similar values, a secondary column must be specified. Again, click a column 
in the Sort By Available Columns list, and then click the Add button to place the column in the Sort Order list. Similarly 
third, fourth and fifth Sort By columns can be specified in the same manner if previous columns contain similar 
values. Note that the Sort By columns are a hierarchy with the topmost specified column being used for the primary 
sort, then the second, then third, etc. 

To move columns up or down the hierarchy after they have been specified, simply select the appropriate column in 
the Sort Order list and click either the Up or Down button. To remove any Sort By columns from the hierarchy, select 
the column in the Sort Order list and click the Remove button. 

Attribute operations can be set to determine how each attribute column is handled. By default all attribute 
operations are set Clear if different, meaning that the attribute is cleared if there are more than two unique values 
present after the join. Depending on the attribute type (string, boolean, integer or real) other operations include 
Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical and Concatenate. The latter three 
operations can only be applied to string attribute types. Alphabetical sorting returns either the first or last item 
from an alphabetized list. Concatenate joins string values together and separates them with a separator.

Note that a maximum of five columns can be used to sort points into a logical order. If the columns specified to sort 
by do not distinguish an ordering between certain points, the order of these points in the attribute table will be 
used to determine the order of the nodes in the generated line string.

RESULTS

When all the options have been set click OK to join the points on the specified layer. A MAP Area or Line layer will be 
generated, depending on the specified output layer type, which will be placed in the same MAP View as the Input 
Point layer which has been joined.
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Join Lines 
Object > MAPublisher > Join Lines or MAP Toolbar  

FUNCTIONALITY

Join Lines allows a group of line features to be joined based on a common attribute. For example, it may be desirable 
to join all segments of a particular street by the common attribute of street name in order to create a single line 
element representing that street. When Join Lines is completed, a new map layer is created that contains the joined 
lines. These lines contain an attribute column based on the column used to join them.

Join Lines can be very useful for reducing the size of a data file by joining related lines and thus reducing the 
number of segments and associated data present in the file. It is also very useful to run Join Lines prior to labeling 
with Label Features in order to reduce the occurrence of duplicate labels (see chapter 10 Labeling).

PREREQUISITES

Join Lines can only be used on MAP Line layers.

USING JOIN LINES

To use Join Lines, click the Join Lines button on the MAPublisher toolbar or choose Object > MAPublisher > Join 
Lines. In the Target Layer drop-down list, select the Line layer where the join will be performed. In the Destination 
options, choose either to perform the join on the original target layer or specify a name for the new line layer that 
MAPublisher will create to hold the joined lines.

Under Join Options, a Proximity value should be entered and proximity Units assigned. Units can be specified in map 
units or page units. A proximity value of zero will only join line segments that are touching. If the distance between 

Only apply attribute operations to grouped 
components that satisfy: - Use an expression 
to define which joined lines the above 
attribute field options will apply to

Apply to every grouped 
component - Choose to apply 
Join Lines options to every 
grouped component

Only join lines with shared values from: 
Check to join lines that have 
shared attribute values

Target Layer - Layer on which 
the join will be performed

Destination - Defines line 
features to be joined. Join 

original lines on target 
layer or copy results to a 

new layer.

Proximity - Assign a 
proximity value to 

determine how close 
together (in map units) 

the lines must be in order 
to be joined. Optionally, 

choose appropriate units.

Close segment gaps - If 
two line segments are 

separated by a distance 
less than the Proximity 

value, checking this 
option will create a line 
segment that connects 

the two lines. Otherwise a 
compound path is created.

Attributes - Determines how 
attributes will be handled 
once features are joined 
into a single object. For 
string fields choose to 
either Clear the field, Clear 
if different (two or more 
unique values are found), 
sort Least Alphabetical (Z-A) 
or Most Alphabetical (A-Z). 
For Integer or Real fields 
options include Clear the 
field, Clear if different (two 
or more unique values are 
found), return the Sum or 
Average of the grouped 
values or enter the Largest 
Value or Smallest Value of 
the grouped fields.
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the end of a segment and the start of another is greater than the set proximity value, these lines will not be joined. 
If two line segments in the selection are separated by a distance less than the set proximity value, check the Close 
segment gaps option to create a line segment that connects the two lines. When not selected, a compound path will 
be created. By default, the Only join lines with shared values from option is checked. Specify an attribute which the join 
will be based on. It is noted in the Operation column as Join on. For example, when joining streets, join based on a 
common identifier or street name. To further narrow down which lines should be joined, check the Only Join selected 
lines option. These lines should be selected prior to opening the Join Lines dialog box.

When lines are joined, many attributes that were valid to the original lines may no longer be valid. For example, 
after joining street line data, an attribute that contains address ranges will no longer be valid because values will 
not be unique anymore. Thus, operations can be set to determine how each attribute field is handled. By default all 
attribute operations are set Clear if different, meaning that the attribute is cleared if there are more than two unique 
values present after the join. Depending on the attribute type (string, boolean, integer or real) other operations 
include Clear, Sum, Average, Smallest Value, Largest Value, Least alphabetical, Most alphabetical and Concatenate. The last three 
operations can only be applied to string attribute types. Alphabetical sorting returns either the first or last item from 
an alphabetized list of attributes. Concatenate joins string values together and separates them with a separator.

The Concatenate operation has options to adjust the separator. When Concatenate is chosen in the Operation 
column for an attribute, the text Using defaults; double-click to edit appears in the Options column. Double-click the 
text to open the Concatenate Operation Options dialog box. Choose a separator from the Use drop-down list or 
specify a custom one.

String attribute sizes may become lengthy due to a join. Adjust the set string attribute size setting to increase or 
decrease the maximum number of characters of which the attribute field can store.

There are two options to apply attribute operations to grouped components. Choose Apply to every grouped component 
option to apply all. Alternatively, choose Only apply attribute operation to grouped components that satisfy to enable the 
expression builder to enter an expression that will only apply the attribute operations to values of the object where 
the expression condition is met. All other values that aren't satisfied will be cleared. For example, the expression 
"Street = Main St" would only apply the operations to attributes of the object that has the attribute "Street" and 
value of "Main St". All attributes for this art object will maintain its attributes.
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Units - Select page units or map 
units (angular or linear unit list 
depending if the map coordinate 
system is projected or geodetic) 
used for the proximity tolerance

FUNCTIONALITY

Simplify Art allows for the simplification or generalization of vector line and area data. It uses the popular 
Douglas-Peucker algorithm for removing nodes and vertices during simplification. For more information about this 
algorithm, see Appendix A1.

Simplify Art is used to reduce the number of points required to represent a vector-encoded line where lines are 
approximated by a stream of X-Y coordinates. The operation can be used on Line or Area MAP layers and removes 
nodes based upon a proximity value in either Page Units or Map Units. The list of map units depends on the MAP 
View coordinate system—e.g. angular units (page units, degrees, etc) for geodetic coordinate systems; linear units 
(such as metre, feet) for projected coordinate systems.

The Proximity value or simplification tolerance is based on the vertical difference between the begin/end line 
and points off a line, not the distance between anchor points on the line. The Douglas-Peucker algorithm takes 
the proximity value and iterates through the line vertices to determine the points that fall within the specified 
proximity distance off the line and removes those vertices. Once all vertices are determined to be greater than the 
proximity value, the line processing ends. A smaller proximity value will usually result in a fewer number of nodes 
being removed.

USING SIMPLIFY ART

To use Simplify Art, select the lines on a Line layer or areas on an Area layer, then click the Simplify Art button on the 
MAPublisher toolbar or from the menu Object > MAPublisher > Simplify Art. Enter a proximity value in Page Units or 
Map Units by making a selection from the Units drop-down list. Page Units are the units of the current document. 
Enter a proximity value in the unit specified by typing a value or by using the arrows. 

Click the Preview button to see the simplification result before committing to it. The Vertex Count shows how many 
vertices are in the simplified result (and calculates a percentage of overall simplification). Adjust the proximity as 
necessary in order to achieve the desired results particular to the scale and coverage area. Click OK to complete the 
simplify operation.

Simplify Art 
Object > MAPublisher > Simplify Art or MAP Toolbar  

Proximity - Set the simplification 
tolerance (type or use arrows) 

based on specified units

Vertex Count - Shows the original 
number of vertices of the 

selected lines. Click the Preview 
button to display the number of 

vertices after simplification.



167Chapter 8: Geoprocessing
Simplify Art 

RESULTS

All selected lines or areas are simplified according to the settings. Simplified lines or areas will not be simplified 
again unless the tolerance value is increased. For example, if a line has been simplified with a proximity of 1.5 km, 
then it will not be simplified again until the tolerance is set to a value larger than 1.5 km.

In practice, it means that simplified lines can be selected again with non-simplified lines to run the operation again, 
when the Simplify Art operation is run only the new lines will be simplified (unless the proximity value is increased).

Notes:	 It is a good idea to perform Simplify Art on artwork before exporting to a web map (see chapter 15). This will 
reduce the file size and improve performance and loading times.

Bezier curves cannot be simplified using the MAPublisher Simplify Art tool. To smooth the appearance of 
paths using Bezier curves, use the Adobe Illustrator Simplify tool (menu Object > Path > Simplify).
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Flip Lines 
Object > MAPublisher > Flip Lines or MAP Toolbar  

FUNCTIONALITY

MAPublisher Flip Lines reverses the endpoints of a line or an area (open or closed path). 

Adobe Illustrator Brushes and Type on a Path tools are designed to position patterns and text depending on the 
direction of the endpoints. Two consequences of this are:

•	 Labels are placed upside down and backward when using the MAPublisher labeling tools (MAP Tagger 
tool and Label Features, see chapter 10 - Labeling).

•	 When applying graphic styles with a brush pattern to paths (manually or using MAPublisher MAP 
Themes), patterns are not applied at the right side of the line or in the expected orientation.

In order for the labels or patterns to be consistent for a group of lines, flipping lines may be necessary.

PREREQUISITES

Lines can be flipped on Line and Area layers.

USING FLIP LINES

To flip lines, select lines on the artboard and click the Flip Lines button on the MAPublisher toolbar or from the menu 
Object > MAPublisher > Flip Lines.

Notes:	 Flip Lines is a discrete operation. It may not be apparent that the lines are flipped.

When exporting Area layers to GIS formats, polygon outlines must have a positive #Area value in the MAP 
Attributes panel. If some values in the #Area column are negative (and #AreaDirection is equal to Counter 
Clockwise), Flip Lines can then be used to reverse the #AreaDirection and convert the #Area to a positive value. 

For compound paths, the #AreaDirection property is always equal to Indeterminate, even though compound 
paths can be flipped.

The MAPublisher MAP Tagger tool and Label Features have an option to enable Flip upside-down labels to create 
text in a consistent orientation, without requiring the use of the Flip Lines operation (see chapter 10).
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Buffer Art 
Object > MAPublisher > Buffer Art or MAP Toolbar  

FUNCTIONALITY

MAPublisher Buffer Art creates area objects of specified distance around point, line, and area features. This may be 
useful when attempting to calculate distances on each side of a road, creating proximity around fire hydrant points, 
or buffering parcel lots.

USING BUFFER ART

If required, select the art to buffer and click the Buffert Art button on the MAPubilsher toolbar or from the menu 
Object > MAPublisher > Buffer Art. Buffers are added to all art on the specified layer, unless the option to Only buffer 
select art is checked.

The buffer width can be entered as a fixed value or by selecting an attribute column that contains numeric values. 
With the Static value option checked, a buffer is created with the specified value. With the Attribute value option 
checked, a buffer is calculated and created based on the value related to the selected object in the attribute table. 
Set the buffer value units in the Units drop-down list. For example, a value of 5 map units will create a buffer of 5 
map units around a feature. 

Optionally, enable Add buffer intervals of and specify an interval distance to create equally spaced rings around 
features. This is also known as creating concentric rings. Enable the Merge buffered results by buffer width value option to 
remove any compound path segments and create one resulting buffer area. This is also known as dissolving buffers.

Choose an existing Area layer as the destination for the new buffer. Alternatively, specify a new layer name to create 
a new layer where the buffer areas will be stored.

Buffer Options
Enable the Apply Style option and choose a preset Graphic Style or Custom stroke, fill and transparency.

Static value - Enter a specific 
value and choose appropriate 

units to buffer the art by

Attribute value - Buffer by values 
contained in an attribute table

Apply Style - Enable to choose  
stylization options

Merge buffered results by buffer width 
value - Dissolves separate segments 

to create one buffer area

Source Layer - Specify the layer to 
base the buffer art on. To buffer only 

selected art on the specified layer, 
check the option below it.

Units - Select a unit to use for the 
buffer values. The default is the 
current map unit.

Destination - Select the Area layer 
which will hold the buffered 
objects or create a new layer



Vector Crop
Object > MAPublisher > Vector Crop or MAP Toolbar    

FUNCTIONALITY

The MAPublisher Vector Crop trims vector data to a rectangular or ellipse area by using page or world coordinates, 
and by location type (using either a bounding box or by a single coordinate position). Use it to create a precise crop 
of a larger dataset based on coordinate locations (by bounding box or position). It is very useful for creating map 
insets (smaller maps centered on specific areas).

Input - Specify which input 
coordinate system to use for 

plotting Corner and Opposite 
Corner coordinates

Advanced - Advanced cropping 
options dialog box

Options - Specify shape as 
Rectangle or Ellipse. This  

dialog box shows location 
type as Bounding box. To the 

far right shows options for 
Position location type.

Corner - Specify X and Y 
coordinates to use as a corner 

of the bounding box

Opposite Corner - Specify X 
and Y coordinates to use as 
the opposite corner of the 

bounding box

Target - Target to crop  
everything, MAP Views,  
layers and sublayers

Point - Specify 
anchor point 

and X and Y 
coordinate of it

Dimensions 
Specify units, 

width and height 
of the crop area

Location type: Position

Location type: Bounding box

Point Text - Choose how 
point text is handled 

when intersected by a 
crop boundary

Points - Choose how points are 
handled when intersected by 
a crop boundary

Path Text - Choose how 
point text is handled 

when intersected by a 
crop boundary

Cropping Boundary - Adjust 
accuracy for vectorizing a 
bezier path when intersected 
by a crop boundary

Vector Crop Advanced Options
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PREREQUISITES

Before using Vector Crop, ensure that layers being cropped are visible and unlocked in the Adobe Illustrator Layers 
panel. Invisible and locked layers are not cropped. The extent of the map that will remain after cropping must be 
visible on the screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Note:	 Text typed on a path may not return to their prior state after an undo.

USING VECTOR CROP

On the MAPublisher Toolbar, click the Vector Crop button or from the menu Object > MAPublisher > Vector Crop.

Input Coordinates
The Input sets the coordinate system in which the starting point coordinates are entered. Input coordinates can 
either be Page Coordinates or World Coordinates.

When the Page coordinates (Global Rulers) option is chosen, page coordinate values (in pixels) can be entered for the 
Corner and Opposite Corner coordinates.

When the World coordinates option is chosen, the MAP View drop-down list becomes enabled. Choose the appropriate 
MAP View to use. Its coordinate system is displayed directly below the MAP View drop-down list. The options in the 
dialog box will change to reflect a geodetic or projected coordinate system and corner values can be entered either 
as (a variation of ) decimal degrees or in projected units. To use an alternative coordinate system, click the Use check 
box, and click the coordinate system link. Choose an appropriate coordinate system in the Select Coordinate System 
dialog box.

Shape and Location Type Options
There are two shape options to choose from when plotting areas: rectangle and ellipse. More importantly, two 
location types determine how the shapes are plotted: Bounding box and Position.

When Bounding box is chosen, enter (map page or map world) coordinates into the Corner and Opposite Corner 
coordinates to define the area. A preview of the area can be seen on the artboard (you may have to move the Area 
Plotter dialog box to see it). Note: Any corner and its opposing corner can be used for the bounding box.

Rectangle, Bounding Box

Corner Corner

Opposite Corner Opposite Corner

Ellipse, Bounding Box
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When Position is chosen, choose a coordinate point position relative to the shape. These point position options 
include Center, Upper left, Upper right, Lower left, and Lower right. In the Size section, enter a width and height and 
the appropriate units to plot. A preview of the area can be seen on the artboard (you may have to move the Area 
Plotter dialog box to see it).

Rectangle, Position (Center)

Point position Point position

Ellipse, Position (Center)

Advanced Options
For point text, Vectorize and crop will create 
an outline of the text and then crop it. 
This option does not preserve text editing 
ability. It should be used in situations where 
having text is still important and requires a 
clean cut (e.g. inset or key map).

To preserve text while cropping, use the 
Crop text based on option. The Origin of first 
character sub-option determines whether 
the first character of text is within the crop area or 
not. If it isn't, the text is cropped. The Text bounds 
sub-option determines whether the text bounding 
box is within the crop area or not. If it isn't, the text 
is cropped.

Vectorize and crop Crop based on text bounds

Crop based on origin of first character

Original layout before crop
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For path text, the similar options will yield the same results as explained above. One difference is the Crop path only 
option, which is used to crop the path text to the crop shape. To preserve text while cropping, use the Crop text 
based on option. Similarly, enable the Crop path check box to ensure the path is cropped.

For points, Vectorize and crop will create an outline 
of the points and then crop it. This results in small 
areas that are now partially cropped.

For paths, to crop to a shape of unspecified size, 
click and drag in the artboard until the desired 
crop area is achieved. Use keyboard modifiers to 
help draw shapes more efficiently.

RESULTS

On all visible and unlocked layers: 
•	 Text objects that have their anchor outside of the cropping boundary are deleted. Text objects with its 

anchor inside the cropping rectangle are retained completely.
•	 Points falling outside of the cropping boundary are deleted (the position of the center of the symbol is 

relevant). Symbols that have their center inside the cropping rectangle are maintained as a whole.
•	 Lines are clipped at the boundary of the cropping rectangle.
•	 Areas (polygons) that are completely out of the cropping boundary are deleted. Areas intersecting with 

the cropping boundary are clipped and closed following the edge of the boundary. 

The overall result is a map coverage reduced to the cropping boundary. See examples on the next page.

Notes:	 The purpose of Vector Crop is to cut vector data (points, lines and polygons). However, some Adobe 
Illustrator specific objects may not be cropped properly using this tool:

•	 Blend and Live Paint objects
•	 Any art using effects that have been rasterized
•	 Custom art such as scale bars, grids/graticules, north arrows (expand custom art to crop)
•	 Compound shapes
•	 Legacy and overflowing text
•	 Locked objects (command box: either treat locked layers as unlocked or skip locked layers)
•	 Hidden layers (will be skipped)
•	 Images 

	 "Skipping art because topology is invalid" messages display in the MAPublisher Log when a line intersects 
itself along the border of your crop boundary. "Hidden layer" messages display in MAPublisher Log. 
 
Due to an Adobe Illustrator limitation, text on a path may flip after a crop. This can be corrected by checking 
the Flip option in the Type on the Path Options dialog box (choose Type > Type on a Path > Type on a Path Options).

Point symbol Vectorized and cropped point symbol
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Crop Examples

Crop result: lines and areas are 
cropped, text with first letter 
within the cropping rectangle 
and symbol with center point in 
rectangle are maintained. The 
MAP Objects can be scaled for a 
better fit in the document.

Original map

Create Inset
Create a map inset using Vector Crop:

•	 Open any map, and make a copy of it (choose File > Save a Copy).  
Leave the original map open, make the copy the active document.

•	 Use MAP Vector Crop to crop the area of special interest.
•	 Make the original map active. In the MAP Views panel, select the option menu Import MAP View from 

document. Select the MAP View from the copy .

Original Copy and Crop

The map now contains two MAP Views (at least). Their relative position can be managed from the MAP View editor, 
as well as the scale of the inset map.



175Chapter 8: Geoprocessing
MAP Vector Crop Tool 

FUNCTIONALITY

Use the MAP Vector Crop Tool, to quickly crop MAP Layers using rectangles and ellipses. This tool can be used using two 
methods: crop using click and drag or crop using specific dimensions.

PREREQUISITES

Before using the MAP Vector Crop Tool, ensure that layers being cropped are visible and unlocked in the Adobe 
Illustrator Layers panel. Invisible and locked layers are not cropped. The extent of the map that will remain after 
cropping must be visible on the screen, so make sure to zoom out sufficiently prior to starting the vector crop tool.

Open MAPublisher Preferences to adjust crop settings for MAP Crop Tool. These are the same Advanced settings for 
Vector Crop and Crop to Shape.

USING THE MAP VECTOR CROP TOOL

The MAP Vector Crop Tool consists of two tools: Rectangle and Ellipse. There are two ways to use these tools: 1. click 
and drag to draw the crop shape;  2. single-click to open the MAP Vector Crop dialog box and specify crop options.

Crop using Click and Drag
To crop to a shape of unspecified size, click and drag in the artboard until the desired crop area is achieved. Use 
keyboard modifiers to help draw shapes more efficiently: hold the Alt key (Windows) or the Option key (Mac) to draw 
from the center; hold the Shift key to constrain the proportions; or hold the space bar to move the area. Enable 
Adobe Illustrator Smart Guides to snap to features for better control when drawing. Release the left mouse button 
to finish cropping the area.

Crop using Specific Dimensions
To crop to a shape of specified size, single-click at a point in the MAP document at the desired location to specify a 
starting crop location using options in the MAP Vector Crop dialog box (see previous section). By default, the crop area 
is centered over the click point and its coordinates populate the X and Y boxes. Enter width and height values to 
specify a crop size. A preview of the crop area can be seen on the artboard (you may have to move the Area Plotter 
dialog box to see it).

MAP Vector Crop Tool 
Tools > MAP Vector Rectangle Crop Tool   / Tools > MAP Vector Ellipse Crop Tool  



176 Chapter 8: Geoprocessing
Crop To Shape

Crop To Shape
Object > MAPublisher > Crop to Shape or MAP Toolbar  

Target - Specify which layers 
to crop: all unlocked layers in 

document, all unlocked layers 
in a specific MAP View, or a 

specific layer (and sublayers).

Point Text - Choose how 
point text is handled 

when intersected by a 
crop boundary

Points - Choose how points are 
handled when intersected by 
a crop boundary

Path Text - Choose how 
point text is handled 

when intersected by a 
crop boundary

Cropping Boundary - Adjust 
accuracy for vectorizing a 
bezier path when intersected 
by a crop boundary

Crop To Shape Advanced Options

FUNCTIONALITY

Use Crop To Shape to quickly crop MAP Layers using shapes other than rectangles and ellipses.

PREREQUISITES

Before using Crop To Shape, ensure that layers being cropped are visible and unlocked in the Adobe Illustrator Layers 
panel. Invisible and locked layers are not cropped. The extent of the map that will remain after cropping must be 
visible on the screen, so make sure to zoom out sufficiently. Crop To Shape only works with closed paths (areas).

USING CROP TO SHAPE

To crop to a shape, select a closed path object and click the Crop To Shape button on the MAPublisher Toolbar, or from 
the menu Object > MAPublisher > Crop To Shape.

In the Crop To Shape dialog box, choose the layers to target for crop: All unlocked layers, All unlocked layers in a 
specific MAP View, or only a specific layer (and sublayers).
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The All unlocked layers option will crop everything from an unlocked layer.

For the All unlocked layers in [a specific MAP View] option, choose a MAP View from the drop-down list. Only 
unlocked layers in the chosen MAP View will be cropped.

For the Only [layer] option, choose a specific layer from the drop-down list. Only objects on that layer will be 
cropped. Optionally, click the Include sublayers check box to include sublayers belonging to the chosen layer.

Advanced Options
The Advanced options here function the same as explained in the Vector Crop section.

  

Vectorize and crop Crop text based on origin 
of first character

Crop text based on
text bounds
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MAPublisher MAP Themes provide tools for a variety of 
thematic mapping operations. Stylesheet themes are used 
for quick, easy and accurate styling of points, lines, areas 
and text. Chart themes produces feature specific bar and pie 
charts while Dot Density themes aid in the generation of the 
thematic dot density maps.

No map is complete without a legend. Easily create MAP 
Theme legends with a wide array of options to adjust and 
tweak its appearance.

The topics covered in this section are as follows:
MAP Themes
Stylesheet Themes
Dot Density Themes
Chart Themes
MAP Theme Legends

MAP 
Themes
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MAP Themes
Window > MAPublisher > MAP Themes or MAP Toolbar  

OVERVIEW

MAP Themes are a collection of thematic cartography tools designed to increase productivity by automating how 
styles and symbols are applied, chart production and data plotting. The former MAP Stylesheets (in MAPublisher 8.3 
and older) have been integrated into MAP Themes and is now called Stylesheet theme. Two new types are the Chart 
theme and Dot Density theme.

The new Stylesheet theme offers enhancements over the previous version of MAP Stylesheets. Adobe Illustrator 
graphic styles can be assigned to stylesheet rules and stroke fill and opacity can now be assigned on a per rule basis 
within the Stylesheet dialog box. The Stylesheet dialog box now offers a Batch Generate Rules feature where attributes 
can be automatically classified using a variety of common classification methods.

The Chart theme offers an interface for quickly generating individual bar and pie charts for a chosen attribute of 
selected features. The Dot Density theme provides a thematic mapping tool that assigns a unit value to Illustrator 
symbols and randomly distributes symbols throughout associated areas based on attribute values.

MAP Themes offer a lot of flexibility. They can be edited, applied, duplicated, exported and cleared without affecting 
the spatial referencing of map features.

MAP Theme List - List of MAP 
Themes in the current document. 
Displayed in order of Stylesheets 

first, organized and color 
sorted by Area, Line and Point 

Stylesheets, Chart Themes and 
Dot Density Themes. 

New MAP Theme - Opens the  
New MAP Theme dialog box to specify 
theme type and options

Duplicate Selection - Create a duplicate of the 
selected MAP Theme

Edit Selection - Opens the MAP Theme Editor 
dialog box to edit the selected MAP Theme

Apply Selection - Apply selected MAP Theme 
to the document

Delete Selection - Delete selected MAP Theme

Clear Results of Selection - Removes the 
application of the MAP theme from the 
document, not the theme itself

Create Legend - Create a legend from the 
selected MAP Theme

View Log - A log viewer that provides 
information on processes performed on 
individual MAP Themes

Export MAP Themes - Export MAP Themes to an 
Adobe Illustrator document

Copy MAP Objects From - Copy MAP Themes 
from another open document

Preferences - Opens MAPublisher Preferences 
on the MAP Themes Panel property sheet 
(see chapter 1)

Create Legend - Create a legend 
based on the selected theme

Apply MAP Theme - Apply selected 
MAP Theme to the document

New MAP Theme - Opens the  
New MAP Theme dialog box to 

specify theme type and options

Delete MAP Theme - Delete 
selected MAP Theme
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Load Symbols and Styles
The symbology used by MAP Themes are directly related to the symbols and styles which exist in several Adobe 
Illustrator panels. In order to correctly function, MAP Themes require that symbology or styles are established in the 
corresponding Adobe Illustrator panels:

For Stylesheet themes:

Area stylesheets: Graphic Styles panel (Window > Graphic Styles)

Line stylesheets: Graphic Styles panel (Window > Graphic Styles)

Point stylesheets: Symbols panel (Window > Symbols)

Text stylesheets: Character Styles panel (Window > Type > Character Styles)

Fill/Stroke: Swatches panel (Window > Swatches)

For Chart and Dot Density themes:

Appearance: Graphic Styles panel (Window > Graphic Styles)

Labeling: Character Styles panel (Window > Type > Character Styles)

Fill/Stroke: Swatches panel (Window > Swatches)

Symbols: Symbols panel (Window > Symbols)

Custom symbology can be added to the Adobe Illustrator Graphic Styles, Symbols and Swatches panels. Another 
great source of styles comes from the custom graphic style, symbol and swatch libraries installed by MAPublisher.

To open MAPublisher supplied graphic style, symbol and swatch libraries, navigate to the following panels:

Graphic Styles panel options menu > Open Graphic Style Library > MAP Graphics

Swatches panel options menu > Open Swatch Library > MAP Swatches

Symbols panel options menu > Open Symbols Library > MAP Symbols

These styles and symbols are stored in Adobe Illustrator documents in the Helpful Styles & Symbols folder. To create 
a style library, simply create your own Adobe Illustrator documents containing your symbols, graphic styles and 
character styles and save them to the appropriate Helpful Styles & Symbols subfolder. See Appendix 4 for more 
information.

Along with the ability to style map art using Adobe Illustrator Graphic Styles and Symbols, MAP Themes allow users 
to manually specify stroke, fill and scale properties on a per rule basis.
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FUNCTIONALITY

Apply MAP Themes
There are several ways to apply a MAP Theme. Click the Apply button in any of the Edit Theme dialog boxes to 
immediately apply theme options to the map document. Another way is to click the Apply MAP Theme button in 
the MAP Themes panel. This method is useful for applying themes at a later time. Save the theme settings made in 
any of the Edit Theme dialog boxes and in the MAP Themes panel, select a MAP Theme and click the Apply MAP Theme 
button. Alternatively, choose Apply "[theme name]" in the MAP Theme panel options menu.

Clear MAP Themes
Click the Additional MAP Themes options button and in the context menu, click Clear [Theme]. This does not delete 
the MAP Theme, it only removes the style from the data.

Duplicate Themes
A document can contain as many MAP Themes as desired. Choose Duplicate "[theme name]" to create a copy of an 
existing MAP Theme. The rules and styles are preserved during a copy. This is useful when creating different styles 
for a map; each theme can have the same rules, but different visual properties. To apply the different themes, clear a 
previous theme and apply another one. 

Export MAP Themes
To export MAP Themes, choose Export MAP Themes from the panel options menu. In the Export MAP Themes dialog 
box, click a check box beside each theme to select it for export. Click OK and a Save dialog box will prompt for a file 
name. MAP Themes are exported to an Adobe Illustrator document and are considered MAP Objects. They can be 
imported using the Import MAP Objects function. See chapter 4 for more information about Import MAP Objects.

MAP Theme Log
MAP Theme processes can be viewed in the log file associated with each type of theme. View the log through the 
Additional MAP Theme Option context menu. Logged theme processes include the start and finish time of theme 
processes along with the number of pieces of art found and the number of pieces stylized.

Add/Remove Item from Selection 
Add or remove warning or 
critical messages

Clear Selection - Clear selected 
feature on the map

Export - Save log to a text file

Zoom To - Zoom to the selected 
feature on the map

MAP Theme Log Operations 
Lists completed processes for 

the selected theme. Use the 
Show buttons below to filter 

information, warning, and 
critical messages.

Show - Show general 
information, warnings and 

critical messages.
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Stylesheet Themes

OVERVIEW

Stylesheet themes are able to read and work with the data found in the MAP Attributes panel and used to quickly 
style MAP Layers using Adobe Illustrator symbols, graphic styles and character styles.

Theme rules can be created in two ways: manually (one by one) or generated using a data classification method.
In addition, themes can be applied to data on a one-to-one basis, where specific attribute values are assigned with 
a specific style or symbol (e.g. each country its own distinct colour) or with attribute value ranges (e.g. a country's 
population growth that falls within a range of 2.9 to 4.6% and a colour used to represent it).

FUNCTIONALITY

Create New Stylesheet
To create a new stylesheet, click the Create New Map Theme button in the MAP Themes panel. Alternatively, choose  
New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, where the 
theme name, theme type, and feature type for a new stylesheet is specified. With Stylesheet selected as the theme 
type, the Feature Type drop-down list contains a list of available feature types: Area, Line, Point and Text.

Feature Type - Specify a feature 
type for the stylesheet:  
Area, Line, Point or Text

New Stylesheet MAP Theme

Name - Specify a name for the 
new Stylesheet

Theme Type - Select Stylesheet from 
theme type drop-down list

Stylesheet themes are displayed in the MAP Themes panel. To edit a Stylesheet theme, double-click a Stylesheet 
name or select Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Stylesheet Theme 
dialog box

Note:	 It may be useful to enable the Base attribute schema on option and then choose an appropriate MAP layer in 
the Undefined Layer dialog box (see Chapter 4) before attempting to apply Stylesheet MAP Themes to a new 
layer. The new MAP layer will inherit the chosen attribute structure and applying Stylesheet MAP Themes will 
be easier because creating or editing the attribute structure is not required.
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Stylesheet Theme Editor
The Edit Stylesheet Theme dialog box is where rule generation and styling takes place.

Theme Name - Edit name of 
Stylesheet theme

Layers - Opens the Select 
Layers dialog box

Visual properties - Click to edit 
reset options (see below)

Move Up/Down - Edit rule 
hierarchy (seen in Legend)

Rule List - Selectable list of 
named rules. The green 

check mark indicates a valid  
Expression. A red X indicates 

an invalid Expression.

Rule Name - Edit rule name as 
it will appear in Legend

Expression - Determines which 
range or subset of data to 
style for each generated rule.
See Assign Expression.
Apply Visual Properties - Style 
properties applied to the 
selected rule.
See Apply Style Properties.

Stop applying rules if art qualifies 
for this rule - Limit application 
of subsequent rules to art 
that meets rule criteria
Do not apply this rule - Prevent 
rule from being applied

Rule Operations  
Add a rule  

Copy a rule  
Remove selected rule 

Batch Generate Rules 
Generate multiple rules 
based on different 
classification methods. 
See Add Stylesheet Rules with 
Batch Generate Rules.

Batch Edit Rules 
Edit visual properties for 
generated rules.  
See Batch Edit Rules.

The Theme name is reflected in the MAP Themes panel and can be edited.

At least one MAP Layer must be specified before generating rules. Click the Layers button to open the Select Layers 
dialog box to choose applicable layers. Multiple layers can be chosen, however, rules can only be generated on a 
per layer basis (meaning multiple rules can not be created across multiple layers simultaneously). Selected MAP 
Layers are listed beside the Select Layers button.

The Auto-assign setting can be used to auto-assign any imported layers to the stylesheet that have the same 
feature type or only auto-assign layers to the stylesheet if they match a pattern. This may be useful when importing 
layers that are similar to an existing stylesheet theme and will decrease the amount of setup time for each one. The 
pattern type can consist of Equals, Starts with, Ends with, Contains, and Wildcard. Auto-assign can be set to be case 
sensitive for each pattern. 

The Visual properties setting can be used to either reset visual properties before applying rules or reset visual 
properties for art that does not qualify for any rule. The Clear instead of reset setting removes all styles from art 
objects, sets fill and stroke to none and returns opacity to 100%.
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Add Stylesheet Rules Manually
To add a single rule, click the Add Rule button. Rules are shown in the rule list on the left hand-side of the Edit 
Stylesheet Theme dialog box. When a rule is selected, the settings for it are active to the right where its Name, 
Expression and Visual Properties can be assigned.

Note:	 Use caution when assigning a Stylesheet theme to grouped objects or compound paths, the graphic styles 
may not apply universally.

Assign Expression
The Expression section provides options to define the criteria in which the data chosen will be styled. There are two 
modes to define an expression: simple and advanced.

By default, the Simple Expression mode is displayed and is intended to facilitate quick expression generation.

Attribute Column - Attribute column 
of the associated MAP Layer

Range operator - Click to activate 
the second row to enable the 

composition of range expressions

Values - List of values in the 
selected attribute column

Toggle Mode - Toggle between 
Simple and Advanced mode

Expression - The completed 
expression

Comparison - Operators used 
to compare values

First, choose an attribute column from the drop-down list or manually type in an attribute name. Secondly, choose 
from a comparison operator from the drop-down list:

> 	 Greater than >=	 Greater than or equal to

<	 Less than <=	  Less than or equal to

=	 Equal to !=		 Not equal to

�Finally, type or choose value against which the comparison will be applied. To create an expression based on a 
range, click the Range operator check box to enable an additional comparison and value input pair.

Property and read-only attributes cannot be selected in the Simple Expression mode. To use property and read-only 
attribute values, click the Toggle Mode button to switch to the Advanced Expression mode. 

Expression - Type or use the 
Expression Builder to define 

an expression.

Expression Builder - Create an 
expression in the Expression 
Builder. See Chapter 5.

Expression Library - Choose an existing 
expression. See Chapter 5.

In Advanced Expression mode, construct more complex expressions and to use read-only and property attributes.
The Expression Validity icon will report if the expression entered is valid. Otherwise it will report invalid and include 
additional warning notes. Alternatively, use the Expression Builder to create and edit expressions. To use a saved or 
recent expression, use the Expression Library. See chapter 5 for more information on both.
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Apply Visual Properties
The Apply Visual Properties section provides many options to style data including graphic style, stroke, stroke 
weight, fill, scale and opacities. Depending on the type of stylesheet feature type, the style properties may differ:

For Area and Line feature types
Style - Select a predefined 

graphic style for selected rule

Stroke/Opacity/Weight - Choose a 
predefined swatch style. Adjust 
the transparency of the stroke. 

Adjust the stroke weight (in pts)
Fill/Opacity - Choose a 
predefined swatch style. 
Adjust the transparency 
of the fill.

Toggle Mode - Toggle between 
Simple and Advanced mode

Scale - Adjust the scale of style 
and stroke properties

Opacity - Adjust the transparency  
for all properties

Click the check box beside each option to enable it. The Style option contains a drop-down list of styles that exist in 
the Adobe Illustrator Graphic Styles panel.

For Point feature type
Graphic style - Select a predefined 

graphic style to apply to the 
selected symbol

Symbol - Choose a predefined 
point symbol style.

Rotation - Specify a custom 
symbol rotation

Toggle Mode - Toggle between 
Simple and Advanced mode

The Symbol option contains a drop-down list of symbols that exist in the Adobe Illustrator Symbols panel.

For Text feature type
Graphic style - Select a predefined 

graphic style to apply to the 
selected text

Symbol - Choose a predefined 
character style symbol style.

Font - Choose font and style

Font size - Choose font size

Toggle Mode - Toggle between 
Simple and Advanced mode

The Style option contains a drop-down list of character styles that currently exist in the Adobe Illustrator Character 
Styles panel. Note that enabling the Font and Font size options will override the Style option.
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Click the Toggle Mode button to toggle between Simple and Advanced mode for style properties. In the Advanced 
mode, an expression can be entered manually, created with the Expression Builder or chosen from the Expression 
Library. This essentially allows attribute information to be used as the basis for style properties.

Toggle Mode - Currently in 
Advanced mode

Expression Builder - Create an 
expression in the Expression 
Builder. See Chapter 5.

By default, the Scale is 100%. Editing the scale will alter the symbol size (points) or stroke weight (areas and lines). 
The maximum scaling factor is 1000%.

The Opacity setting adjusts the transparency of all visual properties. For area and line feature types, there are 
separate fill and stroke opacity settings. Combine with the Opacity setting to increase overall opacity.

Move Simple Expression to Advanced Expression
It is possible to move an expression from Simple Expression mode  to the Advanced Expression mode. This may 
help when tweaking rule expressions to achieve optimal thematic results. To move a simple expression, right-click 
below the Simple Expression input settings (on the Expression line) and click Move to Advanced in the context menu.

The expression will appear in the Advanced Expression mode. 

Note:	 An advanced expression cannot be moved to a simple expression. Doing so will remove the expression from 
the Simple Expression mode.
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Add Stylesheet Rules with Batch Generate Rules
To generate multiple rules based on a classification, click the Batch Generate Rules button in the Edit Stylesheet Theme 
dialog box. This opens the Batch Generate Rules dialog box:

Layer - Select source layer
Add - Add these rules to 
the Rule list

Overwrite - Overwrite 
and remove all existing 
rules in the Rule list

Data classification table 
Table that shows the 
expression, starting 
and ending range 
values and any of 
the visual property 
assignment settings.

Source - Displays number of 
values and unique values

Attribute - Select attribute 
to generate rules for

Load - Load the selected 
attribute values

Data Classification Method  
Equal Intervals, Quantiles, 

Natural Breaks (Jenks-
Caspall) or Unique Values

Data Classes - Number of 
classes to classify by

Inclusive Boundary - Choose 
either start value or end 
value to include as class 

data boundary

Visual Property Assignment 
Set the style properties 

for the data classifications 
above. The styles are 

global and affect all of 
the rules.

The Batch Generate Rules dialog box is used to generate rules on a per layer, per attribute basis (however, if multiple 
layers share  a common attribute, it can be chosen). Once a MAP Layer and attribute are chosen, click the Load 
button to populate the Data Classification table below it. The default classification method is Equal Intervals, but 
can be changed to any of the data classification methods described below. The classification is dependent on how 
many data classes are specified. In addition, set the start or end value as the inclusive boundary which determines 
whether the data range starts or ends on a boundary value. Enable the Ignore option and enter an expression (or 
use the Expression Builder or Library) to specify data values that will be ignored.

Stylesheet MAP Themes support four types of data classification methods:

Equal Intervals This classification method sets the value ranges in each category equal in size. The 
entire range of data values is divided equally into the number of categories chosen.

Quantiles This method classifies data into the number of categories chosen with an equal number 
of units in each category.

Natural Breaks 
(Jenks-Caspall)

This classification method is based on the Jenks-Caspall algorithm. It uses an empirical 
approach based on minimizing the sum of absolute deviations around class means. 
Using arbitrary set of classes, it calculates a total error and attempts to reduce this error 
by moving observations between adjacent classes.

Unique Values This method creates a category for each unique value in the chosen data set. This 
method is most appropriately used when there are few unique values within a data set.
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Use the Visual Property Assignment section to specify how the data classifications are styled. Each style property 
(except for stroke weight) can be set in two ways: as a ramp or as a single application. By default, the Ramp mode 
is enabled. This applies a style property to all data classes in a ramp manner (ascending to descending, or if the 
reverse option is checked, descending to ascending). When a style property is in Single Value mode, the options 
available change. This option applies the same style property to all data classes.

For Area and Line feature types

Ramp mode - Style is 
in ramp application 
mode. The style 
ramp is applied to all 
data classifications 
in ascending (or 
descending) manner

Single Value mode 
The style is in single 

value application 
mode. The same style 

applies to all data 
classifications.

For Point feature types

For Text feature types

Any enabled style options are shown in the data classification table under its own column heading and each 
classification its respective style setting. When additional classes are added to the table, visual styles that are in 
Ramp mode will be adjusted proportionally. For example, a layer has an opacity ramp from 0% to 100% and each 
of its three classes has an opacity value of 0%, 50% and 100%. When a fourth class is added, the opacity for each 
class is proportionally changed to 0%, 33%, 66% and 100%. This works best for visual properties that may be 
continuously adjustable such as scale or colour gradients. A warning icon appears when there is a greater number 
of classes than colour swatches (groups) or styles. This will lead to colours or styles being repeated.

When the rules and style properties are set, click Add or Overwrite. Add adds more rules to the Rules list. Overwrite 
clears all existing rules in the Rules list and replaces it with the current rules and styles.
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Batch Edit Rules
Instead of overwriting rules just to change styles, click the Batch Edit Rules button in the Edit Stylesheet Theme dialog 
box to edit existing applied styles.

Changes - Original (left) 
changed to adjusted 
style property (right)

Property Change - Adjust 
existing style property

New Property - Add new 
style property to rules

Select (or deselect) existing rules from the Affected rules list and change style properties in the Overwrite Visual 
Properties section. Changes made to rules with existing styles are reflected in the Changes table where a green 
arrow indicates the new style changes. Similar to the Batch Generate Rules dialog box, any new style properties 
added are reflected in the Changes table. All style changes to rules are updated in the Edit Stylesheet Theme dialog 
box. There is no need to recreate existing visual properties in order to maintain them.

MAPublisher dialog boxes that have adjustable size, distance or length settings can have its units converted.  
Right-click the spin box and choose a new unit of measure. The value in the box automatically converts to the 
chosen units.
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Dot Density Themes

OVERVIEW

Dot density themes are sometimes called dot distribution maps because they show where particular data 
characteristics occur. It uses dots or other symbols to represent the number of occurrences of a given data 
characteristic in a particular location. Each dot or symbol used on the map may represent a single entity 
(one dot = one person) or as a one-to-many entity (one dot = 1000 people). The data is read from each MAP Layer 
and MAP Themes quickly styles the data using Adobe Illustrator symbols and graphic styles.

Since dot density maps are most useful for showing where particular data occur, they only work on area MAP 
Layers. Most often, symbols are used to represent data occurring within a bounding polygon such as a census tract, 
zip code or county. Use caution when analyzing dot density maps, it should be understood that the dots or symbols 
do not always indicate the exact location of the data.

FUNCTIONALITY

Create New Dot Density Theme
To create a new Dot Density theme, click the Create New Map Theme button in the MAP Themes panel. Alternatively, 
choose New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, 
where the theme name, theme type, and feature type for a new Dot Density theme are specified.

New Dot Density MAP Theme

Name - Specify a name for the 
new Dot Density theme

Theme Type - Select Dot Density from 
theme type drop-down list.

Dot Density themes are displayed in the MAP Themes panel. To edit a Dot Density theme, double-click it or select  
Edit "Theme Name" from the MAP Themes panel option menu. This opens the Edit Dot Density Theme dialog box.

Dot Density Theme
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Dot Density Theme Editor
The Edit Dot Density Theme dialog box is where attribute, density and symbols are chosen.

Layer - Select source layer

Theme name - Change the 
default theme name

Dot value - The value 
represented by each dot 

Attribute - Select attribute 
to base density on

Data range - Displays the 
minimum and maximum 

values of chosen attribute 

Specify - Choose a simple 
dot style, size and 

appearance (stroke, 
stroke width and fill) 
using Custom Mode. 

Alternatively, click the 
toggle button to switch 

to Graphic Style mode 
to choose a pre-defined 

graphic style.

Use Symbol - Choose a 
custom symbol to use and 

set its scale and opacity

Dot density is created on a per layer, per attribute basis. When an attribute is chosen from the drop-down list, click 
the Load button. The data range displays the minimum and maximum values for that attribute. These values should 
be taken into account when determining a one-to-many dot density and dot value.

A dot value of 1.00 represents a single (one-to-one) entity. A dot value greater than 1.00 represents a group 
(one-to-many) entity. See Considerations for Dot Density Maps.

Dot Options
Choosing dot size is a subjective decision based on visual perception limits and aesthetics (see Considerations for 
Dot Density Maps). There are two main options to style dots: simple and symbol. Choose the Specify option to use 
simple dot styles from the drop-down list. By default, the Appearance options are in Custom Mode. Click the toggle 
button to switch to Graphic Style mode, where a graphic style can be chosen from the drop-down list. Alternatively, 
choose the Use symbol option to use symbols sourced from the Adobe Illustrator Symbols panel. Adjust the scale and 
opacity as necessary. Check the Always regenerate dot positions when applying to randomize the dot positions when the 
Apply button or Apply MAP Theme button in the MAP Themes panel is clicked.

Note:	 Only basic appearances can be applied to dot density dots. Adobe Live Effects, graphic styles with opacity, 
multiple strokes and other non-basic appearances or effects cannot be used.
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After a Dot Density MAP Theme is applied, the effect is listed in the Adobe Illustrator 
Appearance panel. Select an area containing the dot density effect and click Dot 
Density in the Appearance panel to open the Dot Density dialog box. This dialog 
box differs from the Edit Dot Density Theme dialog box. The Dot Density dialog box 
can be used to fine tune the dot density appearance of individually selected areas 
instead of making a global change.

Considerations for Dot Density Maps
When creating one-to-many dot density maps, several considerations should be noted: enumeration units, dot size, 
dot value and dot placement. The scale, size, shape, and distribution of data across enumeration units (e.g. census 
tracts or block groups) can cause variations in how a dot density map is patterned. On average, smaller sized and 
more regularly shaped enumeration units result in a more realistic density map.

The dot value and dot size should be determined together to get an idea of how many dots will populate the map. 
Take into consideration the minimum and maximum values of the selected attribute. A rounded dot value should 
be chosen for easy approximation. There is a trial and error phase when choosing the most appropriate dot value 
and size. Generally, a medium sized dot should be chosen. Small dots produce a widely dispersed dot pattern and 
may convey disproportionate map accuracy. Large dots produce overly dense dot patterns and hide any noticeable 
map patterns. As a general rule when an appropriate dot value and dot size are chosen, two to five dots should be 
seen in enumeration units with the smallest values. MAPublisher allows for automated, random placement of dots.

Too sparse Too dense Optimal

When the value for a particular feature is lower than the "Dot value", a dot may not be assigned for that object.  This 
happens because MAPublisher only accepts values that are greater than fifty percent of the dot value to be given 
a dot. For example, if an object has a value of 4,000 and the dot value is 5,000, it will be assigned a dot because it 
is greater than fifty percent (or 2,500) of the dot value. Alternatively, an object that has a value of 2,000 will not be 
assigned a dot because it is less than fifty percent (or 2,500) of the dot value.



194 Chapter 9: MAP Themes
Chart Themes

Chart Themes

OVERVIEW

Chart themes come in two types: bar chart and pie chart. A bar chart is represented by rectangular bars with 
lengths proportional to the attribute values that they represent. A pie chart is comprised of a circle divided into 
sectors, showing attribute value proportion. These charts are generally placed near the center of the aggregation 
area (e.g. census tract or state).

Chart data is read from attributes from a MAP Layer and MAP Themes quickly styles the data using Adobe Illustrator 
symbols and graphic styles. Charts can plot both discrete and continuous data. Some examples of discrete data 
include voters or hair color. Some examples of continuous data would be temperature or height.

FUNCTIONALITY

Create New Chart Theme
To create a new Chart theme, click the Create New Map Theme button in the MAP Themes panel. Alternatively, choose 
New MAP Theme from the MAP Themes panel options menu. This opens the New MAP Theme dialog box, where the 
theme name, theme type, and feature type for a new Dot Density theme are specified.

New Chart MAP Theme

Name - Specify a name for the 
new Chart theme

Theme Type - Select Chart from theme 
type drop-down list.

Chart themes are displayed in the MAP Themes panel. To edit a Chart theme, double-click it or select  Edit "Theme 
Name" from the MAP Themes panel option menu. This opens the Edit Chart Theme dialog box.
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Chart Theme Editor
The Edit Chart Theme dialog box is where the chart type, style and its options are chosen:

Theme Name - Edit name 
of Chart theme

Output Layer - Choose 
which layer where 

charts are saved

Layer - Choose a layer 
to load the Attribute 

drop-down list Scaling - Click to 
open the chart 
Scaling dialog box

Type - Choose chart 
type: Bar chart or 
Pie chart

Tabs - Switch 
between tabs for 
more options

Move Up/Down - Adjust 
placement of attribute 
in the bar or pie chart

Appearance - Adjust 
the stroke, stroke 
width, fill, and 
opacity of each 
attribute using 
Custom Mode 
(default) or Graphic 
Style Mode

Chart Preview  
A preview of the 
chart with current 
settings. Adjust  
quality of preview 
in the Quality drop-
down list

Chart Attributes 
Add attribute  

Remove attribute 

The Theme name is reflected in the MAP Themes panel and can be edited. Specify either Bar chart or Pie chart from 
the Type drop-down list. Depending on the type of chart chosen, several appearance and option settings will differ.
Choose the appropriate Legend layer to store the charts from the Output layer drop-down list. Enable the Ignore 
option and enter an expression (or use the Expression Builder or Library) to specify data values that will be ignored.

Add Source Data
In the Source Data tab, choose a MAP Layer to load its attributes from the Layer drop-down list (Text layers are not 
supported). Only the attributes of a single layer may be chosen at a time (meaning mixing layers and attributes 
is simultaneously is not possible). Click the Add attribute button to add an Unspecified attribute slot into the list. 
Select an <Unspecified> item in the list and choose an attribute from the Attribute drop-down list. The attribute 
name is automatically used in the Label box, however it can be edited. Any changes to label and appearance are 
reflected in the attribute list as well as the chart preview. To change the sort order, select an attribute in the list and 
click the Up or Down arrow.
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Adjust Bar Chart Appearance and Options
To change the appearance of an attribute, select one from the list to enable its appearance properties. The 
Appearance section, in Custom Mode (default), has adjustments for stroke, stroke opacity, stroke width, fill and 
fill opacity. Alternatively, click the Toggle Mode button to switch to the Graphic Style Mode. In that mode, choose 
a predefined graphic style from the drop-down list (sourced from the Graphic Styles panel). Changes made are 
reflected in the style indicator in the attribute list as well as the chart preview at the bottom of the dialog box. 

Style Indicator - Color 
chip shows a preview 
of the bar chart style Stroke Width

Stroke

Fill
Toggle Mode

Stroke Opacity

Fill Opacity

In the Chart Options tab, adjust basic bar chart settings—width, height, bar orientation and bar spacing. Other 
options include setting the bars relative to maximum data value. In this case, all the bar values are divided by the 
maximum value and then drawn as a relative proportion to it. For point layers, an alignment control is available to 
position the chart.

Initial Alignment - For Point layers only. 
Choose alignment position for the chart. 
It will only be aligned the first time.

Bar thickness/Maximum bar length 
Adjust the size of each bar

Bar orientation - Choose vertical 
up/down or horizontal right/left

Bar spacing - space between 
each bar

Bar style - Choose Normal or 
Stacked chart style

Bar height relative to - the bars 
are adjusted to a relative 

maximum attribute data value

In the General Options tab, enable the Apply style to chart option to choose a predefined style. The Sort Values 
option sorts (from left to right) increasing and decreasing values (not shown in the chart preview). The Draw chart 
border option is not enabled by default; click the check box to enable it and adjust its appearance options.

Apply style to chart - Choose a 
graphic style to apply to the 

entire chart

Sort Values - Sort the bars 
in either increasing or 
decreasing order (not 

shown in preview)
Draw chart border - Enable 

to draw a border 

Margin - Adjust the 
space between the 
chart and the border 

Border style - Adjust the stroke, stroke width, fill, 
and opacity of each attribute using Custom 
Mode (default) or Graphic Style Mode
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Adjust Pie Chart Appearance and Options
The Pie Chart Appearance options differ slightly from the Bar Chart options. Only the options applicable to pie 
charts are shown here. The other Appearance options function identically as explained in the previous section. 
The Explode option creates separation of a selected attribute (slice) from the rest of the pie chart. To adjust the 
separation of all slices, use the Explode option in the Options section.

Explode - Adjust how 
far the selected 
attribute is separated 
from the pie chart

In the Chart Options tab, adjust basic pie chart settings—pie radius, hole radius, explode and rotation. The Hole 
Radius option creates a hole in the middle of the pie chart and results in chart that looks like a ring. The Explode 
option here is different than the attribute Explode option in that this applies to all the slices and not just a single 
slice. The Rotation (default at 0) starts at the top (12:00 o'clock position) of the pie chart and rotates clockwise 
(negative rotation values cannot be used) up 359 degrees.

The General Options function identically as explained in the previous section.

Pie Radius - Adjust the size of 
the pie chart

Hole Radius - Adjust size of 
the hole in the pie chart

Explode - Adjust the 
separation of all slices

Rotation - Adjust the rotation 
of the pie chart from 0 to 

359 degrees

For any adjustable size, distance or length setting, right-click the spin box to change the units.
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Chart Labeling
There are multiple options to label both bar and pie charts. In the Edit Chart Theme dialog box, the Title and 
Labels tabs contain labeling settings. By default, all labeling options are disabled. Click the check box beside Show 
title, Show attribute value labels and Show attribute name labels to enable labeling options for each one. The Show 
attribute name labels option only applies to bar charts. The labeling options are shown below with an example of 
what some of the settings do.

Examples
Show title

Show value labels

Show name labels

Appearance - Adjust the font 
and font size of the title. 

Specify a title in the box or 
choose from an attribute 

that contains text
Alignment - Align the title to 

the left, center or right

Shrink title to fit chart - Adjusts 
the title so that it is 

proportional to the overall 
size of the chart

Show title line - Add a line 
below the title. Adjust 

its style properties using 
Custom or Graphics Mode.

Offset - Adjust how far the 
label is from the chart

Rotation - Align the title to 
the left, center or right

Displayed decimals - Set how 
many decimal places are 

shown with each label

Show name labels - These 
options only applies to bar 
chart themes

Align value labels - Align all 
chart values horizontally

Label with pie percentage - 
Only for pie charts. Place 
percentage beside slice.

Click the Appearance text link to edit labels in the Edit Text Rendition dialog box. Click the Rendition toggle to 
choose a predefined character style in Character Style mode or set appearance options in Custom mode.

Custom mode Character Style mode
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Chart Scaling
There are multiple options to adjust how charts are scaled. In the Edit Chart Theme dialog box, click the Scaling 
button to access the Scaling dialog box. There are two options to scale charts: fixed size or use a value from an 
attribute. The fixed size option scales all the charts equally by the set percentage. From the initial size, a scale above 
100% increases chart size and a scale below 100% decreases chart size.

To scale from attribute, click the attribute drop-down list and choose the appropriate attribute. Click the Load 
button to load the data range so that the Scaling dialog box knows which values to use. When the data range 
values are clicked, they populate the boxes below (Normalize and Tie to value).

Use the perceptual scaling option to create a more visually accurate depiction of the scale. Perceptual scaling 
modifies the scaling slightly in a way that tends to make users perceive the relationship between scaled symbols as 
intended. When checked, the scaling will not be mathematically accurate but should be viewed as visually accurate.

From attribute - Scale the chart 
based on an attribute value. Load 

the data range to obtain values.

Attribute value is scale percentage 
Use this option if the attribute is 

contains percentage values

Normalize - Enter a value to set it as 100%. 
Other values  scaled based on it.

Attribute value determines scale from range 
Use the data range to determine scale. 

Option to tie values to the minimum 
and maximum.

Fixed size - Scale the chart at 
a set percentage

Use perceptual scaling  
Adjusts the scaling so that it 

is more visually accurate 

Use the Attribute value is scale percentage option to scale the charts directly using the values for the selected 
attribute. The maximum scale value allowed is 999 percent. Any values that do not conform will be marked by the 
MAP Themes Log as an error and the scale for that chart will not be applied.

Use the Normalize option to set a value as 100 percent. All other values are converted to a percentage based on 
the set value and used to scale the charts. For example, if an attribute has a value of 2000 to be normalized as 100 
percent, that means a value of 1500 will be considered as 75 percent, effectively reducing the size of the chart.

The Attribute value determines scale from range option contains a number of setting to fine tune how the scale is set 
based on a range of values. The settings of the Minimum (default 5%) and the Maximum (default 100%) are based 
on the minimum and maximum of the data range. The Tie to value box specifically states which value in the range 
that is set as the Minimum or Maximum. It has two options available where any values below (minimum) or above 
(maximum) can be discarded or bound. This may be useful if there are extreme low or high values that could affect 
the scaling.
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MAP Theme Legends

OVERVIEW

A legend can be created from any MAP Theme—Stylesheets, Dot Density and Charts. Each theme has its own 
options and settings to create a legend. A legend is composed of boxes to represent area layers, lines to represent 
line layers, point symbols to represent point layers and text for text layers.

FUNCTIONALITY

MAP Theme legends must be added to a Legend layer. One can be created first using the Add MAP Layer button in 
the MAP Views panel and choosing a Legend feature type (see chapter 4). Alternatively, MAP Themes will create one 
if no Legend layers are present.

To create a legend, select a MAP Theme and click the Create Legend button at the bottom of the panel. Alternatively, 
choose Create Legend in the panel options menu.

Create Legend

The Legend Editor dialog box will differ depending on the type of MAP theme chosen: Stylesheets open the 
Stylesheet Legend Editor, Dot Density opens the Create Dot Density Legend, and Charts open the Create Chart Legend.

Similar to other MAPublisher functions, the legend editors are dependent on several Adobe Illustrator panels 
including Swatches, Graphic Styles, and Character Styles to style legend symbol elements. Populate these panels 
with swatches and styles before creating legends.

Legends are not dynamically linked to the MAP Themes. When MAP Theme styles change, a new legend must be 
generated. Select a MAP Theme that already has an existing legend, click the Create Legend button and adjust 
the settings to create a new legend. It is most useful when tweaking a legend to make it match or fit a layout 
design. Furthermore, legend elements can edited freely using the Direct Selection tool, in isolation mode or if it is 
ungrouped (menu Object > Ungroup).
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Stylesheet Legend Editor
The Stylesheet Legend Editor is used to create legends from point, line and area Stylesheet MAP Themes.

Output Layer - Select a 
Legend layer as output

Display name - Rule 
name displayed in 
legend (if enabled)

Display expression 
Expression 
displayed in the 
legend (if enabled)

Legend Preview - A 
preview of how 
the legend key 
looks with current 
settings. Choose 
from several 
preview qualities 
and actual size.

Legend Entries 
Add entry  

Remove entry 

In the Legend Entries tab, the Legend Entries list determines how many items are listed in the legend. Use the Add 
and Remove entry buttons to adjust how many entries are listed and use the Up and Down arrows to adjust the 
hierarchy. Select a legend entry and adjust the Display name and Display expression. These labels are used in the 
legend and are dependent on whether or not the Include name and Include expression options are enabled in the 
Legend Key Options (below).

Include icon - Check to 
include the legend 

icon. Set the size, icon 
style or use Advanced 

to match legend 
entries to rules. 

Columns - Specify 
number of columns in 
the legend

Alignment - Align the 
legend elements to 
the left, center, or right

Space between entries - 
The distance between 
each legend entry

Include expression - 
Check to include the 

legend rule expression

Include name - Check 
to include the legend 

entry names

In the Legend Key Options tab, the Include icon option is enabled by default. This is the legend icon to the left of 
an entry display name. Edit the size of the graphic using the vertical and horizontal size adjustments. Click the 
Advanced button to apply more than one rule style to a legend layer. This may be useful in cases where two styles 
such as one for a highway and one to represent high traffic volume, can be both chosen for one legend entry to 
represent a high trafficked highway. In addition, there are many shapes available in the Icon style drop-down list. 
The Icon style list is different for Line and Area Stylesheet themes (unavailable for Point Stylesheet themes). Use 
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the Alignment option to align the legend entries left, center or right. Use the Columns option to adjust how many 
columns are in the legend. The minimum number of columns is one and the maximum number is dependent on 
how many legend entries exist. The Space between entries option determines the distance between each entry.

In the Title tab, use the Draw title options to add a title to the legend. Specify a title in the Label box and use the 
options to align and set a style. Enable the Draw title line to place a horizontal line in between the title and the 
legend entries. The Element spacing option determines the distance between the title, title line and legend entries.

In the Border tab, use the Draw border options to add a border around the legend entries. Toggle between Custom 
Mode and Graphic Style mode to choose border style settings. 
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Create Dot Density Legend
The Create Dot Density Legend dialog box is used to create a legend from Dot Density MAP Themes.

Border - Check to place 
border around legend 
entries. Use options to 

style border.

Appearance - Adjust the legend 
label font and font size

Margin - Adjust the distance 
between the border and 

legend label

Legend label - Label is entered 
by default. Edit to change it.

Dot spacing - The space between 
the dot and the legend label

Dot icon size - The dot size 
represented in the legend

By default, the Use actual size check box for the Dot icon size setting is enabled. Uncheck it to manually set a size (in 
pixels). The preview shows how the legend will look depending on the settings. Adjust the Dot spacing option to 
increase or decrease the distance between the dot and the legend label.

The Legend label box provides the legend with a title. It uses a %value% variable to determine the value from 
the Dot Density theme. To adjust the value, close this dialog box and edit the Dot Density theme. Click the label 
appearance link to change the label font, style and size.

By default, the Border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to set the 
style of the border. Increase or decrease the value Margin option to adjust the distance between the legend label 
and the border.
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Create Chart Legend
The Create Chart Legend dialog box is used to create legends from Chart MAP Themes.

Style Options - Depending on 
Standard or Chart style, these 
options will differ. See below.

Label appearance - Adjust the 
legend label font and font size

Click the Label appearance link to change the font, style and size of the legend entry labels.

In the Style tab, the Style drop-down list has two options: Standard and Chart. The Standard option gives the 
legend an icon style (see above screenshot). The Chart option provides more options to create a legend that is 
representative of the chart. When the legend is created for bar charts, these options are provided:

Bar chart style options

The chart size is the overall size of the chart, not the individual bars themselves. The Label offset is the distance 
between the bars and its respective label. The Do not apply chart graphic style option removes any graphic styles 
that were applied to the chart when it was created. The Label angle rotates the label to a specified degree. Bar sizes 
can be set to Increasing, Decreasing or Equal. These are for visual purposes only and do not reflect the actual data.
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When the legend is created for bar charts, these options are provided:
Pie chart style options

By default, the Ignore explodes option does not display an exploded pie chart in the legend when it is checked. Set 
a Rotation to rotate the pie chart clockwise.

In the Title & Border tab, use the Draw title options to add a title to the legend. Specify a title in the title box and use 
the options to align and set a style. Enable the Draw title line to place a horizontal line in between the title and the 
legend entries. Use Custom Mode or Graphic Style Mode to set the line style.

Draw title - Edit title and 
appearance options

Draw border - Adjust border 
appearance

By default, the Draw border option is enabled. Use the options in either Custom Mode or Graphic Style Mode to 
set the style of the border. Increase or decrease the value Margin option to adjust the distance between the legend 
entries and the border.
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One of the most useful features of MAPublisher is the ability 
to create labels for map objects using values from the MAP 
Attributes panel. Manually entering and placing labels is not 
necessary, provided that the labeling information is included 
in the map attributes of the MAP Layer being labeled.

MAPublisher provides two methods of adding labels 
to a map, both of which contain options to place labels 
intelligently using defined label settings.

One way to create feature labels is to first select all the 
features to be labeled and use Label Features to label all of 
them by specified attribute values. 

An alternate method involves using the MAP Tagger Tool to 
apply labels individually, also by specified attribute values.

As a complement to the labeling functions, Create Knockouts 
masks the part of line features covered by text labels for 
improved text legibility.

Topics covered in this section:
Label Features
MAP Tagger Tool
Create Knockouts
Right-to-Left Text
Text Utilities

For more advanced labeling capabilities refer to chapter 17 
about MAPublisher LabelPro (additional license required).

Text and 
Labels
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Label Features 
Object > MAPublisher > Label Features or MAP Toolbar  

FUNCTIONALITY

The Label Features tool creates labels based on attributes of selected features on Area, Line, or Point MAP layers. 
Features selected on multiple MAP layers can be labeled simultaneously. Additional settings to fine tune labeling 
are available, such as alignment to lines of latitude, minimum font size, horizontal scaling and label position in order 
to place labels intelligently.

PREREQUISITES

Labels need to be added to a Text layer. Use Add MAP Layer in the MAP View panel to create one (see chapter 4)

LAYER LABELS

Layer and Attribute
The Layer column shows the Area, Point, or Text layers that currently have selected features to label.

For each layer, the Attribute drop-down list is populated with the attributes of that layer. Click to choose the 
appropriate attribute to label with.

Target
In the Target column, choose a Text layer that the labels will output to. Labels can only be created on Text layers in 
the same MAP View as the MAP layer.

Style
In the Style column, choose a pre-defined character style or use the current settings. For best results, set up 
character styles for type font, size, justification, fill and stroke in the Character Style panel before labeling (Window > 
Type > Character Style). Alternatively, set the appropriate settings (fill, stroke, font, etc.) and then use Label Features 
tool. Label Features will generate labels based on current settings.

Layer - Lists the Point, Line and Area 
layers that can be labeled. Only 

selected features can be labeled.

Attribute - Select the attribute that 
contains the values you wish to use 

as labels for the selected features

Label Settings - Click the appropriate 
tab to assign label settings and 

rules for each layer type (see below)

Target - The target text layer is where 
all the labels will be stored

Style - Labels are styled based on 
the chosen Character style or 
current settings
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LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, 
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These label settings are 
common to Label Features and the MAP Tagger Tool (including MAP Contour Tagger).

Area Labels

Placement Accuracy - To quickly generate 
labels, choose Low. To force labels within 
the boundaries of area of complex shape, 
choose High.

Set all labels to the same minimum size - When 
at least one label has been reduced in font 
size due to the implementation of rules, 
then all text items will be reduced to that 
font size (Label Features only)

Labels curve with lines of latitude  
For projected layers, choose this option to 

generate curved text along latitude lines

Adjust label if larger than line - Specify rules 
for the scaling of text if the text will not fit 

inside the area object in its entirety. 
Click the Up or Down buttons to adjust 

the order in which the rules will be 
implemented in the labeling process.

MAPublisher places Area labels depending on the shape and size of the area polygon. Click the Area Settings tab to 
see all the area label settings.

The High Placement Accuracy option makes more advanced calculations for the label positions so as to force them to 
fall within the area boundaries (useful for areas with strange shapes, for example some S shape islands). However, it 
does slows down the labeling process so a Low accuracy can be preferable depending on the expected results.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines 
of latitude and place the text along it. If this option is not selected, the labels are placed horizontally. This option is 
enabled only for MAP Views set with a projected coordinate system.

Labels can be modified if they exceed the size of the area in the current default font size. Check the Adjust label if 
larger than area option to activate the label reduction rules. These rules are executed in a hierarchical order and can 
be reordered with the Up and Down buttons. The Reduce font size to a minimum of option allows for font reduction 
to a specified minimum size in points. The Reduce horizontal scaling to a minimum of option allows text to be scaled 
horizontally by the fraction specified. The Wrap labels that are too long option adds a carriage return at the nearest 
space in the text.

Note:	 The Wrap Labels that are longer than area option is not available if the Labels curve with lines of latitude option 
is checked. 

Label Features also provides an additional option which is not available with the MAP Tagger tool. If any of the labels 
have been adjusted in size due to the deployment of an area adjustment rule, all labels can be resized to the same 
size by checking the Set all labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered 
over the area. In situations with compound areas, MAPublisher labels the largest area in the compound.
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Line Labels

Distance from start - Controls how text is 
placed relative to the line: 

Auto - places text at midpoint for straight 
lines and finds the smoothest portion 

closest to the midpoint for curved lines.  
Fixed - allows for precise placement of text 

along a line.

Adjust label if larger than line - Specify rules 
for the scaling of text if the text will not fit 

onto the text path in its entirety. 
Click the Up or Down buttons to adjust 

the order in which the rules will be 
implemented in the labeling process.

Label type - Select whether text should 
follow lines or be placed at a point near 
the selected line. Path length option 
creates short or long text on path.

Reverse right-to-left paths (flip upside-down text) 
Always enabled by default, it automatically 
orients labels uniformly. Disabling this 
feature will not flip the label.

Smooth lines with offset - Check to smooth 
the generated text path. Then, specify an 
offset distance for the text path from the 
original.

Label Position - Choose how the text will be 
placed on the generated text path

Set all labels to the same minimum font size 
When at least one label has been reduced 
in font size due to the implementation of 
rules, then ALL text items will be reduced 
to that font size (in Label Features only)

MAPublisher places Line labels depending on the curvature and length of the line string. Click the Line Settings tab to 
see line label settings. Choose a Label type to either Follow line and create text on a path, Follow line and create point text or 
Don't follow line and create point text. The first option creates text that follows a path where its position can be adjusted 
along it. The second option creates text that follows the angle of the path, but uses a point of reference. The last 
option places the text at the middle point of a line and uses a point of reference.

MAPublisher controls where text is placed along lines by using the Distance from start option. Choosing Auto will place 
text at the midpoint for straight lines and, for curved lines, will find the smoothest portion of the curved line closest 
to the midpoint. When Fixed is chosen, the distance from start is set as a percentage of the length of the line.

Reverse right-to-left paths (flip upside-down text) is enabled by default and will automatically orient labels uniformly if 
some lines are flipped. Disabling this feature will not flip labels.

When the Smooth lines with offset option is enabled, MAPublisher creates a smoothed version of the selected path for 
each text object in the layer and places the text along it at the specified offset value. The labels can be dragged and 
positioned at any position along a line. When Line Smoothing is not enabled, the labels follow the original path.

Note:	 For lines with a high number of vertices (e.g. contour lines), using the Line Smoothing option significantly 
speeds up the labeling process.

The Label position option allows for the selection of the vertical position of the labels relative to the line. Three 
options are available: 

•	 Baseline: places labels above the generated text path. 
•	 Descender: places the portion of a letter in a Latin-derived alphabet that normally extends below the 

baseline of a particular font above the generated text path. 
•	 Center: places the label on the generated text path.
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Labels can be modified if they exceed the length of the line in the current default font size. Check the Adjust label if 
larger than line option to activate the label reduction rules. These rules are executed in a hierarchical order and can 
be reordered with the Up and Down buttons. The Reduce font size option reduces the size of the font to a specified 
minimum size in points. The Reduce horizontal scaling option allows text to be scaled down horizontally by the 
percentage specified. 

Label Features also provides an additional option (not applicable for the MAP Tagger Tool). If any of the labels have 
been adjusted in size due to the activation of a line adjustment rule, all labels can be resized to the same size by 
checking the Set all labels to the same minimum font size option.

When a specified rule cannot be implemented successfully, MAPublisher will default to placing the label centered 
over the line. Also note that text generated for Line labels will be automatically orientated above the lines, 
irrespective of the direction of the line.

Point Labels

Label Position - Choose the position of the 
label relative to the point symbol. The 

preview displays label position.

Use sounding style labels - Specific options 
to label symbols marking a water depth 
position according to hydrographic 
conventions. See details in this chapter.

Labels curve with lines of latitude
For projected layers, choose this option to 

generate curved text on latitude lines.

Click the Point Labels button to assign MAPublisher Point Label Settings.

The Label Position offers nine position options for the text anchor. Choose one of the placements in the drop-down 
list: Upper Left, Upper Middle, Upper Right, Left, Center, Right, Bottom Left, Bottom Middle, Bottom Right. A preview 
shows the label placement.

When the Labels curve with lines of latitude option is selected, MAPublisher creates a path that conforms to local lines 
of latitude and places the text along it. If this option is not selected, the labels are placed horizontally. This option is 
enabled only for MAP Views set with a projected coordinate system.
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Special Point Labels: Sounding Style Labels
The Use sounding style labels option is specific for users wishing to label point symbols marking measured water 
depth positions. These types of labels are officially known as Charted Soundings and its representation on official 
navigational charts are ruled by international standards. 

The aspect of the soundings is always according to the following rule: Numerals representing the decimeter part of 
a sounding should be visibly smaller than those representing whole metres and positioned slightly lower than the latter 
(subscript). Zero decimeter values must not be shown. 

For example:  	 12 	 92

Note:	 Traditionally, slanted text (in italic) represents depth values in metre, straight text represents depths in feet.

On official nautical charts, the actual depth symbol is not plotted — the label itself indicates the depth position. 
Two options are possible for the soundings' placement relative to the depth point:

•	 Use standard label style: soundings are placed in such a way that the centre of gravity (geometric centre) of 
the set of numerals (integer and decimal parts) coincides with the position referred to. This option is the 
most commonly used.

•	 Center on whole number: soundings are placed in such a way that the center of gravity of the integer part of 
the number coincides with the position referred to.

74 74
Depth  position relative 
to label (if it was drawn).

Standard style Centered on whole number

Note:	 More information on these standards can be found on the International Hydrographic Office Website,	  
www.iho.int, see publication S-4 (formerly M-4).

The relative size and position of the decimal (subscript) relative to the integer number (regular type) is controlled 
by the Adobe Illustrator document setup. Choose the menu File > Document Setup to change the subscript size and 
position under Type Options. These settings should be performed prior to running the labeling function because 
they affect the labels placement relative to the source symbols.

LABEL FEATURES RESULTS

When all the Layer Label Options have been set and the Label Settings have been specified click OK to label the 
selected features.

Labels applied using Label Features appear in the current default color, font and font size (as set by the selected 
character style). 

If the destination text layer and source layer have the same attribute schema, the attributes of the labeled features 
are copied as attributes to text features (to apply MAP Themes for example).
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MAP Tagger and MAP Contour Tagger Tool 
Tools > MAP Tagger Tool              and MAP Contour Tagger Tool

FUNCTIONALITY

The MAP Tagger Tool and MAP Contour Tagger Tool are interactive labeling tools that use the attribute data of selected 
features as a source for the labels. These tools function similarly to the Label Features function, however, labels are 
created by clicking features on the artboard. It provides greater control over the initial placement of the label. For 
the MAP Tagger Tool, labels are placed at the position of the mouse click and leader lines can easily be created in 
dense areas. For the MAP Contour Tagger Tool, labels are placed for Line layers only and works best on contour lines.

PREREQUISITES

Labels are added to a Text layer created using the MAP Views panel.

For best results, set up a character style for type font, size, justification and color in the Adobe Illustrator Character 
Style panel. Select the appropriate style while using MAP Tagger tools otherwise labels will appear using the default 
color, font and font size. 

Double-click MAP Tagger Tool to enter new label settings or to edit settings. Click and hold the button to switch to the 
MAP Contour Tagger Tool.

MAP TAGGER TOOL SETTINGS

Source Layer and Column
First set the options in MAPublisher to determine the attribute values that will be converted to text labels. The Source 
Layer list shows all Area, Point and/or Text layers in the current document.

For each layer, the Column drop-down list is populated with the attribute structure of that layer. Select the column 
that holds the desired attributes to label the data with.

Target Text Layer
In the Text layer drop-down list, specify the Text layer that the labels will be output to. Note that labels can only be 
created in text layers in the same MAP View as the Source Layer.

LABEL SETTINGS

MAPublisher provides options to specify label preferences such as label position, alignment to lines of latitude, 
minimum font sizes and horizontal scaling to best place labels within polygons and paths. These Label Settings are 
common to Label Features, MAP Tagger Tool and MAP Contour Tagger Tool (Lines only).
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TAG MAP DATA

Ensure the label settings are completed. With the MAP Tagger Tool enabled, click a map object to add a label for it. It 
may be convenient to lock the layers in the Adobe Illustrator Layers panel or disable undesired features by setting 
the attribute column option to No attribute selected for those data layers that do not require labeling to avoid 
undesired results.

The following list of keyboard modifiers can be used for additional labeling options with the MAP Tagger Tool:
 = click map object with MAP Tagger Tool

Standard label 	  Line labels are placed at click point and assigned angle of line at click point
	  Area labels are placed horizontally at click point
	  Point labels are placed horizontally at click point

Label horizontally
 + Shift

	  Line labels are placed horizontally at click point

Create leader line
+ Shift  + drag

	  Line labels are placed horizontally. Leader line connects text to line feature.
	  Area labels are placed horizontally. Leader line connects text to area feature.
	  Point labels are placed horizontally. Leader line connects text to point feature.

Label and move
 + drag

	  Line labels are assigned angle of line at click point and can be moved immediately
	  Area labels are placed horizontally and can be moved immediately
	  Point labels are placed horizontally and can be moved immediately

Note:	 To create custom leader lines use a graphic style. Create or load a graphic style and select it in the Graphic 
Styles panel while using the MAP Tagger Tool function.

The labeling procedure for MAP Contour Tagger Tool differs slightly. Labels are placed by drawing a line and dragging it 
across paths (instead of clicking features to label them). This is particularly useful for contour lines, routes or rivers 
that are positioned near each other. The label follows the path. Then use Create Knockouts to mask the lines behind 
the labels.
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Create Knockouts 
Object > MAPublisher > Create Knockouts or MAP Toolbar  

FUNCTIONALITY

The Create Knockouts function masks parts of line features that are covered by text. The knockouts can be created 
for any MAP Layer. All lines in the selected feature layer are affected by the function. A knockout is created for all 
text in the selected Text layer.

Line Feature - Line feature being masked

Text Feature - Text base for the knockout mask

Knockout - Knockout extents

The opacity of knockout masks can be set in the Create Knockouts dialog box and can be modified afterwards 
through the Adobe Illustrator Transparency panel.

By default, the size of the knockouts correspond to the Adobe Illustrator text bounding box—that includes 
ascenders and descenders (e.g. bottom of letter g). This size can be increased by adding a buffer in pixels (side, top 
and bottom) or limited to the height of capital letters. Optionally, choose the knockout to correspond to the shape 
of the text. This allow for finer control over the appearance of the knockouts.

Create Knockouts can either append new knockouts to the selected feature layer or replace the exiting ones. It is 
also used to clear knockouts that were previously created with the function.

Note:	 Any text layer can be used to create knockouts, it does not have to be generated by MAPublisher Labeling 
functions. The Feature and Text layers do not have to be in the same MAP View.

PREREQUISITES

Create Knockouts requires any type of MAP Layer and a Text layer to be unlocked and visible. 

All features in the selected layers will be affected by the function. Text and features that are not supposed to be 
masked must be moved to a different layer beforehand.

Feature Layer - Select the line layer that 
will be masked with knockouts

Text Layer - Select the layer containing 
the base text for the knockouts

Mask Opacity - Set the mask opacity 
(100% creates transparent knockout)

Knockout boxes - Set a buffer size 
around the text box

Text shaped knockout - Set a buffer 
knockout based on the shape of 
the text

Limit to cap height - Check this 
option to limit the text box height 
to the size of capital letters.

Clear - Click here to remove all 
knockouts from the selected 
Feature Layer

Replace existing knockouts - Clear the 
existing knockouts in the Feature 

Layer before adding new ones. Do not 
choose this option to append new 

knockouts to the existing ones. 

Use clipping mask instead of opacity mask 
Choose only if exporting document 

to PDF or PostScript. It uses a 
clipping mask instead of an opacity 

mask beneath the label.

Round corners using radius 
Creates mask corners that are 
rounded to a specified radius
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USING CREATE KNOCKOUTS

To access the function, click the Create Knockouts button on the MAPublisher toolbar or from the menu Object > 
MAPublisher > Create Knockouts.

Layers
In the Create Knockouts dialog box, click the Select Layers button to choose at least one Feature Layer (visible and 
unlocked), and then choose a Text layer from the drop-down list. Use the Layer Type Filter to filter which layers are 
shown. Text in the selected text layer should overlap with some of the features in the selected feature layer to get 
reasonable knockout results. 

Mask Opacity
The Mask Opacity option sets the opacity of the masks created behind the text: a 100% setting creates an opaque 
mask (the feature will be invisible behind the text) and a 0% setting does not hide any features at all.

Replace Existing Knockouts
The Replace existing knockout option clears the existing knockouts on the selected Feature Layer before adding the 
new knockouts. This is useful when running the Create Knockouts function again after adjusting the settings 
slightly. To append the new knockouts to the existing one, make sure this option is not checked.

Knockout Boxes
Several parameters are available to set the size of the knockout. By default, the knockout corresponds to the Adobe 
Illustrator text bounding box. That bounding box can be slightly taller than the characters in the selected text 
because it takes into account the size of ascenders and descenders (e.g. | and g characters). To increase the size 
of the knockout, four buffer options are available: Left Buffer, Right Buffer, Top Buffer and Bottom Buffer. Buffer sizes are 
entered as pixel values. The Limit to cap height option reduces the knockout size to the height of the capital letters. For 
example, this option is useful when labeling contour lines that are close to one another where the regular knockout 
size could create masks that overlap from one contour to the next. The knockout boxes are represented below by 
the dashed line (for visual reference only). 

Default knockout size Limit to cap height 
knockout size

Buffer knockout size (2 px)

To achieve a knockout that does not conform to a box, choose the Text shaped knockout option and specify a buffer 
size. This creates a knockout that is based on the shape of each text character. It allows for finer knockout control. 
Optionally, use the Round corners using radius option to round knockout box corners.

Text shaped knockout (1 px)

Note:	 Text shaped knockouts may increase document file size.
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KNOCKOUT RESULTS

All art in the MAP Layers are masked by the text objects in the selected Text layer, where appropriate.

To achieve the knockout effect, Create Knockouts applies an opacity mask at the layer level as can be seen in the 
Adobe Illustrator Layers panel.

This masking does not affect the MAP Layer attributes or properties.

Edit Knockout Masks Opacity
The opacity of all the knockouts within MAP Layers can be edited using the Adobe Illustrator Transparency panel:

1.	 In the Adobe Illustrator Layers panel, click the target button next to the master layer name  .
2.	 Choose Window > Transparency to open the Transparency panel.
3.	 In the Transparency panel, click the right-side preview to start editing opacity mask.

Edit Opacity Mask - Click to 
edit opacity mask

Exit Edit Opacity Mask 
Click to stop editing 

opacity mask

Opacity - Percentage of opacity 
(transparency)

4.	 Click the left-side preview in the Transparency panel to exit the opacity mask editing mode.

Note:	 If for some reason the knockouts are not selected when you exit the opacity mask editing mode, the next 
time you return to this mode, they will not be selected by default—you'll have to select the knockouts again 
from within the opacity mask editing mode (click the object or use the Layers panel target button).

CLEAR KNOCKOUT MASKS

Open the Create Knockouts dialog box, ensure that the MAP Layers that contain the knockouts are selected and 
click the Clear button.

Layer with Opacity Mask - In Adobe Illustrator, 
a dashed line under a layer name indicates 
that the layer has an opacity mask
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Right-to-Left Text
Object> MAPublisher > Right-to-Left Text or MAP Toolbar  

Preset - Choose a preset or use 
custom settings below

Paragraph direction - Choose a Left 
to right or Right to left direction

Digits - Choose which language 
numeric digits are to be typed

Kashidas - Check to insert 
Kashidas in Arabic language

Target - Choose which text to 
apply right-to-left correction to 
and whether to apply it to only 

selected text or not

Composer engine - Choose from 
Standard or Adobe World-Ready 

Composer to handle text

Justification Method - Choose from 
Arabic or Naskh justification

FUNCTIONALITY

Many right-to-left languages, such as Arabic and Hebrew, require additional language-specific processing to get 
the correct glyph output given the incoming character stream. The Right-to-Left Text tool is used to apply proper 
formatting to right-to-left languages.

USING RIGHT-TO-LEFT TEXT

On the MAPublisher toolbar, click the Right-to-Left Text button or the menu Object > MAPublisher > Right-to-Left Text.

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally, 
check Apply to selected text only to only apply formatting to text that was selected before opening the dialog box. 
In the Settings section, the Preset contains options (Left-to-right, Arabic, Hebrew) that sets Paragraph direction, 
Justification method, and Digits. Any other settings chosen are considered as Custom.

The Composer engine has two modes: Standard and Adobe World-Ready Composer. The Standard mode uses the default 
Adobe Illustrator text engine. The Adobe World-Ready Composer enables support for complex script languages 
(such as Arabic and Hebrew). 

The Paragraph direction can be chosen as Left to right or Right to left (this is the result, not the current text).

The Justification method can be left as Default (the same as the language set in the Character panel) or set to Arabic or 
Naskh. To convert text to right-to-left without changing the justification or location of text, �uncheck all options and 
set the composer to Adobe World-Ready Composer.

Choose the language in which numeric Digits are to be typed. The Default setting means that the numbers will be in 
the same language as set in the Character panel, otherwise, choose between Arabic, Hindi, or Farsi digits.

Kashida is a type of justification that elongates characters at certain chosen points. Kashida justification can be 
combined with white-space justification to various extents.
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Text Utilities
Object > MAPublisher > Text Utilities or MAP Toolbar  

Actions - Choose an action to 
perform it on the target text. 
More actions below. Actions 
explained on the next page.

Target - Choose which layer to 
apply text utilities to or choose 

to apply it to all text in the 
document. Optionally, only apply 

it to selected text.

FUNCTIONALITY

The Text Utilities dialog box centralizes many text related actions that map makers require. Many of these text 
actions have come about due to the complexities of working with text, geographic data and follow cartographic 
conventions. Common text issues that Text Utilities can handle are correcting upside down text, separating 
multiline text into single line and cropping text path to text length. These actions can be applied to either all text 
layers or specific text on a layer. Optionally, actions can be applied to selected text only.

USING TEXT UTILITIES

On the MAPublisher toolbar, click the Text Utilities button or the menu choose Object > MAPublisher > Text Utilities.

In the Target section, choose the target text to be a MAP Text layer or target all text in a document. Optionally, check 
Apply to selected text only to only apply formatting to text that was selected before opening the dialog box. 

In the Actions section, choose an action to be performed (actions explained on the next page). Only one text action 
may be performed at a time. Click the Preview button to see how the text may be affected.
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Actions

Convert text on a path to point text
Converts text on a path to point 
text removes curvature and creates 
"straight" text.

Separate multiline text
Separates multiline text into 
individual lines of text (the points 
starting each line in the result).  

Example result produces three separate lines of text.

Merge text
Merge multiple lines of text into 
a single text object. Not available 
when "All text in document" is 
chosen as the Target.

Extend overflowing text
Extends text elements that contain 
overflow.

Flip upside down text
Flips upside down text (corrects 
left-to-right direction) 

Shorten text path
Remove extra line segments at the 
start and end of a path

Set text alignment
Change the insertion point of 
point text without moving the 
text. Alignment can be set to left, 
center, or right.

 
Example result produces right justified text.

Rectify point text to angle
Rotates point text to any angle 
for text within a specific tolerance 
angle.

 
Example result rotated 8 degrees for text within a 10 degree tolerance angle.

Draw shape around text
Draws text shapes or boxes around 
text. Change the style using the 
appearance options. Optionally, 
limit box to cap height of text and 
choose a specific layer for output.

 
Example result has a box shape with side, top and bottom buffer of 4 px.

Note: some text may not appear centered if no descenders are present and the limit to cap 
option is disabled.

Draw anchor point for text
For point text, it draws an anchor 
point at lower left. For path text it 
is relative to the left anchor point.

Adds a "Text" attribute when the point is on a MAP layer.

Original Result
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MAPublisher contains tools for selecting data graphically and 
by attribute values. 

The MAP Selections panel provides functionality to create, 
edit and save multiple selection criteria: based on attribute 
expressions, manual art selections or spatial filters. MAP 
Selections are saved with the document.

The Split Layer function allows to split MAP Layers based on 
attributes values to facilitate data management.

The topics covered in this section:
MAP Selections
Merge Layers
Split Layer

MAP Selections 
and Data 
Organization
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MAP Selections 
Window > MAPublisher > MAP Selections or MAP Toolbar  

Delete MAP Selection - Delete highlighted 
MAP Selections

Create New MAP Selection- Opens the New 
MAP Selection dialog box (below)

Get Subset of Current Selection - Makes a 
selection within the current selection

Remove from Current Selection - Removes 
the highlighted criteria from the current 
selection

Add to Current Selection - Adds the 
highlighted criteria to the current 
selection

Apply as New Selection - Makes a new 
selection using the highlighted criteria

MAP Selections Panel

MAP Selections List - MAP Selections saved 
in the current document

Three different types of MAP Selections: 
•	 Attribute Filter 

•	 Art Selection 

•	  Spatial Filter 

 
Invalid MAP Selections for the currently 
selected layer are marked with an 
additional  sign.

MAP Selections Panel Preferences

MAP Selection Name - Name given to the 
MAP Selection. It can be changed in the 
Edit MAP Selection dialog box.

MAP Selection Parameters - Summary of 
the selection parameters. They can 
be changed in the Edit MAP Selection 
dialog box.

Duplicate MAP Selection - Copies the 
selected MAP Selection

Edit MAP Selection - Opens the Edit MAP 
Selection dialog box

Import MAP Objects - Opens the Import 
MAP Objects function (see chapter 4)

Preferences - Opens the MAPublisher 
Preferences on the MAP Selections 
property sheet

Panel options:

Show filters on two lines - cleared

Show filters on two lines - selected
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New/Edit MAP Selection

Expression Validity - Indicates if 
the expression is  valid or 

 invalid. If invalid, additional 
information is reported

Expression - Enter or edit the expression 
directly into the entry field, or access

 Expression Builder  - see chapter 5

 Expression Library - see chapter 5

Name - Assign or edit the name of 
the MAP Selection

Type (new MAP Selection only) - Choose 
the MAP Selection type:

•	 Attribute Filter 
•	 Art Selection 

•	  Spatial Filter 

 Attribute Filter

Layer(s) - Choose layers to base 
the selection on. By default, the 

selection will be done on the 
currently selected layer.

Click to  make a different choice 
in the Select Layers dialog box

 Art Selection
Art must be selected first.

 Spatial Filter

Filter Using - Choose where the features 
that delimit the spatial filter are taken 
from:
•	 Existing MAP Selection: select a MAP 

Selection name from the Existing MAP 
Selection drop-down list

•	 Art Selection: use the current art 
selection (see options above for edit)

•	 Attribute Filter: enter new attribute 
filter parameters (see Attribute Filter 
dialog box above)

Select From Layers - Choose layers to 
select from. By default, the selection 
will be done on all layers.

Click to  make a different choice in 
the Select Layers dialog box (see above)

Spatial relationship - Choose the method 
applied for the spatial filter:

•	 Intersect and contain: objects that 
intersect or are contained within the 

delimiting features will be selected
•	 Fully contained: only objects that are 

fully contained within the delimiting 
features will be selected

Filter text by - Choose the specific 
behavior for selecting text:

•	 First letter of text: the position of 
the first letter of a text is used to 

make a selection
•	 Full size of text: the bounding box 
of the text is used for the selection

Do not select art on the same layer as the 'Filter 
Using' art - Check this option so as not 
to select art that is on the same layer 

delimiting feature

Edit Art Selection
Show Selection - Highlights the Art 

Selection on the artboard

Replace - Replaces the saved Art Selection 
with the current artboard selection

Add - Adds the current artboard 
selection to the saved Art Selection
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FUNCTIONALITY

The MAP Selections panel provides options to build, edit, save and apply multiple selection criteria based on:
•	 Attribute Filters: selections based on attributes and properties of MAP Layers
•	 Art Selections: saved selections (done with the MAP Selections filters or with the Adobe Illustrator 

selection functions)
•	 Spatial Selections: selections based on a feature's position relative to another (e.g. select points 

contained in a given area). 

MAP Selections are saved in the Adobe Illustrator document. The Copy MAP Objects From function (see chapter 4) 
provides a method to exchange MAP Selections between documents opened in Adobe Illustrator.

Expressions created for Attribute Filter type MAP Selections can be saved in the Expression Library so that it can be 
used in MAP Attributes and MAP Themes stylesheets (see chapter 5 and chapter 9, respectively).

PREREQUISITES

To save or use a MAP Selection, at least one piece of art must be selected on the artboard before creating a new 
selection. This selection does not have to be on a MAP layer, although it must be visible and unlocked.

CREATE A MAP SELECTION

To open the MAP Selections panel, click the MAP Selections button on the MAPublisher toolbar or from the menu  
Window > MAPublisher > MAP Selections. 

To create a new MAP Selection, click the Create New MAP Selection button or from the panel options menu to open the 
New MAP Selection dialog box.

Enter a meaningful Name for the new MAP Selection to facilitate its use. For example, a MAP Selection could be 
named Cities or Countries with 80% or higher literacy or US Highways. 

Choose the desired MAP Selection Type: Attribute Filter, Art Selection or Spatial Filter.

Attribute Filter
Attribute Filters select objects on one or more MAP Layers based on the features' attributes values or properties. 
The selection criteria is an expression created from attributes names, values and/or preset functions.

By default, the selection is done on the currently selected layer. Users may choose a different layer or more layers by 
clicking the Layers button to open the Select Layers dialog box. Check any layers that may need to be included.

In the Expression field, enter a valid expression. Optionally, click the Expression Builder button to open the Expression 
Builder dialog box or click the Expression Library button to choose a saved or recent expression from the Expression 
Library. The Expression Validity icon will report if the expression entered is valid or invalid (and will include additional 
warning notes).

Note:	 The expression validity depends on the layer selection since it is based on some attribute column names.
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The following are some examples of basic expressions which can be entered for use as selection filters.

Expression Result

NAME = “Ontario” All items with the value “Ontario” in the NAME column are selected.

NAME = “Ontario” OR NAME = “Alberta” Result: Items with the value “Ontario” OR “Alberta” in the NAME column 
are selected.

POPULATION < 1000000 All items with values less than one million in the POPULATION column are 
selected.

NAME = “Ontario” AND POPULATION < 1000000 Only items containing the value “Ontario” in the NAME column AND 
values less than one million in the POPULATION column are selected.

Note:	 MAP Selections created in MAPublisher 8.3 or earlier are converted to MAP Selection Attribute Filters, based 
on the <current layer>.

Art Selection
To store a current selection—done through the MAP Selections panel or using the Adobe Illustrator selection 
functions (e.g. Selection tool, menu Select or Layers panel)—select the MAP Selection type Art Selection.  
No parameters are required for this type of MAP Selection.

The current selection must be performed before creating a new MAP selection. 

Spatial Filter
A Spatial Filter MAP Selection selects sets of objects based on their position on the artboard.

A Spatial Filter is based on a selection of features, the boundaries of which are used as a limit for the final selection. 
The Filter Using drop-down list sets the selection of these features. Three options are available:

•	 Existing MAP Selection: the delimiting features are taken from a saved MAP Selection. The MAP Selection 
name is chosen in the Existing MAP Selection drop-down list below.

•	 Art Selection: the current artboard selection is used (the selection must be performed before creating the 
new Spatial Filter). The current selection is stored as part of the Spatial Filter for later use.

•	 Attribute Filter: the delimiting features are selected based on new attribute filter parameters (see Attribute 
Filter MAP Selection).

Once the delimiting features are specified, additional Options can be set.

By default, all objects contained within the delimiting features will be selected, regardless on which layer they 
belong to. The Select From Layer(s) option can be applied to limit which layers will be included in the final selection. To 
do so, click the Layers button to open the Select Layers dialog box. Note that MAP Layers and Non-MAP Layers are 
available for selection.

The Spatial Relationship drop-down list offers two options for the selection method: 
•	 Intersect and contain: objects that intersect or are contained within the delimiting features will be selected.
•	 Fully contained: only objects that fully contained within the delimiting features will be selected.

The option Do not select art on the same layer as the 'Filter Using' art is meant to avoid art that is on the same layer as 
a delimiting feature from being selected based on that feature. For example, if the Spatial Relationship is set to 
Intersect and contain, all areas that share a boundary with an area that is a delimiting feature will be selected. With 
this option, areas that are on the same layer as the delimiting feature will be excluded from the selection.
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EDIT A MAP SELECTION

To edit an existing MAP Selection, click the selection name in the MAP Selections panel and choose Edit MAP Selection 
in the panel options menu. Alternatively, double-click the selection name.

The Edit MAP Selection dialog box allows to rename the MAP Selection and to edit the selection parameters. The dialog 
box options depend on the MAP Selection type.

When editing an Attribute Filter, the selection layer and the expression may be edited as new. 

When editing an Art Selection, three options are offered: 
•	 Show Selection: shows the stored Art Selection on the artboard.
•	 Replace: if art is selected, replace the stored Art Selection with the current selection.
•	 Add: if art is selected, add the current selection to the stored Art Selection.

When editing a Spatial Filter, all the parameters may be changed. If the Filter Using option is set to an Art Selection, 
the same edit options as above are available (Show Selection, Replace and Add).

DELETE A MAP SELECTION

Click one or more selection names in the MAP Selections panel, then click the Delete button or choose Delete MAP 
Selection in the panel options menu.

Note:	 Use caution when deleting, some selections may be dependent on others.

MAKE SELECTIONS

Click the Apply button when creating a MAP Selection. Saved MAP Selections can be applied again at any time.

Note:	 MAP Selections based on Attribute Filters that are set to <use current layer> may become invalid when a 
different layer is selected because its attribute schema may not match the expression.

There are four methods for applying a MAP Selection (available as buttons and menu items):

Apply as New Selection Clears the current selection and selects any art on the current layer that meets 
the criteria of chosen selection filters

Add to Current Selection Adds any art on the current layer that satisfies chosen selection filters to the 
current selection

Remove from Current Selection Deselects any art on the current layer that is selected and satisfies chosen 
selection filters

Get Subset of Current Selection Deselects any art on the current layer that is selected and does not satisfy 
chosen selection filters

Note:	 These selection combinations can themselves be saved as an Art Selection.
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Merge Layers
Object> MAPublisher > Merge Layers or MAP Toolbar  

FUNCTIONALITY

Merge Layers combines at least two MAP Layers of the same feature type into a new MAP layer based on its 
attribute values. The art from the source layers can either be copied or completely moved to the new layer 
(including its attributes).

This tool is particularly useful to combine layers that contains multiple objects. In the example above, eastusa 
(eastern United States) and westusa (western United States) are being combined to form one layer containing both. 
Merge Layers can be used as a preliminary to exporting layers to other GIS formats.

USING MERGE LAYERS

On the MAPublisher Toolbar, click the Merge Layers button or from the menu Object > MAPublisher > Merge Layers.

Source
In the Source section, choose a MAP View from the drop-down list to load its MAP layers. Click the Feature type 
drop-down list to filter the layer list to only show a specific feature type (only layers of the same feature type can be 
merged together). In the Layers list, click the check box of at least two layers to include them in the merge. When 
chosen, layer attributes are shown in Attributes box.

Destination
In the Destination section, enter a new name in the Layer box or choose an existing layer.The new layer will be of 
the same feature type of the source layers. 

Method
The Copy art to destination layer and Move art to destination layer options are available to copy or move the source 
art to the new layer specified in the Destination section, respectively.

Destination - Enter a new 
destination layer name or 

use an existing layer

Method - Copy or move the 
art to the destination layer 

specified above

Source - Choose the MAP View 
and Feature type to include 

in the merge operation

Attributes - Layer attributes 
are listed under Source and 
Destination columns.

Click a Destination attribute 
to choose the appropriate 
one. This is where the Source 
attribute will be copied or 
moved to.

Layer list - Choose which MAP 
Layers are included in the 

merge. Their attributes show 
up in the list to the right.
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Attributes
The Attributes section displays the MAP layers chosen for merge. Click the arrow the arrow beside each MAP layer 
to display its attributes.

The attributes are split into two columns: Source and Destination. The Source column shows the attributes for 
all MAP layers. The Destination column shows where the Source attributes will be moved or copied to in the 
destination MAP layer. To change the destination attribute, click it to reveal a drop-down list (which contains every 
attribute from all chosen layers) and choose a new attribute. Alternatively, choose Drop to exclude it from the 
destination MAP layer.

RESULTS OF MERGE LAYERS

The result of a merge when using at least two MAP layers is a destination MAP layer containing all artwork and 
designated attributes. When the source layers have the exact same attribute schema (provided no changes to 
destination attributes are made) the result in the destination MAP layer will be the same attribute schema. 

When source layers have different attribute schemas, the designated attributes in the destination layer may be 
empty for the opposing layer (unless the attribute was specifically set as a destination for the other layer).

Note:	 After a merge of MAP layers containing sub-layers, the original sub-layer structure is maintained.
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FUNCTIONALITY

Split Layer divides a MAP Layer into new MAP layers based on its objects' attribute values. The new layers can either 
contain a copy of the original objects or objects can be moved from the source layer.

The split can be done:
•	 Based on an expression: when an object's attribute values satisfy the specified expression it is added to 

a new layer.
•	 By unique attribute value: objects that have a same attribute value are grouped into a new layer. Hence 

multiple layers are created (one per unique value).
 
This function is particularly useful to split a layer that contains a lot of objects. For example, a road layer with classes 
such as street, highway and toll road could be split in three distinct layers. Split Layer can be used as a preliminary 
to running MAPublisher LabelPro (to allow labeling of multiple classes with different styles, see chapter 17), or to 
exporting layers to external GIS formats.

USING SPLIT LAYER

The MAP Layer to be split must first be selected in the MAP Views panel or in the Adobe Illustrator Layers panel. On 
the MAPublisher toolbar, click the Split Layer button or from the menu Object > MAPublisher > Split Layer.

In the Action options, specify if the split art should be either copied or move to the new layer.

Note:	 If the source layer is locked, the only option is to copy to the new layers.

Destination - Enter the name of the new layer 
to be created (split art by expression) or 

enter a layer prefix (split by attribute value). 
Use Copy attribute schema option to copy the 

attribute schema to the new layer

Action - Select the option to copy or move objects 
from the source layer to the destination layer

Split art to new layer(s) by unique attribute value 
Choose this method to split the selected 

layer into multiple layers - one per unique 
value of the selected attribute column in 

the Attribute drop-down list.

Split Layer 
Object> MAPublisher > Split Layer or MAP Toolbar  

Source Layer - Indicates the currently selected layer

Expression Validity - Indicates if the expression 
is  valid or  invalid. If invalid, additional 
information is reported.

Expression - Enter or edit the expression directly 
into the entry field, or access:

 Expression Builder  - see chapter 5.

 Expression Library - see chapter 5.

Split art that satisfies this expression - Choose this 
method to create a new layer from objects 
that satisfy the specified expression.
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When the Split art to new layer(s) by unique attribute value method is chosen, choose an attribute name from the Attribute 
drop-down list. Each new layer created will contain only art that share the same attribute value. By default, the 
name of these layers correspond to each single attribute value. 

When the Split art that satisfies this expression method is chosen, enter a valid expression in the Expression field, build an 
expression using the Expression Builder, or select an expression from the Expression Library — see chapter 5 for more 
details (the expression validity icon will report if the expression entered is valid. Otherwise it will report that it is 
invalid and include additional warning notes).

In the Destination section, enter a prefix to be added every layer name. Otherwise, the layer name will use the value 
in the attribute that the split is based on.

The Copy attribute schema option duplicates the attribute schema from the source layer to the destination layer.

RESULTS

When Split Layer is run, a message is displayed that indicates the number of layers that will be created. Click Cancel 
to cancel the Split Layer command or click Create layers to continue.

Depending on the method chosen, one or more new layers are created according to the splitting criteria. The new 
layers are placed on the top of the layers hierarchy in the Adobe Illustrator Layers panel.

The new layers have the same feature type as the source MAP layer and are included in the same MAP View. 

If the Copy attribute schema was enabled, the new layers contain the same attributes as the source layer. 
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Working With 
Images
MAPublisher contains tools for working with georeferenced 
raster images such as aerial photography and satellite imagery.

The Register Image function accurately registers raster images 
with georeferencing information to vector map data. 

Export raster images to various georeferenced formats 
through the MAP Views panel.

Georeferencing information for raster images are usually 
stored in a separate text file where the image and its 
associated reference file have the same file name but a 
different file extension. 

The reference file formats that can be read by Register Image 
or written to by Export Image are:
World (tfw)
Image Report (irp) 
MapInfo Table (tab)
Blue Marble Reference (rsf )
ER Mapper ERS (ers)
ListGeo (lgo)
GeoTIFF (tif, tiff) (contains both the image and reference data)

Topics covered in this section:
Register Image
Export Image
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Tie Points† - Change the tie point 
of the image by clicking another 

corner of the graphic

Pixel Size† - Specify the size of each 
pixel in the selected map unit 

(updates the Effective Map Size). 
Register Image supports non 

square pixels.

Constrain Proportions - Check this 
option to maintain X and Y pixel 

proportions (in map units)

Effective Map Size X/Y† - Specify the 
X and Y size of the image in map 

units (updates the Pixel Size)

Rotation - Displays the amount of 
rotation of an image

Register Image 
Object > MAPublisher> Register Image or MAP Toolbar  

FUNCTIONALITY

Register Image applies geospatial properties to raster images imported using the Adobe Illustrator Place command. 
Register Image uses a coordinate system and coordinates—entered manually or loaded from a reference file—
to properly georeference and scale an image. If the coordinate system of an image matches one of existing 
vector data, the image can be scaled and rotated to fit the vector data. If no matching vector data is found in the 
document, a new MAP view can be created to store the cartographic information of the image to allow for data 
digitization with accurate positioning.

Note:	 Register Image does not have the capability to transform images from one coordinate system to another. Use 
a product like Avenza Geographic Imager to transform images.

Units - Select a unit to use for the 
specification of georeferencing 
information. The default selection is the 
current map unit.† Editing these options is 

not required when using 
the Load File function.

Placement X/Y† - Specify the coordinates 
(in map units) of the selected corner of 
the raster image

Load File - Choose a file containing 
the georeference information for the 
selected raster image. The information 
from the file will be inserted into the 
appropriate fields.

Register Image

Undefined Layer

Reference File Coordinate System - Indicates 
the coordinate system of the loaded file 
(for GeoTIFF images). Set to Unknown 
by default.

This dialog box appears if the image to 
register is not placed on a MAP Layer

Feature type - Choose Image 
feature type

Create or Add to existing MAP View 
Choose to create a new MAP View 

or choose an existing one from 
the drop-down list
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PREREQUISITES

To use Register Image, the geospatial properties of the raster image must be known. Some raster image formats 
store the relationship between source image coordinates (pixel location) and real-world reference coordinates 
in an associated reference file but do not save the coordinate system information (e.g. TFW world file). The 
commonly used GeoTIFF format is embedded with geographic information such as position and coordinate system. 
Depending on the image format, check the position and coordinate system of imagery with the data provider 
before attempting to use this tool.

To import a raster image into a document, select a layer from the Layers panel (Image MAP Layer or not) and 
choose the Adobe Illustrator Place command (File > Place). The image is placed on the artboard, but is not spatially 
referenced at this point—it needs to be registered. 

Notes:	 When placing an image, do not use the Convert Layers to Objects option. It will treat images that may have 
multiple layers as grouped objects and will prevent it from being registered properly. 
 
Using an embedded, unflattened image with an existing transparency may result in incorrect registration.

USING REGISTER IMAGE

With an image selected, click the Register Image button on the MAPublisher toolbar or from the menu Object > 
MAPublisher > Register Image.

If the image is placed on a MAP Layer, the Register Image automatically registers the image using the coordinate 
system of the MAP View containing that MAP Layer.

If the raster image was not imported to a MAP Layer, the Undefined Layer dialog box will appear. Choose either to 
create a new MAP View based on the image or choose to add the image to an existing MAP View. In either case, the 
Image feature type is the only one available for rasters. It is recommended to use the Image feature type for image 
registration and for better layer management and workflow.

When creating a new MAP View, the anchor point and scale are derived from the registration information 
(placement and image size). In the case of GeoTIFF images, the MAP View coordinate system is automatically read 
from the image header—for other image formats, the coordinate system has to be specified manually in the MAP 
View Editor after the registration process (see chapter 4 for more information on Specify coordinate system).

Registration using Reference File
To register an image using a reference file, click the Load File button and navigate to the folder containing the file. 
The reference file may have the same name as the image, but may have a different extension (IRP, TFW, TAB, RSF, ERS 
or LGO). In the case of the GeoTIFF format, the image file itself contains both the image and reference data and the 
needs to be chosen to retrieve the georeferencing information.

The values contained in this reference file are automatically entered into the image parameters. If the file is in 
GeoTIFF format, the image coordinate system is read and displayed under Reference File Coordinate System—for other 
file formats, the coordinate system is left as unknown.
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Manual Registration
To manually enter image parameters, one of the following combinations must be available in page units or map units:

•	 The X and Y coordinates of one corner of the image and the X and Y Pixel Size.
•	 The X and Y coordinates of one corner of the image and the X and Y size of the image.

First choose the units to use for entering parameters by making a selection from the Units drop-down list. Then, click 
the appropriate corner of the graphic to indicate the image placement point and enter the X and Y coordinates for 
this location in the adjacent fields. Next set either the Pixel Size or Effective Map Size. The Pixel Size is the value of a single 
pixel in the units set. The Effective Map Size is the X and Y size of the whole image in the units set. Setting either 
option will update the other accordingly. 

Note:	 MAPublisher Register Image supports the registration of images having non-square pixels.

RESULTS

When registering GeoTIFF images, a warning message will be displayed if the coordinate system of the image 
does not match the selected MAP View's coordinate system. When registering images not in GeoTIFF format while 
creating a new MAP View, the coordinate system of the MAP View has to be specified in the MAP View Editor to 
finalize the georeferencing. 

Provided that the coordinate system, placement and size of the raster image are correct, the image will be scaled 
and registered. When matching vector data is available, the image will fit to the artwork. The MAP Location Tool can 
be used to check the positions (see chapter 4).

Notes:	 Raster images cannot be transformed into another coordinate system. If the vector data is transformed 
through the MAP View Editor Perform Coordinate System Transformation function after the image has been 
register, the image will have to be transformed externally (with Avenza Geographic Imager for example) and 
registered again in MAPublisher.

Registered images will be scaled and rotated together with the vector data, but not automatically. After 
the vector data has been scaled or rotated using the MAP View Editor, Register Image must be used to apply the 
image referencing information. In the case of a manual registration, it is recommended to use the Export 
Image function before applying the changes to the vector data (see next paragraph). This way, registering the 
image again is only a matter of loading a reference file.

SUPPORTED GEOREFERENCED IMAGE REFERENCE FORMATS

World File (tfw, tifw, wld, eww, jgw, jpw, pgw, sdw, eww, blw, dmw) 
World files contain the affine relationship between source image coordinates (pixel locations) and real-world 
reference coordinates (lat/long or other real-world coordinate units). World files simply contain a computed 
relationship between source image coordinates and reference coordinates and not the complete reference point 
information. World files do not support storing coordinate system information.

IRP Image Report File (irp)
IRP Image Report files are ASCII report files indicating the coordinates of the four corners of the raster file and the 
pixel size in ground units to allow for georeferencing of the image in other image processing, CAD, or GIS programs.
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MapInfo Table File (tab)
MapInfo Table file formats save the complete reference point list information such that it can be loaded again in the 
future. MapInfo TAB files support storing coordinate system information.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area 
Azimuthal Equidistant 
Cylindrical Equal Area*
Eckert IV*
Eckert VI*
Equidistant Conic*
Gall Stereographic*

Hotine Oblique Mercator
Lambert Azimuthal Equal Area*
Lambert Conic Conformal
Mercator*
Miller Cylindrical*
Mollweide*
New Zealand Map Grid

Hotine Oblique Mercator 1pt
Polyconic 
Robinson*
Sinusoidal*
Swiss Oblique Mercator
Stereographic Transverse Mercator

* Coordinate Systems using this projection will not be stored when saving the reference file. 

Blue Marble Reference File (rsf)
The Blue Marble Reference Settings File saves the complete reference point list information such that it can be 
loaded again in the future. Within a Blue Marble Reference File, the first line contains the version of the file format 
(not to be confused with the version of the software) and the total number of points in the file. The remaining lines 
contain, in each line, the point ID, the x (row) pixel, the y (column) pixel, the z (elevation) value which is usually 0.00, 
followed by the ground coordinates expressed as Latitude or Northing (Y), Longitude or Easting (X) and Elevation 
(Z). The last value indicates whether the point described on that line is included in the solution, 0 = not included 
and 1 = included. Blue Marble Reference files support storing coordinate system information (all are supported).

ER Mapper File (ers)
The ER Mapper header file is an ASCII file describing the raster data in the data file. The entire header file holds 
information about the data source and is contained in the DatasetHeader block. There are two compulsory 
sub-blocks, the CoordinateSpace block (to define the coordinate space and location) and the RasterInfo block (to 
define the characteristics of the data in the accompanying data file). The RasterInfo block my contain a number of 
optional sub-blocks. To completely define coordinate information in an ER Mapper header file you need to include 
the following data: datum, projection, coordinate type, units, X and Y dimensions for cell size, registration cell X and 
Y values, registration cell coordinates, and possibly null cell value. Coordinate information is frequently, but not 
always, given for the upper left corner of an image. This would be registration cell X and Y values of 0.0 and 0.0. 
For most projections registration coordinates are entered as eastings and northings, the coordinate type will be 
"EN", and units will be meters (or occasionally feet). If you are using latitude and longitude the projection is Geodetic, 
coordinate type will be "LL", and the X and Y dimensions for the cell size will be in decimal degrees.

ER Mapper files support storing a limited number of pre-defined coordinate systems. Check the coordinate system 
details to ensure the ER Mapper identifier exists as the issuer for the coordinate system to be saved. The file will still 
be exported however the coordinate system will not be saved with the reference file.

Note:	 ER Mapper reference files do not support rotated images. When attempting to export a reference file with a 
rotated image ER Mapper will not be listed.
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ListGeo file (lgo)
A ListGeo files are text files containing the GeoTIFF metadata information (or tags), which can then be read, and 
may also be used as input to other programs.

GeoTIFF File (tif, tiff)
Tagged Image File Format (TIF or TIFF) is a common raster graphic file format and one of the most common 
geospatial image formats you are likely to come across. Many raster geographic images from GIS systems are stored 
in this format. A GeoTIFF is a TIFF file with embedded geographic information such as position and scale in world 
coordinates, coordinate system or an explicit list of ground control points.

Note:	 The only way to differentiate a regular TIFF image from a referenced GeoTIFF image is to open it in a spatial 
imaging software application (such as Avenza Geographic Imager).

Unlike the other geographically referenced image formats discussed in this section, GeoTIFFs do not require a 
separate reference file. When registering a GeoTIFF image in MAPublisher, the same file name must be selected in the 
Load File dialog box—the required georeference information is contained in the file header.

Supported projections when saving the coordinate system are listed below:

Albers Equal-Area 
Cassini-Soldner - Cassini
Cylindrical Equal Area
Equidistant Conic
Equidistant Cylindrical
Equirectangular
Gnomonic
Hotine Oblique Mercator
Laborde Oblique Mercator

Lambert Azimuthal Equal Area
Lambert Conic Conformal (1SP)
Lambert Conic Conformal (2SP)
Lambert Cylindrical Equal Area
Mercator
Miller Cylindrical
New Zealand Map Grid
Oblique Mercator 
Oblique Stereographic 
Orthographic

Polar Stereographic
Polyconic
Robinson
Sinusoidal 
Stereographic
Transverse Mercator
Transverse Mercator (South Oriented)
VanDerGrinten
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Georeference type - Select the output 
format for the georeferencing 

information for the selected image

Export Image 
MAP Views panel options menu > Export Image

FUNCTIONALITY

MAPublisher has the ability to export placed raster files as georeferenced images for use in other programs 	
or for archival purposes. This can be useful in a number of ways. For example, when working with an image for 
which there is no georeferencing file, use the MAPublisher Export Image function to create a georeferenced image 
file based on the coordinate system of the MAP View. If the MAP View contains georeferencing information, Export 
Image can be used to save a raster layer to a georeferenced image format. It is also possible to convert the vector 
artwork to a georeferenced raster image. MAPublisher can export selected images as TIFF, PNG or JPG with a choice 
of the reference file formats or as a GeoTIFF (see the previous page).

USING EXPORT IMAGE

With an image selected, go to the MAP Views panel options menu > Export Image.

In the Export Image dialog box, the Georeference type drop-down list has seven available reference file formats: World 
File (TFW), Image Report file (IRP), MapInfo TAB file (TAB), Blue Marble Reference file (RSF), ER Mapper file (ERS), ListGeo file (LGO) and 
GeoTIFF. When exporting to a TIFF, PNG or JPG file, any of reference type can be used. When exporting to a GeoTIFF, 
only a single file is produced since both the image and the georeference information are included.

By default, the JPEG image quality setting is 75, the PNG compression level setting is 6, and TIFF has no 
compression.

Note:	 Image MAP layers are not included when an entire MAP View is exported to a spatial format (e.g. shapefile).

RESULTS

When all of the export options have been set, click the Save As button. Specify a name for the TIF file and the folder 
location where it will be saved. The reference file will have the same file name as the TIF and will be saved to the 
same location.

This image file can be subsequently used in imagery applications, such as Avenza Geographic Imager for Adobe 
Photoshop, or in other Adobe Illustrator documents using MAPublisher.

Notes:	 Exporting a linked image in CMYK color mode or an embedded image with an existing transparency may 
create incorrect color results. For the former situation, an image must either be set to a different color mode or 
embedded. For the latter, the transparency must be removed from the source file.

If a MAP View is rotated, the exported image will not store any rotation parameter (it will be automatically 
rectified—oriented north up).

Save As - Choose a destination name 
and directory for the exported image

Format - Choose from TIFF, PNG or 
JPEG as the export format
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MAPublisher contains tools to easily create map grids and 
map indexes. Grids can be created for reference purposes, 
or to follow designated lines such as latitude and longitude 
(graticule), with optional labeling (cells or axis).

A grid or a graticule can be used as a base to generate 
index files. MAPublisher outputs a text file containing grid 
indexes of text or map object locations that can contain map 
attribute information.

Topics covered in this section:
Grid and Graticules
Make Index

Grids and 
Indexes
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Grids & Graticules 
Object > MAPublisher > Grids & Graticules or MAP Toolbar  

FUNCTIONALITY

The Grids & Graticules tool generates a grid or graticule based on a coordinate system (either of the current MAP View 
or a chosen one). Each type of grid or graticule has numerous options for customizing grid lines, line labels, and cell 
references. Three types of grids and graticules are available:

Index Grid Divide the map into a grid of a specified number of rows and columns.

Graticules Draw lines of latitude and longitude of a specified interval aligned over a 
specified location.

Measured Grid Lay out a series of grid squares of a specified linear unit size, aligned over a 
specified location.

Once a grid or graticule is created, it can be resized dynamically using the corners of its bounding box anchors. To 
edit it, select it and click the Grids and Graticules button on the MAPublisher Toolbar.

PREREQUISITES

Grids and graticules must be created on a MAP Legend layer. A new legend layer will be created automatically if one 
is not present in the document. In the case that there are multiple legend layers in a MAP View (and neither are 
selected), you will be prompted to choose one.

By default, Grids & Graticules uses Arial 12 pt black or the Normal Character Style as the style for line labels. Custom 
character styles should be created (Window > Type > Character Styles) before using Grids & Graticules. Alternatively, 
use the Custom mode to change text appearances directly in the dialog box.

By default, Grids & Graticules uses a default grid line style (black, 1 pt stroke width). Custom graphic styles should 
be created before (Window > Graphic Styles) before using Grids & Graticules. Alternatively, use the Custom mode to 
choose the style options directly in the dialog box.

The MAP View must have a coordinate system assigned in order to plot a grid. Graticules and Index Grids can be 
generated for any coordinate system. Measured Grids cannot be generated for geodetic coordinate systems.
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USING GRIDS AND GRATICULES

Click the Grids & Graticules button on the MAPublisher Toolbar  or from the main menu Object > MAPublisher >  
Grids & Graticules.

In the Grids & Graticules dialog box, the left hand panel lists the grid collection (grids and graticules created for a 
single object). Multiple grids can be created and edited in one collection. Three types of grids are available: an index 
grid, a graticule, and a measured grid (if the coordinate system is not geodetic). An option to load grid settings from 
an existing configuration file is available. When a grid or graticule is added or chosen, options will appear to the 
right of the list. Grid line, line label, and cell reference options will differ depending on the grid or graticule chosen.

Grid Collection  
Collection of grids and 

graticules for one Grids & 
Graticules object. Use the 
top buttons to add, copy, 

and remove grids. Use the 
up and down arrows to 

change the object draw 
order. Double-click grid 

name to rename it.

Create Grid - Click Add 
button and choose 
a grid type to create. 
When no grids have 
been created, this is 
shown in the main 
Grids & Graticules 
dialog box.

Load From File - Load a saved grid 
from a configuration file

To save a grid (or a collection of grids) to configuration files, click the Save 
Settings button, then choose a folder to store the grids.

Two configuration files are created per grid: grid settings and label settings. 
Grid settings configuration files store information for all related grid options 
(e.g. ticks, intervals, offsets, borders). Label settings configuration files store 
information for all related label options (e.g. axis labels, fonts, styles), even 
for multiple grids. Label settings are saved with a _labelData suffix. The 
*_labelData.cfg file should not be renamed.

When loading settings from a file, choosing the grid setting configuration file will automatically load the label 
setting configuration file with the same name. If only the label setting configuration file is chosen, you will be 
prompted to choose the accompanying grid  

Note:	 Graphic styles, character styles, fonts, and swatches that are used on one system may not be available on 
another system. A warning message will appear in the event that any of these are missing.
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Index Grid
The Index Grid is a grid that is based on a specified number of columns/rows or cell size in page units. By default, the page 
units are specified in MAPublisher Preferences (see chapter 1). The By cell size in page units option may result in 
partial cells being created. When this option is chosen, the Partial cells get labeled option is enabled (in order to 
include them in the indexing process) in Cell References. The Minimum size of cells setting is used to set the minimum 
size of the partial cells to be labeled—cells that are smaller than this minimum will not get labeled and will not be 
used for indexing. 

By default, a grid is created for the entire extent of the MAP View. To limit the grid to only a certain extent, click 
the Set Bounds button to define grid bounds. Use artboard corners, coordinates, or MAP Locations to define grid 
boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

By number of columns/rows 
Select this option to create a 
grid with the specified number 
of rows and columns

By cell size in page units  
Select this option to specify 
the cell size in page unit 
(as specified in the Adobe 
Illustrator Document Setup)

Specify Grid Bounds - Specify 
coordinates for the grid 
bounds. Click the MAP 
Locations button to use 
defined page or world 
positions or artboard corners.
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Grid Lines

Cell References

Line Labels

Grid Border

Label placement control - Click the labels to 
toggle between X, Y, Both, or Disabled

Cell Reference Labels - Click the border and center 
labels to toggle between enabled and disabled

Draw Grid Lines - Enabled by default. Draw 
solid lines or intercepts (where grid lines 

intersect). Click the style link (shows 
stroke) to edit line appearance.

Draw Border - Enabled by default. Draws 
a solid border. Optionally, choose to 

increase offset from grid cells. Click the 
style link to edit line appearance.

Draw Border Intervals - Draws border 
intervals around the grid bounds. Use 
the Minor and Major Intervals settings 

to set a size (height). The Subdivide 
Major Intervals option draws lines in the 

subdivision intervals and can be set to 
be drawn at even or odd intervals. Click 

the style link to edit line appearance.

Draw Ticks Along Border - Draws tick marks 
along the grid border. Choose to 

increase offset from center of tick and 
set orientation away/toward map face 

or prime meridian/equator. Click the 
style link to edit line appearance.

Coordinate Values Along Grid/Graticule Border 
Click the Easting and Northing style link 

to edit label appearance

Corner Labels - Click the style links to edit 
the appearance, offset, rotation, and 

format of corner labels

Alpha/Numeric on left/right, top/bottom 
Choose to swap the alpha and numeric 

along the left/right and the top/bottom

Advanced - Custom start alpha and 
numeric characters, reference separator,  

and reference label order

Row/Column order - Chose descending or 
ascending row/column label order 

Label Orientation - Settings that affect all, 
east/west, north/south, or individual 

labels. The West/East/North/South 
settings are enabled based on 

drop-down option. Click the style link to 
edit its appearance.

Remove overlapping labels  
Remove overlapping labels from other 
grids listed lower in the Grid Collection

Border between Major 
and minor interval border

Miter corner

Border

Subdivide major 
intervals (top)
(odd interval)

Subdivide major 
intervals (left)
(odd interval)

Minor intervals

Ticks along border

Tick offset 

Intercepts

Place labels off cell by - Select a label offset 
from the grid bounds

Border style - Affects border reference 
labels. Click style link to edit appearance

Center style - Affects center cell labels.
Click link to edit text appearance

X (Easting)

Corner label

Y (Northing)

North label

West label

Format
(decimal places)

Offset

Corner labels 90° rotation

Center label

Border label

Row order
(ascending)

Column order
(descending)

Offset

Border Intervals
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Graticules
The Graticules option places grid lines at specific intervals of latitude and longitude (in degrees). Specify the interval 
for lines of latitude and longitude and, as required, a latitude and longitude value to pass through (in degrees). Use 
the vertices slider to increase or decrease the number of vertices used in the graticules (use a higher number if the 
graticules are highly curved due to the current projection). Grid bounds limit the extent of the grid. Use artboard 
corners, coordinates, or MAP Locations to define grid boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references.

Latitude interval - Specify the interval 
for each line of latitude

Longitude interval - Specify the 
interval for each line of longitude 

Pass through longitude - The line of 
longitude that must be included 
(any meridian). Must be in decimal 
degrees.
Pass through latitude - The line of 
latitude that must be included (any 
great circle). Must be in decimal 
degrees.

Vertices - Use the slider 
to increase or decrease 

the number of nodes to 
create the graticule line 

(use more for curved)

Specify Grid Bounds - Specify 
coordinates for the grid bounds.

Specify Graticule Constraints -Specify 
coordinates to constrain the 
graticule. Use MAP Locations for 
defined page or world positions or 
artboard corners.

Draw Grid Lines - Enabled by default. Draw 
solid lines or intercepts (where grid lines 

intersect). Click the style link (shows 
stroke) to edit line appearance.

Show Ticks Along Grid Lines - Draw tick 
marks along grid lines. Choose to 

place ticks at specific intervals, specific 
pass through, tick length, offset and 
orientation. Enable Tick follows line 

direction to allow ticks to have the same 
angle as grid lines where it meets at 
the border. Enable the Use grid style 

option and click the style link to edit line 
appearance (shows stroke).

Grid Lines

Solid grid lines

Tick marks  
(Away from prime 

meridian and equator)
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Grid Border

Border Intervals

Line Labels

Cell References

Draw Border - Enabled by default. Draws 
a solid border. Optionally, choose to 

increase offset from grid cells. Click the 
style link to edit line appearance.

Draw Border Intervals - Draws border  
intervals around the grid bounds. Use 
the Minor and Major Intervals settings 

to set a size (length), pass through, and 
division size (height).

The Subdivide Major Intervals  option 
draws lines in the major intervals and 

can be set to be drawn at even or odd 
intervals. Click the style link to edit line 

appearance.

Draw Ticks Along Border - Draws tick marks 
along the grid border. Choose to 

increase offset from center of tick and 
set orientation away/toward map face 

or central meridian/equator. Tick follows 
line direction angles ticks at border. Click 

the style link to edit line appearance.

Remove overlapping labels 
Remove any labels that overlap the 

labels set here

Coordinate Values Along Grid/Graticule Border 
Click the Longitude and Latitude style 

links to edit label appearance

Label Orientation - Settings that affect all, 
east/west, north/south, or individual 

labels. The West/East/North/South 
settings are enabled based on 

drop-down option. Click the style link to 
edit its appearance.

Corner Labels - Click the style links to edit 
the appearance of corner labels

Line Tick Labels - These settings only 
enabled when "Show ticks along option 

grid lines" is checked in Grid Line 
Options section. Click the style links to 
edit the appearance of line tick labels.

Place labels off cell by - Select a label offset 
from the grid bounds

Border style - Affects border reference 
labels. Click style link to edit appearance

Center style - Affects center cell labels.
Click link to edit text appearance

Alpha/Numeric on left/right, top/bottom 
Choose to swap the alpha and numeric 

axis labels along the left/right and the 
top/bottom

Advanced - Custom start alpha and 
numeric characters, reference separator,  

and reference label order

Don't label - Click check boxes to not label 
first/last row or column

Ticks along border

Tick offset 

Label placement control  - Click the labels to 
toggle between Lng, Lat, Both, or Disabled.

Corner label
Longitude

Latitude
Tick label

West label

Line tick label

Corner labels
North label

Offset
90° rotation

Minor interval division size
Major interval division size

Miter corner

Border

Minor interval size

Major interval size

Subdivide major 
intervals (top)
(odd interval)

Subdivide major 
intervals (left)
(odd interval)

Center label

Border label

Row order
(ascending)

Column order
(ascending)

Offset
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Measured Grids
The Measured Grid option creates a grid based on a grid cell size specified in map units, when the current MAP View 
is in a projected coordinate system. The cell size is specified in the Width and Height boxes (the map units can be 
specified in the Units drop-down list). Measured grids may contain partial cells. The pass through can be specified 
by entering an X, Y position (Grid passes through point) or choosing an alignment position relative to the page extent 
(Preset origin). Grid bounds limit the extent of the grid. Use artboard corners, coordinates, or MAP Locations to define 
grid boundaries.

See the following pages for detail on how to adjust and style grid lines, grid border, line labels and cell references. 

Cell Size - Specify the width and 
height of each cell in the grid. The 
Units drop-down provides many 
units of measurements to use.

Grid passes through point  
Choose this option to 

specify coordinates for the 
X and Y pass through

Preset origin - Choose a 
position for the X and 

Y origin
Coordinate System  

The coordinate system of 
the grid. Use the current 

MAP View or an alternative 
coordinate system. Chosen 

coordinate system is 
reflected in the grids list.

Specify Grid Bounds - Specify 
coordinates for the grid 
bounds. Click the MAP 
Locations button to use 
defined page or world 
positions or artboard corners.

Draw Grid Lines - Enabled by default. Draw 
solid lines or intercepts (where grid lines 

intersect). Click the style link (shows 
stroke) to edit line appearance.

Show Ticks Along Grid Lines - Draw tick 
marks along grid lines. Choose to place 

ticks at specific intervals, specify a 
pass through, tick length, offset and 
orientation. Enable Tick follows line 

direction to allow ticks to have the same 
angle as grid lines where it meets at 
the border. Enable the Use grid style 

option and click the style link to edit line 
appearance (shows stroke).

Grid Lines

Solid grid lines

Tick marks  
(Away from prime 

meridian and equator)
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Grid Border

Border Interval

Draw Border - Enabled by default. Draws 
a solid border. Optionally, choose to 

increase offset from grid cells. Click the 
style link to edit line appearance.

Draw Border Intervals - Draws border  
intervals around the grid bounds. Use 
the Minor and Major Intervals settings 

to set a size (length), pass through, and 
division size (height).

The Subdivide Major Intervals  option 
draws lines in the major intervals and 

can be set to be drawn at even or odd 
intervals. Click the style link to edit line 

appearance.

Draw Ticks Along Border - Draws tick marks 
along the grid border. Choose to 

increase offset from center of tick and 
set orientation away/toward map face 
or central meridian/equator. Click the 

style link to edit line appearance.

Ticks along border

Tick offset 

Minor interval division size
Major interval division size

Miter corner

Border

Minor interval size

Major interval size

Subdivide major 
intervals (top)
(odd interval)

Subdivide major 
intervals (left)
(odd interval)

Line Labels

Remove overlapping labels 
Remove any labels that overlap the 

labels set here

Coordinate Values Along Grid/Graticule Border 
Click the Easting and Northing style link 

to edit label appearance

Label Orientation - Settings that affect all, 
east/west, north/south, or individual 

labels. The East/West/North/South 
settings are enabled based on 

drop-down option. Click the style links 
to edit its appearance and formatting.

Corner Labels - Click the style links to edit 
the appearance of corner labels

Line Tick Labels - These settings only 
enabled when "Show ticks along option 

grid lines" is checked in Grid Line 
Options section. Click the style links to 
edit the appearance of line tick labels.

Label placement control - Click the labels to 
toggle between X, Y, Both, or Disabled.

Corner label

X (Easting)

Y (Northing)
Tick label

West label

Line tick label

Corner labels

North label, format: 
Full value with units 
and Direction

Offset
90° rotation

Cell References
Place labels off cell by - Select a label offset 

from the grid bounds

Center Style - Click the style link to edit the 
text appearance

Axes Style - Click the style link to edit the 
text appearance

Alpha/Numeric on left/right, top/bottom 
Choose to swap the alpha and numeric 

axis labels along the left/right and the 
top/bottom

Advanced - Custom start alpha and 
numeric characters, reference separator,  
and reference label order

Center label

Border label

Row order
(ascending)

Column order
(ascending)

Offset

Label partial cells if cell size is larger than  
the minimum size of partial cells before 

being labeled
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Grid Line and Border Styles
Click the grid line and grid border style links to open the Edit Appearance dialog box. The are two modes to edit the 
appearance of grid lines: Custom and Graphic Style.

Custom mode

Graphic Style mode

Stroke - Choose a colour from the 
drop-down list. Alternatively, click the 

colour chip to pick a custom colour.

Stroke Opacity - Set the transparency of 
the stroke or fill. 100% is solid.

Stroke Weight - Set the stroke width of 
the grid/border line. 1.00 pt is default.

Style - Choose a graphic style from the 
Graphic Style panel.

Switch Mode - Click to switch to 
Graphic Style mode

Switch Mode - Click to switch to 
Custom mode

Line Labeling
The Coordinate Values along Grid/Graticule Border options affect the coordinate labels of the grids and graticules (X,Y 
for indexed and measured grids; Lat, Lng for graticules). In the label placement control, click a label indicator to 
change its status: disabled, X, Y or X&Y for grids; disabled, Lat, Lng, Both for graticules. When the mouse hovers over label 
indicators or label options, green highlight appears to indicate its relation.

Click the label style links to open the Edit Text Appearance dialog box. The are two modes to edit the appearance 
of grid labels: Custom and Character Style. Character styles must be defined in the Adobe Illustrator Character Style 
panel before use in this dialog box.

Stroke/Fill - Choose a colour from the 
drop-down lists. Alternatively, click the 

colour chip to pick a custom colour.

Font - Set the font family, font style, and 
font size with these settings.

Toggle Mode - Click to switch to 
Character Style mode

Graphic Style - Choose a graphic style 
from the Graphic Style panel.

Click label orientation links to open the Label Orientation dialog box. Label offset and orientation can affect all 
borders at the same time, left-right/bottom-top, or individually (west, east, north, south).

Offset from border or line - Specify 
an offset to place labels further 

away from the border or line

Rotation - Choose from  
No rotation, 90° counter-clockwise, 
90° clockwise, and 180°
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Click the Format links to open the Label Format dialog box (applies to Index and Measured grids).
Label Format - Available UTM format styles or 

choose No UTM Format:

Label values / Append units to labels - Include 
unit to labels. Only for Index grids.

Apply locale formatting 
to numbers - Apply 
number formatting 
according to the locale 
settings in MAPublisher 
Preferences. Only for 
Index grids.

For a graticule, only these label formats apply:

Label Format - Choose a label 
format style. The drop-down 

list includes Degrees Minutes 
Seconds format variations.

Cell Reference Labeling
The Cell References options affect the indexing labels of grids and graticules. In the label placement control, click a 
label indicator to change its status: border labels (A, B or 1, 2) and center labels (A1, A2, B1, or B2). When the mouse 
hovers over label indicators or label options, green highlight appears to indicate its relation. To swap the border 
alpha and numeric border label positions, choose either Alpha on left/right, numeric on top/bottom or Numeric on left/right, 
alpha on top/bottom. The Row order and Column order settings set the border labels in ascending or descending order. The 
position is relative from the top-left corner of the grid. Specify the border label distance from the grid border using 
the Place Labels off cell by setting—a negative value places labels inside the grid. Click the Center style and Border style 
links to edit text appearance.

Advanced Cell Reference Labeling
Click the Advanced button to access additional grid extents and labeling options.

To edit the first alpha or numeric value used for cell labels, change the Start alpha 
index at or Start numeric index at values. To omit certain alpha characters from cell 
references, enter them into the Do not use characters box. For example, it may be 
useful to omit the characters “I” and “O” for indexing purposes (when entering 
alpha characters to omit, separate characters with a comma). Enter a character 
into the Reference separator box. For example, a ~ separator will yield a label like so: 
A~1. The Reference label order can be set to either alpha-numeric (A1) or numeric-
alpha (1A).
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Generating and Editing the Grid
When all the options have been set, click the Preview button to display a preview of the result. The 
Grids and Graticules dialog box can be minimized in the preview mode by clicking Hide In Preview.

Click OK to create the grid or click Restore to return to setting up the parameters. The grid is plotted 
on the legend layer using the entered parameters. 

When the grid is added to the artboard, use the bounding box of the generated grid (View > Show Bounding Box) to 
resize it. Resizing grids horizontally or vertically will add, remove or resize (index grid) component cells in the grid.  
All grids within a grid collection will be affected. Note that grids with specified bounds cannot be resized this way.

After transforming a MAP View containing a grid, the grid will be transformed and scaled within its current bounds 
(the physical extents of the grid on the page is not edited). The grid may have to be resized manually.

To change any parameter without generating a new grid, simply select the grid and click the Grids & Graticules 
button from the MAPublisher toolbar. This opens the Grids and Graticules dialog box populated with the current 
parameters of the grid. All parameters can be edited, even the grid type selection. 

IMPORTANT NOTES

Manually editing grid text positions, fonts, and colours is not possible in its default custom art state. To manually 
edit a grid, it will need to be expanded (Object > Expand). However, this will prevent any opportunity to further edit 
the grid using the Grids & Graticules dialog box. When expanded, grids cells are converted to both polygons (from 
index) and lines.

Please see Appendix A3 for more information on working with grids and graticules in MAPublisher.
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Make Index 
Object > MAPublisher > Make Index or MAP Toolbar  

Sort by - Choose to sort the 
entries in the index file by 
either Feature label or Grid 

cell address

Click a button to open the 
Edit Separator dialog box. 
Choose between Tab, None 
or a Custom separator.

Make index based on label position - An index 
will be created by assigning one index 

location for each label found on the 
selected label text layer

Make index based on label and matching 
feature position - MAPublisher will 

determine what features to index by 
matching label text on the indicated 
Label layer to the indicated attribute 
on the Feature layer. An index will be 

created for every grid cell in which the 
labeled feature can be found.

Advanced - Click this button to open 
the Advanced Options dialog box 
(below) to specify additional options 
for the index format

Advanced Options

Output Format
Single-line condensed  

Creates one index entry 
for each unique label. The 

index is compressed in the 
format: A1-3;B2,4

Single-line expanded  
Creates one index entry 

for each unique label. The 
index is in the format:  

A1,A2,A3,B2,B3

Multiline  
Creates one index per 

label recurrence

Select Additional Attributes 
Select one or more 
attributes to be added 
to the index file. The 
selected attributes appear 
in separated columns 
delimited by the chosen 
Index Separator.

Specify Bounding Attributes - Select 
one or more attributes from the 
bounding art to be included in 
the index

Make index based on feature position and 
attribute value - An index location is 

added for each feature found on the 
selected label Feature layer. The index 
label will be the value of the selected 

Attribute for each feature.

Specify Index Separator  
Select a delimiter to separate the 
different elements of the index file: 
label, attribute, grid column, grid 
row, continuous spanning, discreet 
spanning and next in the list. Choices 
are reflected in Sample Indexes.

Apply locale formatting 
to numbers - Choose to 
apply locale formatting 
(e.g. decimal separator 
as dot or comma), see 
MAPublisher Preferences. 

Treat grouped text as single entry 
Select this option to create a 

single index for grouped text 

By art on layer - Select a layer and 
corresponding attributes to filter by

Current Grid:  - Select from available grids 
or MAP Area layers to make index from

Using MAP Selection - Select a saved 
MAP Selection to filter by

Spatially filter the source art 
Check this checkbox to limit 
index to labels or art intersecting 
chosen bounding geometry
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FUNCTIONALITY
The Make Index feature can be used to generate a map index based on the position of text elements or map features 
in a grid (index or measured), a graticule or a MAP Area Layer. Index files generated using this function are produced 
as a simple text file and sorted alphabetically (by label or cell reference). A typical file would be formatted as follows:

		  Millwood Road	 B4
		  University Street	 A4
		  Broadway Ave	 B5

For text elements, the position of the first letter of the text is indexed. For map features of type Line or Area, all cells 
intersecting the feature are index. For map feature of type Point, the center of the symbol is indexed.

The index file contains a header indicating the name of each column (name, attribute name [if applicable], and grid 
locations).

PREREQUISITES
To create a map index, an Index grid, Measured grid, Graticule or MAP Area layer can be used. This grid must exist on 
a Legend layer and not be expanded (by Adobe Illustrator). An index will be created even if grid labels are hidden.

The Text layer containing the labels to be indexed and/or the Feature layer must be located in the same MAP View as 
the grid.

USING MAKE INDEX

Click the Make Index button on the MAPublisher Toolbar or from the main menu Object > MAPublisher > Make Index.
•	 The selected grid will be used as the index reference.
•	 When no grid is selected, Make Index will detect a grid in the document. If more than one grid is 

found, the Select Index Grid dialog box opens. Click the Previous Grid or Next Grid buttons to browse through 
available grids in the document. The selected grid is highlighted on the artboard.

•	 Alternatively, Use area layer as grid (choose appropriate area layer and grid label attribute). This layer can 
be of irregular shape (non-rectangular).
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Index Based on Label Position
Select the Make index based on label position button to generate an index using this method. Then choose one or 
more layers containing the text to be indexed from the Label layer drop-down list. This method creates an index by 
assigning one index location for each label found on the selected text layer. For example, if the label "High Street" is 
only found in grid cell A4, the only entry for "High Street" in the index file would be as follows:  High Street A4

Index Based on Label and Matching Feature Position
This method creates an index by matching label text on a selected Label Layer to the indicated attribute on the 
Feature layer, creating an index entry for every grid cell in which the feature can be found. Note that only features 
that have labels will be indexed. For example if "High Street" passes through grid cells A3, B3 and C4, each grid cell 
will be in the index — on a single or multiline (see advanced options). For example as:  High Street A3, B3, C4

Use this function as follows:
•	 Select the Make index based on label and matching feature position option to generate an index using this method.
•	 Choose the layer containing the text to be indexed from the Label layer drop-down list.
•	 Choose the layer that was used to generate the labels from the Feature layer drop-down list. 
•	 In the Label text matches attribute list, select the attribute column in the selected Feature layer which matches 

the labels to be indexed.

Index Based on Feature Position and Attribute Value
This method creates indexes for map features that have not been labeled. 

The map features to be indexed are contained in the selected feature layer. Any MAP Layer of type Point, Line or Area 
contained in the same MAP View as the grid can be selected. 

The index position is based on each feature on the grid — for Area and Line layers all cells that intersect with the 
feature are indexed; for Point layers the cells that contain the center of the feature symbol are indexed. 

The actual index label listed in the output index file corresponds to the value of the selected Attribute.

Spatially Filter the Source Art	
This option affects the range of feature labels, feature labels and art, or pieces of art selected to be indexed.

Choose the By art on layer option to limit index creation to those entries that intersect the bounds of the art on the 
specified layer.

Choose the Using MAP Selection option to limit index creation to those entries that intersect the bounds of the art 
selection resulting from the application of the chosen pre-defined MAP Selection.

Click the Specify Bounding Attributes button to open the Specify Attributes dialog box. Use this dialog box to select 
multiple attributes from the bounding art to be included in the index.
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Advanced Formatting Options
To set additional options to control the formatting of the index file, click the Advanced button.

The Sort index by option controls the order of the index entries. The default setting is Feature label — entries  are 
ordered based on the label text (alphabetical). Alternatively, Grid cell can be selected to sort by the cell indexes.

The Specify Index Separator indicates which delimiter is used to separate the different columns in the index file (label, 
additional attributes and indexes). To change a specific delimiter, click the separator button in between the two 
desired elements. The separator options are Tab, None, or a Custom delimiter. When using a custom delimiter, type the 
desired character(s) in the adjacent text field. The separator settings are reflected in the Sample Indexes section.

The Treat group text as single entry option is required to create a single index for grouped text. Enabling this option is 
recommended to create index for labels created with MAPublisher Label Pro because the generated text is often 
grouped (e.g. multiline labels or along a curve).

There are three output formats for indexes (examples are using the default separators):

Output format Description Example Notes

Single-line condensed One index for 
each unique 
label is created, 
condenses grid 
locations

Label A1-3; 
B2,4; F-H9

•	 A dash (-) indicates a range: A1-3 means the label 
is found in cells A1, A2 and A3; F-H9 means the 
label is found in cells F9, G9 and H9. The ranges 
by number are grouped first and then the 
ranges by letter.

•	 A comma (,) indicates a list: B2,4 means the label 
is found in cells B2 and B4 but not B3.

•	 A semicolon (;) separates each entry.

Single-line expanded One index for 
each unique 
label is created

Label A1, 
A2, A3, B2, 
B4, F9, G9, 
H9

•	 A comma (,) separates each entry.

Multiline One index 
for each cell 
reference is 
created

Label A1
Label A2
Label A3

•	 Each entry is on its own line

			 
Users can add more attributes to the index file by selecting one or more attributes from the Select addition attributes 
drop-down list. Additional attributes are inserted in the file in columns between the label and the grid locations, 
separated by the chosen Index Separators. For example:

			   Label	 Attribute1	 Attribute 2	 A1-3;B2,4;F-H9 

Note:	 Duplicated labels that have different selected attribute values, will have a separate entry in the index file 
(single-line options). Duplicated labels that share the same attribute values will have a single index entry but 
each location will be reflected in the cell references.



255Chapter 13: Grids and Indexes
Make Index 

The Apply locale formatting to numbers option applies number formatting according to the locale settings in the 
MAPublisher General  Preferences (e.g. 10000 may be written 10,000 or 10.000 or 10 000).

Saving the Index File
When all indexed options have been set, click the Save As button. Then specify a name for the text file, and the 
location where it will be saved. The index file can be opened in a text editor, or placed back into the document 
using the Adobe Illustrator Place function.
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Scale Bars and 
North Arrows

MAPublisher contains tools for plotting accurate scale bars 
and north arrows onto your map. 

The Scale Bar tool offers a number of different designs that 
you can choose from, including double-bar designs for the 
placement of scale bars in multiple units. 

North Arrows are created from selected artwork on the page 
using the Create North Arrow tool and are immediately aligned 
to true north.

Topics covered in this section:
Scale Bar
Create North Arrow
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Scale Bar 
Object > MAPublisher > Scale Bar or MAP Toolbar  

Object > Edit Scale Bar

Interval Options:

Labeled intervals - Enter the 
number of interval which will 
comprise each bar.

Horizontal lines - Select the desired 
number of horizontal lines to be 
included in the scale bar. Used 
with certain scale bar styles only.

Intervals to subdivide - Enter the 
number of scale bar intervals to 
be subdivided.

Sub intervals - Select the number 
of sub-intervals for each 
subdivided scale bar interval. 

Apply locale formatting to numbers 
Insert a comma (or another 
locale format) to the scale and 
ratio numbers.

Scale Appearance 
Set the scale label style in the 

Edit Text Rendition dialog box.
Scale Label and Ratio Label 
Set the scale or ratio label. Use 
the variables available below. A 
preview of the scale or ratio is 
shown below the text box.

Customize Labels 
Opens the Customize Labels dialog box. Use 
it to change the label of page and world units 
and adjust the appearance and variable of 
scale and ratio labels. See below.

Display page to map units ratio 
Check this option enable 

options to show the scale as 
page unit to map unit ratio 

(select from Inches, Centimeters 
and Millimeters), the  decimal 

precision and placement.

Preview Panel - Displays a preview 
of the generated scale bar.

Select Style - Click the up or down 
button to browse through the 

scale bar styles.

Units - Select the desired 
map units to be used in the 

selected scale bar.

Interval - Specify the length of 
each interval in the selected 

map unit.

Tick label spacing - Specify the  
spacing between the scale bar 

and scale bar label.

Maintain relative size - Check this 
option to convert the interval 

values when units are changed

Apply local - Use the locale 
format settings specified 
in the General section of 
MAPublisher Preferences

Add interval label left of '0' - 
Places an interval label left 
of the zero marker on the 
scale bar.

Labeling Options:
Tick label appearance - Select the 

Adobe Illustrator Character 
Style to be applied to the text

Display scale value - Check this 
option to enable options to 

position the scale value above 
or below the bar and left, 

center or right aligned.

Page unit and World units - Check 
these options to be able to 

specify custom labels. These 
override the unit labels specified 

in the Scale Bar dialog box.

Variables - Use these 
variables in the Scale and 

Ratio label text boxes.

Display units to right of last interval label 
Check this option to display the 

interval unit at the end of the last 
interval label.
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FUNCTIONALITY

MAPublisher contains ten different scale bar designs that may be incorporated into a map. After creation, 
MAPublisher scale bars can be subsequently resized using the bounding box (for example to add or remove 
component intervals). Scale bars can also be edited by selecting the Object > Edit Scale Bar menu item.

PREREQUISITES

To accurately create a scale bar, a MAP View must contain accurate georeferencing information and the coordinate 
system must be projected. (i.e. not in degrees). Scale bars are added on Legend layers. If no legend layer is present 
in the document, a new legend layer will be created automatically.  To manually create a new Legend layer, use the 
Add MAP Layer button on the MAP View panel and specify a feature type of Legend (see chapter 4 for more details).

If a custom character style is to be used for the labels of the Scale Bar, it is also advisable to establish this style 
(Window > Type > Character Styles) before opening this dialog box. Alternatively, use the Edit Text Rendition dialog 
box to specify the font, colour, size and style of text to use.

ADDING A SCALE BAR

Click the Scale Bar button on the MAPublisher toolbar or choose Object > MAPublisher > Scale Bar.

Standard Options

Use the Up and Down buttons to select a scale bar design. Note that some scale bar designs contain two bars and 
when such a design is selected, the Second Bar column of options is enabled.

In the Units drop-down list, specify the units for the scale bar intervals to be based on. The default units are that of 
the current MAP View.

In the Interval text box, specify a real-world distance that each interval of the scale bar will represent. This number 
will be in the unit specified in the Units list.

Note:	 A scale bar cannot be created on a MAP View that contains a coordinate system using custom (user defined) 
point styles or units.

Specify the number of cells in the scale bar by entering a number in the Number of labeled intervals scroll box. 

Depending on the chosen style of scale bar, it may be required to specify the Number of horizontal lines that will 
compose the scale bar.

To subdivide some of the intervals or cells in the scale bar, specify a number in the Number of intervals to subdivide scroll 
box. The subdivided cells begin at the left side of the scale bar. The Number of sub-intervals that compose each of these 
cells can be specified in the next scroll box. As required, choose to Add an interval left of zero.
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Labeling Options
Click the Tick label appearance to adjust the tick labels of a scale bar in the Edit Text Rendition dialog box. Choose a 
predefined Character Style in the Graphic Style mode or set font, stroke and fill options in the Custom mode.

In Graphic Style mode, labels can be styled using predefined Adobe Illustrator Character Styles. Graphic Styles can 
be applied to these labels by choosing one from the Graphic style drop-down list. In Custom mode, labels can be 
styled using the font, font size, stroke, stroke width and fill options available.

Graphic Style modeCustom mode

Adjust the Tick label spacing to increase or decrease spacing between the tick label and the scale bar.

The Display scale value option shows the scale value above and to the left of the scale bar (by default). The position 
and alignment can be changed using the respective drop-down lists. The Display page to map units ratio option adds the 
page unit to map unit ratio label (select from Inches, Centimeters and Millimeters). Use the decimal precision and 
placement options to adjust the appearance as necessary.
 
To further enhance the look of scale bar labels, click the Customize Labels button. Under the Label Unit Overrides 
section, check the options to override the Page unit and World unit labels and type text into the text boxes. Under 
the Formatting section, click the Scale and Ratio appearance links to open the Edit Text Rendition dialog box (same 
as above) to adjust the font, color, size, stroke and fill of the scale and ratio labels. Type text into the Scale and Ratio 
label text boxes to specify custom labels along with using the available variables (e.g. %page_unit%). The variables 
represent stored values from the Scale Bar dialog box and the map document. A preview of the scale is shown 
below each of the text boxes.

Click OK to place the selected scale bar on the legend layer at a default position (centered on the artboard).
The Adobe Illustrator editing tools may be used to move the scale bar to a desirable location.
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EDIT A SCALE BAR

Use the bounding box of the generated scale bar (View > Show Bounding Box) to resize. Resizing scale bars 
horizontally will add or remove intervals from it. Resizing vertically will adjust the width of the bars.

Scale bars can also be resized using the Adobe Illustrator menu Object > Transform >Transform Each, by changing 
the horizontal or vertical scales. 

To change the design of the scale bar, or to modify any parameter without generating a new version, select the 
scale bar and access the Object > Edit Scale Bar menu item. This will re-open the Scale Bar dialog box and the current 
parameters of the bar are available for editing.

Note:	 Manually editing a scale bar is not possible in its default grouped state. However, manual editing is still 
possible if the object is expanded first (Object > Expand). Note, that this will break the dynamic link between 
MAPublisher and the scale bar and it cannot be edited through the Object > Edit Scale Bar menu item 
anymore. Please see Appendix A3 for more information on working with scale bars in MAPublisher.
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Create North Arrow 
Object > MAPublisher > Create North Arrow or MAP Toolbar  

FUNCTIONALITY

The Create North Arrow tool converts a selected symbol into a directional true north arrow.

In this process, the selected symbol is rotated toward true north at its location. This property is maintained through 
subsequent moves of the map, projection or rotation. 

The true north is the direction to the geographic North Pole — this direction may vary on a map depending on the 
selected MAP View coordinate system. To visualize this, think of the lines of latitude in a graticule (see chapter 13) — 
these lines can be straight or curved.

Note:	 True north usually differs from magnetic north (the direction of the magnetic north pole, which varies in time 
and space) and grid north (the direction northwards along the measured grid of a projected map).

PREREQUISITES

Any Adobe Illustrator symbol may be used to create a north arrow. The only requirement is that the symbol is placed 
on a Legend layer (within a MAP View) and must be selected. 

Note:	 Sample north arrow symbol designs are included with MAPublisher. In the Symbols panel options menu,  
choose Open Symbol Library > MAP Symbols > Other Symbols > North Arrows.

CREATING A NORTH ARROW

Select the symbol to be converted to a north arrow and click the North Arrow button on the MAPublisher toolbar. 
Alternatively, from the main menu Object > MAPublisher > Create North Arrow.

Upon creation, the selected symbol is aligned to true north, based on the coordinate system of the MAP View and 
its position on the map. If the north arrow symbol is repositioned on the map, it will be re-oriented to true north at 
the new location.

Note:	 If the selected art is not already a symbol, it needs to be converted to an Adobe Illustrator symbol. Simply 
add it to the Adobe Illustrator Symbols panel.
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Users should have a basic understanding of HTML and 
general web terminology to use this feature.

MAP Web Author creates interactive Flash and HTML5 web 
maps. Flash maps are supported when the Adobe Flash 
Player plug-in is installed. HTML5 is natively supported by 
many of the leading web browsers.

Export Adobe Illustrator documents with GIS attribute data to 
interactive web maps complete with callouts, rollovers, layer 
control, search, pan and zoom controls. Additionally, web 
map export offers controls for the layers visibility and map 
features (points, lines, and areas).

Users with a good understanding of HTML, CSS (Cascading 
Style Sheets) and JavaScript will be able to customize maps 
to embed into any webpage using the MAP Web Author API 
and CSS tools.

Topics covered in this section:
MAP Web Author Workflow
MAP Web Author Panel
Edit Web Tag
Export to Flash
Export to HTML5
Advanced Features

MAP Web 
Author
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MAP Web Author Overview

MAP Web Author creates interactive Flash or HTML5 maps for display in a web browser. Users can either create 
new or work with existing documents to create web maps. Create web tags (callout bubbles) to display attribute 
information about features. Although the web tag creation process may feel similar to both Flash and HTML5, each 
web map type has it's own unique differences.

Creating a Flash map requires the Adobe Flash Player plug-in. Exported maps are based on Flash technology and 
can only be viewed with web browsers that support the Adobe Flash Player. Mobile web browsers may not be able 
Flash compatible. Creating graphs and expressions in web tags are only available in Flash.

Creating an HTML5 map does not require any extra plug-ins. Most modern web browsers are natively compatible 
with HTML5, including mobile web browsers. A fundamental difference between HTML5 and Flash maps is the way 
HTML5 handles the artwork. Vectors are rendered as vectors, including symbols and other line work. Map tiles are 
created for the base layer. 

MAP WEB AUTHOR WORKFLOW

The following workflow outlines the major steps to create a web map.

1) Design map with considerations for a web map
Create a map document for viewing on the web while taking into consideration purpose, document size, and how it 
will be viewed (on desktop or mobile device). To create Flash maps, ensure the latest Flash Player version is installed. 

2) Preparing for MAP Web Author

a) Create a working directory and source media folder
Create a folder to store all the components for the web map and the exported Flash or HTML5 files. 

b) Prepare attribute table information
To use attribute information for web tags, it must be organized using the MAPublisher MAP Attributes panel. 
This may require creating new attribute columns for elements such as website links or graphic file paths.

c) Prepare data
Optimize the map by removing unused art. Use the crop tool, generalize features, simplify lines, and remove 
unneeded attributes.

3) Using MAP Web Author

a) Choose the source media folder
Choose an absolute or relative path to the Source Media Folder. It contains images used in web tags.

b) Create callout bubbles
Use the Edit Web Tag dialog box to insert content (such as a title, images and text) and use the Show Preview 
option to see an example of how the callout bubble will look prior to the export process.
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4) Export to Flash or Export to HTML5
Export the map to either Flash or HTML5. Each has its own unique settings. It is recommended to try different 
configurations to achieve optimal results as maps vary widely.

5) View exported maps with a web browser
Update to the latest version of Firefox, Internet Explorer, or Chrome web browser. HTML5 maps can be viewed in 
any of these web browsers and mobile browsers such as Mobile Safari. To view Flash maps, ensure the latest Flash 
Player version is installed. Flash maps may not be supported in mobile browsers.

WEB MAP EXAMPLES
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MAP Web Author Panel 
Window > MAPublisher > MAP Web Author or MAP Toolbar  

FUNCTIONALITY

MAP Web Author is used to export MAPublisher documents as interactive Flash or HTML5 maps for display in a web 
browser. Together with the map artwork, web tags (also known as callout bubbles) are included in the export. Prior 
to the export process, the MAP Web Author panel is used to create, edit or modify interactive objects.

Web tags can either be populated one object at a time or for a selection of objects. To create or edit multiple web 
tags, select artwork and click the Edit button. Using this method, the same web tag format is applied to all selected 
artwork. Information can be entered manually or extracted from MAP Attribute fields (when available for the object 
layer). At any time, web tags can be edited or modified.

Text and image formatting is created using simple HTML (Hyper Text Markup Language). The results can be checked 
in the Show Preview window available in the Edit Web Tag dialog box.

Additional settings such as customizing the navigation and callout bubbles are available during the export process.

Export to Flash or HTML5 - Open the 
Export to Flash or Export to HTML5 
dialog box to choose export settings

Edit - Open the Edit Web Tag dialog 
box. Create or modify web tags

Remove - Delete web tags of any 
selected objects

All Web Art - Select all artwork that have 
a web tag in the document

Specify Source Media Folder

Specify Source Media Folder - The local 
directory of media files

Browse - Browse to the directory 
containing the media files (images and 
Flash animations)

Absolute Path - Choose this option to 
set an absolute path (best used when 

working on a single computer)

Relative Path - Choose this option to set 
a path relative to the current location 

of the Adobe Illustrator document 
(best used when files have to be 

moved). Newly created documents must 
be saved for this option to be enabled.

Reset - clear the current Source Media 
Folder settings

MAP Web Author Panel

Web Art On Layer - Select all the artwork 
that have a tag in the currently 
selected layer
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PREREQUISITES

The Adobe Illustrator artboard will determine the size of the web map. It is recommended to set an appropriate 
document size before completing the map (using the Adobe Illustrator Artboard Tool). Using pixel units is the most 
practical to determine web map sizes suitable for a web browser.

To populate web tags, MAP layers must have relevant attributes populated in their MAP Attributes tables. For example, 
to insert links to graphics (images and Flash animations [Flash only]), the MAP layer can have a dedicated attribute 
field containing a path (e.g. \images\picture1.jpg). The Source Media Folder containing the graphics must be organized 
properly. The supported image formats are JPEG, PNG and GIF and supported Flash animation format is SWF.

Notes:	 Not just any map can be made into a web map. A print ready map does not necessarily mean that it is ready 
to be a webmap. Extra art and unused attributes should be removed and lines should be simplified. Layers 
that do not require tagging will still be exported. 

Only the active artboard will be exported as a web map.

MAPublisher exported Flash web maps require Flash Player to be installed. A link to download Flash plug-in 
appears if a browser does not have it. To ensure compatibility, download and install the latest Flash Player at 
http://get.adobe.com/flashplayer. HTML5 web maps do not require any plug-ins to be viewed, only an up-to-date 
web browser is required.

USING MAP WEB AUTHOR

Specify the Source Media Folder
The Source Media Folder is the directory containing graphics that might be displayed in the web tags (callout bubbles). 
The path to this directory is chosen through Specify Source Media Folder in the MAP Web Author panel options menu.

Either an Absolute Path or a Relative Path may be entered. An absolute path refers to the full folder directory path 
(e.g. C:\folder1\folder2...). A relative path refers to the folder path from the current location of the Adobe Illustrator 
document. In the example below, the relative path starts from \MAPWebAuthor_Tutorial.

Absolute Path example Relative Path example

If the Adobe Illustrator file is to be exchanged between computers, it is good practice to use a Relative Path to avoid 
having to reset the link to Source Media Folder when the files are moved.
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Add, Edit and Remove Web Tags
To add or edit a web tag, select a piece of artwork and click the Edit button in the MAP Web Author panel. In the 
Edit Web Tag dialog box, use the options to define web tag settings (see next section). When multiple artwork is 
selected, any settings made in the Edit Web Tag dialog box are applied for all of the selected artwork. They may be 
individually modified by scrolling through the web tags or at a later time by selecting the artwork and clicking the 
Edit button.

To remove web tags from selected artwork, click the Remove button in the MAP Web Author panel.

Notes:	 Document artwork (lines, areas, points) associated with callout bubbles are also called web art. Only web art 
will be searchable in a web map. Text cannot be tagged as web art. 
 
Grouped art will not display attributes.

Selection
Select artwork in the document and the MAP Web Author panel displays if it is web art. To only select all artwork 
with web tags, click the All Web Art button. To select all artwork with web tags on a specific layer, select the layer in 
the Adobe Illustrator Layers panel, and click the Web Art On Layer button.

Export
A map can be exported in two formats: Flash and HTML5. In the MAP Web Author panel Export section, click either 
the Flash button or the HTML5 button to begin the export process (opens the Export to Flash and Export to HTML5 
dialog box, respectively). See the Export to Flash and Export to HTML5 sections for detailed information.
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Edit Web Tag 

Title - The title of the web tag 
(callout bubble)

Callout options - Change available 
options based on callout type

Show Preview - Open or close the 
preview of the callout bubble. 
Click Previous or Next arrow 
buttons to switch from one web 
tag to another (enabled when 
multiple artwork is selected).

Content - Enter web tag content. 
Supported HTML tags may be 

used to format the text and 
images in the content.

Web Tag Size - Set the size (width 
and height in pixels) of the 

callout bubble. Use Auto Size 
to automatically size the callout 

bubble around its content.

Web Tag Image - Browse for an 
image or type an attribute name 
that contains a path to the image. 
Specify the image width and 
height in pixel or use the loaded 
default size.

Use HTML Tags and Graphic Tools 
to edit the text. From left to 
right: Bold, Italic, Link, Line 
Break, Unordered List, and 
Image. For Flash only: Bar 

Chart, Pie Chart, and In-line 
Expression. The Insert Attribute 

drop-down list contains 
attributes stored in the layer.

External URL Triggers
Control how URLs are opened 
when either clicking or hovering 
over Web art. Framesets or target 
must be created to direct the Web 
page to a specific frame.

Web Tag Example

Web tag title

Web tag image 
Web tag contents - It can contain 
text, images, and graphics

FUNCTIONALITY

Click the Edit button in the MAP Web Author panel to open the Edit Web Tag dialog box. This dialog box is used to 
design the web tags (callout bubbles) using HTML. These callout bubbles appear when objects in the web map are 
clicked or hovered over (however, not all objects in the map need to be associated with a callout). Use the Show 
Preview option to see how the HTML affects the web tag.
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PREREQUISITE

In the Edit Web Tag dialog box, text and image parameters are formatted with HTML (Hyper Text Markup Language). A 
markup language is a set of markup tags. These HTML tags are keywords (tag names) surrounded by angle brackets 
like <html> that indicate how the Web browser should display content. There are opening tags and closing tags 
and usually come in pairs, like <a> and </a>, where the end tag contains a forward slash. To learn more about HTML 
formatting, visit http://www.w3schools.com/html/default.asp.

Examples of text formatting

			   <b>Maps of the World</b>  Maps of the World	
	
			   <i>Maps of the World</i>  Maps of the World	

Examples
Some HTML tags are used to insert links and images.
•	<a href="http://www.avenza.com">Avenza Web Page</a> 

 Creates a link to www.avenza.com accessed when clicking "Avenza Web Page" text.

•	<img src="sourcemedia/picture.jpg" hspace="0" vspace="0" align="left" >

 Inserts an image (picture.jpg located in the Source Media Folder).

HTML ignores extra spaces and returns, therefore tags such as <br> (to create line breaks) and <p> (to start a new 
paragraph) should be used. In addition to the HTML tags, MAPublisher uses special text to extract data from the 
MAP Attributes table. These attribute field references are surrounded by percent signs, like %AttributeName%.

Examples of using attribute fields
•	<b>%Street_Name%</b>

 Main Street

•	<img src="sourcemedia/%image%" hspace="0" vspace="0" align="left" >

 Displays image indicated in the attribute called "image" (a string text). hspace and vspace sets the 
horizontal and vertical space left blank around the image. The align setting sets the image alignment to the 
left of the page.

•	<a href="http://%website%">Avenza Web</a>

 Avenza Web (opens the website value indicated in the website attribute).

Opening Tag Closing Tag
Text

Result
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USING EDIT WEB TAG

Web Tag Preview and Size
The Show Preview option displays a preview of the web tag (callout). As the title, text and graphics are inserted, the 
preview is updated accordingly. Set the width and height of the callout (in pixel units) in the Web Tag Size section. 
Use the Auto Size option to automatically size the bubble to its contents.

Insert a Title
A title are typed in as text, but it can also be a MAP Attributes field, like %PARK_NAME%. Titles can be formatted 
using HTML tags.

Add and Edit Contents
The Edit Web Tag dialog provides a set of HTML tag buttons to help format content (see table on next page). Several 
options are only availble depending on the Callout option chosen. Charts and In-line Expressions are only available 
when creating Flash callouts.

To insert a tag into the Content box, click a tag button. Then type callout text in between the opening and closing 
tags. Alternatively, highlight content text and click a tag button to wrap tags around it. Use the preview to see how 
the text, links or charts are displayed.

Aside from HTML tags, pick MAP Attributes from the Insert Attribute drop-down list (visible attributes only) to add 
them to the Content box.

Notes:	 MAP Attributes field names are case sensitive. 
 
Flash options do not appear if the final web export is to HTML5 format. Expressions are not supported for 
HTML5 and are not evaluated even if included in the Content box. 
 
To improve searchability in the map viewer, remember that the searchable attribute must be in the web tag. 
Otherwise, enable the Export all attributes with map features setting (this may increase exported file size).

Insert an Image or Flash Animation
Images and Flash animations (Flash only) can be inserted into web tags. To insert an image, click Browse For Image 
and navigate to the image file. To use an attribute value containing the path to the graphic file, enter the attribute 
field name into the Web Tag Image box, like %Image_File%.

By default, the original image size is used. To change the image size, adjust the width and height value in the web 
Tag Image section (aspect ratio is maintained). The preview shows the size actual size of the image. 

Note:	 The maximum size for a callout is 800 pixels by 800 pixels. When this limit is reached, graphics are 
automatically scaled to fit (aspect ratio is maintained).
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Tag button Tag Function HTML tag example Result

Bold <b>Madrid, Spain</b> Madrid, Spain

Italic <i>Land Parcels</i> Land Parcels

Link <a href=”http://www.avenza.com”>Avenza website</a> Avenza website

Line Break Orlando,<br>Florida
Orlando, 
Florida

Unordered List
<ul> 
  <li>Roads</li> 
  <li>Avenues</li> 
</ul>

•	 Roads
•	 Avenues

Insert Image <img src=”ImageFile/Canada.png”>

 
(Flash only)

Pie chart
<chart type=”pie” showLegend=”true” values=”’key1’, 
‘%attrib1%’ | ‘key2’, ‘%attrib2%’” colors=”0xff0000, 
0x00ff00” width=”180” height=”180” >

(Flash only)

Horizontal bar chart
(Flash only)

<chart type="horizontalbar" showLegend="true" 
showAxisValues="true"  values="'key1', '%attrib1%' 
| 'key2', '%attrib2%'" colors="0xff0000, 0x00ff00" 
width="180" height="180" >

Vertical bar chart
(Flash only)

<chart type="verticalbar" showLegend="true" 
showAxisValues="true"  values="'key1', '%attrib1%' 
| 'key2', '%attrib2%'" colors="0xff0000, 0x00ff00" 
width="180" height="180" >

(Flash only)

In-line Expression %IF(LENGTH(attribute)>0, "Attribute: " & attribute & 
"<br/>", "")%

Attribute: 
<value>

Additional information for pie and bar charts (Flash only):
•	 key1: Legend for the first value. Enter a text in between single quotes. For example: 'Table Title'
•	 %attrib1%:  Attribute that contains the first numerical value for the graph, as found in the MAP Attributes 

panel. For example, if the attribute is named MALE_POP enter '%MALE_POP%'
•	 key2:  Legend for the second value. You can enter a text of your choice in between ' sign. For example: 

'Female Population'
•	 %attrib2%:  Attribute that contains the second numerical value for the graph, as found in the MAP 

Attributes panel. For example, if the attribute is named FEMALE_POP enter '%FEMALE_POP%'
•	 colors: enter a list of colors for the chart (first color, second color etc...). The color values must be entered 

in hexadecimal values. For example, use the Adobe Illustrator Color Picker and select color : the hex 
value (below the B of RGB). However, Illustrator writes the color as #BC1E1E , but in MAP Web Author, 
the # sign by 0x (zero-x) replaces the # — so 0xBC1E1E must be entered.

•	 width and height: Size of the graph in pixels.
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Advanced HTML tag combinations can be used to create more effects. For more information and a complete list of 
HTML tags supported by Adobe Flash, click the link on the Web Tag dialog box or go to http://livedocs.adobe.com/
flash/9.0/main/wwhelp/wwhimpl/common/html/wwhelp.htm?context=LiveDocs_Parts&file=00000922.html.

Note:	 Inserting attributes with HTML recognized characters such as "<" and ">" (e.g. <AttributeName>) may cause 
MAP Web Author to interpret them as HTML tags instead. Avoid naming attributes in this style.

External URL Triggers
The External URL Triggers settings allow an advanced Web designer to load a specified HTML document (designated 
by its URL address) into a targeted HTML frame. Attribute fields may be used (i.e. %ATTRIBUTE_NAME%). This option 
occurs when web art is clicked or hovered over. 

A web browser can be divided into multiple panes called HTML frames in order to present documents in multiple 
views, which may be independent windows or subwindows. For example, within the same window, one frame 
might display a static banner, a second a navigation menu, and a third the main document that can be scrolled 
through or replaced by navigating in the second frame. An example layout could be as follow:

Frame 1

Frame 2

Frame 3

Names of frames created by Web designers must begin with an alphabetic character (a-z/A-Z). Some special 
purpose HTML frames have reserved names with a leading underscore. The following reserved names are available 
for selection from the Target drop-down list.

_blank Loads a linked document into a new blank window (unnamed). 

_parent Loads a linked document into the immediate parent of the document 
the link is in (frame containing web map).

_self Loads a linked document into the same frame in which the link was 
clicked (frame containing web map).

_top Loads a linked document into the entire window, clearing the frames.

To use the External URL Triggers, enter a URL of the HTML document to open in the Click URL or Hover URL boxes. The 
URL can be any page available locally or any external webpage (for example http://www.avenza.com). In the Target 
drop-down list, enter the name of the destination frame (type in the name given by Web designers or use one of 
the four available reserved names).
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Export to Flash

Export Settings

Export location- The destination 
folder of the exported 

Flash documents

Layer Controls - Lists all the layers 
in the active artboard. All layers 
will be visible, but only checked 

layers under User Toggle can be 
shown/hidden by a user. 
Options - Set layer export 

options. Show a layer at certain 
zoom levels, set initial layer 

visibility and static content is 
affected by pan and zoom.

Export - Export the document to 
a Flash map

Compress map data file map.xml 
Compress the map data file, 
map.xml to make it smaller

Viewer Settings 
See next section for more details

Viewer Style 
See next section for more details

Viewer Style - Use these setting to 
control the style and position of 
navigation objects and map elements. 
Any changes to the default settings 
will output a new CSS file. 

Use external CSS file - If an external CSS file 
is specified, it will override any of the 
settings specified above. When a CSS file is 
specified, an Edit link is enabled. It opens 
the file in the system's default text editor.

Viewer Settings - Customize the navigation 
controls of the map. The default settings 
shown are shown here.

JPEG Image quality & resolution
Drag the slider to control 

the amount of JPEG file 
compression

Simplify outlines of tagged artwork 
Simplify outlines of tagged 

artwork in the Flash map

Format numbers using locale  
Use numbers formatted to 

your region

Map Settings 
Width and Height - Size of the 
Flash map in the browser. 
Cannot be larger than the 
Adobe Illustrator document.
Set To Artboard - Reset the width 
and height to its original values
Pan X and Pan Y - Initial pan shift 
applied to the Flash map (from 
top-left corner)
Initial zoom - Zoom level when 
the Flash map is opened 
Minimum zoom - The minimum 
zoom level that the map can 
be set to 
Maximum zoom - The maximum 
zoom level that the map can 
be set to

Use Preserve Appearance setting for 
Flash export - When unchecked, 

path simplifications are applied 
by Adobe Illustrator. 

Flash Player security sandbox 
Provides a restricted area for 
the map that prevents access 
to private data. Depending 
on location of final Flash map, 
choose Local or Network. It is 
set to Auto by default.
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FUNCTIONALITY

Use Export to Flash to set the appearance of a Flash map. Style navigation objects and map elements such as buttons, 
the search box, overview map, layer list, callout bubble, zoom slider, and highlight lines and colours.

PREREQUISITE

Web tags must be first created using the Edit Web Tag dialog box.

USING EXPORT TO FLASH

In the MAP Web Author panel, in the Export section, click the Flash button. The Export to Flash dialog box contains 
three tabs: Export Settings controls the export location, layer controls (visibility, toggleable, etc.) and the Flash map 
settings; Viewer Style controls the appearance of Flash widgets; and the Viewer Settings controls how Flash widgets 
operate and function.

EXPORT TO FLASH - EXPORT SETTINGS

In the Export Location box, specify the directory that will store the HTML index file (by default index.html) and Flash 
export files.

Layer Controls
To have a layer list in the Flash map, at least one layer check box in the User Toggle column must be checked (Export 
Settings tab) and the Show Layer List option must be enabled (Viewer Settings tab). Layers that are checked are 
included in the Flash map layer list and can be toggled on or off. The layers that are unchecked are exported, but 
can not be toggled on or off.

Navigation buttons - Pan up, pan down, 
pan left and pan right buttons. 

Home button in the center of the 
pan buttons centers the map to its 

original view.

Zoom Slider - Move the slider arrow 
up or down to zoom in or out, 

respectively. Use the Zoom In or 
Zoom Out buttons to zoom at 

specific increments.

Layer list - Check boxes toggle 
layer visibility. Only layers 

checked under User Toggle are 
shown in the layers list.

Search box - Type text into search box 
and it searches through the contents 
of all the exported callout bubbles. 
Results are highlighted on the map.

Callout Bubble - Web tag or pop-up 
displays content created in the Web 
Tag Dialog

Overview Map - Displays the full 
extent of the map at all times. When 
zoomed into the main map it shows 
the zoom extent. The zoom extent is 
interactive and can be used to pan 
around the map.

Highlighted Lines - By default, objects 
clicked on are highlighted in blue, 
objects hovered on are in green 
and objects found by the search are 
in yellow
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Layer Export Options
To customize the visibility and zoom of each layer, double-click [Double Click Here To Set Layer Options] to access the Layer 
Export Options dialog box.

Map Settings
Use map settings to change how the Flash map is displayed in a web browser:

•	 Adjust the width and height of the Flash map. It cannot be larger than the Adobe Illustrator document. 
Click the Set To Artboard button to reset the width and height to the original artboard values.

•	 Set the initial position of the Flash map upon load using Pan X and Pan Y (if zoomed-in).
•	 Set the initial zoom upon load. Set the minimum and maximum zoom that the map is allowed to have.

Additional Settings
The Compress map data file (map.xml or map.xml.zip) is used by the Flash viewer to get information on the initial zoom 
level, Web tag content, tagged object geographic coordinates. It is recommended to keep this option enabled to 
use a compressed version of this file (map.xml.zip) to maintain a fast loading map. However, advanced users may 
use the uncompressed version (map.xml). For example, an advanced user could create programs that automatically 
update the Web Tag contents. Once compressed, this file cannot be uncompressed to map.xml. If this file is required, 
the export must be run again with this option disabled.

The Use Preserve Appearance setting for Flash export option flattens the artwork to a single layer before exporting. It is 
recommended to maintain the artwork quality. However, some known issues with Adobe Illustrator Flash export 
cause some documents to fail to export with this option enabled.

Use the Format numbers using locale option to format numbers based on the locale setting in MAPublisher Preferences. 
This option does not work with expressions.

Use the Simplify outlines of tagged artwork option to generalize tagged artwork to reduce overall file size.

Images in Adobe Illustrator are exported as JPEG. The JPEG Image quality & resolution slider sets the compression level of 
exported images. This setting does not apply to images included in web tags.

See Flash Security and Permissions section to learn more about these settings.

Initial Visibility - Show or hide 
the layer when the map is first 

loaded in a Web browser.

Zoom Range Visibility - By default, 
the layer is always shown. 

Choose a zoom level range for 
the layer to be visible within. 
When the layer is outside the 

zoom range, it is hidden.

Static Content Layer - By default, 
the layer will be affected by pan 

and zoom. Choose the second 
option so that a static layer is 

not affected by pan and zoom.

Layer Export Options
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EXPORT TO FLASH - VIEWER STYLE

To set the style and position of Flash map viewer controls, edit the Viewer Style list or use CSS (Cascading Style 
Sheet), a style sheet language that enables the separation of document content (HTML, JavaScript) from document 
presentation—it is a simple mechanism for adding style (e.g. fonts, colors, spacing) to multiple webpages at once.

The Viewer Style list contains map viewer controls and properties in the Viewer Styles list are as follows—all positions 
are relative to the top left corner of the Flash map:

•	 Pan Up Button (Top, Left) - Position of the pan up button.
•	 Pan Down Button (Top, Left) - Position of the pan down button.
•	 Pan Left Button (Top, Left) - Position of the pan left button.
•	 Pan Right Button (Top, Left) - Position of the pan right button.
•	 Pan Home Button (Top, Left) - Position of the pan home button.
•	 Zoom In Button (Top, Left) - Position of the zoom in button.
•	 Zoom Out Button (Top, Left) - Position of the zoom out button.
•	 Zoom Slider (Top, Left) - Position of the zoom slider widget.
•	 Click Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a 

callout bubble when it is clicked.
•	 Hover Callout Bubble (Corner Radius, Show Arrow, Drop Shadow, Fill Colors Start, Fill Colors End) - style of a 

callout bubble when it is hovered over.
•	 Fixed Position Callout Bubble (Top, Left, Width, Height, Corner Radius, Draw Bubble, Fill Colors Start, Fill Colors 

End) - position and style of a static position callout bubble.
•	 Click Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Hover Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Search Highlight Line - (Visible, Color, Transparency, Line Thickness).
•	 Search Box (Top, Left) - Position of the search box.
•	 Layer List (Top, Left, Width, Height) - Position and size of the map layer list.
•	 Overview Map (Top, Left, Proportion) - Position and proportion (relative to map size) of the overview map. 

Each control can be styled and positioned by adjusting basic property values. Users can export with the default 
values without further adjustment. If any control properties are changed from the default values, a custom CSS file 
is exported to the export data folder. The controls in the Viewer Style list contain only basic properties, use CSS for 
more advanced designs.

For advanced users, the appearance of Flash maps can be fully customized using CSS. Enable the Use external CSS file 
option and browse to a CSS file. The file will overwrite any of the configurations made in the Viewers Style list. Using 
an external CSS file for styling the viewer is advantageous because more visual aspects of the viewer can be set—
such as, callout bubble style, text font, images for buttons—and external CSS can be reused for multiple maps. If the 
need arises, the external CSS file can be updated after the map has been exported.

The CSS implementation is based on the Adobe Flex 3 CSS system. Only class selectors are supported. Full 
documentation is located at http://www.avenza.com/mapublisher/mapwebauthor/css. This site includes full maps, 
CSS samples and examples of CSS code.
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EXPORT TO FLASH - VIEWER SETTINGS

The Viewer Settings tab contains settings that affect the operation or function of Flash widgets. Check/uncheck any of 
the options to enable or disable them. Most of these options are enabled by default unless otherwise specified. The 
visibility of these controls may also be set through an external CSS file (specified in the Viewer Style tab).

Navigation
•	 Enable Navigation - Displays all of the navigation buttons, search box, layers list and overview map.

•	 Show Panning Widget - Show pan widget in map viewer.
•	 Show Zooming Widget - Show zoom widget in map viewer.
•	 Show Search Box - Show search box in the map viewer.

•	 Automatically zoom to search results - Zoom the map viewer to search results. Disabled by default.
•	 Show Click Callout for search results - Show click callouts for search results. Disabled by default.

•	 Show Layer List - Show the layer list in the map viewer.
•	 Show Overview Map - Show the overview map in the map viewer.
•	 Drag map with mouse to pan - Allows the user to pan the map using the mouse in the map viewer.
•	 Double-click on map to zoom in - Allows the user to zoom in with the mouse on double-click.
•	 Zoom with mouse scroll wheel - Allows the user to zoom in and out using the mouse.

Callout Bubbles
•	 Show the Click Callout Bubble - Display a callout bubble when a feature with a Web tag is clicked.

•	 Use Lightbox Style for Click Callout - Disabled by default.
•	 Show the Hover Callout Bubble - Displays a callout bubble when a feature with a Web tag is moused over.

•	 Use full callout content for Hover Callout - Displays full callout bubble when option to show hover callout 
bubble is enabled. Disabled by default.

•	 Show the Fixed Position Callout Bubble - Displays a fixed position callout bubble. Disabled by default.
•	 Use centroid instead of mouse for callout position - places the callout bubble position of a feature with a Web tag on 

the centroid. Disable it so that the callout position occurs where the mouse position is.

Animations
•	 Disable viewer navigation animations - Enabling this option disables panning and zooming animations. Disabled by 

default.
•	 Use low stage quality during animations - Lowers the quality of animations for improved performance. Disabled by 

default.

Attributes
•	 Export all Attributes with map features - Forces all attributes to export, regardless of whether they are used in a Web 

tag or not. Disabled by default.

Expressions
•	 Allow expressions in Search Box - Allow users to type expressions into the search box. Disabled by default.
•	 Allow expressions in Web Tags - Evaluate expressions in web tags at runtime. Disabled by default.
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WEB EXPORT LOG (FLASH)

In the Export to Flash dialog box, click the Export button to begin the export process. An export summary is 
displayed in the Web Export Log.

An index.html file and index_data folder are created in the specified export directory (default names; a custom name 
and location can be substituted in the Export Location box). Some of the important files are:

•	 map.xml.zip (or map.xml when the Compress Map Data File option is not checked).
•	 MAPublisherViewer-local.swf and MAPublisherViewer.swf (map viewer implementation files).
•	 map_L#.swf (where # is the layer number; one file per layer when option to toggle is checked). 

Note:	 View the README.txt file inside the export data folder for more information about each file.

The Web Export Log displays several export file size statistics: the total SWF file size and the metadata file size. These 
file sizes are meant to warn the users when files get very large. Large files should be avoided as they may slow the 
Flash map when opened on a website. Several recommendations to reduce exported file sizes are provided at the 
bottom of the dialog box.

Layer List - List of the exported 
layers, including file name, 
number of vertices and file size

Export folder - Link to the export 
folder. Right-click to copy link 

location to clipboard.

Metadata (.xml) file size - Size of 
the created metadata.xml file.
Less than 50 KB compressed 

(xml.zip) is ideal.

Total SWF file size - Total file size 
of the created SWF files. 

Less than 600 KB is ideal.

Set folder permissions - Set folder 
permissions. Read more 

about Flash Security and 
permissions section.

Export Again - Return to the Web 
Export Dialog

Web Export Log - Flash
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Flash Security and Permissions
The Flash Player security sandbox (located in the Export to Flash dialog box) provides a secure area in which a Flash map 
will load. Three options are offered:

•	 Auto: If the file is opened from a Web based URL, the sandbox is automatically switched to Network.  
If the file is opened from a file folder, the sandbox switches to Local. 

•	 Network: Flash Player classifies assets (including SWF files) from the Internet in separate sandboxes 
that correspond to their Website origin domains. By default, these files are authorized to access any 
resources from their own server, but can not load any local files or resources unless these are enabled 
through the Flash Security Settings (see later in this chapter).

•	 Local: Flash Security Settings are not required, however only content from the local host computer can 
be accessed by Flash Player (i.e. hyperlinks, API will not function). This option is recommended when 
distributing Flash maps on CD, for example.

When exporting a Flash map intended for Web distribution, choose the Network option in the Flash Player Security 
Sandbox drop-down list. If a Flash map is intended for only local use, choose the Local option. By default, the Auto 
option is chosen and automatically detects whether the Flash map is run on a network or locally. If the Network 
option is selected, the Global Security Settings must be configured in the Adobe Flash Player Settings Manager 
before an Internet browser can properly view the Flash map without posting it on a server. If the Local option is 
chosen, it is not necessary to set folder permissions. However, files exported with this option will not work for a 
Website and will have to be exported again with either the Network or Auto option.

Click the Set Permissions button in the Web Export Log dialog box to access the Adobe Flash Player Settings Manager 
(http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager04.html):

1.	 Click Edit Locations.
2.	 Click Add Location.
3.	 Click Browse For Folder or copy the full path as written in 

the Web Export Log dialog box and click Confirm.

The folder is added to the list of trusted locations. Locations 
can be modified or deleted at a later time.

Note:	 You must be connected to the Internet in order to set these permissions.

View Flash Map
To view the exported Flash map, browse to the Flash export folder (as specified in the Web Export Dialog) and open the 
file index.html (or name specified in Export Location) in a Web browser. Check that the Web browser has the latest 
version of Flash Player installed (http://www.adobe.com/products/flashplayer/). An outdated version may cause the 
Flash map to display incorrectly.

Note:	 Depending on the security settings of the Web browser used, some warnings may appear when opening files 
exported with Local option enabled. These can be ignored.
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Export to HTML5
Export Settings

Export location - The destination 
folder of the exported web files

Viewport - The web map 
viewport size. Click the Set 

Viewport To Preset Size button to 
choose a predefined viewport 
size depending on use. Enable 

Set an initial viewport home 
location to create a custom 

view location when the web 
map home button is clicked. 

Navigation - Adjust web map 
interactive settings and  

navigation controls

Export - Export the map to an 
HTML5 web map

Controls - Hide/show and choose 
position for the Search box and 
Layer list

Feature Highlights - Hide/show 
web feature highlights

Callouts - Hide/show and adjust 
settings for callouts

FUNCTIONALITY

Export to HTML5 is used to export a MAPublisher map to a package of files that includes an HTML document that 
will enable you to view it in a web browser. Use Export to HTML5 to set the appearance of an HTML5 web map. Style 
navigation objects and map elements such as buttons, the search box, overview map, layer list, callout, zoom slider, 
and highlight lines and colours.

PREREQUISITE

Web tags must be first created using the Edit Web Tag dialog box. 

The largest challenge when creating an HTML5 web map is making it work efficiently across all desktop and mobile 
browsers. Export to HTML5 has many similarities and differences to Export to Flash and it should be noted that a 
map designed for Flash may not be directly exported as an HTML5 map.

USING EXPORT TO HTML5

In the MAP Web Author panel, in the Export section, click the HTML5 button. In the Export location box, specify the 
directory that will store the HTML index file (by default index.html) and associated web export files. 

The Export to HTML5 dialog box contains four tabs: Viewer has controls to set export location, viewport size, 
navigation controls and callout settings; Hide/Show Layers has controls to show and hide specified layers; Scale 
Dependent Layers has controls to adjust what is visible at set zoom scales; Theme has controls to adjust the appearance 
of foreground, background, and highlight colours; and Advanced has controls to adjust additional settings.
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EXPORT TO HTML5 - VIEWER

The Viewer tab contains settings that affect the operation of elements in the web map. Check/uncheck any of the 
options to enable or disable them. Most of these options are enabled by default unless otherwise specified.

Viewport
Use the viewport settings to change how the web map is displayed in a web browser:

•	 Adjust the width and height of the web map. It cannot be larger than the Adobe Illustrator document. 
Enable the Maintain aspect ratio option to adjust the viewport width and height values in the same ratio.  
Click the Set Viewport to Preset Size button to set the width and height to the predefined widths including 
800px (large, for websites and tablets), 640px (medium, for websites and tablets), 320px (small, for mobile 
phones), or set to artboard size. 

•	 Enable the Set location and zoom scale for home button option to choose a custom home position on the web 
map (based on Center X and Center Y for position, and zoom scale)

Navigation
•	 Allow panning with mouse and touch - Allows the user to pan the map with mouse and by touch on mobile.
•	 Allow zooming with mouse and touch - Allows the user to zoom the map with mouse and by touch on mobile.
•	 Show navigation controls - Show navigation controls in the web map. Choose position and maximum zoom.

Controls
•	 Show Search Box - Show search box in the map viewer. Choose position. Disabled by default.
•	 Show Layer List - Show the layer list in the map viewer. Choose position.

Callouts
•	 Show the Click Callout - Display a callout when a feature with a web tag is selected. The Callout will appear at the 

current tap or click position.
•	 Use centroid instead of mouse position for Callout - The callout will appear at the centroid of the feature rather 

than at the mouse position.
•	 Show the Hover Callout - Display a callout when the mouse pointers moves over a feature with a web tag. This is 

not available on touch devices.
•	 Use full callout content for Hover Callout - Displays full callout when option to show hover callout is enabled. 

Disabled by default.
•	 Show the Fixed Callout - Display a callout at a fixed position when a feature with a web tag is selcted. Disabled by 

default.

Feature Highlights
•	 Show Click Highlight - Show a highlight over top of a feature when it is selected.
•	 Show Hover Highlight - Show a highlight over top of a feature when the mouse moves over it. This is not available 

on touch devices.
•	 Show Search Highlight - Show a highlight over top of a feature when it matches a search.
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EXPORT TO HTML5 - HIDE/SHOW LAYERS

The Hide/Show Layers tab contains settings that allow layers to be toggled on and off in the viewport. Click the Allow 
the user to hide and show layers in the layers list option to enable its controls. Layers can be added individually or be 
grouped. Grouped layers all share the same options.

Individual layer

Layer group Options - Change the display 
name, set initial visibility, hide 
from layer list, and add a layer 
list icon.

In the Options frame for each respective layer or group, there are settings to change the display name (what is 
showsn in the layer list in the web viewer), a setting to change initial visibility, or to not show it in the layers list at 
all. The layer list icon (must be 32x32 pixels or smaller) is optional. The Only show one layer group at a time option (bottom 
of the dialog box) allows the visibility of one layer group at a time in the viewport.

EXPORT TO HTML5 - SCALE DEPENDENT LAYERS

The Scale Dependent Layers tab contains settings to adjust layer visibility at specific zoom scales. Click the Hide and 
show layers only at specific zoom scales option to enable its controls. Layers can be added individually or be grouped. 
Grouped layers all share the same options. It is important to note that layers cannot be added to both the 
Hide/Show Layers tab (above) and Scale Dependent Layers tab (below). It is recommended to priortize which layers 
can have its visibility hidden/shown and needs to be shown at specific zoom scales to ensure the correct display in 
the viewport.

Individual layer

Layer group

Options - Change the zoom scales 
for layers and layer groups

When a layer is added to a group it will be displayed at the top of the map layer hierarchy when exported.
This means that if a layer that was at the bottom of your map hierarchy and it is added to a Hide/Show Layer layer 
group, it will automatically be moved to the top level or your layer hierarchy when exported.

A layer that is not added as a Hide/Show Layer is considered a base layer.  A base layer is comprised of rasterized 
images (tiles) for the required number of zoom scales. Layers do not have to be designated as a base layer as this is 
the default location for all layers. A base layer appears underneath all other layers.
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Important Layer Notes
Due to hardware and software limitations with mobile devices and most desktop browsers it is best to limit the 
number of toggleable layers to no more than three hide/show layers (however this limit is completely dependent 
on the size of the map and the data that is used).

EXPORT TO HTML5 - THEME

The Theme tab contains settings to change the appearance of the web map viewer. Two default themes are available: 
Light Theme and Dark Theme. The Custom Theme option has custom colour settings available. Themes do not affect the 
style in your map document, it only affects the appearance of the map viewer foreground, background, border, and 
highlight colours. 

Theme types

Custom Theme settings

Control foreground

Control highlight

Control background

Control border

Feature highlight
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EXPORT TO HTML5 - ADVANCED

The Advanced tab contains extra settings to change functionality of the web map viewer.

Web Tags
•	 Format numbers using locale - Use locale as source for number formats. Disabled by default.
•	 Simplify outlines of tagged artwork - Removes extraneous vertices from artwork.
•	 Export all attributes with map features - Map attributes are included in the exported web map. Disabled by default.

Tiled Layers
•	 Use JPEG for base layer tiles - Change format to JPEG for base layer tiles. Disabling this option will use PNG for base 

layer tiles.
•	 Scale patterns in tiled layers - Patterns are scaled for better looking tiles.

Debugging
•	 Display frames per second in the viewer - Shows value in a corner of the viewer. Disabled by default.
•	 Include the debug information widget in the viewer - Debug information Disabled by default.

WEB EXPORT LOG (HTML5)

In the Export to HTML5 dialog box, click the Export button to begin the export process. An export summary is 
displayed in the Web Export Log dialog box.

An index.html file and index_data folder are created in the specified export directory (default names; a custom name 
and location can be substituted in the Export Location box). Some of the important exported files are:

•	 avenza.css and avenza-theme.css (CSS files that can used to customize style of the map viewer).
•	 layer # folder (where # is the layer number; folder contains tiles).
•	 avenza-viewer.js (the Javascript file containing information to form the map viewer).
•	 data.js (the Javascript file containing information to place data in the map viewer).

The Web Export Log displays several export file size statistics: the number of tiles created and total file size, and the 
map data total file size. Large file sizes should be avoided as they may slow the web map when opened in browser.
Several recommendations to reduce exported file sizes are provided at the bottom of the dialog box.
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HTML5 WEB MAP DATA AND DESIGN CONSIDERATIONS

Artboard Size

The Export to HTML5 processing time is dependent on map size. A large artboard means there are more pixels to 
export. It is recommended that web map dimensions are  800 x 600 pixels. Keep in mind what kind of devices your 
web maps may be viewed on (smartphone, tablet, or desktop).

Viewport Size

The viewport is independent of the artboard size and will affect the runtime speed of the map. Generally, a smaller 
viewport will produce a faster web map. Use the Set Viewport to Preset Size options to choose an appropriate size.

Zoom scales

Export to HTML5 creates tiles for your art based on the number of required zoom scales.  So, the more your map can 
zoom in and out the longer it will take to export and larger the exported files will be.

Data Generalization

For all exported data, the detail (ie. artwork, number of objects) and amount of data on the artboard will affect the 
processing speed of the export. Art that contains web tags could slow performance of the final map. Web art is 
always exported with a vector layer to be able to show the highlighted feature.

iOS/Android/Mobile Limitations

Mobile devices using operating systems such as Apple iOS and Android have the ability to render HTML5, however 
these devices have limited hardware and software which may cause HTML5 rendering issues. Using hide/show 
layers on a mobile device may slow the device. Use a maximum of three hide/show layers. Web maps viewed on a 
mobile device (with a touch screen) will have the following HTML5 viewer options disabled:

•	 Show Hover Highlight
•	 Show the Hover Callout

Attributes
A large number of attributes associated with web tags can cause performance issues in the exported web map.
Unused attributes are removed automatically from the tagged layers when exporting.

Browsers
All browsers (including mobile browsers) display HTML5 differently. Ensure that your exported HTML5 web map is 
tested on popular browsers before it is deployed. Web safe fonts work better in certain browsers.

Navigation
Pan and zoom gestures when viewing websites on a mobile device are very similar to pan and zoom gestures when 
viewing a web map. It is recommeded that only one type of gesture is active (i.e. disable pan and zoom in the map 
or disable pan and zoom on the web page). The included example index.html shows how to disable pan and zoom 
on the web page.



Advanced Features 

Users with good knowledge of HTML and Javascript can benefit from some advanced MAPublisher features. 
Additional information about these features is provided on the Avenza Systems Inc. website (www.avenza.com).  
This information is available to all MAPublisher customers. MAP Web Author examples are also provided on the 
MAPublisher DVD.

EXTERNAL CSS

As explained earlier in this chapter, the visual aspects of the widgets that appear in the MAPublisher Web Author 
viewer can be configured using CSS (Cascading Style Sheets). The CSS implementation is based on the Adobe Flex 3 
CSS system. Only class selectors are supported. 

Refer to the webpage at http://www.avenza.com/mapublisher/mapwebauthor/css for information on how to edit the 
CSS file and for a reference to the list of classes available for styling and their supported properties. 

MAP WEB AUTHOR API REFERENCE

The MAP Web Author API Reference allows developers to embed and interact with maps produced by MAPublisher 
in web pages. There are two API references: Flash and HTML5.

Some webpages have been developed on the Avenza Systems website to provide a guide to the API. It includes 
both Flash and HTML5 API References, FAQs and examples.

Refer to http://www.avenza.com/mapublisher/mapwebauthor/api for for more information.
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Adobe Illustrator documents with GIS data can be exported 
to georeferenced PDF files thanks to the MAPublisher Export 
Geospatial PDF feature. 

A geospatial PDF is an Adobe Acrobat file that contains 
geospatial coordinates. With coordinates, users can view and 
interact with the PDF to find and mark location data.

MAPublisher exports all MAP Attribute data in an Adobe 
Illustrator document to a geospatial PDF. Attribute values can  
be viewed and searched in Adobe Acrobat.

Geospatial PDF files exported with MAPublisher can be used 
in Adobe Acrobat to:

•	 Find and mark location coordinates
•	 Measure distance, perimeter, and area
•	 View coordinates in measurement units in 

various formats/units
•	 Copy location coordinates to clipboard
•	 View attributes of map objects
•	 Reopen geospatial PDF in Adobe Illustrator with 

MAPublisher capabilities maintained.

Topics covered in this section:
Export Geospatial PDF
View Geospatial PDF

Export 
Geospatial PDF
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FUNCTIONALITY

The Export Geospatial PDF feature exports any MAPublisher document containing a MAP View with a specified 
coordinate system to the Adobe Acrobat geospatial PDF format while retaining the georeference and attribute 
information. All layers are exported to PDF, including non MAP layers (regular Adobe Illustrator layers).

The geospatial PDF files exported from MAPublisher are compatible with Adobe Acrobat 9 and higher. The Adobe 
Acrobat Analysis Tools allow viewing and marking coordinates, viewing attributes, measuring distances, perimeters 
and areas.

With Acrobat Pro and Pro Extended (version 9), the measurement tool is always enabled. To enable this tool in 
Acrobat Reader (standard), the file must first be opened in Acrobat Pro to enable annotations on the PDF (menu 
Comments > Enable for commenting and analysis).

Note:	 Geospatial PDF files can also be opened in Adobe Acrobat 8, however no geospatial information will be 
visible, only attributes.

PREREQUISITES

Export Geospatial PDF can only be used with MAPublisher documents, meaning that it must contain at least one 
MAP View with a specified coordinate system. All coordinate systems within MAPublisher are supported, including 
user-defined systems*. Multiple MAP Views are supported with no limitation. Individual document size must be 
smaller than 14,400 pixel by 14,400 pixel to maintain correct georeferencing.

* With some unusual coordinate systems, measurements in Adobe Acrobat may not give proper results. This is an Adobe Acrobat 
limitation. Predefined coordinate systems with an EPSG code will provide accurate results.

Export Geospatial PDF 
File > Export> Geospatial PDF or MAP Toolbar  

Export Attributes  - Enable which 
layers will be exported  
with attributesMAP View - Click the check 

box to enable/disable the 
attribute export of all layers in 

the selected MAP View

MAP Layer - Click the check box 
to enable/disable the attribute 

export for the selected layer

Use attribute for item name 
Enable display of attribute 
name rather than the Adobe 
Illustrator  object name in the 
Adobe Acrobat Model Tree. Then 
choose an attribute from the 
drop-down list.

Model Tree Preferences - Set the 
Model Tree display options for 
the selected layer (shown):

Item Sorting:
Sort order - Choose Ascending or 
Descending for the sorting order

Use natural string comparison - Sort 
numerical values in a natural 
order (e.g. 1-2-10 rather than 
1-10-2)

Embed AI file within PDF - Enable to 
preserve the Adobe Illustrator 

editing capabilities in the 
exported PDF
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Depending on the expected behavior of the geospatial PDF, settings for MAP Views, MAP Attributes, and MAP 
Layers may need additional attention.

Adobe Illustrator documents created using MAPublisher legacy versions (8.1 or earlier) as well as documents 
created by third-party software (such as Cartographica) must be opened, saved and closed with at least 
MAPublisher 8.3 prior to exporting to geospatial PDF. If these steps are not taken, a warning may be prompted on 
export and the Adobe Acrobat data tools (see later in this chapter) will not function properly.

Note:	 Some Adobe Illustrator effects are not supported during export. The attributes will not be visible for objects 
with the following effects† : 

•	 All Adobe Photoshop effects
•	 Any effect that modifies the outline shape of the artwork will cause attributes to fail. (i.e. Warp effects, 

Convert to Shape, 3D effects, Distort and Transform, and some of the Pathfinder effects).
•	 Any effect that rasterizes the art will cause attributes to fail (several SVG filters do this).
•	 Gradient Fills are supported, although transparency gradients (going from opaque to transparent) and 

Gradient Mesh are not supported. 

Geospatial Information Extents
A geospatial PDF only contains geographic information in the extent covered by a MAP View. In other words, Adobe 
Acrobat Geospatial Location Tool and Measurement Tool will not work outside the spatial extents of a MAP View. To 
increase the extents of the MAP View so that it covers a larger part of the document, create a polygon on a MAP 
area layer.

Layers and MAP Views Structure
All layers in the Adobe Illustrator document are exported including locked and hidden layers. The visibility status 
is maintained in the exported geospatial PDF, however not the locking status. Locking layers must be done within 
Adobe Acrobat.

Layer name and order are maintained as they are in the Adobe Illustrator document (with the exception of nested 
layers). Layers must have a unique name. If multiple layers have the same name, a warning message is prompted 
upon export. Adobe Acrobat does not support nested layers therefore only top most layers are maintained in the 
exported geospatial PDF. Objects in nested layers are still exported but they are included in the top most layer. It is 
not recommended to use nested MAP Layers because their attributes will not be exported unless the master layer is 
also a MAP Layer. 

All MAP Views are exported in the order that they appear in the MAP Views panel (alphabetical): the top most 
is exported first and lowest is exported last. If some MAP Views are overlapping, the positions shown in Adobe 
Acrobat are calculated based on the coordinate system of the latest exported MAP View (the lowest one in the MAP 
Views panel). When working with inset maps, the inset MAP View should be placed at the bottom of the tree in the 
MAP Views panel (using an appropriate MAP View name since the order is alphabetical).
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MAP Attributes
The Geospatial PDF Settings dialog box allows the user to customize which layer attributes to export. When attributes 
are exported, only visible attributes for map objects are exported to PDF. The attribute name displayed in the Adobe 
Acrobat Model Tree Property list corresponds to the attribute Display Name specified in the MAP Attributes panel. 

Prior to exporting, users can delete or hide/display relevant attributes in the MAP Attributes panel (through the Edit 
Schema dialog box or using the Show/Hide button). The Edit Schema dialog box is also used to change the attribute 
display name - see chapter 5 for details):

Display Name - Attribute name 
displayed in the Object Data pane of 
the Model Tree

Column - Select the column to edit

Visible - Set the visibility status of the 
selected attribute column

USING EXPORT GEOSPATIAL PDF

To export to geospatial PDF, click the Export Geospatial PDF button on the MAPublisher Toolbar. Alternatively, choose 
File > Export and select Geospatial PDF in the Save as type (Windows) or Format (Mac)(drop-down list).

After selecting an export directory and file name, the Geospatial PDF Settings dialog box opens to offer the export 
options described hereafter.

Export Attributes For Layer
The Export attributes for layer tree lists all the MAP Layers that can be exported with attributes and is sorted by MAP View 
and document. To select which layers will have their attributes exported: 

•	 Click the Export Attributes check box for each individual layer to enable or disable the export of attributes.
•	 Click the Export Attributes check box for a given MAP View to enable or disable the export of attributes for 

all layers within the MAP View. 
•	 Click the Export Attributes check box next to the document name or next to MAP Views to enable or disable 

the export of attributes for all layers of all MAP Views.

Layers that are exported without attributes will be visible in the Adobe Acrobat Layers panel but not in the Model Tree.

Notes:	 Due to Adobe Acrobat limitations, attributes of Text layers cannot be exported. In addition, 
<compound path> objects that have an element outside the artboard are exported without attributes.
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Model Tree Preferences
In Adobe Acrobat, the Model Tree displays a list of all the map objects in the document along with their attribute 
information (if applicable), organized in a tree structure in MAP View/Layer Name/Object Name—see next section 
on how to view Geospatial PDF. 

The Model Tree Preferences options control, by layer, how objects will be displayed in the Adobe Acrobat Model Tree. 
To set these options, first select a layer in the Export Attributes for Layer tree. The name of the selected layer is then 
written next to the Model Tree Preferences caption. 

The Use attribute for item name option assigns a specific attribute value as a name to objects prior to export in order to 
make the geospatial PDF more readable for users.

By default, the name of the objects displayed in the Structure Pane of the Model tree are derived from the map 
object's name as shown in the Adobe Illustrator Layers Panel. The default names given by Adobe Illustrator 
to objects are often meaningless an end user. For example, lines and areas have a default name of <Path> or 
<Compound Path>, points have the name of the symbol or ordering number.

To use a specific attribute value as an object name, enable the Use attribute for item name option and choose the 
desired attribute column from the drop-down list.

MAP Views Panel Adobe Illustrator Layers Model Tree Objects List

The Item Sorting options control the order of the objects in the object tree (even if objects are not renamed):
•	 In the Use attribute for item name drop-down list, choose the attribute column that will be used for sorting. 
•	 In the Sort Order drop-down list choose Ascending or Descending order. 
•	 Enable Use natural string comparison to sort numeral values by natural order (e.g. 1,2,10 instead of 1,10,2).
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Embed AI File Within PDF
The Embed AI file within PDF option preserves the Adobe Illustrator editing capabilities in the resulting PDF.

This option is enabled by default. When the Adobe Illustrator editing capabilities are preserved, users will be able 
to retrieve MAP Views, MAP Layers and MAP Attributes when opening the exported geospatial PDF in Adobe 
Illustrator (see chapter 3 - Geospatial PDF Import). When this option is disabled, the geospatial PDF will open in 
Adobe Illustrator with no georeferencing or attribute information and all layers will be merged into one—this may 
be useful for secured documents.

Note:	 If a preserved geospatial PDF is opened in Adobe Illustrator and some changes are made, the file will have to 
be exported again using the Export Geospatial PDF function. Simply saving the document will not maintain 
the geospatial capabilities of the PDF.

RESULTS

The exported geospatial PDF can be opened in Adobe Acrobat—the geographic reference and attribute 
information are available for query (see next section).

The MAPublisher data is accessible through the Object Data Pane of the Model Tree—this displays either the coordinate 
system of a MAP View, if a MAP View is selected in the Model Tree, or the exported attribute information of a 
selected object.

MAP Views properties Attributes properties

Notes:	 Layers exported without attributes can be seen in the Adobe Acrobat Layers panel, but not in the Model Tree. 
 
During export, a warning may appear: "Multiple Art Objects Matched - One or more map objects may be 
missing attribute information". This simply states that the layers listed in the warning have objects that are 
close enough in proximity to each other that they are indistinguishable. There is an option in the warning to 
select these objects in the event that the user may want to work on them.

The default PDF settings are applied, regardless of any specific preferences set elsewhere: 
•	 Compatibility: Acrobat 8, PDF 1.7.
•	 General: Embed Page Thumbnails and Create Acrobat Layers from Top-Level Layers. 
•	 Compression: no image compression, Compress Text and Line Art is enabled.
•	 Security: no master or user password required.

To change PDF file settings (compression, password access, etc.) open the exported geospatial PDF file in Adobe 
Acrobat Pro or Pro Extended (version 9) and resave the document.
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Geospatial PDF files are compatible with the geospatial tools in Adobe Acrobat 9 and higher. The availability of 
these tools depends on the Acrobat version: Reader, Standard, Pro, or Pro Extended (Adobe Acrobat 9 only), but no 
additional Acrobat plug-in is necessary to view a geospatial PDF. 

Note:	 Geospatial PDF files can also be read in Adobe Acrobat 8, however, only attribute information is accessible 
(through the menu Tools > Object Data > Object Data Tool) and it does not have the geospatial tools that are 
available in Adobe Acrobat 9 or higher.

All traditional Adobe Acrobat tools apply with the following being the most relevant:
•	 Search: select objects with matching name first, then objects that have a matching attribute value. 
•	 Acrobat Layers panel: displays all layers and controls the display and lock of the layers.
•	 Object Data Tool: select map objects and display their attributes in the Adobe Acrobat Model Tree 

(Structure Pane and Object Data Pane).

Adobe Acrobat has the following special tools to access geospatial information:
•	 Measuring Tool: measure distance, area and perimeter.
•	 Geospatial Location Tool: display, mark and query geospatial locations.
•	 Geospatial Registration Tool: spatially register a PDF document by digitizing control points (Adobe Acrobat 

9 Pro Extended only).

These tools and the Object Data Tool are found on the Analysis Toolbar (menu View > Toolbars > Analyze).

Object Data Tool - Enable selection of MAP 
objects and display name and information in 
the Adobe Acrobat Model Tree (menu View > 
Navigation Panels > Model Tree).

Measuring Tool - Measure 
distance, perimeter and area.

Geospatial Location Tool 
Display, mark and query geospatial locations. 

Preferences for the Measurement and Geospatial tools are found in the menu Edit > Preferences, under the category 
Measuring (Geo).

View Geospatial PDF
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These analysis tools are described in detail in the Adobe Acrobat documentation that can be found under the 
Adobe Acrobat menu Help > Adobe Acrobat Help or on the Adobe Website www.adobe.com.

Not all tools are available for every Adobe Acrobat version, below is a matrix showing the features availability per 
Adobe Acrobat version:

Acrobat version Reader 9 and higher Standard and Pro 
9 and higher

Pro Extended 9
(Windows only)

Geospatial Measuring Tool

Measure distance/perimeter/area PÛ P P
Store measurements as comments PÛ P P
Export/import PDF comments PÛ P P
Geospatial Location Tool

Show on-screen coordinates P P P
Search for/zoom to a location P P P
Mark location with right click O P P
Copy coordinates to clipboard O P P
Geospatial PDF Registration Tool

Create from GeoTIFF/JPG2000 O O P
Georegister a PDF map/image O O P
Add shapefile layers to a map O O P

* To enable the measurement tool in Acrobat Reader, the file must first be opened in Acrobat Standard, Pro or Pro 
Extended to enable annotations in the PDF (menu Comments > Enable for commenting and analysis).

Notes:	 The extended tools of Adobe Acrobat Pro Extended are not necessary for MAPublisher users because these 
functions can be performed by MAPublisher. Adobe Acrobat Pro Extended is currently not supported for Mac 
operating systems. 
 
By default, viewing coordinates with the Geospatial Location Tool will show latitude and longitude in WGS84 
when the Always display latitude and longitude as WGS 1984 option is enabled in Adobe Acrobat preferences. 
A map with a geodetic base other than WGS84 should have the Always display latitude and longitude as WGS 
1984 option unchecked.
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MAPublisher LabelPro 2.0 is a comprehensive collision-free 
labeling solution integrated into MAPublisher. Using rules 
and styles for text placement, it extracts label information 
from map layer attributes and performs fast, intelligent, 
cartographic text placement. Placement rules can be saved to 
a file and imported into other labeling work sessions.

Topics covered in this section:
MAPublisher LabelPro
MAPublisher LabelPro Settings
MAPublisher LabelPro Styles
MAPublisher LabelPro Rules
Label Verification

MAPublisher LabelPro is available as an optional add-on to 
MAPublisher. To purchase a MAPublisher LabelPro license, 
please contact sales@avenza.com or visit www.avenza.com.

For information on how to activate a purchased or evaluation 
license please refer to chapter 1.

Note:	 The evaluation version of MAPublisher LabelPro 
scrambles the text of placed labels but preserves the 
case, spacing and punctuation, so that the results give 
a sense of how actual labels would be placed based on 
the rule settings.

MAPublisher 
LabelPro™
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MAPublisher LabelPro 
Object > MAPublisher > MAP LabelPro or MAP Toolbar  

Source - Displays MAP 
Views and its associated 
MAP Layers chosen for 
labeling in Setup Layers

Label - Click to 
specify if a layer 

should be labeled 

Label source - Choose the 
attribute containing the 

data to be used as labels 
for selected features

Output layer - Choose a 
destination from available 

text layers. The destination 
layer stores the labels.

Priority - Assign a label priority 
level to each layer. Multiple layers 
can have the same priority.

Style - Choose a default set 
of label styles or create 

custom styles that change 
label appearance

Rules - Choose a default 
set of label rules or create 
custom rules that dictate 

label placement

Suppression layer
Store labels in a layer that 

could not be placed based 
on the rules set Label filter controls

Add, copy, remove 
selected label filters. 

Label - Label based on the 
settings in the dialog box

Save - Save the current 
settings in the LabelPro 
configuration dialog 
box without performing 
labeling process

Setup Layers - Open the 
Setup Layers dialog box to 

choose which layers are 
to be used for labeling 

and/or obstacles

Label filter  - Label or 
obstacle unique values 
for a specified attribute. 
Create multiple label 
filters to perform flexible 
labeling options.

Batch generate label filters - Generate multiple 
label filters based on unique values of a 
specified attribute.

Advanced - Specify user 
defined extents for 
labeling operations

Obstacle - Click to 
specify if a layer 
should be an obstacle

Import/Export Settings  
Import or export a MAP 
LabelPro Settings file (lps), 
a format that stores all 
the settings in the current 
dialog box

Context menus
Right-click (Windows) or Ctrl-click (Mac) to access the following context menus:

Source MAP View

Source MAP Layer

Set destination layer - Set the same 
destination layer for all source 

layers in the MAP View

Set suppression layer - Set the same 
suppression layer for all source 

layers in the MAP View

Mark as obstacle / Unmark as obstacle  
Add/remove the selected layer 
to/from the obstacle list

Mark as labeled / Unmark as labeled 
Add/remove the selected layer 
to/from the labeled list

Setup layers - Opens the 
Setup  Layers dialog box

Edit style - Opens the 
Style dialog box

Edit rules - Opens the 
Rules dialog box

Batch generate label 
filters - Opens the Batch 

Label Filter Generator 
dialog box
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FUNCTIONALITY

The MAPublisher LabelPro labeling engine offers advanced labeling capabilities beyond those available in 
MAPublisher Label Features. The MAPublisher LabelPro engine contains sophisticated algorithms that solve 
many of the most common map labeling problems such as complex conflict resolution across multiple layers, the 
ability to specify data as obstacles and the ability to create complex labeling conventions via user defined rules. 
The MAPublisher LabelPro engine uses map data attributes for labeling and provides a much greater level of 
sophistication and control that can be configured through an intuitive user interface. Data layers may be assigned 
an order of prioritization for labeling sequences and existing text can be recognized as obstacles for multiple 
labeling sessions if necessary. Placement rules and properties can be saved to a settings file and imported into 
other documents.

Only Point, Line and Area layers can be labeled using MAPublisher LabelPro. Text layers may only be used as 
obstacles.

PREREQUISITES

Before labeling with MAPublisher LabelPro, it is necessary to create destination MAP Text layers (where new labels will 
be contained). Optionally, create text suppression layers for labels that can't be placed by MAPublisher LabelPro. To 
create a new text layer, use Add MAP Layer in the MAP View panel (see chapter 4).

For each source layer, MAPublisher LabelPro derives the labels from a selected attribute column. Use the 
MAP Attributes panel to analyze and/or edit the information prior to labeling. For instance, to force some labels to be 
stacked, users can insert the characters && in the MAP Attribute value to indicate a Carriage Return — this can be 
done by combining two columns into a new one or using the Find and Replace function.

MAPublisher LabelPro generates static text, therefore, the map extent and scale should be established prior to 
labeling. Once placed, labels do not maintain a link with the source data.

In MAPublisher Preferences, the base rule and style folder paths can be set for MAPublisher LabelPro. By default, 
invisible objects are ignored by MAPublisher LabelPro (they will not be labeled or used as obstacle). To take them 
into consideration, uncheck the Ignore invisible artwork option. Also, check the Merge multiline text option to create 
single line text labels. For more information about MAPublisher Preferences, see chapter 1.

USING MAPUBLISHER LABELPRO

To start MAPublisher LabelPro click the MAP LabelPro button on the MAPublisher Toolbar or from the menu 
Object > MAPublisher > MAP LabelPro.
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SETUP LAYERS

Before labeling, click Setup Layers to configure which MAP Layers are used in the Source list in the MAP LabelPro 
dialog box—these source layers can be set as obstacles, as labels, or both. Obstacles are map objects that are 
included in the conflict resolution decision making process, and are considered objects that must be avoided 
when trying to place a label. The Setup Layers dialog box displays all valid MAP Views and their MAP Layers in 
the document. To show layers in the Source list, check the appropriate Show check box to the right of the layer 
name. All layers are listed in the dialog box, but only layers that are checked will be included in the labeling 
process or considered as obstacles. All label settings (including styles and rules) are remembered even if a layer is 
subsequently not shown.

Name – Displays all MAP Views 
associated layers that can be 

used as labels or obstacles
Show – Enable the check box for 
each data layer to be shown in 
the main MAP LabelPro dialog 
box. This control enables or 
disables which source layers 
can be labeled or set as 
obstacles. Enabling the option 
beside the MAP View name 
will enable the label option 
for all the data layers that 
belong to it.

Note:	 Layers may be used as both a label and an obstacle concurrently. It is possible to perform labeling operations 
for multiple MAP Views simultaneously, however, source data layers and output text layers must belong to 
the same MAP View.

ADVANCED OPTIONS

In the Advanced options dialog box, set the Label Placement Area option to the extents based on the current 
artboard or the extents of labeled source layers. To set Label Margins, enable the option and enter the extents of the 
label container in increments of the current document units. Data that is outside of the label margins is disregarded 
in the labeling process. Right-click Label Margin boxes to change measurement units.

Extents of the current artboard 
(Default) Label all designated data 
that falls within the extents of the 

current artboard

Extents of labeled layers – Label data 
only to the extents of the selected 

MAP Layers

Label Margins – Enable to add 
margins to the selected extents

Obstacles – Enable to specify that 
paths without stroke are not 

considered obstacles.

Note:	 These settings are applied in conjunction to the settings from the Source Art section in the main MAP LabelPro 
configuration dialog box. Units for margins are determined by Document Setup in Adobe Illustrator.

MAPublisher LabelPro Settings
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LABELS AND OBSTACLES

The Source column shows the MAP View, Area, Point, Line and Text layers that are enabled in Setup Layers. Select a 
layer in the Source list and view its settings to the right of the Source list. Each layer can be set to either be labeled 
or be an obstacle. Click in the Label column beside the layer to set it to be labeled or click in the Obstacle column to 
set it to be an obstacle. Obstacles are used to prevent labels from being placed over or around specified features.

When a layer is set to be labeled, its label settings become enabled. Choose the appropriate attribute as the source 
for labels in the Label source drop-down list (see how to style labels in the MAPublisher LabelPro Styles section).

Note:	 By default, label case matches the attribute table exactly. To modify a label's case, use the Label case setting 
located in the Style dialog box.

OUTPUT AND SUPPRESSION TEXT LAYERS

Generated labels are placed on layers specified in the Output layer and Suppression layer drop-down lists. Set 
Output layers to contain only the labels that could be placed successfully on the map based on the defined rules. 
Suppression layers are repositories for labels that could not be placed successfully according to the rules and 
have not met all placement conditions. For best viewing results after labeling, hide the suppression text layers. 
Alternately, set the suppression layer to [Ignored] and unsuccessfully placed labels will not output to any layer.

Note:	 Locked output or suppression layers are displayed in red in the Source list in the configuration dialog box. 
It is normal for a certain percentage of labels to not succeed in being placed due to rule or data conflicts. 
Information regarding the success rate of placement can be reviewed in the MAPublisher Log.

PRIORITY

The Priority setting allows for complex hierarchical labeling sequences. The priority is the order of preference 
in which labels are placed. Set priority by selecting a number in the Priority setting for a respective layer. Layers 
with a priority of 1 will be placed first (high priority). Layers with a priority of 12 will be placed last (low priority). 
Consequently, layers with a low priority may have more labels sent to suppression layers (dependent on how styles 
and rules are setup). 

Note:	 A maximum of twelve priorities may be assigned at any given time, however the same priority number can 
be assigned to multiple layers.
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LABEL FILTERS

Label filters are used to label unique values for a specified attribute. For example, a road layer contains multiple 
codes to classify its type (local, highway, ramp, etc). The label filter can be based on the classification code where 
rules and styles for each filter can be customized to label each road type differently.

To add a label filter to a selected source MAP layer, click the Add Label Filter button (below the Source list). In the Label 
Filter section, the Limit by expression option provides settings to enter an expression (or use the Expression Builder 
or Expression Library—see chapter 5). The labels limited by expression will follow the label settings specified 
above the Label Filter section. A label filter can effectively be "disabled" by choosing Apply to all. This means that any 
remaining labels in the source layer that are not filtered by an expression will follow the rules and styles set in the 
label filter with the Apply to all option enabled.

Reorder label filters using the up and down arrows to the left of the Source list. The order is important if the Stop if 
art satisfies this expression option is enabled. This option can prevent subsequent label filters from being executed.

Add multiple label filters to a MAP layer to create flexible labeling options. To create multiple label filters at once, 
click the Batch generate label filters button. In the Batch Label Filter Generator dialog box, base the label filter on an 
attribute in the Attribute drop-down list and click the Load button to view how many values the chosen attribute 
has. Then choose a data classification method (Equal Intervals, Quantiles, Natural Breaks or Unique Values).  The 
number of data classes will determine the number of label filters generated. Optionally, in the Default Settings 
section, choose whether the label filters should be an obstacle, a label, or both. All the settings in this section are 
considered the default for all of the generated label filters.

Attribute – Choose an attribute 
and click Load to display 
the values into the Data 

Classification section

Data Classification – Choose 
a classification method to 
determine the expression 

used for each label filter

Default Settings – Set default 
settings for the label filters. 

Further customization for 
each label filter can be done 

after adding them here.

After adding label filters, the settings for each label filter can be further customized. Select a label filter and its 
settings appear to the right of the Source list.

To copy a label filter, click the Copy Label Filter button. To delete a label filter, click the Remove button.
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MAPublisher LabelPro Styles

POINT AND AREA STYLES

The Style dialog box is used to set label style properties for each map layer. To access the dialog box, click the 
Style edit button. Set the text properties for font family, style, size and colour. A sample preview of the stylized text 
reflects the changes made. Once the desired settings have been made, they can be collectively saved into a style file 
by clicking Save As. MAP LabelPro offers a pre-configured default style of 12 point Arial as a base labeling option (.
Once saved, styles are added to the Style drop-down list in the MAP LabelPro Configuration dialog box. 

Font family/style - Specify the font and 
font style for the labels

Size – Specify the font size

Color – Click the color chip to 
open the Adobe Illustrator  

Color Picker dialog box.
Choose by color model or pick 

colors from available swatches.

Preview – Text sample (result may not 
be exact for some font families)

Save As – Save the current settings 
into a style file

Label case – Change the label case:
•	 Leave as is: default case of the 

attribute value
•	 Convert to lower case: e.g. abcd
•	 Convert to upper case: e.g. ABCD
•	 Convert to proper case: e.g. AbcdOpacity – Specify the level of 

opacity for the labels

Add halo to label – Add a halo to 
the labels. Click the color chip 

to choose a different color. 
Adjust the size of the halo in 

the Size setting.

This is helpful in maintaining labeling consistency among similar mapping projects or when multiple users are 
working on the same project. Existing styles may be deleted by selecting it from the Style drop-down list and then 
clicking the Delete button. Style files are saved to either a point, line or area folder depending on the type of map 
layer it is associated with.

By default, styles are saved in the following location:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9\LabelPro\Styles
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\Styles
Mac OS X: Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/LabelPro/Styles

The default save path for the Styles can be modified in the MAP LabelPro section of MAPublisher Preferences. 
Choose Edit > MAPublisher Preferences (Windows) or choose Illustrator > MAPublisher Preferences (Mac).

Notes:	 For Windows, labeling with PostScript Type 1 fonts that are not placed in the Windows system font folder will 
produce a Failed to perform label placement: FontNotFound Exception error message. In these very rare cases, 
the font files should be copied from the Adobe font folder (usually under C:\Program Files\Common Files\
Adobe\Fonts\Reqrt\Base) to the Windows font folder (found from Control Panel > Fonts). Notably, Myriad font 
is such a PostScript Type 1 font that is not installed on the Windows font folder by default.

Attributes consisting of Unicode characters must be labeled with a Unicode font that contains the 
appropriate characters. For example, attempting to label Japanese characters with an Arial font will result in 
an error or incorrect results.
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LABEL LINE DATA WITH SYMBOLS

MAPublisher LabelPro has the ability to place labels inside symbols. A typical application of this would be 
numbered highway route shields. To label lines with symbols, check the Label with symbol check box to enable 
the symbol options. Choose an appropriate symbol set from the Symbol File drop-down list and select a symbol 
from the Symbol drop-down list. Use the Height option to change the size of the symbol in the Adobe Illustrator 
document unit (e.g. inches or millimeters).

Label with symbol – Enable to 
activate the symbol options

Symbol file – Choose a symbol 
file (lsf ) that contains the 

desired set of symbols

Symbol – Choose the symbol 
from this drop-down list

Height– Specify a height 
manually or allow the symbol 
to be scaled automatically 
to fit the label's text via the 
Auto option.

Symbols are stored in the location set in the MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9\LabelPro\Symbols
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\Symbols
Mac OS X: Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/LabelPro/Symbols

Notes:	 The label font size and a fixed symbol height (not Auto size) affect how a label is sized inside a symbol. For 
example, if a fixed symbol height of 0.5 in is used, but the label font size of 5 pt, the symbol will be 0.5 in but 
the label inside will be no greater than 5 pt. If the label font is set to 50 pt, but the fixed symbol size is 0.5 in, 
the label will have a maximum size of whatever fits inside the symbol or the selected font size. 
 
Each symbol file has one version in RGB colour and one in CMYK. 
 
Labeling with symbols is only available for Line layers. To label areas with symbols, use Plot Centroids in the 
MAP Point Plotter (see chapter 6).
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MAPublisher LabelPro provides users with an intuitive, easy to understand graphical user interface for setting up 
labeling rules. Each Point, Line and Area rule dialog box has numerous label placement options for a high level of 
label detail and a variety of configurations.

To access label rules for each layer, make sure it is set to be labeled, then locate the Rules drop-down list. Click the 
Rules edit button beside the list to open either the Area, Line or Point Rules dialog box.

Rules operate in a very similar approach to styles in that once added to the Rules list, they can be immediately 
applied, reused later in the same file or in other documents provided they are being applied to the same type of 
data. Rules are saved to the Area, Line or Point folder depending on the feature type of the MAP layer.

MAPublisher LabelPro offers a pre-configured [Default] rule for each data type. It is loaded by default and used until 
new rules have been created or selected. The default rules are a good starting choice as it is configured to be useful 
for the most common labeling situations, however, creating custom rules can be very useful when specific labeling 
conventions are required. Default rules can be overwritten. Saved rules are added to the Rules drop-down list.

In an Area, Point or Line Rule dialog box, the sequence in which the rule options appear and are checked have no 
bearing on the order of label placement, only whether the option is enabled or not. Adjust the Priority value of 
layers to adjust the sequence of label placement. Existing rules may be deleted by selecting them from the Rules 
drop-down list and clicking the Delete button. 

Rules are saved to the location set in MAPublisher Preferences (see chapter 1). The default locations are:

Windows XP: C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9\LabelPro\Rules
Windows Vista/7: C:\ProgramData\Avenza\MAPublisher 9\LabelPro\Rules
Mac OS X: Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/LabelPro/Rules

Note:	 Labeling results will vary depending on which rules are enabled. If no rules are enabled, MAP LabelPro will 
not perform any labeling.

MAPublisher LabelPro Rules
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AREA RULES

The Area Rules dialog box contains the label configuration options for labeling Area layers. Rules can be set by 
selecting an area feature type layer and clicking the Rules edit button in the Rules column. The placement settings in 
the screenshot below represent the default configuration, however, these settings may be changed to match any 
labeling requirements. Click the Save As button to save the label configuration. The rule will be saved with a user 
assigned name. Click OK to apply the current settings.

About Allow overlapping labels

When the Allow overlapping labels option is enabled, labels are placed without applying other placement rules. In other 
words, this discards other specified rules and labels are "forced" at its first position. Generally it is recommended to 
leave this option off and use Allow font reduction, Allow stacking, and Allow use of leader lines to increase label placement.

Notes:	 For Area type data, labels are placed relative to an object's centroid.

For areas grouped in a compound path, the largest area of the compound will be labeled.

Allow horizontal inside 
Labels are allowed to be 

placed horizontally inside 
the polygon

Allow dominant angle – Labels 
are allowed to be placed 
parallel to the dominant 

angle of the polygon

Allow extending beyond boundary  
Labels are allowed to exceed 

the boundaries of the 
polygon being labeled

Allow outside – Labels are 
allowed to be placed outside 

the polygon being labeled

Allow inside, along boundary 
Labels are allowed to be 

placed inside the polygon, 
following the polygon 

boundary

Allow stacking – Labels are 
allowed to stack up to a 
maximum of two, three, 
or four lines. Choose 
Alignment option: Feature, 
Left, Center or Right.

Allow overlapping labels 
Area Labels are allowed to 
overlap other labels in the 
same labeling session

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each step 
shrinks the selected font 
by 0.5 pt.

Allow labels to cross lines 
Labels are allowed to cross 
line features and area 
boundaries.

Allow use of leader lines – Incorporates the use of 
leader lines. Options include the number of 
lines the leader line are allowed to cross, the 
width of the leader line being used and the 
style of arrow to be used as the leader line.
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LINE RULES

The Line Rules dialog box contains the label configuration options for labeling Line layers. Rules can be set by 
selecting a line feature type layer and clicking the Line Rules edit button in the Rules column. The placement settings 
in the graphic below represent the default configuration, however, these settings may be changed to match any 
labeling requirements. Click the Save As button to save the label configuration. The rule will be saved with a user 
assigned name. Click OK to apply the current settings.

Starting Point – Specify where the start of the label is placed. Start: the 
beginning of the label placed at the starting point of the line.  
Center: label placed in the center of the line. End: label placed at the 
end of the line. The starting point of a line depends on the direction 
of the vertices.

Placement – Place labels 
using an offset or on a 

centerline. Offset labels 
Above or Below a line. 

Vertical Split places multiple 
word labels above and 

below the line and relative 
to the center of the line. 

 If the generated label only 
has one word, it will be 

placed on the suppression 
layer. The Centerline option 
places labels directly on top 

of the line.

Allow overhang – Labels  
are allowed to overhang 
the line up to a set 
percentage. The 
percentage of overhang 
is relative to the start of 
the label and the end of 
the line.

Allow stacking – Labels 
are allowed to stack to a 
maximum of two lines

Allow Labels to Cross Lines 
Labels are allowed to cross 
line features and area 
boundaries

Allow font reduction 
Automatically reduces the 
label size incrementally, 
when necessary. Each step 
shrinks the selected font 
by 0.5 pt.

Allow use of leader lines 
Incorporate the use of 
leader lines. Allowed 
Line Crosses permits the 
number of lines the leader 
line will be allowed to 
cross. Leader Width and 
Arrow Style adjusts the 
thickness and style of the 
leader line, respectively.

Label joined feature – Places 
one label on a line that is 

joined together

Label each feature – Labels 
each and every  

line segment

Divided highways – Label 
multiple road segments 
with a common symbol 

such as a shield. Lines must 
be within 0.25 inch and 

75% of the lines must be 
parallel to be considered 

a divided highway. The 
divided highway symbol 
will be placed on the line 

with the longest geometry.
Repeat labels– Repeat labels along 
a line at specified amounts

Allow overlapping labels – Allow line 
labels to overlap with other labels 
in the same labeling session

Spread words – Multiple word 
labels placed a specified 
amount apart

Notes:	 Text as obstacles will not work unless the Allow labels to cross lines option is disabled. This is because text 
obstacles are treated as areas and not as text. Also, text will only be avoided being placed where it intersects 
the outline of the shape and not within it.

Using the Placement option Vertical Split may require additional line smoothing (straightening or simplifying). 
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POINT RULES

The Point Rules dialog box contains the label configuration options for labeling Point layers and follows the same 
conventions mentioned for the previous two data types.

Placement – Click the 
placement buttons in 

the desired order of 
priority. Use the Clear 

Last or Clear All options 
to remove selections. 
Unselected positions 

will not be considered. 
Click the center 

placement button to 
set label on the center 

of the point

Allow use of leader lines 
Incorporate the use of 

leader lines. Allowed 
Line Crosses permits 
the number of lines 

the leader line will 
be allowed to cross. 

Leader Width and 
Arrow Style adjusts 

the thickness and 
style of the leader line, 

respectively.

Allow stacking – Labels are 
allowed to stack up to a 
maximum of two, three, 
or four lines. Set the 
alignment to the Feature, 
Left, Center, or Right.

Allow labels to cross lines 
Labels are allowed to 
cross line features and 
area boundaries.

Allow font reduction 
Automatically reduce the 
label size incrementally, 
when necessary. Each 
step shrinks the selected 
font by 0.5 pt.

Allow overlapping label 
Allow point labels to 
overlap with other labels 
in the same labeling 
session

Note:	 For each point label there is a fixed minimal zone of 0.3 inches, within which no other point feature can be 
labelled. Consequently, when two point features are closer than 0.3 inches of each other, their labels are 
automatically placed in the suppression layer (if selected).

SAVE AND LABEL

Once the layers, main configuration, style and rule based options have been completed, proceed to label the map data 
by clicking the Label button. Click the Label button to save the current settings, close the main MAP LabelPro dialog 
box and begin the labeling process.

Due to the complexity of the calculations involved in rule based text placement, a progress meter will be displayed 
for most labeling processes except those that are sufficiently simple or small. Cancel the labeling process at any 
time by clicking the Cancel button in the progress dialog box.

Alternatively, save the current settings without labeling by clicking the Save button. This will close the main MAP 
LabelPro configuration dialog box and will not label any features. The dialog box can be reopened later to edit the 
saved label settings or be used to label the map.
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IMPORT AND EXPORT SETTINGS

MAPublisher LabelPro settings can be saved to a LabelPro Settings file (LPS). In the MAPublisher LabelPro dialog box, 
click the Export Settings button.

The Saved Styles & Rules drop-down list contains two save options: Save contents and Save reference only. Save 
contents saves all layer and obstacle settings including styles and rules. Save reference only saves only the reference 
to the Style and Rule (meaning the individual settings in Style and Rule could change, but the reference to it is kept 
intact). Click the Include advanced settings option to also save settings from the Advanced dialog box.

To import a LabelPro Settings file, cilck the Import Settings button and navigate to the location of it.
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The graphic below shows results of a typical labeling result using options such as stack labels, repeat labels, allow 
labels to cross lines, and many others.

Verify that labels were successfully placed in accordance to the rule base set out in the MAP LabelPro configuration. 
Also verify that labels were placed on the appropriate Output layers. Text failing to meet the labeling criteria will 
be placed in a Suppression layer (if one is available and has been set). If no Suppression layer is available, the label 
is ignored and is not generated. Once placed, the labels are considered standard text and may be further modified 
using Adobe Illustrator or MAPublisher operations.

Note:	 Undo and Redo operations are supported when labeling. LabelPro settings are retained after an Undo.

MAPublisher Log

Open the MAPublisher Log to view statistical information after the labeling process is completed. This information 
is useful in determining how successful the labeling operation was based on the number of labels written to 
Destination and Suppression layers. It may help indicate whether adjustments to the rule base are required to 
achieve a higher rate of successful placement. The log can be exported as a text file for future reference.

Label Verification
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Graphic File Formats 
AI
The Adobe Illustrator native postscript file format. Refer to the Adobe Illustrator User Guide for more information.

DOQ
Digital Orthophoto Quadrangle (DOQ) are geographic images from the United States Geological Survey (USGS) and 
are stored in the JPG format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register 
Image function. DOQ are usually very large files (30 MB or more) and require extremely large amounts of RAM.

DRG
Digital Raster Graphics (DRG) are scanned images of published topographic maps from the USGS stored in TIF 
format. They can be placed by Adobe Illustrator and registered by the MAPublisher Register Image function. DRG 
are also usually very large files (30 MB or more) and require extremely large amounts of RAM.

EPS
The Encapsulated Post Script (EPS) file is used to transfer PostScript language artwork between applications. EPS 
files are easily opened by Adobe Illustrator because the format is widely supported by most graphics programs. It 
is the preferred format for export to most illustration and page-layout programs. EPS files are vector based, but can 
contain embedded raster graphics and fonts.

GIF
Graphic Interchange Format (GIF) is a colour-indexed graphics format, commonly used for web pages and image file 
transfer. Adobe Illustrator can export 8-bit indexed-colour or grayscale GIF.

JPEG
Joint Photographic Experts Group (JPEG or JPG) is a compression technique for raster file formats. The Digital 
Orthophoto Quadrangle geographic images from the USGS are stored in this format, which can be imported by 
Adobe Illustrator and registered by the MAPublisher Register Image function.

PDF / GEOSPATIAL PDF
Portable Document Format (PDF) is a standardized format developed by Adobe for use across Macintosh, Windows, 
DOS, and UNIX platforms. Based on the PostScript Level 2 language, PDF supports both raster and vector graphics. 
A Geospatial PDF is an Adobe Acrobat file that retains geospatial coordinates.

TIF/TIFF (GEOTIFF)
Tagged Image File Format (TIFF or TIF) is a common raster graphic file format that can be imported by Adobe 
Illustrator. Many raster geographic images from GIS systems are stored in this format, which can be imported 
by Adobe Illustrator and registered by the MAPublisher Register Image function. A GeoTIFF is a TIFF file with 
embedded geographic information identifying its position and scale in world coordinates.

OTHERS
Please refer to the Adobe Illustrator User Guide for other graphics file formats supported by Adobe Illustrator.

Appendix 1: Technical Reference Guide
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This section contains descriptions of the GIS formats supported for import by MAPublisher. Here you will find 
an overview of the structure of each format, as well as information on supported format versions and elements 
unique to each data type. Each file format will carry a checklist covering which core elements are supported by 
MAPublisher during its import. You can also refer to the Frequently Asked Questions section in this guide for 
information on any issues associated with the various file formats.  Also see chapter 2 on Map Data File Formats.

AUTOCAD DRAWING (DWG) AND DRAWING EXCHANGE (DXF)

There are two formats used by AutoCAD: DXF and DWG. DXF is a CAD data file format, developed by Autodesk as 
their solution for enabling data interoperability between AutoCAD and other programs. The DWG format is used for 
storing two and three dimensional design data and is the internal format for the AutoCAD Computer Aided Design 
package. DWG is also the common name for AutoCAD proprietary DWG technology developed by Autodesk for 
their AutoCAD package.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dwg, *.dxf	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  Yes 
	 User-Defined Attributes 	 Yes		  Circular Arc	 Yes 
	 Coordinate System Support 	 No		  Elliptical Arc 	 Yes 
	 Generic Colour Support 	 Yes		  Ellipses 		  Yes 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 3D Support		  Yes		  Point 		  Yes
						      Line 		  Yes
						      Text 		  Yes
	 Supported Versions
 	 Windows: Releases vrs. R12 to 2007
	 Mac OS X: Releases vrs. R12 to 2007. 

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Group Entities - Group entities by Layer Name or Geometry. 
•	 Hatches - Check this box if you want MAPublisher to read your hatch patterns upon import.
•	 White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the 

original colour settings contained in the file. Check the Change white lines and fills to black box to import black 
lines instead of the files native white lines. Check the Create black background option to incorporate a layer 
containing a black background to mimic the AutoCAD environment.

MAPublisher Import Formats 
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DELIMITED ASCII TEXT (CSV, TSV, TXT )

An ASCII file containing a tabular data where delimiters separate the columns and rows. Common delimiters are 
commas, spaces or tabs. Microsoft Excel and many other spreadsheet programs will export data in these formats. 

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.csv, *.tsv, *.txt	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 No 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  No
	 Schema Required 		  Yes		  Donut Polygon 	 No
						      Point 		  Yes
						      Line 		  No
						      Text 		  No

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import: 

•	 Axis Column - Specify which columns contain the x and y coordinates for the point data to be read in.
•	 Coordinate Format - Choose the formatting type of the data you wish to import (e.g. Decimal Degrees, Delimited 

Degrees Minutes Seconds, Packed DMS) — formats are described in chapter 6.
•	 Use first line as header - Allows the user to enable the first line of the text file to be used as column headings.

ESRI INTERCHANGE FILE (E00)

An archive of files that describes a complete ArcInfo coverage. This is either ASCII or compressed into a binary and is 
used to transfer files between different versions of ArcInfo. It is a commonly found format for freely distributed data 
such as that found at the GIS Data Depot (http://www.geocomm.com).

A single E00 file describes a complete ArcInfo coverage. The file itself is actually an archive of several smaller files, 
referred to as subfiles. Some of these subfiles have fixed names which do not vary from coverage to coverage, and 
follow a predefined data format. The remainder of the subfiles contained within an E00 are the info files. These files 
may contain user-defined attributes, and have names which vary from coverage to coverage. 

	 Supported Elements				     Supported Geometry
	 Typical File Extensions 	 *.e00		   Aggregate 	 No
	 Automated Translation	 Yes		   Circles 		  No 
	 User-Defined Attributes 	 Yes		   Circular Arc	 Yes 
	 Coordinate System Support 	 Yes		   Elliptical Arc 	 Yes 
	 Spatial Index 		  Never		   Ellipses 		  No 
	 Schema Required 		  Yes		   Polygon 		  Yes
	 Geometry Type Attribute 	 e00_type		  Donut Polygon 	 Yes
						      Point 		  Yes
			    			   Line 		  Yes
						      Text 		  Yes		

There are essentially four types of geometry defined in E00 files, which will be reproduced as layers during import:
Arcs (lines), Points, Polygons, and Text. Prior to the import process, an additional Setting can be made:

•	 Tic points layer - This option enables you to include an additional layer which will hold the registration points for the 
imported data. The default is to set to Yes.
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ESRI ARCINFO GENERATE (GEN)

Esri simple ASCII storage and interchange format. There are three different types of .gen files each with of its own 
syntax one for points, one for lines, and one for text geometries. This is the format exported by ArcInfo generate 
command. The *.gen files are use by ArcInfo to transfer coverages to other mapping systems.

	 Supported Elements			    	 Supported Geometry
	 Typical File Extensions 	 *.gen		   Aggregate 	 No
	 Automated Translation	 Yes		   Circles 		  No 
	 User-Defined Attributes 	 No		   Circular Arc	 No 
	 Coordinate System Support 	 No		   Elliptical Arc 	 No 
	 Generic Colour Support 	 No		   Ellipses 		  No 
	 Spatial Index 		  Never		   Polygon 		  No
	 Schema Required 		  Yes		   Donut Polygon 	 No
	 Geometry Type Attribute 	 arcgen_geometry	  Point 		  Yes
						       Line 		  Yes
						       Text		  Yes		

ESRI GEODATABASES

A Geodatabase is a native Esri ArcGIS data format for storing geographic data. It is a collection of geographic 
datasets of various types used in ArcGIS and managed in either a file folder or a relational database. There are two 
main types of geodatabases: 

•	 Single-User: Personal Geodatabases (extension *.mdb) and File Geodatabases (extension *.gdb)
•	 Multi-User: server based geodatabases, also known as ArcSDE Geodatabases.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.mdb (personal), *.gdb (file) 	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  Yes 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes			   Elliptical Arc 	 Yes
	 Generic Colour Support 	 No			   Ellipses 		  Yes
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Transaction Support 		  Yes			   Point 		  Yes
	 Enhanced Geometry		  Yes			   Line 		  Yes
	 Geometry Type Attribute 	 geodb_type		  Text 		  Yes
	 Encoding Support		  Yes			   Raster		  No
							       Solid		  No
							       Surface		  No
							       Z value		  Yes
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ESRI SHAPEFILE (SHP)

The Esri Shapefile is a geospatial vector data format for geographic information systems software. It is developed 
and regulated by Esri as a mostly open specification for data interoperability among Esri and other software 
products. A Shapefile is a digital vector storage format for storing geometric location and associated attribute 
information. This format lacks the capacity to store topological information

A single logical Shapefile consists of three physical files, each with one of the following file name extensions:
*.shp :	 Geometric data
*.shx :	 Index to the geometric data
*.dbf :	 Attributes for the geometric data

These extensions are added to the base name of the Shapefile , creating separate physical files that must all reside 
in the same directory. You must select the *.shp file for import. Point, multipoint, polyline, and polygon geometric 
data can be stored in *.shp files. However, a single *.shp file can contain only one type of geometry. Each entity in 
a *.shp file has a corresponding entry in the *.shx index file and a corresponding row of attributes in the associated 
*.dbf file. The order of the entries in each of these files is synchronized. For example, the 3rd geometric entity in the 
*.shp file is pointed to by the 3rd entry in the *.shx index file and has the attributes held in the 3rd row of the *.dbf. 

A single Shapefile may also consist of a number of additional files, with the following file name extensions:
*.sbn / *.sbx : 	Spatial index files for the geometric data. These two files are only generating by an Esri product 
however they are not required by MAPublisher for import and will they be generated when exporting data to the 
Shapefile format..
*.prj :	 Spatial coordinate system information.

If a *.prj file exists in your Shapefile directory, holding the coordinate system information of the Shapefile , this will 
automatically be read by MAPublisher on import. If your Shapefile folder does not contain a .prj file you will be 
required to specify the coordinate system in order to fully utilize MAPublisher. 

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.shp (*.shx, *.dbf, *.prj)	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  No 
	 User-Defined Attributes 	 Yes			   Circular Arc	 No
	 Coordinate System Support 	 Yes (if have *.prj)		  Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No 
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 SHAPE_GEOMETRY		  Line 		  Yes
							       Text 		  No
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GEOGRAPHY MARKUP LANGUAGE - SIMPLE FEATURES (GML)

GML was designed as a geographic interface language for the Geo-Web. It is currently in draft as an ISO standard 
(ISO 19136). The goal of the format is to provide users with a set of abstract base objects that can be built into 
working real world datasets. It uses as XML base to store geometry and feature information that can easily be 
transported across the Internet. 

The GML simple feature profile was created by the Open Geospatial Consortium as a restricted subset of the GML 
specification. It provides a reduced geometry and metadata profile that can be shared across many GIS tasks. This 
simple feature model can be used as a base to generate local application profiles for a specific work area. Since the 
GML models base abstract classes, these application profiles (schemas) are required for accessing and processing 
any GML datasets. Generally, GML data has a *.gml extension, and requires any application specific schema files 
(*.xsd).  For more information on GML, and the GML simple features profile, please visit the Open Geospatial 
Consortium web site: www.opengeospatial.com
	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.gml (*.xml) *.xsd		  Aggregate 	 Yes
	 Automated Translation	 Varies			   Circles 		  No 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  Yes (*.xsd)			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 xml_type			   Line 		  Yes
							       Text 		  No

GOOGLE EARTH (KML, KMZ)

KML is an XML-based language for managing the display of three-dimensional geospatial data in the programs 
Google Earth, Google Maps, Google Mobile and WorldWind. The KML file specifies a set of features for display. Each 
feature always has a longitude and a latitude and can have other data, such as tilt, heading, and altitude. KML shares 
some of the same structural grammar as GML. KML files are very often distributed as KMZ files, which are zipped 
KML files with a .kmz extension. MAPublisher uses KML version 2.2 specifications for import and export.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.kml, *.kmz	 Aggregate 	 Yes
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 Yes		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  No		  Donut Polygon 	 Yes
	 3D Support		  Yes		  Point 		  Yes
						      Line 		  Yes
						      Text 		  No

Prior to the import process, additional Settings can be made, which will affect how the selected KML file will import. 
The following parameters can be applied to the import: 

•	 Allow Random Colour Mode - This option allows Adobe Illustrator to generate random colour settings for the data.
•	 Expand Network Links - Checking this box will enable the use of network linked KML files.
•	 Import KML Properties as Visible - Check this option to make KML properties visible attributes (hidden by default).
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MAPINFO INTERCHANGE FORMAT (MIF)

MIF is a published ASCII storage format used by the MapInfo. It is used as a file format for map and database 
exporting/importing in MapInfo software products. The MapInfo Reference Manual describes the MIF format and all 
constants it uses for colour, style, symbol, and fill patterns. MapInfo Interchange Format Files are often called MIF or 
MIF/MID files. 

A single logical MIF file consists of two physical files, having the following file name extensions:
*.mif :	 Geometric data
*.mid :	 Attributes for the geometric data

These extensions are added to the base name of the MIF file, creating separate physical files that must all reside in 
the same directory. You must select the *.mif file for import.

Each entity in a *.mif file has a row of attributes stored in an associated *.mid file. A single .mif file contains many 
different types of geometry however, the associated attribute in the *.mid file must have the same number and 
type of fields for each entity in the *.mif file. The order of the entries in the two files is synchronized. For example, 
the second geometric entity in the *.mif file has the attributes held in the second row of the *.mid file. The number 
and type of attributes associated with each entity is specified by the user. There must be at least one attribute field 
in the *.mid file.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.mif (*.mid)	  Aggregate 	 Yes
	 Automated Translation	 Yes		   Circles 		  Yes 
	 User-Defined Attributes 	 Yes		   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 		   Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes		   Ellipses 		  Yes 
	 Spatial Index 		  Never		   Polygon 		  Yes
	 Schema Required 		  Yes		   Donut Polygon 	 Yes
	 Geometry Type Attribute 	 mif_type		   Point 		  Yes
						       Line 		  Yes
						       Text 		  Yes

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute 
table.

The MAPublisher MID/MIF importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded 
rectangle, region (polygon), and text geometric data in *.mif files. Each geometric entity present in a *.mif file has 
display properties such as pen and brush width, pattern, and colour. Supported MID/MIF properties are as follows:

MAPublisher supports the import of line weights (0-7), colours (24 bit RGB), strokes (1-71). It also supports fonts 
(family, style, justification) for text. In order to use line patterns and fill patterns you must have opened or accessed 
the style library equivalents. Two library files have been created, MIF - Line Styles.ai and MIF - Area Styles.ai, which 
provide support for many of the standard MapInfo pen styles (stroke patterns) and brush styles (fill patterns). These 
files can be found in the Helpful Styles & Symbols folder installed with MAPublisher. Please refer to your Adobe 
Illustrator User Guide for details about how to add these libraries to your Adobe Illustrator Graphic Style panel. 
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MAPINFO TABLE (TAB)

TAB is a proprietary geospatial vector data format for geographic information systems software used by MapInfo 
mapping products. A minimum of two files are required for the tab format. The .DAT file which stores the attribute 
data and the .TAB ASCII file which is the link between all other files and holds information about the type of data 
file. The MapInfo TAB importer is closely patterned after the MapInfo MIF/MID reader and writer. This commonality 
makes it easy to support both MIF and MapInfo native formats in the same mapping file. 

A single logical TAB file consists of a number of physical files, having the following file name extensions:
*.tab :	 The main file for a MapInfo table, it is associated with the appropriate dat, map, id and ind files.
*.dat :	 Tabular data for a table in MapInfo native format
*.id :	 An index to a MapInfo graphical objects (MAP) file.
*.map :	 Contains geographic information describing map objects
*.ind :	 An index to a MapInfo tabular (DAT) file

These extensions are added to the base name of the TAB file, creating separate physical files that must all reside in 
the same directory. You must select the *.tab file for import.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.tab (*.dat, *.id, *.map, *.ind)	 Aggregate 	 Yes
	 Automated Translation	 Yes			   Circles 		  Yes 
	 User-Defined Attributes 	 Yes			   Circular Arc	 Yes
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes			   Ellipses 		  Yes 
	 Spatial Index 		  Always			   Polygon 		  Yes
	 Schema Required 		  Yes			   Donut Polygon 	 Yes
	 Geometry Type Attribute 	 mapinfo_type		  Point 		  Yes
								        Line 		  Yes				  
								        Text 		  Yes		

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import:

•	 Import as Visible Attributes - Enable this option to view the pen and brush pattern values in the imported attribute 
table

The MAPublisher TAB importer supports the storage of point, line, polyline, arc, ellipse, rectangle, rounded 
rectangle, region (polygon), and text geometric data in .tab files. Each geometric entity present in a *.tab file 
has display properties such as pen and brush width, pattern, and colour. Supported TAB properties match those 
described for MID MIF files on the previous page.

Raster TAB files cannot be imported in MAPublisher.
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MICROSTATION DESIGN (DGN)

DGN are the native files created for Bentley Systems Inc. MicroStation product. These files consist of a header, 
followed by a series of elements. The header contains global information including the transformation equation 
from design units to user coordinates, as well as the dimension of the elements in the file. Each element contains 
standard display information, such as its colour, level, class, and style, as well as a number of attributes specific to 
its element type. For example, a text element has fields for font, size, and the text string in addition to the standard 
display attributes.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dgn		  Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  Yes 
	 User-Defined Attributes 	 Yes		  Circular Arc	 Yes
	 Coordinate System Support 	 No 		  Elliptical Arc 	 Yes
	 Generic Colour Support 	 Yes		  Ellipses 		  Yes 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 Geometry Type Attribute 	 igds_type		  Point 		  Yes
	 3D Support		  Yes		  Line 		  Yes
						      Text 		  Yes
	 Supported Versions
 	 Windows: V7, V8. Mac OS X: V7,V8

Prior to the import process, additional Settings can be made, which will affect how the selected file will import. The 
following parameters can be applied to the import. Note: versions V7 and V8 are supported for import, attached raster 
files are ignored.

•	 Group Elements - Choose how you want to group the elements of the file on import. If you group the elements by 
level, it may result in a large number of output files. By Level is the default.

•	 Coordinate Units - Choose Master or UOR (Unit of Resolution) as the coordinate units. Master is the default.
•	 White Lines and Fills - Enabling the Import as is option will instruct MAPublisher to import the data true to the 

original colour settings contained in the file. Check the Change white lines and fills to black box to import black 
lines instead of the files native white lines. Check the Create black background option to incorporate a layer 
containing a black background to mimic the AutoCAD environment.

•	 Other - Check Drop complex chains if you want each component of a complex chain to be returned as its own 
feature, otherwise all elements of the complex chain will be merged into a single linear feature. 

Note:	 Line weight in Microstation are integer number only, as such, the Microstation export will round the Adobe 
Illustrator stroke width. 0 is a valid line weight in Microstation.
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INTERNATIONAL HYDROGRAPHIC OFFICE S-57 FORMAT (000)

S-57format is intended for the exchange of digital hydrographic data between national hydrographic offices and 
for its distribution to manufacturers, mariners and other data users. It is used for the supply of ENC cells (Electronic 
Navigational Charts) to ECDIS (Electronic Chart Display and Information System).

The format is public, developed and maintained by the IHO (International Hydrographic Office) CHRIS working 
committee (Committee on Hydrographic Requirements for Information Systems). The objects spatial geometry can 
be of Point, Line or Area geometry, while object descriptions are categorized in object classes, organized in specific 
attributes schemas. For a full format description, please visit http://www.iho.shom.fr/PUBLICATIONS/IHO_Download.
htm#S-57 (Appendix A in particular). An online object catalog is also available on www.s-57.com

An S-57 base file has the extension *.000, while the update files have extensions like .001, .002 and so on. It can also 
be accompanied by other files:
*.000: main file
*.001: update file 1
*.002: update file 2
*.00n: update file n
files.TXT and files.JPG: ancillary text and picture files indicated in attribute definition

Update files contains only the changed (new/deleted/modified) objects and are only used as a complement 
of a .000 file. Only the *.000 file is required for the import into MAPublisher. The update files will be applied at 
conversion, when present. However, text and image files linked to attributes will be ignored.

	 Supported Elements					     Supported Geometry
	 Typical File Extensions 	 *.000 (*.001 *.002...)		  Aggregate 	 No
	 Automated Translation	 Yes			   Circles 		  No 
	 User-Defined Attributes 	 No			   Circular Arc	 No
	 Coordinate System Support 	 Yes 			   Elliptical Arc 	 No
	 Generic Colour Support 	 No			   Ellipses 		  No
	 3D Support 		  Yes			   Polygon 		  Yes
	 Schema Required 		  N/A			   Donut Polygon 	 Yes
	 Transaction Support 		  No			   Point 		  Yes
	 Geometry Type Attribute 	 s57_type			   Line 		  Yes
							       Text 		  No

Note:	 Most ENC producers (private and public) publish their .000 files in encrypted formats. Only non-encrypted 
files can be imported in MAPublisher (from NOAA or USACE for example).
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TIGER/LINE (RT1, BW1)

Topologically Integrated Geographic Encoding and Referencing (TIGER). TIGER is the United States Census Bureau 
format for its digital database of geographic features. TIGER includes both land attributes such as roads, buildings, 
rivers, and lakes, as well as areas such as counties, ZIP codes, census tracts, and census blocks. Some of the 
geographic areas represented in TIGER are political areas, including counties, congressional districts, school districts, 
and ZIP codes. Others are statistical areas, including Metropolitan Statistical Areas (MSA), census tracts, census block 
groups, and census block. The database contains information about these features such as their location in latitude 
and longitude, the name, the type of feature, address ranges for most streets, the geographic relationship to other 
features, and other related information. More information on the TIGER/Line file format and data product can be 
found on the U.S. Census web page at: http://www.census.gov/geo/www/tiger/
This web site contains a detailed description of the current TIGER/Line format, with an explanation of field meaning 
for each feature type. A detailed description of the TIGER/Line 1998 format, with an explanation of field meaning for 
each feature type, is available at: http://www.census.gov/geo/www/tiger/tiger98.pdf

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.rt1, *.bw1	 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 Yes		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 Yes		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  Yes		  Donut Polygon 	 Yes
	 Transaction Support 		  No		  Point 		  Yes
	 Geometry Type Attribute 	 tiger_type		 Line 		  Yes
						      Text 		  No
	 Supported Versions:  	 1992, 1995, 1997, 1998, 1999, 2000, 2002

USGS SDTS (*CATD.DDF)

SDTS is the USGS robust way of transferring Earth-referenced spatial data between dissimilar computer systems with 
the potential for no information loss. It is a transfer standard that embraces the philosophy of self-contained transfers, 
i.e. spatial data, attribute, georeferencing, data quality report, data dictionary, and other supporting metadata all 
included in the transfer. More info can be found at http://mcmcweb.er.usgs.gov/sdts/. Files in the SDTS format will 
have the extension *.ddf. More information on this format can be found at: http://mcmcweb.er.usgs.gov/sdts/

A group of *.ddf files is normally identified by the catalog file, or *CATD.DDF file, which relates the files of a single 
SDTS transfer, and binds together all the files with a common prefix. Always select the SDTS file which ends in CATD, 
i.e. HP01CATD.DDF. 

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.ddf		  Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 No		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Yes		  Polygon 		  Yes
	 Schema Required 		  N/A		  Donut Polygon 	 Yes
	 Transaction Support 		  No		  Point 		  Yes
	 Geometry Type Attribute 	 sdts_type		  Line 		  Yes
						      Text 		  No
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USGS DIGITAL LINE GRAPH (DLG) (OPT)

DLG is a fixed field record that may or may not have end of line markers. The DLG file structure was designed to 
accommodate all categories of spatial data represented on a conventional line map. DLG is a published ASCII format 
developed by the United States Geological Survey (USGS) Federal Agency and is intended to assist in data exchange 
with the National Digital Cartographic Data Base (NDCDB).

The DLG reader supports all three distinct types of DLG data:
	 • Large-scale DLG data (1:24,000-scale)
	 • Intermediate-scale DLG (1:100,000-scale)
	 • Small-scale DLG data (1:2,000,000-scale)

The three scales of DLG data are physically formatted into files in one of these ways: standard, optional, and graphics 
formats. MAPublisher supports both the standard and the optional DLG distribution formats; however the graphics 
format is not supported. Most DLG data is distributed in the optional format. The DLG file structure was designed to 
accommodate all categories of spatial data represented on a conventional line map. Node, line, and area data types 
are present within the DLG format, along with linkages and attribute codes. Linkages are references to other features 
within the same DLG data set, used in a variety of contexts. DLG files do not explicitly store attribute values but use a 
feature coding approach in which unique feature codes are assigned to the different types of features stored within 
the data set. MAPublisher will look for the extension .dlg or .opt for the input DLG files.

	 Supported Elements				    Supported Geometry
	 Typical File Extensions 	 *.dlg, *.opt		 Aggregate 	 No
	 Automated Translation	 Yes		  Circles 		  No 
	 User-Defined Attributes 	 No		  Circular Arc	 No
	 Coordinate System Support 	 Yes 		  Elliptical Arc 	 No
	 Generic Colour Support 	 No		  Ellipses 		  No 
	 Spatial Index 		  Never		  Polygon 		  Yes
	 Schema Required 		  No		  Donut Polygon 	 Yes
	 Geometry Type Attribute 	 dlg_type		  Point 		  Yes
						      Line 		  Yes
						      Text 		  No
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MAPublisher Unicode Support 

This section contains information regarding Unicode character encoding in MAPublisher. MAPublisher supports 
Unicode character encoding in MAP Views, MAP Attributes, MAP Themes, and MAP Selections. MAPublisher can also 
reference Adobe Illustrator layers, graphic styles and character styles using Unicode encoding.  

To use Unicode character encoding you require a Unicode compliant font. Mac OS X users will have Unicode 
compliant fonts installed with OS X. Windows users will require Unicode compliant fonts to render Unicode. For 
more information on Unicode visit http://www.unicode.org. 

The following tables display Unicode—UTF8 support in MAPublisher, for GIS data formats that are Unicode—UTF8 
compliant. Unicode support for importing and exporting data is different, so for each platform two tables have 
been created. For each data format there are four areas where Unicode character encoding can be used:

1. File Directory - when Unicode encoding is used in the path to where the file is located.
2. Filename - when Unicode encoding is used in the filename.
3. Attribute column name - when Unicode encoding is used in a column name for attributes.
4. Attribute value - when an attribute value contains Unicode encoding.

Windows Unicode Support (Import)

Data Format File  
Directory Filename

Attribute 
Column 

Name

Attribute 
Value

Delimited 
Text P P P P

CAD-DWG P P FORMAT HAS NO  
ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri ArcInfo 
Generate P P FORMAT HAS NO  

ATTRIBUTES

Esri ArcSDE 
Geodatabase P P P P

Esri File 
Geodatabase P P P P

Esri Inter-
change File P P P P

Esri Personal 
Geodatabase P P P P

Esri  
Shapefile P P P P

GML (Simple 
Features) P P P P
MapInfo  
MIF/MID P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML/KMZ P P P P
S57 P P

FORMAT USES SIMPLE 
ASCII TEXT FOR ATTRIBUTE 
NAMES AND MOST VALUES

Windows Unicode Support (Export)

Data Format File  
Directory Filename

Attribute 
Column 

Name

Attribute 
Value

Delimited 
Text P P P P

CAD-DWG P P FORMAT HAS NO  
ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri Inter-
change File P P P P
Esri ArcInfo 

Generate P P FORMAT HAS NO  
ATTRIBUTES

Esri  
Shapefile P P P P

GML (Simple 
Features) P P P P
MapInfo  
MIF/MID P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML P P P P
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Mac OS X Unicode Support (Import)

Data Format File  
Directory

File-
name

Attribute 
Column 

Name

Attribute 
Value 

Delimited Text P P P P
CAD-DWG P P FORMAT HAS NO  

ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri ArcInfo 
Generate P P FORMAT HAS NO  

ATTRIBUTES

Esri ArcSDE 
Geodatabase NOT SUPPORTED ON MAC OS X

Esri File 
Geodatabase NOT SUPPORTED ON MAC OS X

Esri Inter-
change File P P P P

Esri Personal 
Geodatabase NOT SUPPORTED ON MAC OS X

Esri Shapefile P P P P
GML (Simple 

Features) P P P P
MapInfo  
MID/MIF P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML/KMZ P P P P
S57 P P

FORMAT USES SIMPLE 
ASCII TEXT FOR ATTRIBUTE 

NAMES AND MOST 
VALUES

Mac OS X Unicode Support (Export)

Data Format File  
Directory

File-
name

Attribute 
Column 

Name

Attribute 
Value 

Delimited Text P P P P
CAD-DWG P P FORMAT HAS NO  

ATTRIBUTES

CAD-DXF P P FORMAT HAS NO  
ATTRIBUTES

Esri Inter-
change File P P P P
Esri ArcInfo 

Generate P P FORMAT HAS NO  
ATTRIBUTES

Esri Shapefile P P P P
GML (Simple 

Features) P P P P
MapInfo  
MID/MIF P P O P

MapInfo TAB P P O P
MicroStation 

Design O O FORMAT HAS NO  
ATTRIBUTES

KML P P P P



A1/15﻿
﻿

Windows Unicode Support  
(Working with Images)

Data Format File Directory 
(Register Image)

Filename 
(Register Image)

File Directory 
(Export Image)

Filename 
(Export Image)

World File (.tfw) P 
Û

/ P
t

P 
Û 

/ P 
t

P 
Û

/ O
t

P 
Û

/ O
t

Image Report (.irp) P 
Û 

/ P 
t

P 
Û 

/ P
t

P 
Û

/ O 
t

P 
Û

/ O 
t

MapInfo TAB (.tab) P 
Û

/ P
t

P 
Û

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O 
t

ListGeo (.lgo) P 
Û 

/ P 
t

P 
Û 

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O
t

GeoTIFF (.tif) P 
Û

/ P 
t

P 
Û

/ P 
t

P 
Û

/ O 
t

P 
Û

/ O
t

ÛWhen using system encoding  
 on Windows XP 
 (for example, using the default 
Japanese encoding on Japanese 
Windows XP)

t�When using non-system 
encoding on Windows XP 
(for example, using Japanese 
encoding on English Windows XP)

Mac OS X Unicode Support  
(Working with Images)

Data Format File Directory 
(Register Image)

Filename 
(Register Image)

File Directory 
(Export Image)

Filename 
(Export Image)

World File (.tfw)  P 
�

P 
�

P 
�

P 
�

Image Report (.irp)  P 
�

P 
�

P 
�

P 
�

MapInfo TAB (.tab)  P 
�

P 
�

P 
�

P 
�

ListGeo (.lgo)  P 
�

P 
�

P 
�

P 
�

GeoTIFF (.tif)  P 
�

P 
�

P 
�

P 
�

�Limited support 
 (not all combinations of Unicode 	 
characters are supported) 
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Technical Support Options / FAQ 

MAPublisher support is provided free of charge to customers with a current MAPublisher Maintenance Program 
(MMP) subscription. All new license and upgrade purchases include a one year MMP subscription. Customers 
without a current MMP subscription may obtain support from a qualified MAPublisher technical specialist at the 
rate of US$49 per incident.

TECHNICAL SUPPORT

Please consult the FAQs, the additional how-to’s on the following pages as well as the following online options 
before contacting Avenza technical support as your situation may be easily addressed by one of the answers 
contained therein.

MAPublisher Online Resources
The Avenza Systems Inc. Website provides additional source of information to assist you in the use of MAPublisher. 
The Avenza Resources are located at http://www.avenza.com/resources

•	 Avenza Resources Blog: tips, how-tos and news on MAPublisher and Geographic Imager software.
•	 Map Gallery: examples of maps created with MAPublisher.
•	 Styles and Symbols: a collection of styles and symbols to help make your maps look better. 
•	 User Forums and Frequently Asked Questions: answers to common technical questions may be 

found in the Common Support Issues and FAQs category. All users with a MAPublisher license (evaluation or 
permanent) can post and read topics under the General Questions for Evaluation and Licensed Users category. 
Additionally, users with maintenance have access to the Maintenance Users category. There, users can find 
additional information relative to software updates, etc.

•	 MAP Web Author API and CSS: find advanced information on MAP Web Author API functions and CSS 
support - see chapter 15 for more details.

Contacting Avenza Technical Support

Avenza offers a number of methods for direct communication with our qualified and experienced technical experts. 
Please have your MAPublisher registration details handy to get prompt attention and include it in any email 
correspondence. Support issues are handled on a first come, first-served basis. For non-maintenance users, Avenza 
does not guarantee a response within any specified time. MAPublisher Maintenance Program subscribers receive 
free and unlimited support. All others are eligible for support at the rate of US$49 per incident.

•	 Hours: 9:00am to 4:00pm Eastern Standard Time
•	 Email: support@avenza.com 
•	 Online request form: http://www.avenza.com/support/form
•	 Phone: +1 (416) 487-6442
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MAPUBLISHER MAINTENANCE PROGRAM (MMP)

The MAPublisher Maintenance Program is a subscription-based service plan that guarantees its members:
•	 unlimited priority technical support—guaranteed same business day or next business day response
•	 unlimited telephone support
•	 free MAPublisher updates
•	 free MAPublisher version upgrades
•	 additional discounts and offers available to MMP members only

Your MAPublisher purchase includes a one-year membership in the MAPublisher Maintenance Program so you are 
well on the way to worry-free use of MAPublisher for the first year and will be able to enjoy all the benefits of the 
MMP immediately. All MAPublisher Maintenance Program subscriptions begin on the date of purchase and run for 
one calendar year.

Your email address has been automatically entered in the mp-maintenance-l online email list for MMP subscribers 
so that you are assured of receiving all the latest MMP news and access to all the update and upgrade files. If you 
purchased your MAPublisher license from a reseller or are the end user but not the person who purchased the 
software, please contact us at sales@avenza.com to ensure that we receive your email address and add you to the 
MMP notification group.

Renewal
You will be notified regarding renewal options approximately six to eight weeks prior to the expiration of your 
annual MMP subscription. You will be contacted a minimum of five times prior to expiration in order to ensure that 
you have ample opportunity to renew or not at your discretion. You will have the option of renewing your MMP for 
an additional year at the then prevailing price or canceling without penalty. Of course, if you cancel or let your MMP 
lapse you will no longer be entitled to the benefits of the program as outlined above and will thus have to purchase 
future upgrades at the upgrade price.

There is a grace period of approximately 30 days from the time of the MMP expiry during which you may still renew 
without penalty. All post-expiration renewals will be backdated to the actual expiry date.

Lapsed Subscriptions
Failure to renew your MMP within 30 days from the expiry date will result in a lapsed MMP subscription. Lapsed 
subscriptions may not be renewed and the licensee will be required to purchase support and upgrades accordingly.

Please direct all MMP questions and purchase inquiries to info@avenza.com.

WISHLIST

As either a new or experienced MAPublisher user we value your opinions on how we can improve our product. 
Please let us know what functions you would like to see incorporated into future upgrades of MAPublisher.
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RAM RECOMMENDATIONS

Occasional User: 2 GB of RAM is recommended.
A graphics or GIS user who uses MAPublisher with medium sized data sets with up to 20 layers, minimal text labels, 
and some low-resolution or small coverage raster images.

Power User: 4 GB or more of RAM is recommended. 
A professional cartographer who uses MAPublisher daily and works with large urban data sets (including large 
transportation layers) with 20 or more layers, raster based air photographs, large numbers of text labels, complex fill 
patterns, etc.

RAM USAGE HINTS

Users often ask us why is so much RAM needed to operate MAPublisher. First of all, Adobe Illustrator requires a 
significant amount of RAM itself in order to run smoothly. Secondly, map data sets are often large which increases 
the need for RAM even further. Map data sets contain both vector and attribute data which must be stored in 
memory. Since we are adding a database to Adobe Illustrator this increases the file size, which increases the 
RAM requirements. MAPublisher builds a mini-GIS application inside Adobe Illustrator so that it can geo-code 
information and attach data to objects. This also has some overhead.

GIS users also often ask why so much more memory is needed with MAPublisher than is with GIS software. The 
graphics environment software of Adobe Illustrator loads the entire file into memory rather than just reading it 
from disk, thus more RAM memory is required.

When you are importing a large number of files into Adobe Illustrator using MAPublisher, you’ll notice that the 
amount of available memory will decrease rapidly and your computer loses speed. This is due to the memory 
management. MAPublisher reserves a fairly large amount of memory for each import-action, which is not properly 
returned when the import is done or even when it is cancelled. The solution is simple: save your file, close it and 
open it again. It’s not even necessary to close Adobe Illustrator itself. By closing the file, the reserved memory is 
properly returned. 

RAM SAVING TIPS

Since a percentage of the memory is taken for attribute storage, remove any redundant or otherwise unnecessary 
attribute fields from the MAP Attributes table of a layer.

Many sources of street data include paths/vectors that are segmented based on street addressing information. You 
can use the MAPublisher Join Lines function to join these into single linear features based on a selected attribute 
field. Reducing the number of objects (and data records) in the map file will free up memory.

Many GIS data files are large and when a series of such files is imported, you may find that the import function 
starts to run more slowly. This is because scratch and memory allocations are being used up. The best solution is to 
periodically save your work, quit Adobe Illustrator and then restart. This will free up the available scratch memory.

Memory Considerations 
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Reduce the minimum number of Undo commands (since they all reside in memory).

Use polylined or pre-joined linear feature data sets where available.

In your GIS application, strip out the attributes you won’t be using for queries or labeling before importing the data 
into Adobe Illustrator.

You can set a primary and secondary scratch disk under the Adobe Illustrator preferences option in order to draw 
additional storage from a partitioned or multi-drive environment.

Turn off the layer preview icon that appears to the left of each layer name in the Adobe Illustrator layers panel. 
This can be done by clicking the options menu in the layers panel and then selecting small panel rows in the panel 
option dialog box.
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For geographic information system (GIS) users, the appeal of graphics is strong and the increasing ability to discover 
and share GIS across the Internet is fascinating. The Internet offers a large number of free-access GIS-related web 
sites from which you can access map and information data sets. To find some information on the source listed it, use 
any internet search browser such as Google to get access to the websites.

For the general public, there’s general information about countries, states, and places; simple maps of areas (e.g., 
GIF, PS format); lists and maps of Internet resources in an area. For cartographers and geography researchers, there 
are cartographic/ GIS base map files (e.g., USGS Demos, DLGs, TIGER); thematic data of a geographic nature (e.g., 
census data); and complete GIS data sets (e.g., Esri Interchange Files).

FREE MAP DATA

Many sites on the Internet offer GIS data free of charge. Data is available from these and other Internet sites in a 
wide variety of formats. Please consult the sections in this manual on file formats (chapter 2) to ensure that you 
download usable data. Some popular sites:

•	 CAST data: Center of Advanced Spatial Technologies, University of Arkansas.
•	 EROS Data Center: access to USGS digital datasets.
•	 Geocommunity and GIS Data Depot: very good source of free GIS data.
•	 Geoconnections/Geoconnexions: Canada Ministry of Natural Resources site.
•	 Geography Network: world-wide geographic contents.
•	 Geogratis: maps offered by Natural Resources Canada.
•	 Geoscience Australia: Australian National Mapping Agency.
•	 National Atlas of the United States: excellent data source for the United States.
•	 NOAA ENC Download: free download of electronic nautical charts in S-57 format (USA).
•	 Robert E. Kennedy Library @ California Polytechnic State University: US based map inventory.
•	 United State Geological Survey: various data formats available (DLG, GeoTIFF, etc.) from the USGS website.
•	 United States Fish and Wildlife Service: variety of map data in USGS DLG format.
•	 USACE IENC download: US Army Corps of Engineers, S-57 and Esri Shapefile of US waterways.

OTHER VALUABLE GEOSPATIAL RESOURCES

In some additional places on the Internet where you can find news, reviews, tips and general GIS, cartographic and 
geographic information. Some popular sites:

•	 Directions Magazine
•	 Geospatial World
•	 GIS Cafe
•	 GIS Dictionary
•	 GIS Lounge
•	 GIS Development
•	 GISuser
•	 University of Edinburgh
•	 University of Florida - Geoplan Center
•	 US Census Bureau

Online Sources 



A1/21﻿
﻿

General Tips and Hints 

CREATING DELIMITED XY TEXT FILES

There may be times when you wish to add a point or a series of points to your map but you do not have a GIS or 
ASCII file containing these points ready for import. Provided you have the real-world coordinates for the locations 
you wish to plot*, you can manually create a delimited ASCII file using a text editor (e.g. Notepad) or a spreadsheet 
program (e.g. Microsoft Excel). This file can then be imported using either Simple or Advanced Import using the 
Delimited XY Text Data format.

In a text editor, one column in the file must contain the X coordinate and another must contain the Y coordinate. 
Add as many additional columns as you wish containing additional information to be imported as attribute data.

If you are using a text editor, you can simply type in your data in the following format:

“Column 1 Header”,”Column 2 Header”,”Column 3 Header”...etc
“Column 1 Value 1”,”Column 2 Value 1”,”Column 3 Value 1”...etc
“Column 1 Value 2”,”Column 2 Value 2”,”Column 3 Value 2”...etc

Note that negative values for the X and Y coordinates denote west longitude and south latitude, respectively. Also 
make sure to enter a carriage return using the Enter key on your keyboard after the last line of data otherwise the 
last line may be ignored by MAPublisher Simple or Advanced Import.

In a spreadsheet application, enter your point information as a table and save the file in a text format, preferably 
.csv or .txt, choosing either comma or tab delimiting. The spreadsheet application will format the text automatically. 

*	 The MAP Location Tool can be used to generate the X and Y coordinate values suitable for building ASCII Point 
Files. See chapter 4 for more information.
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JOINING SDTS TABLES
The following information should be used in conjunction with the MAPublisher Join Table function.

When working with United States Geological Survey SDTS files it is necessary to join tables frequently in order 
to obtain the map attribute table you require to make the map you want. This is due to the fact that SDTS data is 
constructed such that the primary vector data is held separately from the various attribute tables that one might 
want to use for a particular mapping purpose. The attribute table that comes as part of the vector file usually 
contains a unique identifier (RCID) for each map element that is used to join it with the other data tables. For 
example, a particular vector file containing the geography of rivers would contain a data column called RCID. 
Various data tables containing information such as vegetation, fish counts or flow rates might be available each also 
with an RCID column. The desired tables are then joined to the initial map attribute table by RCID value using the 
techniques described in the previous pages. 

To find the SDTS tables to join with the vector map file look for the files which have names that start with the same 
character string as the name of the vector file. MAPublisher imports SDTS files that have the characters “CATD” at the 
end of the file name. A typical table to import and join with this file might be called HY01CATD.ddf.

Use the MAPublisher table importer with SDTS file type chosen to import these files. When you join layer and table, 
you do the join based on the column from the layer matched to the RCID column of the table. Note that the CATD 
catalog file found amongst the SDTS files explains what each table is.

ROTATING OBJECTS INDIVIDUALLY IN ADOBE ILLUSTRATOR
On some occasions you may wish to rotate selected objects about their own centres rather than as a group about 
a common origin. This can be accomplished using the Adobe Illustrator Transform Each function. To use this function, 
first select the objects you wish to rotate. Then go to Object > Transform > Transform Each. In the Rotate box enter a 
desired rotation value and click OK. Each of the selected objects will be rotated individually about their own centres.

You may also use the #Rotation property column to individually rotate point symbols or text items based on a 
specified value. See chapter 5 for guidelines on how to use this function.

GEOREFERENCING AN ADOBE ILLUSTRATOR FILE
If you are using an existing Adobe Illustrator file that was created without the use of MAPublisher and as such does 
not contain any geographic parameters or attribute data, the following steps will enable you to georeference your 
Adobe Illustrator file and ultimately create an attribute-rich and accurate scale and world grid structure for your 
map. Please note that the steps that follow refer to functions that are outlined in more detail in the body of this user 
guide. Please familiarize yourself with the main MAPublisher functions and in particular those under the MAP Views 
section (see chapter 4) before proceeding.

Before beginning to georeference an Adobe Illustrator file you must be in possession of the following information:
1.	 The real-world scale of your data
2.	 Details of the coordinate system the data is in (i.e. Projection, Datum etc)
3.	 The X-Y coordinates of one tie-in point in the coordinate system of your data
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To determine the real-world scale of your data, use the scale bar drawn on the map for reference (measure the 
page size using the Adobe Illustrator Measure tool and divide by the scale size indicated - make sure to correct for 
the measurement units). If no scale bar is available, try measuring distances in page units in Adobe Illustrator and 
compare with the same distance measured in real unit with a mapping or GIS software, beware that differences in 
coordinate systems may affect the distance measurements.

Determining the coordinate system of the map may be difficult. If no information is provided as meta data or in the 
map legend, try to compare with other maps of the same area or with traditional coordinate systems used in the 
area (e.g. US State Plane zone matching a county name in the USA).

To determine the real-world tie point, find a specific location in your document for which a real-world coordinate 
location is known or can be easily determined (such as known feature or grid or graticule crossing positions). 
Record the location of this point in real world coordinates on a piece of paper.

When you have this information please use the following guidelines in order to georeferencing data with 
MAPublisher in Adobe Illustrator. 

1.	 Identify the registration or tie-in point in your document for which you know the X,Y or Lat,Long coordinates.
2.	 Determine the page position of the same point on the Adobe Illustrator page using the Info panel (Window > 

Info).
You should now have the location of your tie-in point in both map and page units (e.g. –79.5, 43.5 in Lat/Long is located 
at 4cm, 2cm in the document).
3.	 In the MAP Views panel, choose New MAP View in the panel options menu. 
4.	 Enter a name for the MAP View. 
5.	 Click the Specify button in the Source Coordinate System section. Choose the coordinate system that matches that 

of your vector data and click OK.
6.	 Set the Scale to the proper scale of the map. It is important to set the scale after the coordinate system but 

before you enter the map anchors. 
7.	 Click OK in the MAP View Editor to apply the information to the new MAP View.
8.	 In the MAP Views panel, choose Specify Anchors in the panel options menu.
9.	 Set the Map Anchors to the value of the tie-in location in map units using the values determined earlier 

(e.g. Longitude= –79.5o, 43.5o).
10.	 Set the Page Anchors to the value of the tie-in location in Page Units using the values determined in step 2 

(e.g. X=4cm, Y=2cm). Then click OK.
11.	 If you have not previously done so, ensure that each layer in your Adobe Illustrator file contains only one feature 

type (Point, Area, Line, Text, Legend). 
12.	 In the MAP Views panel drag each of the layers which contain your data in to your new MAP View, ensuring that 

you set the appropriate Feature Type in the Define Layer dialog box.
13.	 Repeat steps 1-13 for any other coordinate systems which exist in your document (such as inset maps for 

example).
14.	 Your document is now a georeferenced MAPublisher file wherein each feature is also georeferenced and 

capable of accepting attributes using MAP Attributes (see chapter 5). You can also use the MAPublisher Export 
function to create a GIS file from this newly georeferenced Adobe Illustrator map.



A1/24 ﻿
﻿

TIPS ON EXPORTING TO OTHER GIS SOFTWARE WITH MAPUBLISHER
These strategies do not focus on how to do the procedures, as these are discussed in the Export section of the MAP 
Views chapter, but more on what you need to know and understand for successful export results.

First and most importantly you need to understand that the MAPublisher export was designed to export MP 
imported or created data one layer and one feature at a time. Why is it important to know this? MAPublisher only 
recognizes objects that have been imported by or created with its functions. If a layer was not imported with 
MAPublisher or is not hosted by a designated MAP View, then MAPublisher will not allow you to export the layer. 

If you have an entire layer that was not created by MAPublisher then:
1.	 Ensure that your layer contains only a single feature type (Point, Area, Line or Text). 
2.	 In the MAP Views panel, check that you have a designated MAP View with a matching coordinate system. If you 

do not, create a new MAP Views.
3.	 Select the layer in the MAP Views panel.
4.	 Drag the layer to the MAP View containing the matching coordinate system to georeference the layer. 
There are also a couple of additional considerations to be aware of when exporting:

Since the current exported vector formats are GIS formats that do not support the concept of Bezier curves you 
need to compensate for this. If you have Bezier curves in your Adobe Illustrator file they will not be recognized in 
the GIS software. In order for these features may be represented correctly you will need to add points to these lines 
in Adobe Illustrator first. Simply identify and select any objects that use Bezier curves and then select Object > Path 
> Add Anchor Points. Repeat this command until the line has a sufficient number of anchor points that the shape of 
your curves will not be lost on export.

Adobe Illustrator stores the origin of text that has been applied along paths differently from other text objects. We 
have found the following steps to be the most successful way to get such Text exported to GIS files:
1.	 Create a new Adobe Illustrator layer
2.	 Select any text that has been created along paths.
3.	 Drag this text to the new Adobe Illustrator layer
4.	 Select Type > Create Outlines. The text will be converted to vector objects.
5.	 In the MAP Views panel, drag this layer back into your MAP View, specifying Area as the feature type
You can now export your Text as Area objects. Since the text is no longer text, you can no longer modify the fonts. 
We recommend that you make a copy of the original text objects before you do this process. These hints on how to 
transfer Adobe Illustrator files are necessary because the graphics environment handles text and curves differently 
and they need some modification in order for the GIS software to represent these accurately.

DOUGLAS-PEUCKER LINE SIMPLIFICATION
The Douglas-Peucker algorithm was primarily designed to reduce the number of points required to represent a 
vector line. A common problem in digital cartography and geographic information systems can occur when lines 
are generated automatically from a mathematical function, which records points at a fixed interval regardless if 
they are all lying along a straight line. A reduction of the number of points makes for a cleaner and more readable 
cartographic line. As well in cartographic work within Adobe Illustrator the removal of points along a path can 
significantly improve the speed of file redraws and reduce the overall file size.

The Douglas-Peucker Algorithm was created in Fortran 66 by David H. Douglas and Thomas K. Peucker at the 
University of Ottawa in 1970-71. It was extensively tested in 1972 and was publicly communicated in the following 
article: Algorithms for the Reduction of the Number of Points Required to Represent a Digitized Line or Its Caricature, 
Canadian Cartographer, Vol. 10, No. 2, December 1973.
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BEZIER CURVES AND OTHER MAPUBLISHER OPERATIONS

Bezier curves are defined using four control points. Two of these are the end points of the curve, while the other 
two effectively define the gradient at the end points. These two points control the shape of the curve. The curve is 
actually a blend of the control points. This is a recurring theme of approximation curves; defining a curve as a blend 
of the values of several control points.

Most GIS formats do not support Bezier curves when used in graphics software such as Adobe Illustrator. Typically, 
curved sections of GIS data will be composed of a series of small line segments rather than an actual curve. This is 
also how features imported by MAPublisher will first appear in Adobe Illustrator. Use Adobe Illustrator Object > Path 
> Simplify to convert this type of feature into a Bezier curve (see chapter 8). Furthermore, Bezier curves cannot be 
simplified using the MAPublisher Simplify Lines tool.

If Bezier curves are exported from Adobe Illustrator using any of the MAPublisher Export functions they will be 
converted to link and node topology (i.e. the end points of the curve will simply be joined as straight lines). It is 
therefore necessary to create additional points to curves to retain their true shape. This can be done globally by 
using the Adobe Illustrator Object > Path > Add Anchor Points function.

This version of MAPublisher supports Bezier curve features during the following operations:
•	 Scale and Projection transformations via the MAP View Editor
•	 Area and length calculations

CREATING SYMBOLS FOR USE IN POINT STYLESHEETS

A MAPublisher Symbol Library and a National Parks Symbol Library are supplied in the Helpful Styles & Symbols 
folder. You may also find that a search on the internet may be useful for finding additional libraries. If you are 
required to create new symbols, the steps below will help you to quickly create symbols manually in Adobe 
Illustrator.

1.	 Use Adobe Illustrator Tools for the manual creation of artwork that will comprise the new symbol. If you wish to 
use a character that are contained in a font library, select the text character instance and click the menu 	
Type > Create Outlines to convert the text to vector art.

2.	 Open the Adobe Illustrator Symbols panel (Window > Symbols).
3.	 Select the artwork that will comprise the new symbol and drag it into the Adobe Illustrator Symbols panel 

double-click the symbol in this panel to assign a name.
4.	 When Edit Stylesheet Theme is accessed for Point stylesheets, this symbol will be available in the Style column.

CREATING A MAP THEMES TEMPLATE

You can create template files with legends to automate the production of a series of similar maps. The procedure 
when using MAP Themes is as follows:
1.	 Create a prototype map using MAP Themes to create the desired look.
2.	 Make a copy of your prototype map file. Delete all the layers from the file so that only the designated MAP 

Themes exist.
3.	 Save it to a new Adobe Illustrator template file (*.ait).
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4.	 Use this template file as a base for future maps as follows:
a) 	 Make a copy of the template file.
b) 	 Import all map layers into the template file and do any needed processing.
c) 	 In the MAP Themes panel, assign your MAP Layers into the desired MAP Themes type. 
d) 	 Apply the MAP Themes and your new layers will be symbolized.

CREATING A MULTI-CONDITIONAL IF EXPRESSION

In Edit Expression it is possible to assign symbology to map objects by assigning an expression to the #Style 
column. In the following example this is achieved by creating a multi-conditional IF statement.

In the following example, a point layer represents cities. Each point has the value “Y”, “N” or “C” in the CAPITAL 
attribute column, describing whether the city is a state capital (Y), is not a state capital (N) or is a country capital (C).
There are three point symbols to assign to the type of point. In this example the following expressions can be 
assigned to the #Style column of the point layer (both expressions have the same result):
Expression 1:
IF(CAPITAL = “Y”, “MAP Symbol 01”, IF(CAPITAL = “C”, “MAP Symbol 02”, “MAP Symbol 03”)) 
Expression 2:
IF_CASE("MAP Symbol 01", CAPITAL="C", "MAP Symbol 02", CAPITAL="N", "MAP Symbol 03")

Therefore: If the capital is “Y”, assign the symbol “MAP Symbol 01”. If the capital is “C” assign the symbol “MAP Symbol 
02”. All other symbols assign “MAP Symbol 03”.

NOTES FOR EXPORTING IMAGES

If the document colour mode is CMYK, exporting an embedded image may result in increased file size compared to 
RGB mode. 

If the image is linked consider the following:

1.	 The image will be exported in the original colour mode of the image irrespective of the current colour mode of 
the document (i.e. a linked grayscale image in a CMYK document will be exported as a grayscale image, whereas 
a linked RGB image in an CMYK document will be exported as a RGB image).

2.	 A linked image with Alpha channels may be exported in a different colour model. For example a grayscale with 
two alphas will export as an RGB or an RGB with an alpha channel will export as CMYK.

3.	 Linked images in CMYK mode (regardless of the color mode of the document) will export with an incorrect 
result and should therefore be avoided (see chapter 12).

If the image is embedded consider the following:

1.	 The image will be exported in the colour mode of document (i.e. an embedded grayscale image in a CMYK 
document will be exported as a CMYK image, whereas an embedded CMYK image in an RGB document will be 
exported as an RGB image).

2.	 Embedded grayscales do not pick up the document colour model (i.e. an embedded grayscale image will be 
exported as grayscale).

3.	 The export of embedded Bitmap images is not supported.
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In the MAPublisher application, the coordinate system option must be entered at two levels: coordinate system of 
the source data (when importing GIS data) and coordinate system of the final map.

SOURCE DATA COORDINATE SYSTEM

The Source coordinate system is usually detected when the coordinate system information is available with the 
GIS data being imported and when supported in the native GIS format (such as Shapefile , e00). However, in some 
cases, this information is not imported because it is not supported in the original GIS format (e.g. DWG, DXF) or 
when using a non-referenced Adobe Illustrator files. In that case, the coordinate system must be specified by the 
user. It generally can be found from an attached metadata document, by contacting the data provider or in textual 
information on the original data itself (e.g. title or legend of a scanned map). 

In all cases, the source coordinate system must be known with certainty. Then only can the proper parameter 
be specified in the MAPublisher interface. A wrongly specified source coordinate system would make the map data 
unusable for transformations and merging with other datasets.

FINAL MAP COORDINATE SYSTEM

Most of cartographic projects are restricted in the choice of coordinate system for the final map. This parameter 
is usually part of the project requirement. It is the task of the professional cartographer to analyze carefully the 
situation to make the wise decision. For general purpose mapping projects (interpretive or marketing maps for 
example), a more approximative selection of the coordinate systems might be acceptable. Following the request 
from some of our users, who may not have a cartographic expertise, here are a list of simple considerations to take 
into account before making a choice:

•	 Use of a Geodetic Coordinate system (angular coordinates, Lat/Long):
•	 Appropriate for overlay with GPS data recorded in Lat/Long format.
•	 WGS84 system is required to export vector data to KML format (for display 

in Google Earth, Google Maps).

•	 Use of a Projected coordinate system:
•	 Appropriate for printed map (so that users can use a ruler to measure 

distances on the map).
•	 Required to add a scale bar. 

•	 Use of a particular system (within the list of projected and geodetic systems):
•	 Maps that are part of a portfolio or Atlas have to comply to the same 

system to be consistent. 
•	 When a geo-referenced image (geotiff or world tiff) is to be used together 

with the data, it is easier to use the same coordinate system for the vector 
data as of the raster.

•	 Most countries or geographic areas have published standards or usual 
way for representing the land (e.g. for road maps or meteorological maps). 
In this case, the user should make some test with the systems listed in 
MAPublisher. For a convenient use, coordinate systems are sorted by 
continent>country>sub-division (state or county for example).

Appendix 2: Coordinate Systems
Overview
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In doubt, it is recommended to test different coordinate systems and visualize the results.

For more information on the supported coordinate systems and projections in MAPublisher, please refer to the 
Avenza Projections Guide installed with MAPublisher.

Examples of appearance of the USA depending of the chosen coordinate system

Geodetic > World > WGS84 (unprojected) 

Projected > World > Robinson 

Projected > North America > United States > US National Atlas 
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The Geodetic Datasource 

MAPublisher includes an extensive geodetic parameter database called the Geodetic Datasource. It contains all the 
latest updates from the widely used  EPSG Geodetic Parameter Dataset maintained by the Geodesy Subcommittee 
of OGP (International Association of Oil and Gas producers) as well as custom systems maintained by Avenza. 
In addition, the MAPublisher Geodetic Datasource supports user's custom definitions and allows for importing 
external WKT (Well-Know Text) and PRJ (Esri projection file) parameter files.

Over 3500 pre-defined coordinates systems are readily available for use in most cartographic projects. Even though 
the current list of systems is comprehensive, there may be instances where the end users may wish to add a brand 
new coordinate system to meet their particular needs, or perhaps to duplicate and modify an existing definition to 
change the units for example.  A complementary Avenza Projections Guide is installed with MAPublisher. It describes 
all the projections and datum shifts methods supported by MAPublisher, to assist users in the process of creating or 
editing a coordinate system.

The default parameters installed with MAPublisher are stored within read-only XML database files referred to 
as the Geodetic Datasource (files named geodata.xml and avenza.xsp).  The base datasource files shipped with 
MAPublisher are installed in the Data Source Files folder at the following location:

Windows:  C:\Program Files\Avenza\MAPublisher 9\Data Source Files
Mac OS X:  /Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/Data Source Files

Custom definitions and parameters are saved or loaded from separate XML files that must always accompanied 
with a file named geocalc.xsd (when not present, this file can be copied from the Data Source Files folder).

The custom and read-only entries are organized into categories and sub-folders — users may create new folders, 
move entries or create short-cuts. That folder structure is saved in a view file (*.xvw). 

When MAPublisher is uninstalled or a newer release is installed, an option will be given to backup the custom 
coordinates systems and view file (Windows only). The backup files can be found:

Windows XP:	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9
Windows Vista/7: 	 C:\ProgramData\Avenza\MAPublisher 9
Mac OS X: 	 /Applications/Avenza/MAPublisher 9.1/Data Source Backup

LOAD CUSTOM COORDINATE SYSTEMS

A geodetic datasource or coordinate system database can be loaded into MAPublisher, greatly extending the 
coordinate systems available for use. To load a geodetic database within MAPublisher, choose Load Custom Coordinate 
Systems from the MAP Views panel options menu. 

The directory containing the XML file must also contain the file geocalc.xsd. This file can be found in the directory 
of the default geodata.xml file (see above). So the custom XML file can either be copied to the Data Source File 
directory prior to loading, or geocalc.xsd should be copied from there to the custom XML directory.

Any additional change will be saved into the loaded xml file.
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Note:	 Coordinate systems may also be extracted from the input data formats (during import process).

EDIT CUSTOM COORDINATE SYSTEMS

MAPublisher includes an extensive geodetic parameter database. The contents of the Geodetic Datasource can be 
browsed or searched by using a search frame. Users can extend MAPublisher Geodetic Datasource to support an 
unlimited number of custom linear and angular units, ellipsoids, datums, datum shifts, and coordinate systems. 

MAPublisher Custom Coordinate Systems Editor is accessed from the MAP Views panel options menu Edit Custom 
Coordinate Systems. Coordinate systems may also be edited/created from the Specify Destination Coordinate System 
dialog box (opened using the Specify button in MAP Views panel and import dialog boxes), but the other geodetic 
objects are only accessible through Edit Custom Coordinate Systems.

Individual entries in the geodetic data source are known as Data Source Objects. There are different types of objects 
for different types of definition. Objects contained in the geodetic data source are:

•	 *All*: used to define the orientation of axes used and the type of units used in the system.

•	 Angular Units: type of units for measuring rotation.

•	 Coordinate Systems: a complete definition needed to express the context of a set of map data.

•	 Datum Transformations: parameters to transform coordinates from one datum to another.

•	 Ellipsoids: an ellipsoid gives a horizontal datum its size and shape. An ellipsoid does not have an origin 
and cannot be used as a base model for coordinates on its own.

•	 Envelopes: defines a geographic area of use for a particular object.

•	 Horizontal Datums: more commonly referred to as just "datum" is the base model maps are built 
on. All coordinate systems must have a datum associated with them to be related to any other map. 
Without a known datum, coordinates are meaningless.

•	 Linear Units: units for measuring straight line, Cartesian distances.

•	 Prime Meridians: defines longitude values of meridians.
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You can define new coordinate systems, make copy and modify existing objects. The custom objects are stored 
in a separate xml file saved by the user. Users can also re-organize the Geodetic Datasource (default and custom 
parameters) into categories and sub-folders. These changes are saved to a view file (.xvw). The view file may be 
deleted to reset the Edit Custom Coordinate Systems dialog box to its default state.

Datasource - File contains the 
default geodetic parameter 

(geodata.xml).

Custom Data - File contains 
custom geodetic 

parameters. It is loaded or 
saved by the user.

Data Source Object Folders - See 
list on previous page

Search - Search for 
geodetic objects. Search 

in categories such as EPSG 
Code, Envelope, Source 
Datum, Class Type, etc.

Add/Remove - Add and 
remove folders and 

categories.

Save / Save As - Save 
changes to a custom 
file (data to XML and 
view to XVW).

Edit Object Buttons - 
Add, remove, edit, 
information or copy 
objects.

At the top of the Edit Custom Coordinate Systems dialog box, two directory paths are listed: the geodetic data source 
path and the custom data path.

Note:	 The geodetic data source file is protected (read-only). Any additions or modifications to coordinate systems 
are stored in a separate XML file called customsystems.xml.

On the left-hand side of the dialog box is the data source object folders. To expand a folder to see its subfolders, 
click the plus sign (Windows) or arrow (Mac) to the left of the category name. To see the entries at any particular 
level of category, click the category itself. When an object, folder or subfolder is selected, the data source objects 
list box to the right displays the information stored within each one. User defined coordinate system objects can 
be organized using drag-and-drop between folders. Columns can be resized and sorted alphabetically/numerically.  
Right-click on a column header to show or hide it. Entries loaded from the main geodetic data source will be shown 
in black text, while entries from the custom data file will be shown in blue.

To create a new folder, click the New Folder button. A new folder will be titled "New Folder" by default and can be 
renamed. Subfolders can also be created using the same method. Only user-defined categories can be deleted 
using the Delete Folder button.

Changes are saved to customsystems.xml located in:
Windows XP: 	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9
Windows Vista/7: 	C:\ProgramData\Avenza\MAPublisher 9	
Mac OS 		  Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/Data Source Files

The default XVW file (folder structure) is saved to customview.xvw, located in:
Windows XP: 	 C:\Documents and Settings\All Users\Application Data\Avenza\MAPublisher 9
Windows Vista/7: 	C:\ProgramData\Avenza\MAPublisher 9	
Mac OS X:		  Applications/Avenza/MAPublisher 9.1/MAPublisher Plug-In/ 
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CREATE NEW DATA SOURCE OBJECTS

In the Edit Custom Coordinate Systems dialog box, click the New Object button  to create a new data source 
object. When creating new data source objects, the identification information and definition parameters need to be 
completed. Complete this information in the respective Identification and Definition tabs.

The Identification tab is used to name the object and associate identification codes with it (if applicable). It is 
important to enter an appropriate name for the object. The Remarks field can be used to add notes on a definition 
and is optional. The Identifiers list may be used to add identifying codes for an object that may come from other 
databases. The GC code is a unique identifier assigned by Geographic Imager and should not be altered. To enter 
additional codes use the space below it.

The Definition tab is used to define the parameters of an object. Each object has parameters unique to it. Refer to the 
list below when creating new objects.

Note:	 Refer to the Avenza Projections Guide for more information on supported projections and their parameters 
as well as supported datum transformations methods.

*All*
For coordinate points, specify the coordinate point dimensions in either 2D or 3D. For Geodetic and Projected 
Coordinate Points, the Longitude and Latitude style of units must be entered for all 2D Dimensional Points. The 
Longitude, Latitude and Ellipsoid Height style of units must be entered for 3D Dimensional Points.

            

Angular Units
For angular units, enter a conversion for the new unit in terms of the scientific 
standard Degrees. The Abbreviation is used to identify the unit within the 
application interface (Example: The abbreviation for degrees is "deg").



A2/7﻿
﻿

Coordinate Systems
For Coordinate Systems, select an Envelope defining the appropriate area 
of use. If you are unsure of the appropriate envelope, you can leave it set to 
the default World envelope. The Point Style is how you will select the style 
of linear units for your system. For most projected systems, you will want to 
select "Projected point in (units)". Then select the Geodetic model that using 
the appropriate datum for your system. When you select the appropriate 
projection for your system, the parameters needed to define the system will 
appear in the table below. Enter the needed parameters and define the units 
each parameter is specified in.

   

Datum Transformations
For Datum Shifts, select an Envelope (appropriate geographic area of use), 
Source, Target and Method. If you are unsure of a more specific envelope, leave 
it set to the default "World" Envelope. The Source and Target fields are used 
to specify the two geodetic models the Transformation is valid for. The Method 
specifies the necessary parameters to define a particular datum transformation. 
With the proper method selected, enter the appropriate parameters for 
your datum transformation. Be sure to define the appropriate units for each 
parameter by clicking the Units button.

Ellipsoids
For Ellipsoids you must enter the parameters for the Semi-Major Axis and Semi-
Minor Axis (often noted as "a" and "b" respectively) define the linear units the 
axes are specified in by selecting a predefined unit in the appropriate fields. 
The Inverse Flattening (often noted as "1/f") will automatically calculate in 
the field below. Alternately, you can make the Inverse Flattening definitive by 
enabling the check box at the bottom. You can then manually enter the Inverse 
Flattening rather than the Semi-Minor Axis parameter.
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Envelopes
For Envelopes, specify the extents of the envelope (it is not required but 
recommended). If the Specify Extents Points check box is checked, it is required to 
enter the minimum and maximum points of the envelope and the point style the 
value represent.

Horizontal Datums
For Horizontal datums you must select the Ellipsoid the datum is based on, as well 
as the prime meridian used.

Linear Units
For Linear units, enter a conversion for the new unit in terms of the scientific 
standard Meters. The Abbreviation is used to identify the unit within the 
application interface (Example: The Abbreviation for Meters is "m")

Prime Meridians
For Prime Meridians you must enter the longitude value of the Prime Meridian 
and the angular unit that value is in.
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EDIT OBJECTS

To edit a custom or user-defined object, click the Edit Object button . Edits may be made in the respective object 
editor dialog box. Alternatively, double-click an object to open the editor dialog box. When a data source object 
belonging to the master data set is selected, the Edit Object button  is disabled (because these objects are read-
only). To modify an original object, create a copy of the object first then edit it.

DELETE OBJECTS

When a data source object belonging to the master data set is selected, the Delete Object button  is disabled. 
Only user-defined objects can be deleted.

COPY OBJECTS

Any object can be copied. To create a copy of an object, select an object and click the Copy Object button . A 
dialog box will appear with "Copy of:" preceding the object name in the Name box.

MOVE OBJECTS

Any user defined object can be moved. Drag-and-drop an object from the Data Source Objects List to a Data Source 
Object Folder. A dialog box will prompt you to move the object or to create a shortcut to it.

LOAD CUSTOM COORDINATE SYSTEM DEFINITIONS

In some instances, the coordinate system of an image is not listed in the geodetic data source or the reference file 
format does not support the coordinate system. In such cases, it may be useful to load custom coordinate system 
definitions. In the Geographic Imager panel options menu, click Load Custom Coordinate System. MAPublisher can use 
the following coordinate system file formats: WKT definitions (.wkt), MapInfo MAP files (.map), MapInfo TAB files 
(.tab) and ESRI projection files (.prj).

When a new coordinate system definition is loaded, it automatically replaces the source coordinate system of the 
currently selected image. To transform the image to the loaded coordinate system, open another referenced file 
and then load the coordinate system to that file. In the Transform dialog box, choose the Same As option to make 
the destination coordinate system identical to the image of the loaded coordinate system. 
 
When a coordinate system definition is loaded, it is added to the geodetic data source but not saved. If the loaded 
file matches an existing definition, the original definition will be used and the loaded definition will not be added. 
All new definitions are located at the top level of the appropriate category in the Coordinate Systems folder list (in 
either Geodetic or Projected). Before exiting Adobe Photoshop, be sure to save your geodetic data source if you 
wish to use the coordinate system definition again. 
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Appendix 3: MAPublisher How-To’s For Legacy Users

Legend Functionality in MAP Themes 

Users of MAPublisher 6 or earlier should consult the following pages for information on how to perform common 
legacy MAPublisher tasks in MAPublisher 8.4 and newer.  

BUILDING COLOUR RAMPS TO CREATE STYLES

You can enhance the look of your maps by using colour ramps, rather than random colours, for your area and line 
styles. A possible use for this would be in the creation of relief maps.
1.	 Determine the number of new graduated styles you wish to create. 
2.	 Create two rectangles with the Rectangle Tool aligned vertically, one at the top of the page, the other at the base. 
3.	 Colour the first (top) and last (bottom) elements with two end colours for the ramp.
4.	 Choose Object > Blend > Blend Options.
5.	 Choose Specified Steps from the list. Enter the value you determined in the first step minus two. Click OK.
6.	 Select the two rectangles. Choose Object > Blend > Make. The legend elements will be blended between the two 

end colours.
7.	 Choose Object > Expand, then choose Object > Ungroup. This ungroups the art so that the new styles can be 

added to the Graphic Styles panel and be used in the MAP Themes.

ASSIGNING INCREMENTAL VALUES TO STYLES

It is very straightforward to assign styles to values for stylesheets based on Equal to expressions. The following 
examples can be used as a basis for new stylesheets, providing the functionality which was previously available in 
the Unique Occurrences option in Auto Assign Legend Info.

Example 1 (Rule 1 assigned first listed value and first style):
1.	 Create the first Equal to rule, using the first listed style, and an expression based on the first listed value in a 

specified attribute column, i.e. Style A assigned to Column X = "Value 1”. 
2.	 Click the Add button. The second rule will be automatically assigned an incremental expression, i.e. Style B 

assigned to Column X = "Value 2”. 
3.	 Keep clicking the Add button until all the values or styles have been used.

Example 2 (Rule 1 assigned first listed value and third style):
1.	 Create the first Equal to rule, using the first listed style, and an expression based on the third listed value in a 

specified attribute column, i.e. Style C assigned to Column X ="Value 1”. 
2.	 Click the Add button. The second rule will be automatically assigned the first unused style, i.e. Style A assigned 

to Column X = "Value 2”. 
3.	 Keep clicking the Add button. Assignments will be incremental, but will not include the third style again, i.e. 

Style B assigned to Column X ="Value 3”; Style D assigned to Column X = "Value 4”; etc
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CREATING STYLE RULES BASED ON MULTIBLE ATTRIBUTE COLUMNS

Assign Legend Info previously provided options to assign legend criteria to legend elements based on values in 
multiple attribute columns. This functionality can be achieved in the Edit Stylesheet Theme dialog box. Toggle to 
the Advanced mode to compose advanced expressions.

The following are some examples of multi-column expressions in a world countries stylesheet (using a string type 
column named CONTINENT and an integer type column named POPULATION).

CONTINENT=“Africa” AND POPULATION<1000000
Result: only African countries with populations less than one million are assigned the selected style.

CONTINENT=“Africa” OR POPULATION<1000000
Result: all African countries and all countries with populations less than one million are assigned the selected style.

CONTAINS(CONTINENT,“America” AND POPULATION>1000000
Result: only countries in North and South America with populations more than one million are assigned the selected style.

CONTINENT=“Europe” AND POPULATION>1000000 OR CONTINENT=“Asia” AND POPULATION>10000000
Result: countries in Europe with populations more than one million and countries in Asia with populations more than ten 
million are assigned the selected style.

Copy and Paste 
The MAP Copy/Paste function was removed in MAPublisher version 7. You can now achieve the same functionality 
via Adobe Illustrator native Copy/Paste tools.

1.	 Use Edit > Copy or Edit > Cut to copy art. 
2.	 Deselect the art.
3.	 Select the destination layer in the Layers panel 
4.	 Use Edit > Paste in Front or Edit > Paste in Back to paste the art into the new layer at its previous location. 

•	 When pasting to layers which already contain an attribute structure, the destination layer must have an attribute 
schema which matches the source layer (only attributes in common will be transferred). 

•	 When pasting to layers which contain no attribute structure, the destination layer will be assigned the same 
attribute schema as the source layer. 

•	 The destination layer can be contained in any MAP View as required. 
•	 The destination layer must be of a matching feature type as the source layer. 
•	 Pasted data will always maintain its attributes. If you paste into a non-map layer, drag this layer into a MAP View, 

then recreate the schema, attributes will be populated appropriately. 
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Grid and Scalebar Operations 
EDITING CUSTOM ART

Manually editing type (position, font, colour, etc) is not possible on Grids and Scale Bars in their default grouped 
state. Manual editing is possible but objects must be first expanded (choose Object > Expand). Note that this will 
negate any opportunity to subsequently edit the art using MAPublisher editing tools. 

If you require a different design to be used for your Grid or Scale Bar, or wish to change any parameter without 
generating a new version, simply select the Grid or Scale Bar and choose Object > Edit Grid or Scale Bar. This will 
re-open the Grids and Graticules or Scale Bar dialog box with the current parameters of the object for subsequent 
editing. Editing the style of text (text colour, font, alignment, etc) used in the Grid or Scale Bar can be achieved by 
modifying the properties of the style in the Character Styles panel.

Use the bounding box of the generated grid or scale bar (choose View > Show Bounding Box) to resize. Resizing scale 
bars horizontally will add or remove intervals from the bar(s). Resizing scale bars vertically will adjust the width of 
the bar(s). Resizing grids horizontally or vertically will add or remove component cells in the grid.

EXPORTING GRIDS

To export a grid you must first expand the object (choose Object > Expand), then move it to an Area layer. 
Alternatively expand your grid, move the legend layer to the [Non-MAP layers] category, then move it back into the 
MAP View specifying the feature type as Area.

MISSING DATA IN GRIDS ON PROJECTED MAP VIEWS

Certain projections may cause incomplete grids and graticules to be drawn. Such issues may occur if the MAP View 
is in a polar projection or the extents of the data cross the 180 degree west/east meridian.

If the generation of a grid/graticule causes blank or incomplete results, the following workflow should be used:
1.	 Reproject the MAP View to a standard Lat/Long projection (e.g. NAD27 Lat/Long, Degrees). 
2.	 Generate your grid or graticules on this MAP View.
3.	 Expand the object (choose Object > Expand).
4.	 Create a new Area layer in the MAP View. Drag the expanded grid to this new layer.
5.	 Reproject the MAP View back to the original projection.
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Legacy Text Conversion 
Opening legacy files, you may be prompted to update text (legacy text conversion).

Only text objects that are associated to attributes are required to be updated. For other text with no attributes, you 
do not necessarily need to update.

All text art - Choose this option to convert all text 
to the Adobe Illustrator current version.

MAPublisher text art only - Choose this option to 
convert only the MAPublisher text (on MAP 

layers)

Nothing - Choose this option if no conversion is 
necessary
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Appendix 4: Helpful Styles and Symbols Files
The Helpful Styles & Symbols folder is found in the following locations:

Windows XP: C:\Documents and Settings\All Users\Documents\Avenza\MAPublisher 9\Helpful Styles & Symbols
Windows Vista/7: C:\Users\Public\Public Documents\Avenza\MAPublisher 9\Helpful Styles & Symbols
Mac OS X: Applications/Avenza/MAPublisher 9.1/Helpful Styles & Symbols

Helpful Styles & Symbols > MAP Graphic Styles
This folder contains eight sets of graphic styles for areas and lines:

MAP - Area Effects.ai A set of area gradients

MAP - Area Patterns.ai A set of black and patterns for areas

MAP - Area Solid Colors.ai A set of solid colors for areas

MAP - Line Styles.ai A set of line styles

Format specific styles

DGN - Line Styles.ai A set of MicroStation DGN line styles 1-7

MIF - Area Styles.ai A set of MapInfo MIF/MID area styles 1-71

MIF - Line Styles.ai A set of MapInfo MIF/MID line styles 1-77

S57 - Line and Area Styles.ai A set of S-57 specific styles for lines and areas

Helpful Styles & Symbols > MAP Swatches
This folder contains two sets of swatches:

MAP - Color Groups and Gradients.ai A set color groups and gradient swatches

MAP - Patterns.ai A set of various swatch patterns

Helpful Styles & Symbols > Symbols
This folder contains nine symbol sets of categorized symbols:

MAP - Symbols.ai A set of useful map symbols

KML - Symbols.ai A set of Google Earth symbols used with KML points

S57 - Symbols.ai A set of S-57 specific symbols

LabelPro Arrowheads.ai A set of arrowheads used with MAP LabelPro

Aeronautical Symbols.ai A set of aeronautical point symbols

Bank Symbols.ai A set of symbols from major world banks

North Arrows.ai A set of north arrow symbols

Park Symbols.ai A set of U.S. National Parks Service symbols

Subway Symbols.ai A set of symbols from major subway lines

Transit Symbols.ai A set of symbols from major transit systems

Weather Symbols.ai A set of weather-related point symbols
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Helpful Styles & Symbols > S-57 Symbolization
The S-57 Symbolization folder contains two templates with a series of MAP Theme stylesheets linking S-57 
imported features to appropriate nautical symbols and graphic styles inspired from the International Hydrographic 
Office S-4 publication (previously M-4) (Regulations of the IHO for international (INT) charts and charts specifications 
of the IHO). Graphic styles and symbol names are mostly based on the S-57 naming conventions. The basic template 
allow users to quickly apply styles to the imported data. The advanced template is more detailed to help users learn 
the format and make use of the data.

Subway Symbols.ai Adobe Illustrator template with detailed MAP Themes for use with S-57 data

S57_Basic_Template.ait Adobe Illustrator template with simplified MAP Themes for use with S-57data

US5FL12M Sample ENC file in S-57 format (chart of Tampa Bay, courtesy of NOAA®)

How to use S-57 templates:
•	 Open S-57_Basic_Template.ait or S-57_Basic_Template.ait and import S-57 data.
•	 In the MAP Themes panel, double-click a stylesheet theme to see its settings.
•	 For depth sounding labels, use attribute values with the Label Features - Use sounding style option for 

points labels. To round the depth values according to hydrographic standards, use the expression 
provided in the Expression Library (see chapter 5 on MAP Attributes and chapter 10 on Labeling)

Note:	 This representation is non-exhaustive and meant to assist users with limited knowledge of the S-57 format 
to interpret the data contents more easily. The created map must not be used for navigation, unless further 
processing is supervised by a trained hydrographer.

More Helpful Styles & Symbols on Avenza.com
For even more styles and symbols, visit http://www.avenza.com/resources/styles-symbols.
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